Entire site crashed after update to 4.0.3

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
r0nny1
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Mar 26, 2018 8:34 am

Entire site crashed after update to 4.0.3

Post by r0nny1 » Fri Oct 22, 2021 1:39 pm

Hey,
Reaching out here, as I am not very very smart when it comes to programming and such, but I did believe I could upgrade from 3.10 to 4.0.3 as it told me there was no issues when the check program was run.
Obvoiusly not, at first, on my webpage it worked. I could see Global config and all.
There was 2 problems, one was a table decimal one, and the other I can`t really remember, but the last one sorted itself.

My published webpage though, did not work. And at the end my backend also stopped working.
Have no idea where to go from here and have been googling excessively.
Anyone ?
Last edited by toivo on Fri Oct 22, 2021 11:05 pm, edited 1 time in total.
Reason: mod note: moved, not related to 4.x Installation

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11244
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Entire site crashed after update to 4.0.3

Post by sozzled » Fri Oct 22, 2021 3:55 pm

“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

r0nny1
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Mar 26, 2018 8:34 am

Re: Entire site crashed after update to 4.0.3

Post by r0nny1 » Fri Oct 22, 2021 4:41 pm

sozzled wrote:
Fri Oct 22, 2021 3:55 pm
See viewtopic.php?f=812&t=989423
Thanks. I will try backup, just need to figure out how to do it first :-D

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7259
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Entire site crashed after update to 4.0.3

Post by AMurray » Fri Oct 22, 2021 10:23 pm

I don't know by what method you backed up, but to help you along....

1. Restoring your site should be easy, if you have used Akeeba Backup. You need to clear out all the J4.0 files, upload two files - kickstart.php and the backp archive *.jpa. Then run the script and follow the prompts.

2. If you did a backup via your web host (e.g. through cPanel or similar), it may have a way to restore the site to a time before you updated.

3. If you did a manual backup, that would have involved downloading the J3.10 files and keeping them somewhere on your computer, and exporting the database. You should have a *.sql file. All you need to do is import that file into a fresh database (that's the easiest way), and then re-upload the 3.10 files; this may include third-party extensions, images, media files etc. Delete the J4.0 files first, then uplload the 3.10 files.
Change the database details in the configuration.php to the new database you just imported. The 3.10 site should now be functioning. From here you can try the update again.
Regards - A Murray

r0nny1
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Mar 26, 2018 8:34 am

Re: Entire site crashed after update to 4.0.3

Post by r0nny1 » Sat Oct 23, 2021 2:10 pm

AMurray wrote:
Fri Oct 22, 2021 10:23 pm
I don't know by what method you backed up, but to help you along....

1. Restoring your site should be easy, if you have used Akeeba Backup. You need to clear out all the J4.0 files, upload two files - kickstart.php and the backp archive *.jpa. Then run the script and follow the prompts.

2. If you did a backup via your web host (e.g. through cPanel or similar), it may have a way to restore the site to a time before you updated.

3. If you did a manual backup, that would have involved downloading the J3.10 files and keeping them somewhere on your computer, and exporting the database. You should have a *.sql file. All you need to do is import that file into a fresh database (that's the easiest way), and then re-upload the 3.10 files; this may include third-party extensions, images, media files etc. Delete the J4.0 files first, then uplload the 3.10 files.
Change the database details in the configuration.php to the new database you just imported. The 3.10 site should now be functioning. From here you can try the update again.
Thanks for that.
As I am all fresh at this, I guess I find the akeeba backup through my ftp login ?
I have to look around and see i guess. I do have Akeeba, that I know.

EDIT: I found Akeeba on my ftp. But i do not find the files you mentioned though.
/www/administrator/components/com_akeeba/
akeeba.JPG
You do not have the required permissions to view the files attached to this post.

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7259
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Entire site crashed after update to 4.0.3

Post by AMurray » Sat Oct 23, 2021 10:42 pm

If Akeeba is setup as default configuration, your JPA archive file(s) are likely in the folder, "/backup", which I can see listed in your provided screenshot. You also need the Kickstart utility, obtained from Akeeba. (Search Google for it, I can't post the link).

Upload the kickstart.php, and the *.jpa files to your web server (FTP), after removing the J4.0 files. Set up a clean database for the restoration of the J3.10 site.

Normally, I would expect Akeeba backup to have launched automatically, prior to the CMS doing its update to 4.0. Failing that, the CMS does warn you quite strongly to make sure you have done a backup of your site before proceeding with the update, on the same screen as the Update Advisor checker.

Read Akeeba's documentation as it explains everything - more so than can be explained in a forum.

If Akeeba doesn't work for you, then I would suggest the other option I previously mentioned; speak to your web host, or check in your hosting's administration (cPanel or similar) which should have a function to make and restore backups.

Please also read through these documents when ready to do the 4.0 again:
viewtopic.php?f=812&t=987819
Regards - A Murray

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11244
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Entire site crashed after update to 4.0.3

Post by sozzled » Sat Oct 23, 2021 11:13 pm

AMurray wrote:
Sat Oct 23, 2021 10:42 pm
If Akeeba is setup as default configuration, your JPA archive file(s) are likely in the folder, "/backup", which I can see listed in your provided screenshot. You also need the Kickstart utility, obtained from Akeeba. (Search Google for it, I can't post the link).
Yes, that's the default location where Akeeba creates backup files.

AMurray wrote:
Sat Oct 23, 2021 10:42 pm
Normally, I would expect Akeeba backup to have launched automatically, prior to the CMS doing its update to 4.0.
Only if you enable the plugin System - Backup on update (which is disabled by default) in J! 3.x. This plugin does not exist in in Akeeba Backup core version, meaning you have to consciously perform a backup before you update or purchase the PRO version that has this plugin.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

r0nny1
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Mar 26, 2018 8:34 am

Re: Entire site crashed after update to 4.0.3

Post by r0nny1 » Sun Oct 24, 2021 1:15 pm

Thanks a lot guys.
The dude that did the initial setup of my page, is unfortunately not to be reached anymore.
So I am fiddling around with it myself, which obviously is not a good idea.
I will check a bit and see if I find the J4 files to remove.
I do now that I have 1 of 2 databases available, so a clean one for a "restart" is available.
I have downloaded the akeeba kickstart, so think I have most of it ready.
I do think, that my best shot will be to find someone to actually do it for me, so I don`t F*** it up even more though

User avatar
AMurray
Joomla! Champion
Joomla! Champion
Posts: 7259
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Entire site crashed after update to 4.0.3

Post by AMurray » Sun Oct 24, 2021 10:01 pm

@r0nny1 - On the professional services forum you can request paid services - but forum members can't solicit paid work. viewforum.php?f=177

Thanks @sozzled - my answer was based on using Akeeba Backup Pro but it is a pity the backup on update is not in Akeeba's core component, and in Pro, not enabled by default.
Regards - A Murray

r0nny1
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Mon Mar 26, 2018 8:34 am

Re: Entire site crashed after update to 4.0.3

Post by r0nny1 » Thu Oct 28, 2021 2:05 pm

AMurray wrote:
Sun Oct 24, 2021 10:01 pm
@r0nny1 - On the professional services forum you can request paid services - but forum members can't solicit paid work. viewforum.php?f=177

Thanks @sozzled - my answer was based on using Akeeba Backup Pro but it is a pity the backup on update is not in Akeeba's core component, and in Pro, not enabled by default.
Thanks again.
That is duly noted. I am still trying to fiddle around a bit myself, but so far no luck


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”