Joomla site down after upgrading from 3.10.3 to 4.0.4

This forum is for general questions about extensions for Joomla! 4.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
oubernie
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Tue Nov 04, 2008 12:17 pm

Joomla site down after upgrading from 3.10.3 to 4.0.4

Post by oubernie » Wed Nov 24, 2021 10:15 am

Hello,
I've tried to upgrade my joomla 3.10.3 with the upgrade package 4.0.4, and now it is down. I edited the config file and change debug to true. These are the errors :

############

Too few arguments to function plgSystemHikashopuser::onPreprocessMenuItems(), 2 passed in /home/cabinet/public_html/lab/libraries/src/Plugin/CMSPlugin.php on line 285 and exactly 4 expected

Exceptions 2 Stack Traces 2

ArgumentCountError
in /home/cabinet/public_html/lab/plugins/system/hikashopuser/hikashopuser.php (line 524)

$app->setBody($body);
else
JResponse::setBody($body);
}
public function onPreprocessMenuItems($name, &$items, $params, $enabled) {
if($name != 'com_menus.administrator.module' )
return;
$remove = array();
foreach($items as $k => $item) {

plgSystemHikashopuser->onPreprocessMenuItems('administrator.module.mod_submenu', array(object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem))) in /home/cabinet/public_html/lab/libraries/src/Plugin/CMSPlugin.php (line 285)
in /home/cabinet/public_html/lab/libraries/vendor/joomla/event/src/Dispatcher.php -> Joomla\CMS\Plugin\{closure} (line 486)
Dispatcher->dispatch('onPreprocessMenuItems', object(Event)) in /home/cabinet/public_html/lab/libraries/src/Application/EventAware.php (line 111)
WebApplication->triggerEvent('onPreprocessMenuItems', array('administrator.module.mod_submenu', array(object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem), object(AdministratorMenuItem)))) in /home/cabinet/public_html/lab/administrator/modules/mod_submenu/src/Menu/Menu.php (line 51)
Menu::preprocess(object(AdministratorMenuItem)) in /home/cabinet/public_html/lab/administrator/modules/mod_submenu/mod_submenu.php (line 39)
include('/home/cabinet/public_html/lab/administrator/modules/mod_submenu/mod_submenu.php') in /home/cabinet/public_html/lab/libraries/src/Dispatcher/ModuleDispatcher.php (line 54)
ModuleDispatcher::Joomla\CMS\Dispatcher\{closure}('/home/cabinet/public_html/lab/administrator/modules/mod_submenu/mod_submenu.php', null) in /home/cabinet/public_html/lab/libraries/src/Dispatcher/ModuleDispatcher.php (line 57)
ModuleDispatcher->dispatch() in /home/cabinet/public_html/lab/libraries/src/Helper/ModuleHelper.php (line 295)
ModuleHelper::renderRawModule(object(stdClass), object(Registry), array()) in /home/cabinet/public_html/lab/libraries/src/Helper/ModuleHelper.php (line 167)
ModuleHelper::renderModule(object(stdClass)) in /home/cabinet/public_html/lab/administrator/templates/isis/error.php (line 43)
require('/home/cabinet/public_html/lab/administrator/templates/isis/error.php') in /home/cabinet/public_html/lab/libraries/src/Document/HtmlDocument.php (line 771)
HtmlDocument->_loadTemplate('/home/cabinet/public_html/lab/administrator/templates/isis', 'error.php') in /home/cabinet/public_html/lab/libraries/src/Document/HtmlDocument.php (line 830)
HtmlDocument->_fetchTemplate(array('template' => 'isis', 'directory' => '/home/cabinet/public_html/lab/administrator/templates', 'debug' => 'true', 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php')) in /home/cabinet/public_html/lab/libraries/src/Document/HtmlDocument.php (line 633)
HtmlDocument->parse(array('template' => 'isis', 'directory' => '/home/cabinet/public_html/lab/administrator/templates', 'debug' => 'true', 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php')) in /home/cabinet/public_html/lab/libraries/src/Document/HtmlDocument.php (line 652)
HtmlDocument->render(false, array('template' => 'isis', 'directory' => '/home/cabinet/public_html/lab/administrator/templates', 'debug' => 'true', 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php')) in /home/cabinet/public_html/lab/libraries/src/Document/ErrorDocument.php (line 140)
ErrorDocument->render(false, array('template' => 'isis', 'directory' => '/home/cabinet/public_html/lab/administrator/templates', 'debug' => 'true', 'csp_nonce' => null, 'templateInherits' => '', 'params' => object(Registry), 'file' => 'error.php')) in /home/cabinet/public_html/lab/libraries/src/Error/Renderer/HtmlRenderer.php (line 77)
HtmlRenderer->render(object(Error)) in /home/cabinet/public_html/lab/libraries/src/Exception/ExceptionHandler.php (line 128)
ExceptionHandler::render(object(Error)) in /home/cabinet/public_html/lab/libraries/src/Exception/ExceptionHandler.php (line 71)
ExceptionHandler::handleException(object(Error)) in /home/cabinet/public_html/lab/libraries/src/Application/CMSApplication.php (line 311)
CMSApplication->execute() in /home/cabinet/public_html/lab/administrator/includes/app.php (line 63)
require_once('/home/cabinet/public_html/lab/administrator/includes/app.php') in /home/cabinet/public_html/lab/administrator/index.php (line 32)
Error

Call to undefined method Joomla\CMS\Application\AdministratorApplication::isAdmin()
Sorry, there was a problem we could not recover from.

The server returned a "500 - Whoops, looks like something went wrong."
##########################

Could anyone help me find the solution to this mess, please?
lab.cabinet-ajfc.net
Last edited by toivo on Sat Nov 27, 2021 12:38 am, edited 1 time in total.
Reason: mod note: moved from 4.x Migrating and Upgrading

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 13800
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Joomla site down after upgrading from 3.10.3 to 4.0.4

Post by toivo » Sat Nov 27, 2021 12:42 am

Which version of the third party extension HikaShop are you using?

According to the HikaShop entry in JED, the extension was updated a few days ago and it is compatible with Joomla 4.

Do you have a full backup of the website before the upgrade?
Last edited by toivo on Sat Nov 27, 2021 3:48 am, edited 1 time in total.
Reason: typo
Toivo Talikka, Global Moderator


Post Reply

Return to “Extensions for Joomla! 4.x”