offlajnjoomla3compat.php missing Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Johan Allard
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Thu Dec 17, 2015 2:46 pm

offlajnjoomla3compat.php missing

Post by Johan Allard » Tue Nov 23, 2021 2:12 pm

I was busy doing the pre-update check from 3.10.3 to joomla 4.
Probably something went wrong while cleaning up the incompatible extensions. The website is no longer accessible and I can no longer log in as administrator.

site is www.heemkringokegem.be
http://www.heemkringokegem.be/administrator/index.php

This is the error message:
Warning: require_once(/customers/3/9/d/heemkringokegem.be/httpd.www/plugins/system/offlajnjoomla3compat/offlajnjoomla3compat.php): failed to open stream: No such file or directory in /customers/3/9/d/heemkringokegem.be/httpd.www/plugins/system/offlajnparams/offlajnparams.php on line 15 Fatal error: require_once(): Failed opening required '/customers/3/9/d/heemkringokegem.be/httpd.www/plugins/system/offlajnjoomla3compat/offlajnjoomla3compat.php' (include_path='.:/usr/share/php') in /customers/3/9/d/heemkringokegem.be/httpd.www/plugins/system/offlajnparams/offlajnparams.php on line 15

Johan Allard
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Thu Dec 17, 2015 2:46 pm

Re: flajnjoomla3compat.php missing

Post by Johan Allard » Tue Nov 23, 2021 4:05 pm

I renamed
/plugins/system/offlajnparams
to
/plugins/system/offlajnparams old
and problem solved
(this is not according to the rules, i think)

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 11335
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: offlajnjoomla3compat.php missing

Post by sozzled » Tue Nov 23, 2021 5:11 pm

It works and that's good enough. That's how I would fix the problem. Now, uninstall the extension and you're all done. 8)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?” :)

Johan Allard
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Thu Dec 17, 2015 2:46 pm

Re: offlajnjoomla3compat.php missing

Post by Johan Allard » Sun Nov 28, 2021 5:09 pm

problem solved


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”