Can't upgrade Joomla 4.1.2 to Joomla 4.1.3 Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Tue May 17, 2022 4:43 pm

Dear Joomla Team,

I have two problems.

1. I am facing a problem because my website can't upgrade from Joomla 4.1.2 to Joomla 4.1.3.
Message display for upgrading

An error occurred
The archive is not open for reading.

2. I can't provide the FPA to you here since I am using PHP 8.0 whenever I use FPA, my website shows blank page on Firefox and Safari, and here my website https://cadspc.org/fpa-en.php

but on Brave, it shows this error
This page isn’t workingcadspc.org is currently unable to handle this request.
HTTP ERROR 500

Now I am open
Error Reporting : Maximum
Debug System : Enable
Screen Shot 2022-05-17 at 11.41.56 PM.png
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41499
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Webdongle » Tue May 17, 2022 5:41 pm

Downgrade your php version see what happens
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

Olympe30
Joomla! Intern
Joomla! Intern
Posts: 86
Joined: Sun Dec 12, 2021 9:28 am

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Olympe30 » Tue May 17, 2022 5:53 pm

Hi

Your site works very well at https://cadspc.org/

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Tue May 17, 2022 6:44 pm

I see this at the top of your site page, because debug is on:

Warning: date_default_timezone_get(): Invalid date.timezone value 'Host', we selected the timezone 'UTC' for now. in /home/seekkhmer/domains/cadspc.org/public_html/libraries/src/Date/Date.php on line 117

What you really need to post here is the stack trace.

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Wed May 18, 2022 3:41 am

ceford wrote:
Tue May 17, 2022 6:44 pm
I see this at the top of your site page, because debug is on:

Warning: date_default_timezone_get(): Invalid date.timezone value 'Host', we selected the timezone 'UTC' for now. in /home/seekkhmer/domains/cadspc.org/public_html/libraries/src/Date/Date.php on line 117

What you really need to post here is the stack trace.
Here is my problem
1. Can't upgrade Joomla 4.1.2 to Joomla 4.1.3
2. Why my website can't open FPA https://cadspc.org/fpa-en.php

I want to fix these 2 points and I enable debug because I hope that everyone can see the error relates with those points.

I will post time date_default_timezone_get() later also.

thank u

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Wed May 18, 2022 7:56 am

saovry wrote:
Wed May 18, 2022 3:41 am
Here is my problem
1. Can't upgrade Joomla 4.1.2 to Joomla 4.1.3
2. Why my website can't open FPA https://cadspc.org/fpa-en.php

I want to fix these 2 points and I enable debug because I hope that everyone can see the error relates with those points.
You already have debug enabled. I can see in the queries that you are using something called rsfirewall. What does that do? You have not said whether you can login as admin. If so, try the upgrade again - you should get a stack trace where it goes wrong - that will show what triggered the error and is sometimes more useful than the fpa report.

I suggest you disable all third party extensions before upgrading. Then enable them one by one and test for normal functionality after each.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28943
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Per Yngve Berg » Wed May 18, 2022 8:17 am

Your server have an Invalid Time Zone set. Correct the TZ.

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Wed May 18, 2022 3:38 pm

ceford wrote:
Wed May 18, 2022 7:56 am
saovry wrote:
Wed May 18, 2022 3:41 am
Here is my problem
1. Can't upgrade Joomla 4.1.2 to Joomla 4.1.3
2. Why my website can't open FPA https://cadspc.org/fpa-en.php

I want to fix these 2 points and I enable debug because I hope that everyone can see the error relates with those points.
You already have debug enabled. I can see in the queries that you are using something called rsfirewall. What does that do? You have not said whether you can login as admin. If so, try the upgrade again - you should get a stack trace where it goes wrong - that will show what triggered the error and is sometimes more useful than the fpa report.

I suggest you disable all third party extensions before upgrading. Then enable them one by one and test for normal functionality after each.
Here is the error while I am trying to upgrade it.
Screen Shot 2022-05-18 at 10.34.12 PM.png
You do not have the required permissions to view the files attached to this post.

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Wed May 18, 2022 3:41 pm

Per Yngve Berg wrote:
Wed May 18, 2022 8:17 am
Your server have an Invalid Time Zone set. Correct the TZ.
I fixed the TZ by go down my php version. Now I am using PHP 7.4
And I still can't upgrade it also.

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Wed May 18, 2022 3:58 pm

Now I can use FPA after I drop down my PHP8 to PHP7.4
Forum Post Assistant (v1.6.5) : 18-May-2022 wrote:
Basic Environment :: wrote:Joomla! Instance :: Joomla! 4.1.2-Stable (Kuamini) 30-March-2022
Joomla! Configured :: Yes | Read-Only (444) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: true | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 15 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: false | Proxy: false | LiveSite: | Session lifetime: 15 | Session handler: filesystem | Shared sessions: false | SSL: 2 | Error Reporting: maximum | Site Debug: true | Language Debug: false | Default Access: Public | Unicode Slugs: true | dbConnection Type: mysqli | PHP Supports J! 4.1.2: Yes | Database Supports J! 4.1.2: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 3.10.0 | Technology: x86_64 | Web Server: Apache/2 | Encoding: gzip, deflate, br | System TMP Writable: Yes | Free Disk Space : 11.32 GiB |

PHP Configuration :: Version: 7.4.28 | PHP API: fpm-fcgi | Session Path Writable: Yes | Display Errors: 0 | Error Reporting: 22527 | Log Errors To: | Last Known Error: | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: 1 | Open Base: | Uploads: 1 | Max. Upload Size: 1024M | Max. POST Size: 1024M | Max. Input Time: 60 | Max. Execution Time: 30 | Memory Limit: 256M

Database Configuration :: Version: 5.7.37 (Client:mysqlnd 7.4.28) | Database Size: 22.89 MiB | #of Tables with config prefix:  155 | #of other Tables:  0 | User Privileges : GRANT ALL
Detailed Environment :: wrote:PHP Extensions :: Core (7.4.28) | date (7.4.28) | libxml (7.4.28) | openssl (7.4.28) | pcre (7.4.28) | sqlite3 (7.4.28) | zlib (7.4.28) | bcmath (7.4.28) | calendar (7.4.28) | ctype (7.4.28) | curl (7.4.28) | dom (20031129) | hash (7.4.28) | fileinfo (7.4.28) | filter (7.4.28) | ftp (7.4.28) | gd (7.4.28) | gettext (7.4.28) | SPL (7.4.28) | iconv (7.4.28) | intl (7.4.28) | json (7.4.28) | mbstring (7.4.28) | session (7.4.28) | standard (7.4.28) | mysqlnd (mysqlnd 7.4.28) | PDO (7.4.28) | pdo_mysql (7.4.28) | pdo_sqlite (7.4.28) | Phar (7.4.28) | posix (7.4.28) | Reflection (7.4.28) | mysqli (7.4.28) | SimpleXML (7.4.28) | soap (7.4.28) | sockets (7.4.28) | sodium (7.4.28) | exif (7.4.28) | tokenizer (7.4.28) | xml (7.4.28) | xmlreader (7.4.28) | xmlwriter (7.4.28) | xsl (7.4.28) | zip (1.15.6) | cgi-fcgi (7.4.28) | Zend OPcache (7.4.28) | Zend Engine (3.4.0) |
Potential Missing Extensions ::
Disabled Functions :: exec | system | passthru | shell_exec | proc_close | proc_open | dl | popen | show_source | posix_kill | posix_mkfifo | posix_getpwuid | posix_setpgid | posix_setsid | posix_setuid | posix_setgid | posix_seteuid | posix_setegid | posix_uname |

Switch User Environment :: PHP CGI: No | Server SU: No | PHP SU: No | Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) |

Elevated Permissions (First 10) ::
Database Information :: wrote:Database statistics :: Uptime: 604951 | Threads: 1 | Questions: 327293191 | Slow queries: 0 | Opens: 655255 | Flush tables: 1 | Open tables: 2000 | Queries per second avg: 541.024 |
Extensions Discovered :: wrote:Components :: Site ::
Core ::
3rd Party::

Components :: Admin ::
Core :: com_checkin (4.0.0) 1 | COM_SCHEDULER (4.1.0) 1 | com_templates (4.0.0) 1 | com_actionlogs (3.9.0) 1 | com_cache (4.0.0) 1 | com_joomlaupdate (4.0.3) 1 | com_search (3.0.0) 1 | com_content (4.0.0) 1 | com_users (4.0.0) 1 | com_admin (4.0.0) 1 | com_finder (4.0.0) 1 | com_privacy (3.9.0) 1 | com_modules (4.0.0) 1 | com_config (4.0.0) 1 | com_categories (4.0.0) 1 | com_messages (4.0.0) 1 | com_mails (4.0.0) 1 | com_contenthistory (4.0.0) 1 | com_associations (4.0.0) 0 | com_tags (4.0.0) 1 | com_redirect (4.0.0) 1 | com_menus (4.0.0) 1 | com_fields (4.0.0) 0 | com_languages (4.0.0) 1 | com_login (4.0.0) 1 | com_wrapper (4.0.0) 1 | com_plugins (4.0.0) 1 | com_workflow (4.0.0) 1 | com_media (3.0.0) 1 | com_cpanel (4.0.0) 1 | com_newsfeeds (4.0.0) 1 | com_postinstall (4.0.0) 1 | com_weblinks (4.0.1) 1 | com_ajax (4.0.0) 1 | com_banners (4.0.0) 1 | com_installer (4.0.0) 1 |
3rd Party:: com_djimageslider (4.2) 1 | RSFirewall! (3.0.8) 1 |

Modules :: Site ::
Core :: mod_random_image (3.0.0) 0 | mod_articles_archive (3.0.0) 1 | mod_tags_popular (3.1.0) 1 | mod_articles_popular (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_wrapper (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_stats (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_articles_categories (3.0.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_menu (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_articles_news (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_articles_category (3.0.0) 1 | mod_weblinks (4.0.1) 1 | mod_footer (3.0.0) 1 | mod_search (3.0.0) 1 | mod_login (3.0.0) 1 | mod_feed (3.0.0) 1 |
3rd Party:: DJ-ImageSlider (4.2) 1 | StackIdeas Toolbar (1.0.12) 1 |

Modules :: Admin ::
Core :: mod_submenu (3.0.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_title (3.0.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_user (4.0.0) 1 | mod_latest (3.0.0) 1 | mod_messages (4.0.0) 1 | mod_popular (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_stats_admin (3.0.0) 1 | mod_version (3.0.0) 1 | mod_privacy_status (4.0.0) 1 | mod_loginsupport (4.0.0) 1 | mod_menu (3.0.0) 1 | mod_frontend (4.0.0) 1 | mod_post_installation_messages (4.0.0) 1 | mod_logged (3.0.0) 1 | mod_login (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_toolbar (3.0.0) 1 | mod_sampledata (3.8.0) 0 |
3rd Party:: RSFirewall! Control Panel Module (1.4.0) 0 |

Libraries ::
Core ::
3rd Party:: Library - Foundry by Stackideas (1.1.10) 1 |

Plugins ::
Core :: plg_captcha_recaptcha_invisible (3.8) 0 | plg_captcha_recaptcha (3.4.0) 0 | plg_extension_joomla (3.0.0) 1 | plg_extension_namespacemap (4.0.0) 0 | plg_extension_finder (4.0.0) 1 | plg_workflow_notification (4.0.0) 1 | plg_workflow_featuring (4.0.0) 1 | plg_workflow_publishing (4.0.0) 1 | plg_webservices_tags (4.0.0) 1 | plg_webservices_plugins (4.0.0) 1 | plg_webservices_redirect (4.0.0) 1 | plg_webservices_installer (4.0.0) 1 | plg_webservices_users (4.0.0) 1 | plg_webservices_languages (4.0.0) 1 | plg_webservices_templates (4.0.0) 1 | plg_webservices_menus (4.0.0) 1 | plg_webservices_newsfeeds (4.0.0) 1 | plg_webservices_modules (4.0.0) 1 | plg_webservices_config (4.0.0) 1 | plg_webservices_media (4.1.0) 1 | plg_webservices_banners (4.0.0) 1 | plg_webservices_messages (4.0.0) 1 | plg_webservices_privacy (4.0.0) 1 | plg_webservices_content (4.0.0) 1 | plg_editors-xtd_image (3.0.0) 0 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_menu (3.7.0) 0 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_weblink (4.0.1) 1 | plg_editors-xtd_fields (3.7.0) 0 | plg_quickicon_downloadkey (4.0.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_overridecheck (4.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 0 | plg_quickicon_privacycheck (3.9.0) 1 | plg_installer_urlinstaller (3.6.0) 1 | plg_installer_override (4.0.0) 1 | plg_installer_webinstaller (4.0.0) 1 | plg_installer_folderinstaller (3.6.0) 1 | plg_installer_packageinstaller (3.6.0) 1 | plg_behaviour_versionable (4.0.0) 1 | plg_behaviour_taggable (4.0.0) 1 | plg_system_accessibility (4.0.0) 0 | plg_system_privacyconsent (3.9.0) 0 | plg_system_redirect (3.0.0) 1 | plg_system_logrotation (3.9.0) 1 | plg_system_languagefilter (3.0.0) 0 | plg_system_actionlogs (3.9.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_log (3.0.0) 1 | plg_system_jooa11y (4.2.0) 1 | plg_system_skipto (4.0.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_privacyconsent (3.9.0) 0 | plg_system_redirect (3.0.0) 1 | plg_system_logrotation (3.9.0) 1 | plg_system_languagefilter (3.0.0) 0 | PLG_SYSTEM_ACTIONLOGS (3.9.0) ? | plg_system_p3p (3.0.0) ? | plg_system_highlight (3.0.0) 1 | plg_system_log (3.0.0) 1 | plg_system_updatenotification (3.5.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_logout (3.0.0) 1 | plg_system_remember (3.0.0) 1 | plg_system_fields (3.7.0) 0 | plg_system_sessiongc (3.8.6) 1 | plg_system_sef (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_stats (3.5.0) 0 | plg_system_weblinks (4.0.1) 0 | plg_system_cache (3.0.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_logout (3.0.0) 1 | plg_system_remember (3.0.0) 1 | PLG_SYSTEM_SCHEDULERUNNER (4.1) 1 | plg_system_httpheaders (4.0.0) 0 | plg_system_fields (3.7.0) 0 | plg_system_webauthn (4.0.0) 1 | plg_system_sessiongc (3.8.6) 1 | plg_system_sef (3.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_stats (3.5.0) 0 | plg_system_task_notification (4.1) 1 | plg_system_cache (3.0.0) 1 | plg_actionlog_joomla (3.9.0) 1 | plg_user_profile (3.0.0) 1 | plg_user_terms (3.9.0) 0 | plg_user_joomla (3.0.0) 1 | plg_user_contactcreator (3.0.0) 0 | plg_user_token (3.9.0) 0 | plg_twofactorauth_totp (3.2.0) 0 | plg_twofactorauth_yubikey (3.2.0) 0 | plg_api-authentication_basic (4.0.0) 0 | plg_api-authentication_token (4.0.0) 1 | plg_sampledata_multilang (4.0.0) 1 | plg_finder_tags (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_finder_weblinks (4.0.1) 1 | plg_finder_content (3.0.0) 1 | plg_filesystem_local (4.0.0) 1 | plg_search_tags (3.0.0) 0 | plg_search_contacts (3.0.0) 1 | plg_search_newsfeeds (3.0.0) 1 | plg_search_categories (3.0.0) 1 | plg_search_weblinks (4.0.1) 1 | plg_search_content (3.0.0) 1 | plg_task_requests (4.1) 1 | plg_task_demo_tasks (4.1) 1 | plg_task_check_files (4.1) 1 | plg_task_site_status (4.1) 1 | plg_fields_usergrouplist (3.7.0) 0 | plg_fields_integer (3.7.0) 0 | plg_fields_subform (4.0.0) 1 | plg_fields_calendar (3.7.0) 0 | plg_fields_text (3.7.0) 0 | plg_fields_textarea (3.7.0) 0 | plg_fields_list (3.7.0) 0 | plg_fields_sql (3.7.0) 0 | plg_fields_user (3.7.0) 0 | plg_fields_imagelist (3.7.0) 0 | plg_fields_editor (3.7.0) 0 | plg_fields_radio (3.7.0) 0 | plg_fields_media (3.7.0) 0 | plg_fields_checkboxes (3.7.0) 0 | plg_fields_url (3.7.0) 0 | plg_fields_color (3.7.0) 0 | plg_privacy_message (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_cookie (3.0.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_media-action_resize (4.0.0) 1 | plg_media-action_rotate (4.0.0) 1 | plg_media-action_crop (4.0.0) 1 | plg_content_joomla (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_pagenavigation (3.0.0) 1 | plg_content_finder (3.0.0) 1 | plg_content_emailcloak (3.0.0) 1 | plg_content_vote (3.0.0) 1 | plg_content_fields (3.7.0) 0 | plg_content_loadmodule (3.0.0) 1 |
3rd Party:: plg_editors-xtd_media (2.0.5) 0 | plg_installer_rsfirewall (1.0.0) 1 | PLG_CWGEARS (0.6.5) ? | plg_system_ossystem (1.3.0) ? | System - Foundry by Stackideas (1.1.8) 1 | plg_system_tjupdates (1.0.3) ? | plg_system_t4 (2.1.4) 1 | plg_system_mediaredirect (2.0.5) ? | System - Foundry by Stackideas (1.1.10) 1 | plg_system_t4 (2.1.7) 1 | System - RSFirewall! Active Scanner (1.4.0) 1 | plg_editors_codemirror (5.65.2) 1 | plg_editors_tinymce (5.10.3) 1 | Search - Easy Blog (5.1.0) 0 | plg_search_media (2.0.5) 0 | plg_community_media (2.0.5) 0 | Content - Fast Social Share (3.9) 1 | plg_content_media (2.0.5) 0 |
Templates Discovered :: wrote:Templates :: Site :: cassiopeia (1.0) 1 | t4_blank (1.1.4) 1 |
Templates :: Admin :: atum (1.0) 0 |
Last edited by toivo on Mon May 23, 2022 8:24 am, edited 1 time in total.
Reason: mod note: disabled smilies in post Options for readability

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Wed May 18, 2022 4:04 pm

There is a problem with storing or reading the upgrade zip file. In Global Configuration / Server what is Path to Temp Folder set to? It is supposed to be the tmp folder within your Joomla root. Look in that folder - are there any files there? The installer unpacks the zip there and then moves the files to their final destinations. Check folder permissions in System / System Information. Disable plg_installer_rsfirewall!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41499
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Webdongle » Wed May 18, 2022 4:16 pm

rsfirewall most likely preventing the update.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Fri May 20, 2022 3:49 pm

Webdongle wrote:
Wed May 18, 2022 4:16 pm
rsfirewall most likely preventing the update.
My other websites use rsfirewall and those can upgrade to Joomla 4.1.3

Now I removed rsfirewall from cadscp.org and I still can't upgrade from Joomla 4.1.2 to Joomla 4.1.3

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Fri May 20, 2022 4:20 pm

ceford wrote:
Wed May 18, 2022 4:04 pm
There is a problem with storing or reading the upgrade zip file. In Global Configuration / Server what is Path to Temp Folder set to? It is supposed to be the tmp folder within your Joomla root. Look in that folder - are there any files there? The installer unpacks the zip there and then moves the files to their final destinations. Check folder permissions in System / System Information. Disable plg_installer_rsfirewall!
Here they are
Path to Temp Folder : home/seekkhmer/domains/cadspc.org/public_html/tmp
Path to Log Folder : home/seekkhmer/domains/cadspc.org/public_html/administrator/logs


I used to upgrade joomla 4.1.x to joomla 4.1.2 already with successful already but now I can't upgrade from Joomla 4.1.2 to joomla 4.1.3

Now i removed rsfirewall but I still can't upgrade it.

thank u

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Fri May 20, 2022 4:44 pm

Places to look for more information:

administrator/logs/joomla_update.php - open with text editor and scroll down to the bottom - is a normal end to the last update reported?

tmp - should normally be empty, except for index.html, but that is where zip files are stored to unpack and install. Is there anything there left over from a failed update?

System / Update / Update Sites - do you see the Joomla Core site?

Joomla Update / Options - are you on the Default update channel?

I don't think any of these things will help - I am guessing something is blocking download of the update zip file.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41499
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Webdongle » Fri May 20, 2022 5:32 pm

saovry wrote:
Fri May 20, 2022 4:20 pm
...
I used to upgrade joomla 4.1.x to joomla 4.1.2 already with successful already but now I can't upgrade from Joomla 4.1.2 to joomla 4.1.3...
What has changed since you updated from 4.1.x to 4.1.2?
Is your T4 Template up to date?
Do the sites that updated successfully have the same T4 Template?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Sat May 21, 2022 3:40 pm

Webdongle wrote:
Fri May 20, 2022 5:32 pm
saovry wrote:
Fri May 20, 2022 4:20 pm
...
I used to upgrade joomla 4.1.x to joomla 4.1.2 already with successful already but now I can't upgrade from Joomla 4.1.2 to joomla 4.1.3...
What has changed since you updated from 4.1.x to 4.1.2?
Is your T4 Template up to date?
Do the sites that updated successfully have the same T4 Template?
It is completed successfully without any issue and I think my all plugins, modules and templates up to date for Joomla 4.

Before I update to Joomla 4, I removed many old party software, they don't support Joomla 4. After I updated to Joomla 4, I installed them with new version to support Joomla 4.

thank you for your helping.

I hope that I still continouse to hear from you again to concern with this topic.

thank

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Sat May 21, 2022 3:56 pm

ceford wrote:
Fri May 20, 2022 4:44 pm
Places to look for more information:

administrator/logs/joomla_update.php - open with text editor and scroll down to the bottom - is a normal end to the last update reported?

tmp - should normally be empty, except for index.html, but that is where zip files are stored to unpack and install. Is there anything there left over from a failed update?

System / Update / Update Sites - do you see the Joomla Core site?

Joomla Update / Options - are you on the Default update channel?

I don't think any of these things will help - I am guessing something is blocking download of the update zip file.
administrator/logs/joomla_update.php - open with text editor and scroll down to the bottom - is a normal end to the last update reported?
I don't see my Joomla_updated.php in my Joomla 4.1.2
Here is the file
Screen Shot 2022-05-21 at 10.53.42 PM.png
what should I do, is it because this file?

System / Update / Update Sites - do you see the Joomla Core site?
I see Joomla and the link
Joomla Core
https://update.joomla.org/core/list.xml

Joomla Update / Options - are you on the Default update channel? Yes, I use the default
You do not have the required permissions to view the files attached to this post.

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Sat May 21, 2022 4:28 pm

You did not say if there is anything in the /tmp folder of your site root. Have you tried the Upload and Update button rather than the Update button - you first need to download the update package to your local computer and then select that when prompted.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41499
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Webdongle » Sat May 21, 2022 5:04 pm

saovry wrote:
Sat May 21, 2022 3:40 pm
...

It is completed successfully without any issue ...
thank
If it is completely successful then what is the problem?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Mon May 23, 2022 7:47 am

ceford wrote:
Sat May 21, 2022 4:28 pm
You did not say if there is anything in the /tmp folder of your site root. Have you tried the Upload and Update button rather than the Update button - you first need to download the update package to your local computer and then select that when prompted.
these is nothing in tmp and I tried to install the joomla 4.1.3 by Update your site by manually uploading the update package

The problem is still the same

An error occurred
The archive is not open for reading.

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Mon May 23, 2022 10:58 am

Something to try - go to administrator/components/com_joomlaupdate/extract.php. At the top you will find this text:

Code: Select all

/**
 * Should you want to debug this file, please add a new line ABOVE this comment with the following
 * contents (excluding the space star space at the start of this line):
 *
 * define('_JOOMLA_UPDATE_DEBUG', 1);
 *
 * This will do two things:
 * - it will create the joomla_update.txt file in your site's temporary directory (default: tmp).
 *   This file contains a debug log, detailing everything extract.php is doing during the extraction
 *   of the Joomla update ZIP file.
 * - It will prevent extract.php from being overwritten during the update with a new version. This
 *   is useful if you are testing any changes in extract.php you do not want accidentally
 *   overwritten, or if you are given a modified extract.php by a Joomla core contributor with
 *   changes which might fix your update problem.
 */
So add:

define('_JOOMLA_UPDATE_DEBUG', 1);

Try the update again and see what is in tmp/joomla_update.txt

Remember to remove that line when the problem is fixed.

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Tue May 24, 2022 3:17 pm

ceford wrote:
Mon May 23, 2022 10:58 am
Something to try - go to administrator/components/com_joomlaupdate/extract.php. At the top you will find this text:

Code: Select all

/**
 * Should you want to debug this file, please add a new line ABOVE this comment with the following
 * contents (excluding the space star space at the start of this line):
 *
 * define('_JOOMLA_UPDATE_DEBUG', 1);
 *
 * This will do two things:
 * - it will create the joomla_update.txt file in your site's temporary directory (default: tmp).
 *   This file contains a debug log, detailing everything extract.php is doing during the extraction
 *   of the Joomla update ZIP file.
 * - It will prevent extract.php from being overwritten during the update with a new version. This
 *   is useful if you are testing any changes in extract.php you do not want accidentally
 *   overwritten, or if you are given a modified extract.php by a Joomla core contributor with
 *   changes which might fix your update problem.
 */
So add:

define('_JOOMLA_UPDATE_DEBUG', 1);

Try the update again and see what is in tmp/joomla_update.txt

Remember to remove that line when the problem is fixed.
1. When I tried to updat again and follow your structure, I get the error message after fail to upgrade Joomla
Here is the message

Server error
Joomla Update encountered a server error when applying the update to your site.
Your site may not have been upgraded completely to the new Joomla version.

2. I don't see tmp/joomla_updated.txt, there is only index.php is in tmp/index.php

User avatar
ceford
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Mon Feb 24, 2014 10:38 pm
Location: Edinburgh, Scotland
Contact:

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by ceford » Tue May 24, 2022 4:39 pm

I reinstalled a download of the 4.1.3 update pack via the Upload and Update button. The tmp/joomla_update.txt file contains 88951 rows. The administrator/logs/joomla_update.php file has just a few additional lines because there were no sql queries to execute.

So I am still guessing that download or upload of your zip file is being blocked,

I have no idea what to suggest next!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41499
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Webdongle » Tue May 24, 2022 6:49 pm

Have you tried downloading the update file then using Upload an install in the Joomla update component?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Wed May 25, 2022 2:57 pm

ceford wrote:
Tue May 24, 2022 4:39 pm
I reinstalled a download of the 4.1.3 update pack via the Upload and Update button. The tmp/joomla_update.txt file contains 88951 rows. The administrator/logs/joomla_update.php file has just a few additional lines because there were no sql queries to execute.

So I am still guessing that download or upload of your zip file is being blocked,

I have no idea what to suggest next!
If the zip file is being blocked, it should happen for all the zip files but I can installed any plugins, module and components also without any problem.

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Wed May 25, 2022 2:59 pm

Webdongle wrote:
Tue May 24, 2022 6:49 pm
Have you tried downloading the update file then using Upload an install in the Joomla update component?
I tried already becuase your team sugguest me before but I still can't upgrade it. It still fail like before.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41499
Joined: Sat Apr 05, 2008 9:58 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by Webdongle » Wed May 25, 2022 3:55 pm

saovry wrote:
Wed May 25, 2022 2:57 pm
...

If the zip file is being blocked, it should happen for all the zip files but I can installed any plugins, module and components also without any problem.
Not accurate. If downloading the update file is blocked it does not mean extensions can't be installed or downloaded.

The fact that you have tried to upload & install with the Joomla update component and it failed without placing anything in /tmp then that should give a clue as to what part of the update is failing.

Temporarily rename .htaccess
Also copy the site to localhost (wamp on your PC) and see if the update works there.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

pixelhexe
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Nov 24, 2006 1:31 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by pixelhexe » Fri May 27, 2022 1:33 am

As I had the same error and solved the problem by correcting the $log_path and $tmp_path - are there possibly missing starting slashs in these paths in your configuration.php?

Path to Temp Folder : /home/seekkhmer/domains/cadspc.org/public_html/tmp
Path to Log Folder : /home/seekkhmer/domains/cadspc.org/public_html/administrator/logs

saovry
Joomla! Explorer
Joomla! Explorer
Posts: 344
Joined: Sat Jan 08, 2011 3:52 pm

Re: Can't upgrade Joomla 4.1.2 to Joomla 4.1.3

Post by saovry » Sat May 28, 2022 2:55 pm

pixelhexe wrote:
Fri May 27, 2022 1:33 am
As I had the same error and solved the problem by correcting the $log_path and $tmp_path - are there possibly missing starting slashs in these paths in your configuration.php?

Path to Temp Folder : /home/seekkhmer/domains/cadspc.org/public_html/tmp
Path to Log Folder : /home/seekkhmer/domains/cadspc.org/public_html/administrator/logs
Thank you for your helping me and shared your experience to everyone here.
If you don't show up for my issue, my website never fix about this issue. Everyone tried to help me but we don't have no ideas, the slashes was the problem for this cause.
thank u you.


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”