Back end error after update to 4.1.4 Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Javdbeek
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed May 25, 2022 3:17 pm

Back end error after update to 4.1.4

Post by Javdbeek » Wed May 25, 2022 3:23 pm

Hi,

I dit the update yesterday and seems to be okay, but today I am not able anymore to enter the backhand from the website. The following error is displayed;
0 Call to a member function getXml() on null
When I check the google web developer console I see a error : GET https://www.domainname.nl/administrator/index.php 500
I am not sure if this is causing the issue but perhaps somebody can point me in the right direction.


When i check the hosting logfile i see the following:

CODE 500 - GET /administrator/index.php HTTP/1.0


php: 8.0.19
FPM by apache
Last edited by toivo on Wed May 25, 2022 9:25 pm, edited 7 times in total.
Reason: mod note: split from 4.1.4 Discussion

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 14702
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Back end error after update to 4.1.4

Post by toivo » Wed May 25, 2022 11:15 pm

Welcome to the Joomla forum!

Does this website use RSFirewall 3.0.8? Another site reported the same issue: Call to a member function getXml() on null
Toivo Talikka, Global Moderator

Javdbeek
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed May 25, 2022 3:17 pm

Re: Back end error after update to 4.1.4

Post by Javdbeek » Thu May 26, 2022 7:23 am

That’s correct
By incident I just found out that when a IP adres is listed I could enter the backend …
So the firewall is causing this issue. I see that there is a update so I will do that directly

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 14702
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Back end error after update to 4.1.4

Post by toivo » Thu May 26, 2022 7:28 am

Thank you for the update. Let us know how it went.
Toivo Talikka, Global Moderator

Javdbeek
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed May 25, 2022 3:17 pm

Re: Back end error after update to 4.1.4

Post by Javdbeek » Thu May 26, 2022 8:21 am

It seems to be all okay now after the update ! So case closed ;)
Thanks for helping out !!


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”