Tags [SITENAME], %s and others are not replaced in update info and password change emails Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Thu Oct 01, 2015 7:52 pm

Tags [SITENAME], %s and others are not replaced in update info and password change emails

Post by tychapogoy » Sat Nov 26, 2022 7:55 am

Hi,

I have some issues of unreplaced tags, which seems to be related:
  • My update emails comes in with unreplaced tags. So, I see [SITENAME], instead of the "set name of the site ", [CURVERSION] instead of "Joomla 4.2.5" or "4.2.5"
  • When requesting password change, the confirmation email link is displayed "%s", instead of https://siteURL.cz/confirmyourpasswordhash_or_else
  • When I change Global Configuration > Site Name, the part of the source code related to the title

    Code: Select all

    <span title="recently changed J4.2 site name">old J3.10 site name</span>
    So, the old site name is displayed, and the new title is in the html tag only.
What could go wrong with the upgrade of the site and how can I correct the behaviour to ensure the correct replacement of tags?

SharkyKZ
Joomla! Hero
Joomla! Hero
Posts: 2506
Joined: Fri Jul 05, 2013 10:35 am
Location: Parts Unknown

Re: Tags [SITENAME], %s and others are not replaced in update info and password change emails

Post by SharkyKZ » Sat Nov 26, 2022 10:33 am

This is usually caused by outdated language packs or language overrides. The new mail templates in J4 reuse the same language constants but perform completely different replacements.

tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Thu Oct 01, 2015 7:52 pm

Re: Tags [SITENAME], %s and others are not replaced in update info and password change emails

Post by tychapogoy » Sat Nov 26, 2022 11:23 am

There is no update for any language.

Some languages have a float information about the possibility that the language is outdated, but their version is 4.2.X so, I do not think that is off. Anyway, no new language pack is available.

I do use some language overrides, but none for [SITENAME] or [CURVERSION]

tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Thu Oct 01, 2015 7:52 pm

Re: Tags [SITENAME], %s and others are not replaced in update info and password change emails

Post by tychapogoy » Sat Nov 26, 2022 1:19 pm

The language settings end lists are confusing. I have two different language lists, then also each of site and administrator: System > Manage > Languages and System > Manage > Content languages
https://imgur.com/a/yrSMPZJ

I wish I could uninstall and install some Content language, but there is no option for it.

tychapogoy
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 207
Joined: Thu Oct 01, 2015 7:52 pm

Re: Tags [SITENAME], %s and others are not replaced in update info and password change emails

Post by tychapogoy » Sat Nov 26, 2022 1:41 pm

It seems that reinstalling the language pack in System > Install > Languages solved the issue. I do not recall any other my invasive action.


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”