No menu or navi after upgrade Topic is solved

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
jn6464
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat May 08, 2021 6:58 am

No menu or navi after upgrade

Post by jn6464 » Mon Aug 14, 2023 4:35 am

After the V3 to V4 upgrade, menu and navigation are missing from our site. How to bring them back? Menu items are still there in the system, articles too, but they are not showing up. We were on the beez3 template before the upgrade. Thanks!

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30479
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: No menu or navi after upgrade

Post by Per Yngve Berg » Mon Aug 14, 2023 4:42 am

Change template to Cassiopeia.

Modules have to be adjusted to new position names.

jn6464
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat May 08, 2021 6:58 am

Re: No menu or navi after upgrade

Post by jn6464 » Mon Sep 25, 2023 5:39 am

Thanks. Yes our template was automatically switched to Cassiopeia in that upgrade.

Under Site Modules I see this now:
modules.png
What kind of adjustment do I need? The menu items themselves seem to be intact...phew!
You do not have the required permissions to view the files attached to this post.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30479
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: No menu or navi after upgrade

Post by Per Yngve Berg » Mon Sep 25, 2023 5:50 am

Change Position. Those Positions are in the Protostar Template.

jn6464
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat May 08, 2021 6:58 am

Re: No menu or navi after upgrade

Post by jn6464 » Tue Sep 26, 2023 5:05 am

Super, that made the trick. Our little site is rising up from the ashes now. Many thanks!

jn6464
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat May 08, 2021 6:58 am

Breezingforms after upgrade

Post by jn6464 » Thu Sep 28, 2023 8:01 am

I now notice that our forms built with BreezingForms Pro are not loading. How could we recover from that?

Version 1.1 is installed, but under Components we see these errors:
breezingforms.png
You do not have the required permissions to view the files attached to this post.

gws
Joomla! Champion
Joomla! Champion
Posts: 5626
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: No menu or navi after upgrade

Post by gws » Thu Sep 28, 2023 8:13 am

Current breezing forms is 1.9.1.

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9318
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: No menu or navi after upgrade

Post by AMurray » Thu Sep 28, 2023 8:55 am

You should have been notified about Breezing forms requiring an update at the Pre-Update check when doing the migration from 3.10.x

Curious also why BreezingForms wouldn't have routinely notified you sooner (or why you haven't updated it sooner), given v1.9.1 is from March 2023.
Regards - A Murray

jn6464
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sat May 08, 2021 6:58 am

Re: No menu or navi after upgrade

Post by jn6464 » Fri Sep 29, 2023 6:13 am

Sorry that was a typo. Indeed version 1.9.1 is installed (dated 2022-12-09).


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”