Finished migration - Smart Search Indexing is broken

Need help upgrading your Joomla! website or converting to Joomla! 4.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
adamrayhelppls
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Tue Nov 07, 2023 7:32 am

Finished migration - Smart Search Indexing is broken

Post by adamrayhelppls » Sat Mar 02, 2024 2:37 am

Hi guys, I've completely finished a full site migration and update of all plugins etc etc. The one issue I have is when trying to replace Search with Smart Search and indexing the site contents, it appears to have thrown an error and I can't delete the current index or rerun the indexing function due to this error.

1. I run the indexer from Smart Search menu under Components
2. It runs for a while, then shows this message:

An Error Has Occurred

Call to undefined method Joomla\Component\Finder\Administrator\Indexer\Helper::getContentPath()

Having done this again recently I now have SOME indexed content I can search with a module, but I would like to be able to handover to the client and let them self-manage this without errors? What could be causing this, has anyone seen this before?

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17426
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Finished migration - Smart Search Indexing is broken

Post by toivo » Sat Mar 02, 2024 4:22 am

adamrayhelppls wrote:
Sat Mar 02, 2024 2:37 am
Call to undefined method Joomla\Component\Finder\Administrator\Indexer\Helper::getContentPath()
The function Helper::getContentPath() is used in Joomla 3. It does not exist in Joomla 4. This means that the website has a third party Smart Search/Finder plugin that is not compatible with Joomla 4.

If you are unable to rerun the indexer while the option System Debug in the System tab of the Global Configuration is turned on, please run the Forum Post Assistant (FPA) by following the instructions at https://forumpostassistant.github.io/docs/ and post the results into your reply so that the configuration can be reviewed.
Toivo Talikka, Global Moderator

adamrayhelppls
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Tue Nov 07, 2023 7:32 am

Re: Finished migration - Smart Search Indexing is broken

Post by adamrayhelppls » Tue Mar 05, 2024 9:28 am

Thanks Toivo, I'll get to this as soon as I can.


Post Reply

Return to “Migrating and Upgrading to Joomla! 4.x”