Accessibility Still not showing up. Topic is solved

This forum is for general questions about extensions for Joomla! 4.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Accessibility Still not showing up.

Post by TheINIC » Wed Sep 14, 2022 6:58 pm

I read the non-answers in post From last January. (viewtopic.php?f=811&t=990995&p=3652949)

Same issue here. Works in FF not Chrome.

I am running Joomla 4.1.5 and Cassiopeia. After installing Joomla 4, I went straight to accessibility and made sure both were on. (System - Additional Accessibility Features plus System - Joomla Accessibility Checker)

The icon shows in FF, Chrome - not!

Has this issue been fixed or if not, will it be on short-list?

~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility icon still not showing up.

Post by sozzled » Wed Sep 14, 2022 8:26 pm

To be clear what we're discussing here, see the screenshot below (the backend login screen using Google Chrome v105.0.5195.127 with J! 4.2.2). Is that what we're talking about?
j4x_accessibilityIcon.png
You do not have the required permissions to view the files attached to this post.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility icon still not showing up.

Post by TheINIC » Thu Sep 15, 2022 4:44 pm

sozzled wrote:
Wed Sep 14, 2022 8:26 pm
To be clear what we're discussing here, see the screenshot below (the backend login screen using Google Chrome v105.0.5195.127 with J! 4.2.2). Is that what we're talking about?

j4x_accessibilityIcon.png
Glad you're still around. Thought you might have taken the week off :)

Should be for both. Front and back but I don't need it on back end just for visitors - it is to b a site about handicappers. Version 105.0.5195.127 (Official Build) (64-bit) -

Works in Firefox, not chrome.
~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 15, 2022 5:56 pm

So, it's not clear what we're discussing here? OK. What are we discussing?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Thu Sep 15, 2022 6:02 pm

sozzled wrote:
Thu Sep 15, 2022 5:56 pm
So, it's not clear what we're discussing here? OK. What are we discussing?
"Accessibility" handicap icon does not appear on any page in Chrome (latest) but does show up in FireFox (using same web site of course).
~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 15, 2022 6:05 pm

Can you provide screenshots to demonstrate this inconsistent behavior, please? I would like to know what you are talking about. Thanks.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Thu Sep 15, 2022 6:16 pm

sozzled wrote:
Thu Sep 15, 2022 6:05 pm
Can you provide screenshots to demonstrate this inconsistent behavior, please? I would like to know what you are talking about. Thanks.
the link you asked for View it in Firefox then in Chrome. The Joomla 4 plugin works in FF, not Joomla 4. Too, Joomla site has a big page dedicated to the Accessibility that Joomla claims is first CMS to introduce Accessibility.

Imagine any website page without a handicap icon.

It is NOT inconsistent. It just doesn't work, at all.

I don't see whats so complicated. Joomla4 and Cassiopeia come together to provide the plugin (Joomla's - no no one elses)

When enabled, the plugin provides the accessible tools to navigate, and for those with visual problems, can see, hear it read, or view it in highj or low contrast. When working, there is a small wheelchair icon on bottom left. Clicking it, will show the tools available that can be auto-read, or whatever the visually impaired need
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 15, 2022 6:32 pm

Please calm down a little. I'm not an expert; I'm just trying to understand what we're discussing.

We are not discussing the backend, right? We're discussing the frontend: Cassiopeia. Yes?
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility icon still not showing up.

Post by sozzled » Thu Sep 15, 2022 6:43 pm

To be clear what we're discussing here, see the screenshot below (the frontend screen using Google Chrome v105.0.5195.127 with J! 4.2.2). Is that what we're talking about?
j4x_accessibilityIcon-frontend.png
You do not have the required permissions to view the files attached to this post.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Ti

Post by TheINIC » Thu Sep 15, 2022 9:41 pm

sozzled wrote:
Thu Sep 15, 2022 6:43 pm
To be clear what we're discussing here, see the screenshot below (the frontend screen using Google Chrome v105.0.5195.127 with J! 4.2.2). Is that what we're talking about?
The plugin is supposed to work On Front or Back or Both, but as I already said, I only need it to work on the Frontend. i.e., don't need it for backend.
NOTE: I tried it using Chrome (latest upgrade):
with the settings Both, reloaded browser and site then,
set to Backend, reloaded browser and site
and also tried the setting Both, reload browser and site.
When I used Firefox, it worked on all I needed, the Frontend.

When testing with FireFox I had, Both, then just back-end, then just front-end and all worked. None worked in Chrome.

The link I gave you shows what is supposed to happen if you use Firefox,. Using the same link, with Chrome, nothing for Accessibility showed up (for the same wheelchair icon in the image you show in your last reply.) It only shows in Firefox.
Maybe if you visit the like I gave using Firefox, you'll see the handicapped icon (like in the pic you showed) and then try it with Chrome. IF you see it in Chrome, then it's my system, which I very much doubt.

SUMMARY:
The plugin by Joomla 4:
Works: with Firefox
No work: in Chrome.

~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 15, 2022 9:50 pm

We're discussing the frontend (Cassiopeia template) only and not the backend (Atum template), right? If you don't confirm that's what we're discussing then there's no point in going further. As I've written before, I'm just trying to be clear about what we're discussing. When you've confirmed that I know what we're talking about, I can then provide more information. OK? Back to you. 8)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 7976
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Accessibility Still not showing up.

Post by AMurray » Thu Sep 15, 2022 10:14 pm

The OP has said he can't see the Accessibility Icon in Google Chrome, but for me, it is showing, as expected in Chrome (v105.0.5195.126), Firefox (v104.0.1) and Edge (105.0.1343.33).
Regards - A Murray

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 15, 2022 10:19 pm

Same here, @AMurray. Works for me with Cassiopeia.

But despite my attempts to get a straight yes or no answer to my questions, I'm still unclear whether we're discussing a possible issue with Cassiopeia or with some other front-end template. Until we know exactly what we're discussing, I can't make any further comments or suggestions as to what's happening.

I can add Opera to the list of browsers that I've tested, too.

UPDATE: Hold on. I'm checking the link to the problem website (where the accessibility icon is reported as "missing" in Google Chrome)!

FURTHER UPDATE: Problem not confirmed with my own testing. The problem website uses a Cassiopeia template. The accessibility icon is present in Firefox, Google Chrome, MS Edge, Opera. Screenshot to follow shortly.
Last edited by sozzled on Thu Sep 15, 2022 10:44 pm, edited 1 time in total.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 15, 2022 10:38 pm

This is what I see:

[ redacted ]

The cause of the OP's issue? One of the following:
  1. A broken web browser (re-install Google Chrome)
  2. Stale browser cache (force a browser refresh CTRL_F5)
  3. A conflicting browser add-on
  4. Heightened security on the OP's PC (try another device to see if it works there)
  5. Extraordinarily slow internet connection: the accessibility icon took one second to appear after the page loaded when I tested it.
:)
Last edited by toivo on Wed Sep 21, 2022 11:28 pm, edited 1 time in total.
Reason: mod note: image removed on request
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Fri Sep 16, 2022 8:39 pm

AMurray wrote:
Thu Sep 15, 2022 10:14 pm
The OP has said he can't see the Accessibility Icon in Google Chrome, but for me, it is showing, as expected in Chrome (v105.0.5195.126), Firefox (v104.0.1) and Edge (105.0.1343.33).
Thanks very much @AMurry. That helps me narrow done the issue that may be causing the problem.
If you didn't live so far away, I'd send you a case of your favourite beer. :)

~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Fri Sep 16, 2022 8:41 pm

sozzled wrote:
Thu Sep 15, 2022 10:38 pm
This is what I see:

ere4wkc_accessibilityIcon.png

The cause of the OP's issue? One of the following:
  1. A broken web browser (re-install Google Chrome)
  2. Stale browser cache (force a browser refresh CTRL_F5)
  3. A conflicting browser add-on
  4. Heightened security on the OP's PC (try another device to see if it works there)
  5. Extraordinarily slow internet connection: the accessibility icon took one second to appear after the page loaded when I tested it.
:)
Please remove the image from your post. See it in your reply. Thank you.
~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Fri Sep 16, 2022 9:01 pm

Does the information I posted help you? Have you resolved your problem? ???
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Fri Sep 16, 2022 11:03 pm

sozzled wrote:
Fri Sep 16, 2022 9:01 pm
Does the information I posted help you? Have you resolved your problem? ???
Yes. Problem is solved. I have to disable all stalker-blockers.
~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Wed Sep 21, 2022 10:06 pm

sozzled wrote:
Thu Sep 15, 2022 10:38 pm
This is what I see:
ere4wkc_accessibilityIcon.png
@Sozzled. I'd like to ask that you delete the image of the website for me. It's a long story. Thanks.
sozzled wrote:
Thu Sep 15, 2022 10:38 pm

The cause of the OP's issue? One of the following:
  1. A broken web browser (re-install Google Chrome)
  2. Stale browser cache (force a browser refresh CTRL_F5)
  3. A conflicting browser add-on
  4. Heightened security on the OP's PC (try another device to see if it works there)
  5. Extraordinarily slow internet connection: the accessibility icon took one second to appear after the page loaded when I tested it.
:)
Yes, I had done all that before I searched the Internet and then posted here.

Process of elimination suggest it is the browser. Though Chrome is up to date, as is PHP. FYI, and others with same or similar issue, I can see the Admins test web page on bottom right of each page. So I gather once logged in via backend, that one is auto access/logged into the front end as well.

Thanks for your help - as far as it goes, the icon shows for everyone, and the admin icon doesn't, except for me.

~Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: How to use the forum to get something done

Post by sozzled » Wed Sep 21, 2022 10:17 pm

Whenever you want something done on the forum (e.g. ask for a comment, link, or image to be removed, change the subject, move the topic to a different forum, etc.), you can report a post to a forum moderator—the yellow "!" icon—and ask a forum moderator to make a change. I cannot "delete" anything I wrote several days ago any more than I can delete the link that you posted posted in this discussion topic that refers to the target site. You can do those things yourself by reporting a post (or posts) to the forum moderators who may then do something about your request. 8)
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 14959
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Accessibility Still not showing up.

Post by toivo » Wed Sep 21, 2022 11:30 pm

TheINIC wrote:
Wed Sep 21, 2022 10:06 pm
@Sozzled. I'd like to ask that you delete the image of the website for me.
The screenshot has now been removed from the post.
Toivo Talikka, Global Moderator

TheINIC
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 169
Joined: Thu Feb 17, 2011 5:27 am
Location: Earth - but that too is temporary.
Contact:

Re: Accessibility Still not showing up.

Post by TheINIC » Thu Sep 22, 2022 9:12 pm

@sozzled
@AMurray

Found source of problem. The icon is white w/ transparent background.

I couldn't see the icon because I was looking for the icon on a page with white a background without downsizing my 1920 x 1080 screen.

@sozzled saw it in the screen cap he provided that had a blue background because the image sozzled was viewing with was responsive to his device being smaller than my desktop. White-on-blue verses white-on-white.
Sozzled is right. It was showing the whole time - on small screens.

My Solution:

I intend to find the icon, and give it a background - in short, non-transparent.


I am very sorry for wasting everyone's time. I've attached a image that shows the differences, in case anyone else has similar problems. Additionally, I tried to attach, don't know if it. This reply is a work-in-progress :)
Well, not able to attach the file. Sorry
:-[
Ti
CAUTION: Anything you say can and will be taken out of context and used against you in the courts of social media

User avatar
sozzled
Joomla! Master
Joomla! Master
Posts: 12663
Joined: Sun Jul 05, 2009 3:30 am
Location: Canberra, Australia

Re: Accessibility Still not showing up.

Post by sozzled » Thu Sep 22, 2022 9:48 pm

No problem; just FYI, I use a 27" curved-screen monitor at 1920 x 1080 px resolution. I also make sure that I'm viewing web pages at normal zoom.

In my case, the accessibility icon on your target website (regardless of whether I use Firefox, Google Chrome, MS Edge, Opera) is grey-coloured, not white, and appears a half-second after the page is loaded. So I don't understand (a) what you're describing as white, or (b) the need to change the background colour from transparent to something else. It is as it is. But, yeah, maybe the accessibility icon is not prominent enough for people with poor eyesight and one could make it more prominent by changing the background colour to bright yellow with CSS, like this:

Code: Select all

i._access-icon {
    background-color: yellow;
    font-style: normal;
    transform: none;
    padding-left: 6px;
}
Please be careful in future to use terms like "non-answers" when referring to thoughts we may offer on this forum; we do our best. Sometimes we hit the mark and sometimes we don't. When one loads a question with terms like "non-answers" one is more likely to shoot oneself in the foot instead of hitting the desired target. 8)

Lastly, attaching an image to a post on the forum should be fairly straightforward if you use the "Full Editor & Preview" form of replying instead of the "Quick Reply" form.
“If you think I’m wrong then say, ‘I think you’re wrong.’ If you say ‘You’re wrong!’, how do you know?”
Walking the talk: https://j4xdemo.enduring.com.au
:)


Post Reply

Return to “Extensions for Joomla! 4.x”