Error 500 after Joomla update with CWattachments

This forum is for general questions about extensions for Joomla! 4.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
User avatar
FDE68
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue Oct 18, 2005 2:51 pm

Error 500 after Joomla update with CWattachments

Post by FDE68 » Fri Nov 24, 2023 3:26 pm

Hello,
I use the extension CW Attachments, with which I can add file attachments (mostly PDF) to posts.
This is wonderful in the last version.

Since the update to Joomla 4.4.0, however, I can no longer access the component in the backend.

The red error 500 page of Joomla appears.

When I activate the reporting, I read:

Fatal error: Access level to CWAttachmentsViewCWAttachments::setDocument() must be public (as in class Joomla\CMS\MVC\View\AbstractView) in /var/www/salvator_gs/htdocs/site_x23/administrator/components/com_cwattachments/views/cwattachments/view.html.php on line 110

It seems to be "only" about the view and calculations.

That it is related to the last Joomla version is certain, as I have other pages in this constellation. The component works ...
> Update Joomla to 4.4.0 - error message.

Unfortunately, the developer does not respond - although I have had contact several times over the years to clarify problems or incompatibilities that once existed. But that was a long time ago.

Does anybody know, if he is active any more?

So thanks for any tips ...
By the way, I'm waiting to see when there will be another Joomla update ... which would solve the problem?

gsmela
Joomla! Explorer
Joomla! Explorer
Posts: 289
Joined: Thu Jun 10, 2010 12:38 pm
Contact:

Re: Error 500 after Joomla update with CWattachments

Post by gsmela » Fri Nov 24, 2023 4:57 pm

Are you using the free or the Pro version?

The free version hasn't been updated in three years and is only listed for Joomla 3 while the Pro version says it works with Joomla 4.

User avatar
FDE68
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue Oct 18, 2005 2:51 pm

Re: Error 500 after Joomla update with CWattachments

Post by FDE68 » Tue Nov 28, 2023 12:06 pm

Hello, it works fine with Joomla 4 basically - if this was not clear, sorry for misunderstanding. U use the pro version, of course.

Another J4 Page with 4.3.1 runs fine.
But with update auf 4.4.0 i see this mess.

So ... the developer should check this and provide an update.

But he is not responding - is he noch active any more?
The website seems to be ok - but if i log in to set up a support ticket, i get a error 400 by sending this ticket.

So now - i would be happy, if anybody in this community can help to solve this problem.

Thank you

mmcculli
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Feb 29, 2012 6:24 pm

Re: Error 500 after Joomla update with CWattachments

Post by mmcculli » Sat Dec 02, 2023 3:01 pm

I had this exact same issue happen when I upgraded from 4.3.1 to 4.4.0. One of my custom extensions stated to get that same error message. I could not figure out what is wrong with my HtmlView file. I tried changing the setDocument function to public, but just got a different error.

This is what I did to resolve it.

To took all the code that was in the protected function setDocument() and move it where I was calling it in the display function. In short, replace $this->setDocument() with the code itself. Doesn't make the class read as nice but for me it resolved the issue.

Hope this helps.

User avatar
FDE68
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Tue Oct 18, 2005 2:51 pm

Re: Error 500 after Joomla update with CWattachments

Post by FDE68 » Fri Dec 08, 2023 2:25 pm

Hello @mmcculli - thank you for this info. I need to understand, what the code is, what will be loaded ...

This exactly is the code from line 110 in the view.html.php

>>>>>>>
/**
* Method to set up the document properties
*
* @return void
*/
protected function setDocument()
{
$document = JFactory::getDocument();
$document->setTitle(JText::_('COM_CWATTACHMENTS_ADMINISTRATION'));
}
<<<<<<

Any ideas, where to get the code ... to fill it in here in this file?
Thank you!

samuelagus
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 18, 2020 8:25 am

Re: Error 500 after Joomla update with CWattachments

Post by samuelagus » Thu Feb 29, 2024 7:00 pm

FDE68 wrote:
Fri Dec 08, 2023 2:25 pm
Hello @mmcculli - thank you for this info. I need to understand, what the code is, what will be loaded ...

This exactly is the code from line 110 in the view.html.php

>>>>>>>
/**
* Method to set up the document properties
*
* @return void
*/
protected function setDocument()
{
$document = JFactory::getDocument();
$document->setTitle(JText::_('COM_CWATTACHMENTS_ADMINISTRATION'));
}
<<<<<<

Any ideas, where to get the code ... to fill it in here in this file?
Thank you!
Hi...
Try to rename setDocument to setupDocument
I've tried it in my component, then it works :)

Ref: https://docs.joomla.org/J3.x:Developing ... etDocument


Post Reply

Return to “Extensions for Joomla! 4.x”