Advertisement

CAPTCHA Error 504 Backend or gateway connection timeout Topic is solved

This forum is for general questions about extensions for Joomla! 4.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
trisha_d
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Jun 12, 2024 3:08 pm

CAPTCHA Error 504 Backend or gateway connection timeout

Post by trisha_d » Wed Jun 12, 2024 3:21 pm

Hi, I'm supporting a customer who is running J4.3.4 with CAPTCHA v2 plugin and all was working up until a couple of months ago (they just reported it to me last week). I found this topic, but no resolution was given:
viewtopic.php?f=814&t=997557&p=3675346#p3675346

The hosting company had been engaged and their response was "We tested the site using local DNS {without WAF} and contact page is still not sending mails. It looks an issue with Captcha plugin or compatibility issue with other plugins installed under the site. We recommend you to check this with the help of your developer or application vendor. Also please advise them to suggest a suitable Captcha option for the site."

We also tried using hCaptcha plugin (https://data2site.com/) and the same happens, so there may certainly be a conflict with another plugin or extension.

There are 125 active/enabled Plugins however, so how do I check to see which one is/are causing the conflict?

NOTE: when no CAPTCHA is enabled, the contact form works perfectly, but the customer is being spammed without it.

Any help is greatly appreciated.

Thanks, Trisha

trisha_d
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Jun 12, 2024 3:08 pm

Re: CAPTCHA Error 504 Backend or gateway connection timeout

Post by trisha_d » Wed Jun 12, 2024 3:31 pm

Forum Post Assistant (v1.6.7) : 12-Jun-2024 wrote:
Last PHP Error(s) Reported :: wrote:[12-Jun-2024 01:11:27 UTC] PHP Deprecated: str_replace(): Passing null to parameter #3 ($subject) of type array|string is deprecated in /home/*******/public_html/libraries/src/Uri/Uri.php on line 243
Basic Environment :: wrote:Joomla! Instance :: Joomla! 4.3.4-Stable (Bora) 22-August-2023
Joomla! Configured :: Yes | Read-Only (444) |
Configuration Options :: Offline: false | SEF: true | SEF Suffix: false | SEF ReWrite: false | .htaccess/web.config: Yes | GZip: false | Cache: false | CacheTime: 1 | CacheHandler: file | CachePlatformPrefix: false | FTP Layer: N/A | Proxy: false | LiveSite: | Session lifetime: 60 | Session handler: database | Shared sessions: false | SSL: 0 | Error Reporting: maximum | Site Debug: false | Language Debug: false | Default Access: Public | Unicode Slugs: false | dbConnection Type: mysqli | PHP Supports J! 4.3.4: No | Database Supports J! 4.3.4: Yes | Database Credentials Present: Yes |

Host Configuration :: OS: Linux | OS Version: 4.18.0-553.el8_10.x86_64 | Technology: x86_64 | Web Server: Apache | Encoding: gzip, deflate, br, zstd | System TMP Writable: Yes | Free Disk Space : 58.75 GiB |

PHP Configuration :: Version: 8.3.8 | PHP API: cgi-fcgi | Session Path Writable: Yes | Display Errors: 0 | Error Reporting: 32759 | Log Errors To: error_log | Last Known Error: 12th June 2024 01:11:27. | Register Globals: | Magic Quotes: | Safe Mode: | Allow url fopen: No | Open Base: | Uploads: 1 | Max. Upload Size: 300M | Max. POST Size: 384M | Max. Input Time: 60 | Max. Execution Time: 120 | Memory Limit: 512M

Database Configuration :: Version: 8.0.37 (Client:mysqlnd 8.3.8) | Database Size: 34.63 MiB | #of Tables with config prefix:  174 | #of other Tables:  0 | User Privileges : GRANT ALL
Detailed Environment :: wrote:PHP Extensions :: Core (8.3.8) | date (8.3.8) | libxml (8.3.8) | openssl (8.3.8) | pcre (8.3.8) | zlib (8.3.8) | filter (8.3.8) | hash (8.3.8) | json (8.3.8) | pcntl (8.3.8) | random (8.3.8) | readline (8.3.8) | Reflection (8.3.8) | SPL (8.3.8) | session (8.3.8) | standard (8.3.8) | cgi-fcgi (8.3.8) | ctype (8.3.8) | dom (20031129) | mbstring (8.3.8) | fileinfo (8.3.8) | ftp (8.3.8) | gd (8.3.8) | iconv (8.3.8) | exif (8.3.8) | mysqlnd (mysqlnd 8.3.8) | PDO (8.3.8) | Phar (8.3.8) | posix (8.3.8) | SimpleXML (8.3.8) | sqlite3 (8.3.8) | tokenizer (8.3.8) | xml (8.3.8) | xmlwriter (8.3.8) | xsl (8.3.8) | mysqli (8.3.8) | pdo_mysql (8.3.8) | pdo_sqlite (8.3.8) | xmlreader (8.3.8) | Zend Engine (4.3.8) |
Potential Missing Extensions :: zip | curl |

Switch User Environment :: PHP CGI: Yes | Server SU: Yes | PHP SU: Yes | Potential Ownership Issues: No
Folder Permissions :: wrote:Core Folders :: images/ (755) | components/ (755) | modules/ (755) | plugins/ (755) | language/ (755) | templates/ (755) | cache/ (755) | logs/ (755) | tmp/ (755) | administrator/components/ (755) | administrator/modules/ (755) | administrator/language/ (755) | administrator/templates/ (755) | administrator/logs/ (755) | api/ (755) |

Elevated Permissions (First 10) :: images/archived/ (775) | images/downloads/archived/ (775) | images/downloads/archived/BoD - Board Documents/ (775) | images/downloads/archived/NPSSTS Exec - Executive Documents/ (775) | images/downloads/archived/NPSSTS Staff - Master Lists/ (775) | images/downloads/archived/Schools - Principals Advisory Committee Meetings/ (775) | images/downloads/executives/ (775) | images/downloads/jobpostings/ (775) | images/downloads/safety/ (775) | images/downloads/schools/ (775) |
Database Information :: wrote:Database statistics :: Uptime: 185941 | Threads: 5 | Questions: 286962 | Slow queries: 13 | Opens: 5443 | Flush tables: 3 | Open tables: 3080 | Queries per second avg: 1.543 |
Extensions Discovered :: wrote:Components :: Site ::
Core ::
3rd Party::

Components :: Admin ::
Core :: com_ajax (4.0.0) 1 | com_users (4.0.0) 1 | com_categories (4.0.0) 1 | com_modules (4.0.0) 1 | com_fields (4.0.0) 1 | com_checkin (4.0.0) 1 | com_templates (4.0.0) 1 | com_cache (4.0.0) 1 | com_tags (4.0.0) 1 | com_workflow (4.0.0) 1 | com_actionlogs (3.9.0) 1 | com_newsfeeds (4.0.0) 1 | com_wrapper (4.0.0) 1 | com_languages (4.0.0) 1 | com_scheduler (4.1.0) 1 | com_joomlaupdate (4.0.3) 1 | com_messages (4.0.0) 1 | com_privacy (3.9.0) 1 | com_contenthistory (4.0.0) 1 | com_mails (4.0.0) 1 | com_installer (4.0.0) 1 | com_finder (4.0.0) 1 | com_config (4.0.0) 1 | com_postinstall (4.0.0) 1 | com_plugins (4.0.0) 1 | com_cpanel (4.0.0) 1 | com_search (4.0.0-dev) 1 | com_content (4.0.0) 1 | com_banners (4.0.0) 1 | com_guidedtours (4.3.0) 1 | com_menus (4.0.0) 1 | com_associations (4.0.0) 1 | com_login (4.0.0) 1 | com_media (3.0.0) 1 | com_redirect (4.0.0) 1 | com_admin (4.0.0) 1 |
3rd Party:: com_akeebabackup (9.6.2) 1 | SP Simple Portfolio (2.0.7) 1 | Smart Slider 3 (3.5.1.17) 1 | com_qf3 (3.3.03) 1 | COM_K2 (2.10.3) 0 | com_kunena (6.0.10) 0 | Acym (7.5.5) 0 |

Modules :: Site ::
Core :: mod_articles_categories (3.0.0) 1 | mod_syndicate (3.0.0) 1 | mod_footer (3.0.0) 1 | mod_whosonline (3.0.0) 1 | mod_related_items (3.0.0) 1 | mod_banners (3.0.0) 1 | mod_random_image (3.0.0) 1 | mod_languages (3.5.0) 1 | mod_wrapper (3.0.0) 1 | mod_custom (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_users_latest (3.0.0) 1 | mod_articles_archive (3.0.0) 1 | mod_articles_category (3.0.0) 1 | mod_tags_similar (3.1.0) 1 | mod_tags_popular (3.1.0) 1 | mod_stats (3.0.0) 1 | mod_finder (3.0.0) 1 | mod_articles_popular (3.0.0) 1 | mod_search (4.0.0-dev) 1 | mod_login (3.0.0) 1 | mod_breadcrumbs (3.0.0) 1 | mod_articles_latest (3.0.0) 1 | mod_articles_news (3.0.0) 1 | mod_menu (3.0.0) 1 |
3rd Party:: JT Carousel (1.0) 1 | JT Tabs (1.2) 1 | Sidepanel JT1 (2.0) 1 | JFlickr (1.4.2) 1 | SJ Social Media Counter (1.1.3) 1 | JE Orbit SlideShow (3.3) 1 | Player Squad JT (1.0) 1 | mod_highlighter_gk5 (1.2.4) 1 | Pop up JT (1.6) 1 | JT Content Slider (2.9.6) 1 | VerticalScroller JT Pro (1.9) 1 | JT Login (1.4) 0 | SP Simple Portfolio Module (2.0.7) 1 | mod_qf3 (3.9.01) 1 | JT Image Gallery (1.1) 1 | Smart Slider 3 Module (3.5.1.17) 1 | Articles Count (3.0.2) 1 | Headline JT5 (1.3) 1 | JT Testimonial (1.0) 1 | mod_kunenalatest (6.0.2) 0 | AcyMailing subscription form (7.5.5) 0 |

Modules :: Admin ::
Core :: mod_privacy_status (4.0.0) 1 | mod_latest (3.0.0) 1 | mod_loginsupport (4.0.0) 1 | mod_multilangstatus (3.0.0) 1 | mod_submenu (3.0.0) 1 | mod_guidedtours (4.3.0) 1 | mod_custom (3.0.0) 1 | mod_user (4.0.0) 1 | mod_logged (3.0.0) 1 | mod_feed (3.0.0) 1 | mod_stats_admin (3.0.0) 1 | mod_frontend (4.0.0) 1 | mod_title (3.0.0) 1 | mod_messages (4.0.0) 1 | mod_post_installation_messages (4.0.0) 1 | mod_version (3.0.0) 1 | mod_quickicon (3.0.0) 1 | mod_login (3.0.0) 1 | mod_popular (3.0.0) 1 | mod_latestactions (3.9.0) 1 | mod_privacy_dashboard (3.9.0) 1 | mod_menu (3.0.0) 1 | mod_sampledata (3.8.0) 1 | mod_toolbar (3.0.0) 1 |
3rd Party::

Libraries ::
Core ::
3rd Party:: Kunena Framework (6.0.10) 0 | Regular Labs Library (23.12.10783) 1 |

Plugins ::
Core :: plg_fields_color (3.7.0) 1 | plg_fields_checkboxes (3.7.0) 1 | plg_fields_user (3.7.0) 1 | plg_fields_editor (3.7.0) 1 | plg_fields_text (3.7.0) 1 | plg_fields_calendar (3.7.0) 1 | plg_fields_subform (4.0.0) 1 | plg_fields_media (3.7.0) 1 | plg_fields_list (3.7.0) 1 | plg_fields_url (3.7.0) 1 | plg_fields_integer (3.7.0) 1 | plg_fields_usergrouplist (3.7.0) 1 | plg_fields_radio (3.7.0) 1 | plg_fields_sql (3.7.0) 1 | plg_fields_imagelist (3.7.0) 1 | plg_fields_textarea (3.7.0) 1 | plg_system_fields (3.7.0) 1 | plg_system_task_notification (4.1) 1 | plg_system_updatenotification (3.5.0) 0 | plg_system_sessiongc (3.8.6) 1 | plg_system_skipto (4.0.0) 1 | plg_system_debug (3.0.0) 1 | plg_system_log (3.0.0) 1 | plg_system_cache (3.0.0) 0 | plg_system_stats (3.5.0) 1 | plg_system_highlight (3.0.0) 1 | plg_system_httpheaders (4.0.0) 0 | plg_system_sef (3.0.0) 1 | plg_system_remember (3.0.0) 0 | plg_system_jooa11y (4.2.0) 1 | plg_system_actionlogs (3.9.0) 1 | plg_system_guidedtours (4.3.0) 1 | plg_system_redirect (3.0.0) 1 | plg_system_logrotation (3.9.0) 1 | plg_system_languagefilter (3.0.0) 1 | plg_system_accessibility (4.0.0) 0 | plg_system_webauthn (4.0.0) 0 | plg_system_shortcut (4.2.0) 1 | plg_system_languagecode (3.0.0) 0 | plg_system_logout (3.0.0) 1 | plg_system_privacyconsent (3.9.0) 0 | plg_system_schedulerunner (4.1) 1 | plg_finder_newsfeeds (3.0.0) 1 | plg_finder_tags (3.0.0) 1 | plg_finder_content (3.0.0) 1 | plg_finder_contacts (3.0.0) 1 | plg_finder_categories (3.0.0) 1 | plg_user_contactcreator (3.0.0) 0 | plg_user_joomla (3.0.0) 1 | plg_user_terms (3.9.0) 0 | plg_user_token (3.9.0) 1 | plg_user_profile (3.0.0) 0 | plg_editors-xtd_fields (3.7.0) 1 | plg_editors-xtd_module (3.5.0) 1 | plg_editors-xtd_readmore (3.0.0) 1 | plg_editors-xtd_article (3.0.0) 1 | plg_editors-xtd_pagebreak (3.0.0) 1 | plg_editors-xtd_menu (3.7.0) 1 | plg_editors-xtd_image (3.0.0) 1 | plg_sampledata_multilang (4.0.0) 0 | plg_task_requests (4.1) 1 | plg_task_demo_tasks (4.1) 1 | plg_task_site_status (4.1) 1 | plg_task_check_files (4.1) 1 | plg_behaviour_taggable (4.0.0) 0 | plg_behaviour_versionable (4.0.0) 1 | plg_media-action_rotate (4.0.0) 1 | plg_media-action_crop (4.0.0) 1 | plg_media-action_resize (4.0.0) 1 | plg_search_newsfeeds (4.0.0-dev) 1 | plg_search_tags (4.0.0-dev) 1 | plg_search_content (4.0.0-dev) 1 | plg_search_contacts (4.0.0-dev) 1 | plg_search_categories (4.0.0-dev) 1 | plg_webservices_messages (4.0.0) 1 | plg_webservices_templates (4.0.0) 1 | plg_webservices_modules (4.0.0) 1 | plg_webservices_newsfeeds (4.0.0) 1 | plg_webservices_installer (4.0.0) 1 | plg_webservices_config (4.0.0) 1 | plg_webservices_redirect (4.0.0) 1 | plg_webservices_media (4.1.0) 1 | plg_webservices_privacy (4.0.0) 1 | plg_webservices_users (4.0.0) 1 | plg_webservices_banners (4.0.0) 1 | plg_webservices_languages (4.0.0) 1 | plg_webservices_tags (4.0.0) 1 | plg_webservices_plugins (4.0.0) 1 | plg_webservices_content (4.0.0) 1 | plg_webservices_menus (4.0.0) 1 | plg_installer_webinstaller (4.0.0) 1 | plg_installer_packageinstaller (3.6.0) 1 | plg_installer_folderinstaller (3.6.0) 1 | plg_installer_override (4.0.0) 1 | plg_installer_urlinstaller (3.6.0) 1 | plg_workflow_notification (4.0.0) 1 | plg_workflow_featuring (4.0.0) 1 | plg_workflow_publishing (4.0.0) 1 | plg_filesystem_local (4.0.0) 1 | plg_privacy_user (3.9.0) 1 | plg_privacy_actionlogs (3.9.0) 1 | plg_privacy_consents (3.9.0) 1 | plg_privacy_message (3.9.0) 1 | plg_privacy_content (3.9.0) 1 | plg_actionlog_joomla (3.9.0) 0 | plg_api-authentication_token (4.0.0) 0 | plg_api-authentication_basic (4.0.0) 0 | plg_multifactorauth_fixed (4.2.0) 0 | plg_multifactorauth_totp (3.2.0) 0 | plg_multifactorauth_webauthn (4.2.0) 0 | plg_multifactorauth_yubikey (3.2.0) 0 | plg_multifactorauth_email (4.2.0) 0 | plg_quickicon_joomlaupdate (3.0.0) 1 | plg_quickicon_phpversioncheck (3.7.0) 1 | plg_quickicon_overridecheck (4.0.0) 0 | plg_quickicon_privacycheck (3.9.0) 1 | plg_quickicon_extensionupdate (3.0.0) 1 | plg_quickicon_downloadkey (4.0.0) 1 | plg_authentication_ldap (3.0.0) 0 | plg_authentication_joomla (3.0.0) 1 | plg_authentication_cookie (3.0.0) 1 | plg_content_fields (3.7.0) 1 | plg_content_finder (3.0.0) 1 | plg_content_vote (3.0.0) 0 | plg_content_loadmodule (3.0.0) 1 | plg_content_confirmconsent (3.9.0) 0 | plg_content_emailcloak (3.0.0) 1 | plg_content_pagebreak (3.0.0) 1 | plg_content_joomla (3.0.0) 1 | plg_content_pagenavigation (3.0.0) 1 | plg_extension_finder (4.0.0) 1 | plg_extension_namespacemap (4.0.0) 1 | plg_extension_joomla (3.0.0) 1 | plg_captcha_recaptcha (3.4.0) 1 | plg_captcha_recaptcha_invisible (3.8) 0 |
3rd Party:: plg_system_kunena (6.0.10) 0 | PLG_SYSTEM_REGULARLABS (23.12.10783) 1 | AcyMailing - JCE integration (7.5.5) 0 | AcyMailing - Override Joomla emails (7.5.5) 0 | Smart Slider 3 System Plugin (3.5.1.17) 1 | plg_system_ic_library (1.4) 1 | AcyMailing - Joomla integration (7.5.5) 0 | PLG_SYSTEM_SOURCERER (10.0.4) 1 | T3 Framework (3.2.0) 1 | T3 Framework (3.1.3) 1 | plg_kunena_kunena (6.0.10) 0 | plg_kunena_joomla (6.0.10) 0 | PLG_EDITORS-XTD_SOURCERER (10.0.4) 1 | plg_sampledata_kunena (6.0.10) 0 | AcyMailing - Search emails in Jooml (7.5.5) ? | Smart Slider 3 Updater Plugin (3.5.1.17) 1 | plg_editors_tinymce (5.10.7) 1 | plg_editors_codemirror (5.65.12) 1 | plg_quickicon_kunena (6.0.10) 0 | plg_copy_module_assignments (3.0.0) 1 | plg_content_qf3 (3.9.01) 1 | plg_captcha_hcaptcha (1.4.3) 0 |
Templates Discovered :: wrote:Templates :: Site :: caven (1.0) 1 | cassiopeia (1.0) 1 |
Templates :: Admin :: atum (1.0) 1 |

Mr. Wimpy
Joomla! Explorer
Joomla! Explorer
Posts: 496
Joined: Fri Dec 02, 2005 10:46 am
Location: The Netherlands

Re: CAPTCHA Error 504 Backend or gateway connection timeout

Post by Mr. Wimpy » Wed Jun 12, 2024 6:39 pm

- First: if not done so: do a backup

- Allow url fopen: No, should be Yes, ask the host
- PHP supports J!4.3.4: No, PHP version is too high, set to 8.2
- Joomla 4.3.4 Update Joomla to 4.4.5
- Elevated folder permissions: 775, should be 755
- Update extensions
- K2 is not compatible with J4/5

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9975
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: CAPTCHA Error 504 Backend or gateway connection timeout

Post by AMurray » Wed Jun 12, 2024 9:54 pm

To reemphasise some of the above points (from @MrWimpy) you're running EOL PHP 8.0 and Joomla 4.3.4. I would update both - for security and functional purposes.
Regards - A Murray
General Support Moderator

trisha_d
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Jun 12, 2024 3:08 pm

Re: CAPTCHA Error 504 Backend or gateway connection timeout

Post by trisha_d » Thu Jun 13, 2024 1:22 pm

Mr. Wimpy wrote: Wed Jun 12, 2024 6:39 pm - First: if not done so: do a backup

- Allow url fopen: No, should be Yes, ask the host
- PHP supports J!4.3.4: No, PHP version is too high, set to 8.2
- Joomla 4.3.4 Update Joomla to 4.4.5
- Elevated folder permissions: 775, should be 755
- Update extensions
- K2 is not compatible with J4/5
Thank you - will try this!

trisha_d
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Jun 12, 2024 3:08 pm

Re: CAPTCHA Error 504 Backend or gateway connection timeout

Post by trisha_d » Tue Jun 18, 2024 11:58 pm

Thank you again for your help. For anyone else having this problem.. I did the following and it worked:

Allow URL fopen - changed to Yes
Set PHP to 8.2

I also updated extensions and uninstalled K2. We are planning to upgrade this summer to 4.4.5 but need to test the template and all the plugins/extensions first.

Again, Many thanks!! Trisha
Mr. Wimpy wrote: Wed Jun 12, 2024 6:39 pm - First: if not done so: do a backup

- Allow url fopen: No, should be Yes, ask the host
- PHP supports J!4.3.4: No, PHP version is too high, set to 8.2
- Joomla 4.3.4 Update Joomla to 4.4.5
- Elevated folder permissions: 775, should be 755
- Update extensions
- K2 is not compatible with J4/5


Post Reply

Return to “Extensions for Joomla! 4.x”