Update to 4.4.1 and Helix-ultimate Template blip

Everything to do with Joomla! 4.x templates and templating.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
User avatar
colin99
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 233
Joined: Tue Nov 22, 2005 6:35 am
Location: Victoria - Canada
Contact:

Update to 4.4.1 and Helix-ultimate Template blip

Post by colin99 » Tue Nov 28, 2023 5:29 pm

Just did an update to Joomla 4.4.1 and my template seems to be missing a few pieces as shown in the attached image...

Other than that, the update went well...
You do not have the required permissions to view the files attached to this post.
Editor-Creator coffeecrew.com | dxer.ca | Coffeecrew.com and a whole bunch of neat websites - Joomla user since DAY 1!

User avatar
colin99
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 233
Joined: Tue Nov 22, 2005 6:35 am
Location: Victoria - Canada
Contact:

Re: Update to 4.4.1 and Helix-ultimate Template blip

Post by colin99 » Tue Nov 28, 2023 7:12 pm

Lots of reports on this issue -- looks like the update has changed/corrupted the path for the language file --

Joomshaper website forum has quite a few posts -- no fix as of yet.
Editor-Creator coffeecrew.com | dxer.ca | Coffeecrew.com and a whole bunch of neat websites - Joomla user since DAY 1!

User avatar
ozneilau
Joomla! Guru
Joomla! Guru
Posts: 872
Joined: Tue Aug 04, 2009 9:05 am
Location: Tasmania, Australia
Contact:

Re: Update to 4.4.1 and Helix-ultimate Template blip

Post by ozneilau » Wed Nov 29, 2023 2:13 am

As a temporary fix, I have added the following custom CSS on a website I look after for the same problem you are seeing on the front-end of your website:

Code: Select all

.sp-sign-in > span:last-of-type {display: none !important;}

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17256
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Update to 4.4.1 and Helix-ultimate Template blip

Post by toivo » Wed Nov 29, 2023 7:10 am

This Issue Tracker item has a temporary workaround, tested in Joomla 4.4.1 and 5.0.1. Please note that the reverted files may cause issues elsewhere.

[#42416] - [4.4.1] Language constants of some extensions not translated
Toivo Talikka, Global Moderator

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 12775
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Update to 4.4.1 and Helix-ultimate Template blip

Post by brian » Wed Nov 29, 2023 7:33 am

Do not revert those files. The changes in those files address a security issue.

The root cause of the issue is the language files themself. Both the site and the admin language files for the template are invalid.

Both of them have a faulty string for COM_FINDER_ADVANCED_TIPS

As can be seen there is one invalid string. Instead of it being on one line ending with " it is spread across multiple lines.

As soon as you remove the hard returns in the string everything works.

This is not a core bug ut a problem in the language file that is now exposed.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17256
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Update to 4.4.1 and Helix-ultimate Template blip

Post by toivo » Wed Nov 29, 2023 9:30 am

Thank you, @brian. I raised a new feature request in the FPA subforum and also in Github to get the FPA to report linebreaks in language strings so that issues can be reported if extensions have invalid language files.
Toivo Talikka, Global Moderator


Post Reply

Return to “Templates for Joomla! 4.x”