Problem with meta tags

Discuss Search Engine Optimization in relation to Joomla! 4.x. This forum will also have discussions on SEF/SEO Joomla! 4.x extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
Merl06
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Oct 20, 2022 4:58 am

Problem with meta tags

Post by Merl06 » Sat Nov 05, 2022 7:02 pm

Hello everyone. Again I have to turn to you for help. After installing Joomla 4.2.4, I transferred the site content to it, made settings and came across 2 unpleasant things: 1) the <base href="https://mysite.loc" /> tag is not displayed and 2) the meta tag is not displayed < meta name="keywords" content="..."> how can I fix this please help me. I read about keywords and their irrelevance for Google, but still, even in Google they have little weight, and in other search engines the situation will be better.

User avatar
Rondeb
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problem with meta tags

Post by Rondeb » Sat Nov 05, 2022 10:31 pm

Hi,

do you have a link of your site?

Ron :)

Merl06
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Oct 20, 2022 4:58 am

Re: Problem with meta tags

Post by Merl06 » Sun Nov 06, 2022 2:03 am

The site is on a local server and joomla 3.10.10 is running on the hosting

User avatar
Rondeb
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problem with meta tags

Post by Rondeb » Sun Nov 06, 2022 11:34 am

Hi,

which template do you use?

Friendly URLs and .htaccess enabled?

Ron :)

Merl06
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Oct 20, 2022 4:58 am

Re: Problem with meta tags

Post by Merl06 » Sun Nov 06, 2022 4:23 pm

I am using the standard cassiopeia template.
Friendly links enabled and .htaccess enabled too

User avatar
Rondeb
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problem with meta tags

Post by Rondeb » Sun Nov 06, 2022 4:41 pm

Hi,

When you create a menu item and link an article to it and enter all meta for the article, what is visible?

By the way, you don't use an SEO extension?

Ron :)

Merl06
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Oct 20, 2022 4:58 am

Re: Problem with meta tags

Post by Merl06 » Sun Nov 06, 2022 5:16 pm

I haven't installed SEO extensions yet, but I plan to... Keywords are entered only in articles, they are not in menu items...

Here are the metas that are displayed on the page:

Code: Select all

        <meta charset="utf-8">
	<meta name="rights" content="ООО Теплолидер">
	<meta name="author" content="Super User">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<meta name="description" content="Теплолидер">
	<meta name="generator" content="Joomla! - Open Source Content Management">

User avatar
Rondeb
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problem with meta tags

Post by Rondeb » Sun Nov 06, 2022 7:16 pm

Hi,

download your configuration.php to your desktop.

Look at live_site and enter your domain there, if it's good you will get base href tag.

Ron :)

Merl06
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Oct 20, 2022 4:58 am

Re: Problem with meta tags

Post by Merl06 » Mon Nov 07, 2022 3:05 am

in the config file, the live_site field is filled in from the start...

User avatar
Rondeb
Joomla! Guru
Joomla! Guru
Posts: 551
Joined: Mon Dec 02, 2013 12:14 pm
Location: Meschede - Germany
Contact:

Re: Problem with meta tags

Post by Rondeb » Mon Nov 07, 2022 6:48 pm

Hi,

And if you delete it now, what happens?

Ron :)

Merl06
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Oct 20, 2022 4:58 am

Re: Problem with meta tags

Post by Merl06 » Tue Nov 08, 2022 2:42 am

Hi,

If you delete the Live Site field, then nothing happens, the situation does not change...

pl71
Joomla! Apprentice
Joomla! Apprentice
Posts: 33
Joined: Tue Mar 18, 2014 11:24 am

Re: Problem with meta tags

Post by pl71 » Tue Nov 08, 2022 8:19 am

2) the meta tag is not displayed < meta name="keywords" content="...">
This meta tag is abandoned in Joomla 4 series, being considered not relevant to SEO.
In case you want it back, you should modify the template's "index.php" by yourself.
See here.
Worth to read this also.

monherry9
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Nov 25, 2022 9:39 pm

Re: Problem with meta tags

Post by monherry9 » Fri Nov 25, 2022 9:49 pm

I was solve this problem. The problem was that i was using url's in Greek language. I convert them to Latin letters and everything was solved. Now all meta tag data works.


Post Reply

Return to “Search Engine Optimization (Joomla! SEO) in Joomla! 4.x”