Page 1 of 1

Editors werken niet meer

Posted: Wed Mar 19, 2008 5:46 pm
by dam-man
Ik heb nu op 2 van mijn sites het probleem in IE dat de editor helemaal niets meer weer geeft en fouten van javascript weergeeft. In FireFox werkt alles helemaal goed. Ik kan echter neit van mijn klanten verwachten dat ze overstappen op FF omdat ze CMS al eng vinden klinken.

Dus houd in dat in het 'schrijf vlak' helemaal niets meer staat.. Ik kan niet verklaren hoe het komt.
Wellicht heeft iemand van jullie dit al eens mee gemaakt? Ook de butons werken niet meer??

Robert

Re: Editors werken niet meer

Posted: Wed Mar 19, 2008 7:44 pm
by pe7er
Treedt de fout op aan op front-end of back-end?

De WYSIWYG editor werkt niet goed in de Back-end?
Hoe benader je de website?
http://www.yoursite.com/administrator of http://yoursite.com/administrator
Hoe staat $mosConfig_live_site ingesteld in configuration.php ? met of zonder www. ?
Zie (Engelstalig): http://forum.joomla.org/viewtopic.php?t=87198

De WYSIWYG editor werkt niet goed in de Front-end?
Bevat jouw template's index.php:
<?php if ( $my->id ) { initEditor(); } ?>
<?php mosShowHead(); ?>


Maak je gebruik van .htaccess ?
Kun je die even uitzetten (hernoem naar htaccess.txt) en nogmaals testen?

Welke 3rd party extensions gebruik je op de sites?

Re: Editors werken niet meer

Posted: Wed Mar 19, 2008 9:11 pm
by dam-man
Toppie!

Betreft: Back-End
3rd Paries: 2 eigen gemaakte scripts en JCE (nieuwste versie)

Probleem getackled! Ze benaderen natuurlijk de site met www en ik had hem idd in de configuration.php zonder www gedefinieerd. Dus ze benaderen hem anders en dan werkt het idd niet. Ik bendader de site wel altijd zonder www en dus werkte het bij mij altijd wel. Daarom kon ik nooit zien dat het niet werkte, zij bellen en ik roepen dat het probleem er niet is :D Nou das dan mooi om te weten.

Bedankt Peter!

Re: Editors werken niet meer

Posted: Wed Mar 19, 2008 10:41 pm
by sc00zy
Dit probleem komt me ook erg bekend voor. Laatst nog dezelfde problemen gehad. Gelukkig had ik snel genoeg zo'n helder moment als Peter ook had ;)

Re: Editors werken niet meer

Posted: Thu Mar 20, 2008 7:56 am
by dam-man
sc00zy wrote:Dit probleem komt me ook erg bekend voor. Laatst nog dezelfde problemen gehad. Gelukkig had ik snel genoeg zo'n helder moment als Peter ook had ;)
Ik heb zelfs 1 site helemaal opnieuw geinstalleerd, dar kreeg ik helemaal geen helder moment en ik kon hier op het forum niets over vinden... 1 volledige re-install, terwijl je het met 3 letters op kan lossen.. :'(

Re: Editors werken niet meer

Posted: Thu Mar 20, 2008 8:34 am
by pe7er
dam-man wrote:Ik heb zelfs 1 site helemaal opnieuw geinstalleerd, dar kreeg ik helemaal geen helder moment en ik kon hier op het forum niets over vinden... 1 volledige re-install, terwijl je het met 3 letters op kan lossen.. :'(
:(
Om te voorkomen dat de site verschillend benaderd wordt (met of zonder www.) kun je twee regels in je .htaccess opnemen die een website als example.com altijd omzet naar http://www.example.com:

Code: Select all

RewriteCond %{HTTP_HOST} ^yoursite\.com [NC]
RewriteRule (.*) http://www.yoursite.com/$1 [R=301,L]

Re: Editors werken niet meer

Posted: Thu Mar 20, 2008 3:37 pm
by dam-man
Goeie tip!

Ik ga het proberen. bedankt Peter