No Databases to Choose From Topic is solved

Need help installing Joomla! 5.x? For all Joomla! 5.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
bluedock
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 04, 2013 10:08 pm

No Databases to Choose From

Post by bluedock » Wed Apr 10, 2024 8:14 pm

FYI, I've been using Joomla for over 12 years running a website business with other marketing services. Tried Wordpress in the beginning and that was horrible. Tried Joomla 1.5 and never turned back! Love how Joomla has improved over the years and only gotten better. I wouldn't want to use another platform. Big Fan! (bluedockmedia.com)

That being said, I have been on 3.x since 3 started and I've now used J4 about 6 times and decided it's time to jump into J5. (btw - have been loving the new layout, for J4 & J5, after getting used to it)

I say all of this to let you know I'm very savvy to the installation process. I just loaded Joomla 5.0.3 and during the installation process I'm frazzled. I literally just downloaded J5 from the Joomla website a few minutes ago.

In the "Database Configuration" section, under "Select the database type. *", there is only one option that says "None". Since this is a required field, I cannot go forward with an install.

Very strange ... therefore I need help!

I will say my next move would be to try reinstalling but I thought I would drop question here first, before I go through with that and may need help anyway.

I tried to add a screenshot for your reference but I was not able to submit my post with an attachment.
(Now that is VERY frustrating!)

Here is a link to my site with the screenshot. https://bluedockmedia.com/j5-screenshot

Thanks!

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 31027
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: No Databases to Choose From

Post by Per Yngve Berg » Wed Apr 10, 2024 8:19 pm

check that your php configuration have a database client included.

gws
Joomla! Champion
Joomla! Champion
Posts: 6005
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: No Databases to Choose From

Post by gws » Wed Apr 10, 2024 8:23 pm

Check the hosts data base meet the J5 minimum....

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44132
Joined: Sat Apr 05, 2008 9:58 pm

Re: No Databases to Choose From

Post by Webdongle » Wed Apr 10, 2024 8:44 pm

http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

bluedock
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 04, 2013 10:08 pm

Re: No Databases to Choose From

Post by bluedock » Wed Apr 10, 2024 9:10 pm

Thanks so much for that VERY FAST response and yes that worked!

I will say that I have to put a hold on J5 now because after that worked, I then found that J5 requires MySQL version 8.0.13 and I'm on 5.7.44. If I upgrade that will affect all of my sites, server wide, and I have still have a couple on 2.5 and several over 50 on 3.x ... geeesh!

Do you know if those other versions of Joomla (2.5, 3.x, J4) would work on the newest MySQL version 8.0.13?

Thanks again for your super fast response!

bluedock
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Apr 04, 2013 10:08 pm

Re: No Databases to Choose From

Post by bluedock » Wed Apr 10, 2024 9:39 pm

I found my own answer: It's a big NO for now because J 3.x won't work in mysql 8.x

Oh well, I have some upgrading to do.

Thanks all.

CrackedCredenza
I've been banned!
Posts: 7
Joined: Wed Apr 03, 2024 11:17 pm

Re: No Databases to Choose From

Post by CrackedCredenza » Wed Apr 10, 2024 9:43 pm

MySQL 8.x won't work with Joomla 2.5, no. I can use MySQL 8.0 with Joomla 3.10.12; try it yourself.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44132
Joined: Sat Apr 05, 2008 9:58 pm

Re: No Databases to Choose From

Post by Webdongle » Wed Apr 10, 2024 11:30 pm

Can you not install different database versions? The server I use allows the choice of database version when I create a database. I can export the database, create a database of a newer version, import the sql and edit the configuration.php. But I use Akeeba to install the backup to a newly created database. Is it not possible for you to do that?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".


Post Reply

Return to “Installation Joomla! 5.x”