Advertisement

500 error on Amazon Linux 2

Need help installing Joomla! 5.x? For all Joomla! 5.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
trvail
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 03, 2024 11:21 pm

500 error on Amazon Linux 2

Post by trvail » Wed Jul 03, 2024 11:25 pm

Hello,

I just installed LAMP on an AWS linux 2 server, all updated. I followed these instructions https://forum.phparea.com/thread/how-to ... mla-on-aws, installing the latest joomla zip, but I got an error about php versioning, as the default is php 5 or something. I upgraded and the site threw a 500 error. I started a new EC2 server from scratch, and instead installed the Php 8.2 via the amazon linux extras install and got the exact same error.

Any suggestions to put me in the right direction would be greatly appreciated! I am brand new to Joomla, but coming from installing many Wordpress installations over the years.

Thank you!
Tim

Advertisement
User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 25079
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, Netherlands
Contact:

Re: 500 error on Amazon Linux 2

Post by pe7er » Thu Jul 04, 2024 4:07 am

Welcome to Joomla forum!

How did you check the PHP version?
The PHP CLI version can differ from the PHP used by your webserver (Apache/Nginx/OpenLiteSpeed/etc).
Joomla uses mainly the webserver PHP versionl and the CLI only for Command Line Interface scripts.

CLI PHP check:

Code: Select all

$ php -v
Webserver PHP check:
create a file check.php and add

Code: Select all

<?php phpinfo();
and open it via a web browser.
Kind Regards,
Peter Martin, Global Moderator
Company website: https://db8.nl/en/ - Joomla specialist, Nijmegen, Netherlands
The best website: https://the-best-website.com

trvail
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 03, 2024 11:21 pm

Re: 500 error on Amazon Linux 2

Post by trvail » Sat Jul 06, 2024 6:38 pm

Thank you, but both are 8.2. I checked via the console / cli and the phpinfo.php method.

The php / web server puts out:

PHP Version 8.2.19
System Linux (ip).amzn2.x86_64 #1 SMP Tue Jun 18 14:00:06 UTC 2024 x86_64
Build Date May 21 2024 22:57:37
Build System Linux
Server API FPM/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc
Loaded Configuration File /etc/php.ini
Scan this dir for additional .ini files /etc/php.d
Additional .ini files parsed /etc/php.d/20-bz2.ini, /etc/php.d/20-calendar.ini, /etc/php.d/20-ctype.ini, /etc/php.d/20-curl.ini, /etc/php.d/20-exif.ini, /etc/php.d/20-fileinfo.ini, /etc/php.d/20-ftp.ini, /etc/php.d/20-gettext.ini, /etc/php.d/20-iconv.ini, /etc/php.d/20-mysqlnd.ini, /etc/php.d/20-pdo.ini, /etc/php.d/20-phar.ini, /etc/php.d/20-sockets.ini, /etc/php.d/20-sqlite3.ini, /etc/php.d/20-tokenizer.ini, /etc/php.d/20-zip.ini, /etc/php.d/30-mysqli.ini, /etc/php.d/30-pdo_mysql.ini, /etc/php.d/30-pdo_sqlite.ini

Advertisement

Post Reply

Return to “Installation Joomla! 5.x”