You need MariaDB 10.4 or higher to continue the installation

Need help installing Joomla! 5.x? For all Joomla! 5.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10
Post Reply
User avatar
romagromov
Joomla! Intern
Joomla! Intern
Posts: 60
Joined: Fri Mar 09, 2012 4:17 pm

You need MariaDB 10.4 or higher to continue the installation

Post by romagromov » Wed Oct 18, 2023 10:15 am

Hello!
I'm trying to install Joomla 5.
Getting message, that I can't install it with this error:
You need MariaDB 10.4 or higher to continue the installation. Your version is: 10.1.48-MariaDB-0+deb9u2
I'm confused, because I'm using MySQL DB.

I think Joomla can't work with two different databases at the same time...
Best free windows software at bestwinsoft.com

nacc
I've been banned!
Posts: 347
Joined: Mon Jul 03, 2023 7:08 pm

Re: You need MariaDB 10.4 or higher to continue the installation

Post by nacc » Wed Oct 18, 2023 1:13 pm


User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9739
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: You need MariaDB 10.4 or higher to continue the installation

Post by AMurray » Wed Oct 18, 2023 9:38 pm

You need MariaDB 10.4.0 or MySQL 8.1.0 or PostgreSQL 12.0.x or higher.
https://manual.joomla.org/docs/next/get ... uirements/

Per the above post referenced, lots of people were caught out with the MySQL thing if their web host is only using MYSQL 5.7 J5 won't install.
Regards - A Murray
General Support Moderator

User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2636
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: You need MariaDB 10.4 or higher to continue the installation

Post by JAVesey » Thu Oct 19, 2023 5:15 pm

AMurray wrote:
Wed Oct 18, 2023 9:38 pm
You need MariaDB 10.4.0 or MySQL 8.1.0 or PostgreSQL 12.0.x or higher.
https://manual.joomla.org/docs/next/get ... uirements/

Per the above post referenced, lots of people were caught out with the MySQL thing if their web host is only using MYSQL 5.7 J5 won't install.
Need MySQL 8.0.13 or later...
John V
Cardiff, Wales, UK
Joomla 5.1.0 "live" site on PHP 8.2.15 and MariaDB 10.11.7
Joomla 5.1.0 on XAMMP for OSX with PHP 8.2.4 and MariaDB 10.4.28


Post Reply

Return to “Installation Joomla! 5.x”