Update to version 5

Need help upgrading your Joomla! website or converting to Joomla! 5.x?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
User avatar
JAVesey
Joomla! Hero
Joomla! Hero
Posts: 2634
Joined: Tue May 14, 2013 1:21 pm
Location: Cardiff, Wales, UK
Contact:

Re: Update to version 5

Post by JAVesey » Fri Feb 16, 2024 9:58 am

Mr. Wimpy wrote:
Fri Feb 16, 2024 7:53 am
- F0F May be used by other extensions, disable and check if everything still works constantly used, I guess I should leave it, shouldn't I?
You can leave it, you can disable it and uninstall it later when you are more certain it is not used.
Might be installed with Akeeba extensions? If so then might need uninstalling before upgrade.

Akeeba have made available a tool for removing unnecessary files from their products before J3 —> J4 upgrade (and thereafter). It’s called Magic Eraser and is available here:
https://github.com/akeeba/magiceraser/r ... /tag/1.0.1
John V
Cardiff, Wales, UK
Joomla 5.1.0 "live" site on PHP 8.2.15 and MariaDB 10.11.7
Joomla 5.1.0 on XAMMP for OSX with PHP 8.2.4 and MariaDB 10.4.28

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Fri Feb 16, 2024 11:56 am

I deleted old data from DB, disabled Smartlook and installed MagicEraser from this link:
https://github.com/akeeba/magiceraser/r ... /tag/1.0.1

I ran the update and it didn't do well again:
https://recordit.co/RLpPiYJ1bD

I start debug mode over: configuration.php
Snímka obrazovky 2024-02-16 o 13.18.56.png

What else should I try? :(
You do not have the required permissions to view the files attached to this post.

Mr. Wimpy
Joomla! Explorer
Joomla! Explorer
Posts: 441
Joined: Fri Dec 02, 2005 10:46 am
Location: The Netherlands

Re: Update to version 5

Post by Mr. Wimpy » Sat Feb 17, 2024 10:07 am

Okay... I'm running out of ideas...

1. JoomShopping (JShopping)
I thought you had uninstalled it. I still see it in your video.
Maybe I misunderstood and you only uninstalled Tagz.

2. Behaviour - Backwards Compatibility plugin
You say you don't have it
In J4 the description of this plugin says it needs to be activated before updating to J5
And JoomShopping needs it

Quick Question: Is this plugin available in the updated site? (Just wondering)
If you can't check in the backend, look in the database in #__extensions for plg_behaviour_compat.


Anyway, this plugin was part of J4.4. It should have been there...

Let's see if we can get it:

Reinstall the last backup of the site on your localhost, so we don't have do everything over again.
Then, go to System > Install > Discover and press the button Discover. Does it show the plugin? If so, install it.

If not:
Go to System > Install > Joomla
Make sure the update Channel is set to Default
Then you should see a button that says Reinstall Joomla! core files
Press it and then check if the plugin Behaviour - Backwards compatibility is available now.

After this I think I have run out of ideas...

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Sat Feb 17, 2024 8:05 pm

1. JoomShopping (JShopping)
I use this plugin

2. Behaviour - Backwards Compatibility plugin
I don't think I have

Is this plugin available in the updated site? (Just wondering)
In DB I found this entry
Snímka obrazovky 2024-02-17 o 20.51.44.png
Then, go to System > Install > Discover and press the button Discover
Here is a video of what happened: https://recordit.co/T93bzMImyM

Go to System > Install > Joomla
I don't have that option there. Am I looking right?
Snímka obrazovky 2024-02-17 o 20.55.59.png
What am I doing wrong? I uninstalled the FoxContact resolution a long time ago and it keeps popping up. Could it be causing some problems? How do I reinstall joomla on 4.4.2 so I can then update and v5?
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44070
Joined: Sat Apr 05, 2008 9:58 pm

Re: Update to version 5

Post by Webdongle » Sat Feb 17, 2024 8:39 pm

Do you have a backup of the site before the failed update?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Sun Feb 18, 2024 11:43 am

Yes, I have a backup, but it's over a year old, from date 2022-10-10, it's still Joomla version 3.10.11.
Preview: https://recordit.co/ndrUzZxuq8

So besides updating Joomla itself, some plugins have been replaced since then, because not all of them supported J4. And not to mention the content of the site itself, which has been changed, modified and added.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44070
Joined: Sat Apr 05, 2008 9:58 pm

Re: Update to version 5

Post by Webdongle » Sun Feb 18, 2024 3:37 pm

So you never made a backup prior to the failed update? Buy you must have ticked the box? Pity that recovery will not be easy now.

Behaviour - Backwards Compatibility plugin can be found in plugins search
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Sun Feb 18, 2024 5:19 pm

Wow,
- uninstalled some extensions that were already disable anyway,
- added Behaviour - Backwards Compatibility plugin,
- did a manual update from 4.4.2 to 4.4.2,
- then update to J5 and joy is here!
Screenshot 2024-02-18 at 18.13.43.png

Now to figure out how to get it from localhost to live version. :)
You do not have the required permissions to view the files attached to this post.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44070
Joined: Sat Apr 05, 2008 9:58 pm

Re: Update to version 5

Post by Webdongle » Sun Feb 18, 2024 6:23 pm

Akeeba and kickstart
1. Make a jpa backup
2. Create a new compatible database
3. Delete the Joomla folders/files from the live site
4. Upload the kickstart.php and jpa backup
5. Point your browser at yoursite.com/kickstart.php

https://www.akeeba.com/download.html
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Sun Feb 18, 2024 7:41 pm

Ok, J5 it is already online on the web. I have additional question:

I made a backup on the updated site on J5, and during the backup the following errors popped up again: https://recordit.co/hvqNcEJ0Gm
The backup finally ended with a successful result, the question is whether I can trust such a backup?
Screenshot 2024-02-18 at 20.28.39.png

Question two, does this parameter cause this error? max_execution_time 600s

I contacted the hosting and their response:
we have set max_execution_time 600s on the hosting. I'm sorry but this setting cannot be adjusted as it is globally set and would affect other clients

is that a big problem?
You do not have the required permissions to view the files attached to this post.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30888
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Update to version 5

Post by Per Yngve Berg » Sun Feb 18, 2024 8:58 pm

600s is 10 minutes. That is more than most servers have.

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Mon Feb 19, 2024 10:36 am

I can trust such a backup?
https://recordit.co/hvqNcEJ0Gm

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44070
Joined: Sat Apr 05, 2008 9:58 pm

Re: Update to version 5

Post by Webdongle » Mon Feb 19, 2024 2:48 pm

You are trying to fix a failed update like a patchwork quilt. once the backup fails you most likely have a mismatch of files/database. The ideal way to recover is wipe everything and reinstate your backup but you have no recent backup.

If your database is intact you might be able to reproduce your site.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20652
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ Germany/ S'pore/Bogor/ North America
Contact:

Re: Update to version 5

Post by leolam » Mon Feb 19, 2024 5:14 pm

AMurray wrote:
Sat Feb 10, 2024 12:30 am
Your web host may provide a backup service - ask them if they have a recent backup of your site from the time before you did the update.
That is never a good idea since they are never up-to-date.....Like asking No Daddy to restore a backup :)

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -

User avatar
AMurray
Joomla! Exemplar
Joomla! Exemplar
Posts: 9707
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Update to version 5

Post by AMurray » Mon Feb 19, 2024 9:10 pm

never said it was a "good" idea :).

My host does daily backups...(but then I also do my own with Akeeba)
Regards - A Murray
General Support Moderator

thodorisgo
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Jan 31, 2011 10:30 pm

Re: Update to version 5

Post by thodorisgo » Sun Feb 25, 2024 9:54 pm

Here is how i solved this issue.
From my database i dissabled all the akeeba backup entries on _extensions table by setting the enabled value to 0:
com_akeebabackup
PLG_QUICKICON_AKEEBABACKUP
pkg_akeebabackup

Hope this helps.

Regards

grezom
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Feb 15, 2021 10:45 am

Re: Update to version 5

Post by grezom » Mon Feb 26, 2024 7:12 am

thodorisgo wrote:
Sun Feb 25, 2024 9:54 pm
Here is how i solved this issue.
From my database i dissabled all the akeeba backup entries on _extensions table by setting the enabled value to 0:
com_akeebabackup
PLG_QUICKICON_AKEEBABACKUP
pkg_akeebabackup

Hope this helps.

Regards
I want to use Akeeba backup, but I don't want it to make errors during backup. If I disable the things you mention in DB, will Akeeba work ok?

thodorisgo
Joomla! Apprentice
Joomla! Apprentice
Posts: 37
Joined: Mon Jan 31, 2011 10:30 pm

Re: Update to version 5

Post by thodorisgo » Mon Feb 26, 2024 8:00 am

grezom wrote:
Mon Feb 26, 2024 7:12 am
I want to use Akeeba backup, but I don't want it to make errors during backup. If I disable the things you mention in DB, will Akeeba work ok?
With the steps that i described you just disable the component. Try it and check if it fixes your issue. You can enable it again later.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 17423
Joined: Thu Feb 15, 2007 5:48 am
Location: Sydney, Australia

Re: Update to version 5

Post by toivo » Mon Feb 26, 2024 8:04 am

grezom wrote:
Mon Feb 26, 2024 7:12 am
If I disable the things you mention in DB, will Akeeba work ok?
If you do that, you would not be able to load Akeeba Backup.

Akeeba Backup is a reliable and popular extension. There are no reasons why it should be disabled.
Toivo Talikka, Global Moderator


Post Reply

Return to “Migrating and Upgrading to Joomla! 5.x”