Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

This forum is for general questions about extensions for Joomla! 5.x.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Windows Defender SmartScreen Issues <-- please read this if using Windows 10.
Post Reply
masterfromf
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 15, 2016 11:54 pm

Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by masterfromf » Mon Feb 19, 2024 12:03 am

I have instal joomla on localhost, when i instal vw, I cant to use it. It have this mistake
No Shop Currency defined! Go to http://localhost/joomla5/administrator/ ... k=editshop
Joomla is 5 wm iz com_virtuemart.4.2.4.10922
I am beginer please help me ?

() JROOT\libraries\vendor\joomla\filesystem\src\Path.php:194
2 Joomla\Filesystem\Path::clean() JROOT\administrator\components\com_virtuemart\helpers\shopfunctions.php:1322
3 ShopFunctions::checkSafePathBase() JROOT\administrator\components\com_virtuemart\helpers\shopfunctions.php:1186
4 ShopFunctions::getSafePathFor() JROOT\administrator\components\com_virtuemart\helpers\adminui.php:130
5 AdminUIHelper::writeVmm() JROOT\administrator\components\com_virtuemart\helpers\adminui.php:105
6 AdminUIHelper::startAdminArea() JROOT\administrator\components\com_virtuemart\views\virtuemart\tmpl\default.php:23
7 include() JROOT\libraries\src\MVC\View\HtmlView.php:416
8 Joomla\CMS\MVC\View\HtmlView->loadTemplate() JROOT\administrator\components\com_virtuemart\helpers\vmviewadmin.php:78
9 VmViewAdmin->display() JROOT\administrator\components\com_virtuemart\views\virtuemart\view.html.php:113
10 VirtuemartViewVirtuemart->display() JROOT\administrator\components\com_virtuemart\helpers\vmcontroller.php:126
11 VmController->display() JROOT\libraries\src\MVC\Controller\BaseController.php:730
12 Joomla\CMS\MVC\Controller\BaseController->execute() JROOT\administrator\components\com_virtuemart\virtuemart.php:77
13 require_once() JROOT\libraries\src\Dispatcher\LegacyComponentDispatcher.php:71
14 Joomla\CMS\Dispatcher\LegacyComponentDispatcher::Joomla\CMS\Dispatcher\{closure}() JROOT\libraries\src\Dispatcher\LegacyComponentDispatcher.php:73
15 Joomla\CMS\Dispatcher\LegacyComponentDispatcher->dispatch() JROOT\libraries\src\Component\ComponentHelper.php:361
16 Joomla\CMS\Component\ComponentHelper::renderComponent() JROOT\libraries\src\Application\AdministratorApplication.php:150
17 Joomla\CMS\Application\AdministratorApplication->dispatch() JROOT\libraries\src\Application\AdministratorApplication.php:195
18 Joomla\CMS\Application\AdministratorApplication->doExecute() JROOT\libraries\src\Application\CMSApplication.php:306
19 Joomla\CMS\Application\CMSApplication->execute() JROOT\administrator\includes\app.php:58
20 require_once() JROOT\administrator\index.php:32
Last edited by toivo on Mon Feb 19, 2024 1:59 am, edited 1 time in total.
Reason: mod note: moved from 5.x Installation

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 44067
Joined: Sat Apr 05, 2008 9:58 pm

Re: Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by Webdongle » Mon Feb 19, 2024 4:40 am

Did you use vm's install to install Joomla and vm?
What do vm devs say?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 30880
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by Per Yngve Berg » Mon Feb 19, 2024 6:40 am

https://forum.virtuemart.net/index.php?topic=150623.0

Have you enabled the Backward Compatibility Plugin in J5?

Mr. Wimpy
Joomla! Explorer
Joomla! Explorer
Posts: 441
Joined: Fri Dec 02, 2005 10:46 am
Location: The Netherlands

Re: Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by Mr. Wimpy » Mon Feb 19, 2024 12:48 pm

Update Virtuemart to 4.2.6 and see if that helps.

Some light reading...
https://virtuemart.net/news/virtuemart-for-joomla-5

masterfromf
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 15, 2016 11:54 pm

Re: Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by masterfromf » Mon Feb 19, 2024 10:55 pm

Per Yngve Berg wrote:
Mon Feb 19, 2024 6:40 am
https://forum.virtuemart.net/index.php?topic=150623.0

Have you enabled the Backward Compatibility Plugin in J5?
Yes it is enable ..

masterfromf
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 15, 2016 11:54 pm

Re: Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by masterfromf » Mon Feb 19, 2024 10:58 pm

Webdongle wrote:
Mon Feb 19, 2024 4:40 am
Did you use vm's install to install Joomla and vm?
What do vm devs say?
Installed new joomla from cpanel and new vm
I didn't find anything useful on the Vm forum

masterfromf
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 15, 2016 11:54 pm

Re: Installation, Migration & Upgrade / Re: Joomla 5.0.0 and VM 4.2.0

Post by masterfromf » Mon Feb 19, 2024 11:25 pm

This is help to me
you can temporarily remove it

in /libraries/src/HTML/HTMLHelper.php

in line 158 delete this entry:

Code: [Select]
// if (!$path) {
// throw new \InvalidArgumentException(sprintf('%s %s not found.', $prefix, $file), 500);
// }

/libraries/vendor/joomla/filesystem/src/Path.php

in line 193
Code: [Select]
// if (!\is_string($path)) {
// throw new \InvalidArgumentException('You must specify a non-empty path to clean');
// }


Post Reply

Return to “Extensions for Joomla! 5.x”