Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

A place to discuss recent announcements made by the Joomla! Core Team. Let's hear what you have to say.
User avatar
Chris
Joomla! Guru
Joomla! Guru
Posts: 812
Joined: Sat Aug 20, 2005 3:58 am
Location: Australia
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Chris » Wed Nov 23, 2005 4:00 am

Fabster wrote: After the upgrade I have a few problems with displaying the content. I have a few content items that I generated in another application and copied the whole html into "No WSISWYG editor". Everything was fine with Joomla! 1.0.3 but now I get "&nbsp" all over the place :-(

It seems that "&nbsp" is not parsed correctly and is shown as plain text. Has this anything to do with the charset? Please help because know half of my site looks very ugly..

Thanks, Fabster
If you did write in you script "&nbsp" and not " " then it is NOT the fault of the update!
There is no failure until you give up.

Chris

 
User avatar
Beat
Joomla! Guru
Joomla! Guru
Posts: 840
Joined: Thu Aug 18, 2005 8:53 am
Location: Switzerland
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Beat » Wed Nov 23, 2005 7:39 am

Jinx wrote: Beat,

We indeed messed up with the UTF-8 work. We tried a move to UTF-8 in 1.0.3 and then decided to only do it in 1.1. Changes were reverted but the language iso setting was forgotten. We fixed this in 1.0.4 and forgot about the possible consequences. U are right that we should have informed our users about this change. Our apologies !

U can do two things are u change the iso settings in the english langauge file back to UTF-8 or u resave your content items. We are sticking with ISO-8859-1 for the 1.0 series. In your case it might be better to change them back to UTF-8.
Johan,

Thanks for your reply. Yes, you are right, it was 1.0.3, and not 1.0.2 where utf-8 was introduced. Sorry.

It would be reasonable to issue a small and simple easily understandable complement to the upgrade instructions, like this:


The sites which have started their existence with 1.0.3 should edit manually the following line in their english.php file:

DEFINE('_ISO','charset=iso-8859-1');

to

DEFINE('_ISO','charset=utf-8');

in all future 1.0.x versions, including 1.0.4, to avoid database changes. For other languages, please check the language files, which should all be synchronized on the same character set as is defined above.

All sites which have been designed in 1.0.0, 1.0.1 and 1.0.2 should avoid keeping 1.0.3 and move to 1.0.4 asap to avoid further database corruptions (for non-US-ASCII characters). This is because changes made in 1.0.3 (at least in English-language sites) are saved with a different character encoding (utf-8) than before (iso-8859-1). This is only visible for non-US characters, like accented characters and special signs (like tripple point ... etc.).


Constructively, and many tanks for all the other fixes and little new features,
Beat 8)
www.joomlapolis.com <= Community Builder + CBSubs Joomla membership payment system - team
hosting.joomlapolis.com <= Joomla! Hosting, by the CB Team

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19014
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by infograf768 » Wed Nov 23, 2005 7:55 am

Beat: I have asked to Core Team Members in charge of this to indeed upgrade the instructions (before I read your post ;) )
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

Fabster
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Tue Aug 30, 2005 7:00 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Fabster » Wed Nov 23, 2005 10:42 am

If you did write in you script "&nbsp" and not " " then it is NOT the fault of the update
@chris: Sorry for being a bit incorrect in my first post. It is actually " " in the code that is being misinterpreted. When I look at the content item using mosce everything is fine but on the website it is displayed incorrectly.. Does anyone have an idea? Or should I report that to the bug tracker?

Regards
Fabster

User avatar
nickza
Joomla! Explorer
Joomla! Explorer
Posts: 403
Joined: Thu Oct 13, 2005 2:36 pm
Location: South Africa

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by nickza » Wed Nov 23, 2005 11:23 am

OKay.....

Cool stuff. Joomla rocks, and security is a must.

1stly. I have a site, and i would like to upgrade it. I have to be honest and say that when it comes to stuff like this, i mess things up royaly! So. in order for the site to be active, and still be working as normal before/during/after the upgrade, what do i need to do?

LIke i said, i dont wanna mess anything up, and i just want to upgrade Joomla version. I read that i should just take the upgrade patch and overwrite the files on the server... is that okay? i mean, i might have other content that might be overwritten, or is this not the case?

Thanks.
Be Human!

User avatar
benedikt
Joomla! Explorer
Joomla! Explorer
Posts: 346
Joined: Mon Aug 22, 2005 2:29 pm
Location: Gent - Belgium

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by benedikt » Wed Nov 23, 2005 11:36 am

Upgrading is indeed only a matter of overwriting your installation with the patch.
This will only overwrite the files that need to be replaced.

It is however wise to make a backup first, that way you can always restore the old version.
Also make sure that you're applying the right patch (1.0.3 to 1.0.4, 1.0.2 to 1.0.4, ...)

User avatar
nickza
Joomla! Explorer
Joomla! Explorer
Posts: 403
Joined: Thu Oct 13, 2005 2:36 pm
Location: South Africa

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by nickza » Wed Nov 23, 2005 11:40 am

Cool..

If i highlight all the files on my pc in filezilla, and drop them on he server, and say overwrite the same files, other files will not be affected right?

I also read that there are few bugs in the patch... media manager not working, also read that the read more link dissapears, and other bugs... my site is live, and i cant afford it to be down, or have any problems or glitches...

what you recommend i do, or have you heard anything about the issues?

Thanks
Be Human!

User avatar
benedikt
Joomla! Explorer
Joomla! Explorer
Posts: 346
Joined: Mon Aug 22, 2005 2:29 pm
Location: Gent - Belgium

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by benedikt » Wed Nov 23, 2005 11:52 am

nickza wrote: If i highlight all the files on my pc in filezilla, and drop them on he server, and say overwrite the same files, other files will not be affected right?
Absolutely
I also read that there are few bugs in the patch... media manager not working, also read that the read more link dissapears, and other bugs... my site is live, and i cant afford it to be down, or have any problems or glitches...
Media manager solution is here:
http://forum.joomla.org/index.php/topic,20033.0.html

Read more thing is discussed here:
http://forum.joomla.org/index.php/topic,19961.0.html
As you'll see it may be solved, but since I'm not having this problem I'm not sure

Haven't heard of any other bugs.
If you really wat to be safe, you can always apply the patch to a test site first or even copy the whole site to a subdir and apply the patch there first. (though this will be more work then simply restoring a backup if something goes wrong)

User avatar
kai920
Joomla! Guru
Joomla! Guru
Posts: 542
Joined: Sun Sep 04, 2005 3:59 pm
Location: Hong Kong

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by kai920 » Wed Nov 23, 2005 11:53 am

Read through some of the above posts regarding the "charset" issue...

I am not aware of any other major bugs at the moment, this and the "media manager" problem seem to be the ones that require the most attention.

johanhorak
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Nov 18, 2005 10:05 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by johanhorak » Wed Nov 23, 2005 12:11 pm

Hi All


Just to confirm:

Reading the
Can I just copy the Joomla! files over the top of my Mambo directory?

Yes, but we recommend that you try this on a copy of your file system first and remember to backup your files before you do anything.  When you do copy over your existing files, double check that the files are actually being updated and that no transfer errors occurred (eg, errors about permissions).
from http://help.joomla.org/content/view/818/27/&nbsp; Migrating to Joomla! from Mambo 4.5.2.

1) I will backup my mambo site.
2) Copy my mambo site to a new directory and "just copy the new (full) Joomla! 1.0.4 over the top of my copy of Mambo directory"
3) If this works I can copy it over my actual mambo directory and delete the copy.

Is this the way to go?

Regards


Johan

User avatar
ruigato
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 129
Joined: Sat Aug 20, 2005 4:12 pm
Location: Arouca - Portugal
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by ruigato » Wed Nov 23, 2005 10:42 pm

after upgrading to 1.0.4 i got the error:

Configuration Problem: "" does not exist.

in the media manager component

and wen i try to delete a directory i get this:
opendir(/home/arouca/public_html/imagesstories/thumbnails): failed to open dir: No such file or directory in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 132

Warning: readdir(): supplied argument is not a valid Directory resource in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 133

Warning: closedir(): supplied argument is not a valid Directory resource in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 137

Warning: rmdir(/home/arouca/public_html/imagesstories/thumbnails): No such file or directory in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 141
i think is because this:
ublic_html/imagesstories/thumbnails

wasnt it supose to be : images/stories/thumbnails
Last edited by ruigato on Wed Nov 23, 2005 10:46 pm, edited 1 time in total.

neririn
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Aug 22, 2005 6:43 pm
Location: Salt Lake City, Utah
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by neririn » Wed Nov 23, 2005 11:58 pm

My index.php was changed to a less than pleasant form of content.  I have now patched are there any other things I should worry about?  Is type of defacement a common act of this vulnerability?  Or am I exposed to something else?  To read on the great evil's ($ambo) website, it seems like I should be concerned about root kits etc.  Ideas?  Questions?  Advice?

User avatar
Chris
Joomla! Guru
Joomla! Guru
Posts: 812
Joined: Sat Aug 20, 2005 3:58 am
Location: Australia
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Chris » Thu Nov 24, 2005 12:54 am

It seems that whatever happened to joomla and/or $ambo, it seems to have happened early Nov.?

If that is so, I would advice all and sundry to check all there folders and files to see if any have been edited wihout your knowledge.
If you find one, keep that date in mind and check all folders/files with that date.
Also check all .htaccess files that might have been put in folders.
Last edited by Chris on Thu Nov 24, 2005 12:59 am, edited 1 time in total.
There is no failure until you give up.

Chris

User avatar
The One
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Wed Nov 02, 2005 6:22 pm

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by The One » Thu Nov 24, 2005 3:56 am

updating, let's see how this goes.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 19014
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by infograf768 » Thu Nov 24, 2005 5:51 am

ruigato wrote: after upgrading to 1.0.4 i got the error:

Configuration Problem: "" does not exist.

in the media manager component

and wen i try to delete a directory i get this:
opendir(/home/arouca/public_html/imagesstories/thumbnails): failed to open dir: No such file or directory in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 132

Warning: readdir(): supplied argument is not a valid Directory resource in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 133

Warning: closedir(): supplied argument is not a valid Directory resource in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 137

Warning: rmdir(/home/arouca/public_html/imagesstories/thumbnails): No such file or directory in /home/arouca/public_html/administrator/components/com_media/admin.media.php on line 141
i think is because this:
ublic_html/imagesstories/thumbnails

wasnt it supose to be : images/stories/thumbnails
Ruy, have you patched your admin.media.php?
see here: http://forum.joomla.org/index.php/topic ... #msg120976
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

umek
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Wed Oct 05, 2005 11:48 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by umek » Thu Nov 24, 2005 7:09 am

after upgrading one of my installation gave me the HTML error that forexample the character '-' was being displayed as – etc etc. Any idea how can I fix this problem without the need of having to go back to 1.0.3 ? Note that this site contains a large property database, and thus the database is quite big so as to re-create all the html coding.

10x
ian

User avatar
TheSaint
Joomla! Ace
Joomla! Ace
Posts: 1256
Joined: Sat Aug 20, 2005 4:15 am
Location: California, USA
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by TheSaint » Thu Nov 24, 2005 9:16 am

The Forge is down at the minute. Thanks as always for the timely patching of security exploits. Well done once again! :)
Paul
http://www.gamehostingreviews.com - In development
The only thing necessary for the triumph of evil is for good men to do nothing. - Edmund Burke

AlCher
Joomla! Apprentice
Joomla! Apprentice
Posts: 40
Joined: Mon Sep 19, 2005 8:33 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by AlCher » Thu Nov 24, 2005 9:46 am

That is bug or at me only?

After upgrade on J!1.04 from 1.03 are not displayed on the tab 'Parametres' in Backend onmouseover popup tips on words with dotted underlining. On icons - popup tips are displayed. At 1.03 that was OK.
Where to search, in what files?

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Tonie » Thu Nov 24, 2005 10:43 am

@ALCher
It is not you, there is already a post in the forum for 1.0.4 Quality and Testing. That is over here: http://forum.joomla.org/index.php/topic,20322.0.html

User avatar
Beat
Joomla! Guru
Joomla! Guru
Posts: 840
Joined: Thu Aug 18, 2005 8:53 am
Location: Switzerland
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Beat » Thu Nov 24, 2005 10:50 am

umek wrote: after upgrading one of my installation gave me the HTML error that forexample the character '-' was being displayed as – etc etc. Any idea how can I fix this problem without the need of having to go back to 1.0.3 ? Note that this site contains a large property database, and thus the database is quite big so as to re-create all the html coding.

10x
ian
This is the problem I have raised earlier in this thread, with a acknowledged solution proposal for simple cases. Check this thread for details before these posts. Directions proposal as said before :-[  below:
Beat wrote: The sites which have started their existence with 1.0.3 should edit manually the following line in their english.php file:

DEFINE('_ISO','charset=iso-8859-1');

to

DEFINE('_ISO','charset=utf-8');

in all future 1.0.x versions, including 1.0.4, to avoid database changes. For other languages simultaneously installed, please check the language files, which should all be synchronized on the same character set as is defined above.

All sites which have been designed in 1.0.0, 1.0.1 and 1.0.2 should avoid keeping 1.0.3 and move directly to 1.0.4 asap to avoid further database corruptions (for non-US-ASCII characters). This is because changes made in 1.0.3 (at least in English-language sites) are saved with a different character encoding (utf-8) than before (iso-8859-1). This is only visible for non-US characters, like accented characters and special signs (like tripple point ... etc.).
Beat 8)
www.joomlapolis.com <= Community Builder + CBSubs Joomla membership payment system - team
hosting.joomlapolis.com <= Joomla! Hosting, by the CB Team

umek
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Wed Oct 05, 2005 11:48 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by umek » Thu Nov 24, 2005 1:00 pm

10x beat ... everything seems to be fine now.

User avatar
randoncode
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Thu Oct 20, 2005 12:08 pm
Location: São Caetano do Sul - SP
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by randoncode » Thu Nov 24, 2005 1:57 pm

Hi Guys!

After upgrading my all websites from Joomla! 1.0.3 to 1.0.4, a error with the media manager it appeared.
After access the media manager, and to open sub-folder, appears the following error:

Configuration Problem: "" does not exist.

And no image inside of the folders appears!!!

Now, if access a parent folder the message is another one:

No Images Found

Somebody this having this problem?
: Cybernauta - Soluções para Joomla :
http://www.cybernauta.com.br

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Tonie » Thu Nov 24, 2005 2:32 pm

@randoncode
Please take a look at this thread. You can edit a file, or overwrite one. The choice is yours.
http://forum.joomla.org/index.php/topic ... #msg123571

User avatar
The One
Joomla! Intern
Joomla! Intern
Posts: 56
Joined: Wed Nov 02, 2005 6:22 pm

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by The One » Thu Nov 24, 2005 3:34 pm

Just updated, everything went fine. Good job team! 8)

User avatar
randoncode
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Thu Oct 20, 2005 12:08 pm
Location: São Caetano do Sul - SP
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by randoncode » Thu Nov 24, 2005 6:21 pm

Tonie wrote: @randoncode
Please take a look at this thread. You can edit a file, or overwrite one. The choice is yours.
http://forum.joomla.org/index.php/topic ... #msg123571
Thanks Tonie!!!
: Cybernauta - Soluções para Joomla :
http://www.cybernauta.com.br

BrianB
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 152
Joined: Thu Sep 08, 2005 2:26 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by BrianB » Fri Nov 25, 2005 3:59 am

I had uploaded the patch file on one of my sites... extracted it on the server.  Afterwards, one of my menus was missing, and a newsflash block would not display.

Tried a number of things, and then gave up... uploade the entire 1.0.4 package... .extracted it on the server and overwrote everything.. afterwards, the site was fine.

User avatar
enjoy777
Joomla! Guru
Joomla! Guru
Posts: 554
Joined: Thu Aug 18, 2005 7:02 am
Location: Wroclaw, Poland

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by enjoy777 » Fri Nov 25, 2005 12:58 pm

Beat wrote:
DEFINE('_ISO','charset=iso-8859-1');

to

DEFINE('_ISO','charset=utf-8');
It a little help with display articles, but
I have small problem with my mosCE, after upgrading I lose combination 'right Alt + z' should give > ż but now this combination delete all words before cursor in one row.

chaosvg
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Sun Sep 11, 2005 5:50 pm

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by chaosvg » Sun Nov 27, 2005 6:32 pm

since there's not a lot to find about this is suppose it's not a general problem:

after upgrading to 1.04 the newsflash 'read more' links seem to have dissapeared: http://developer.joomla.org/sf/go/artf2253?nav=1

This is a major issue to me. Does anyone have info on what time frame this will be fixed? I have no clue on where to find it myself, since mod_newsflash itself was unchanged in this release.

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by Tonie » Sun Nov 27, 2005 8:35 pm


heros
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Fri Oct 28, 2005 9:13 am
Contact:

Re: Discuss about : Upgrade to Joomla! 1.0.4 Security Release now!

Post by heros » Mon Nov 28, 2005 10:19 am

I have deep image with Joomla! 1.0.4 Security. This release has solved many my headache problems with Mambo.
Many thanks to the team.
Great work!!!
Heros
==========
Web developer
easyjoomlaweb.com

 

Locked

Return to “Announcements Discussions”