Discuss Joomla! 3.1.5 Stable Released

A place to discuss recent announcements made by the Joomla! Core Team. Let's hear what you have to say.
Locked
User avatar
ooffick
Joomla! Master
Joomla! Master
Posts: 11403
Joined: Thu Jul 17, 2008 3:10 pm
Location: Ireland
Contact:

Discuss Joomla! 3.1.5 Stable Released

Post by ooffick » Thu Aug 01, 2013 1:34 pm

Discuss Joomla! 3.1.5 Stable Released here

Please see announcement for details:
http://forum.joomla.org/viewtopic.php?f=8&t=811953

Note: To report bugs, please use the official Bug Tracker.
Olaf Offick - Global Moderator
learnskills.org

x-joomla-x
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Aug 02, 2013 9:05 am

Re: Discuss Joomla! 3.1.5 Stable Released

Post by x-joomla-x » Fri Aug 02, 2013 9:10 am

version 3.1.5 is not working in php 5.5.1 :(



[Fri Aug 02 08:49:08.143636 2013] [proxy_fcgi:error] AH01071: Got error 'PHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use pre
g_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 656\nPHP message: PHP Deprecated:
preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filt
er/input.php on line 659\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2
311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 656\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated,
use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 659\nPHP message: PHP Depr
ecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joo
mla/filter/input.php on line 656\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/
vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 659\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is dep
recated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 656\nPHP message:
PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libra
ries/joomla/filter/input.php on line 659\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /
var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 656\nPHP message: PHP Deprecated: preg_replace(): The /e modifie
r is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 659\nPHP m
essage: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_ht
ml/libraries/joomla/filter/input.php on line 656\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback inst
ead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 659\nPHP message: PHP Deprecated: preg_replace(): The /e
modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 65
6\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/p
ublic_html/libraries/joomla/filter/input.php on line 659\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callb
ack instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 656\nPHP message: PHP Deprecated: preg_replace()
: The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on
line 659\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/tes
t1.com/public_html/libraries/joomla/filter/input.php on line 656\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_repla
ce_callback instead in /var/www/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on line 659\n', referer: http://test1.com/install
ation/index.php
[Fri Aug 02 08:49:08.143785 2013] [proxy_fcgi:error] AH01071: Got error 'PHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use pre
g_replace_callback instead in /var/w', referer: http://test1.com/installation/index.php
[Fri Aug 02 08:49:08.145080 2013] [proxy_fcgi:error] AH01071: Got error 'ww/vhosts/2311/domains/test1.com/public_html/libraries/joomla/filter/input.php on li
ne 656\nPHP message: PHP Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/vhosts/2311/domains/test1.
com/public_html/libraries/joomla/filter/input.php on line 659\n', referer: http://test1.com/installation/index.php

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11767
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by brian » Fri Aug 02, 2013 9:14 am

Thats a known issue which should be fixed for 3.2 if enough people test it

Please see http://joomlacode.org/gf/project/joomla ... m_id=31197 and if it works (or doesnt) for you please comment there
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

x-joomla-x
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Aug 02, 2013 9:05 am

Re: Discuss Joomla! 3.1.5 Stable Released

Post by x-joomla-x » Fri Aug 02, 2013 9:48 am

yes, it's working,
could you add it in 3.1.6 ?


// Convert decimal
//$source = preg_replace('/&#(\d+);/me', "utf8_encode(chr(\\1))", $source); // decimal notation
$source = preg_replace_callback('/&#(\d+);/m', function($m){return utf8_encode(chr($m[1]));}, $source); // decimal notation

// Convert hex
//$source = preg_replace('/&#x([a-f0-9]+);/mei', "utf8_encode(chr(0x\\1))", $source); // hex notation
$source = preg_replace_callback('/&#x([a-f0-9]+);/mi', function($m){return utf8_encode(chr('0x'.$m[1]));}, $source); // hex notation

User avatar
brian
Joomla! Master
Joomla! Master
Posts: 11767
Joined: Fri Aug 12, 2005 7:19 am
Location: Leeds, UK
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by brian » Fri Aug 02, 2013 10:02 am

Please can you post on the tracker your successful test - thats the process we follow to ensure patches get approved.
"Exploited yesterday... Hacked tomorrow"
Blog http://brian.teeman.net/
Joomla Hidden Secrets http://hiddenjoomlasecrets.com/

User avatar
Chris
Joomla! Guru
Joomla! Guru
Posts: 811
Joined: Sat Aug 20, 2005 3:58 am
Location: Australia
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by Chris » Sat Aug 03, 2013 5:57 am

Today I received your security email about version 3.1.1 etc.
And I just updated with 3.1.4.
And now I see there is an update to 3.1.5.
Is that correct?
Two updates in 1 day?
There is no failure until you give up.

Chris

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22329
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by pe7er » Sat Aug 03, 2013 8:27 am

Chris wrote:And now I see there is an update to 3.1.5.
Is that correct?
Two updates in 1 day?
Yes, it's correct that you see an update for 3.1.5, it's the most recent version: http://www.joomla.org/download.html

Yes it seems fast but nope, not two updates in one day:
3.1.4 was a maintenance release with no security fixes released on 25 July and
3.1.5 was a security release addressing a critical level security issue released on 1 August.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19739
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by leolam » Sat Aug 03, 2013 5:43 pm

Pe7er,
You are right about dates but take 3.1.1 onwards and look at dates and appreciate frustration by users, especially what happened between the versions?

Cheers

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22329
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by pe7er » Sat Aug 03, 2013 7:20 pm

leolam wrote:You are right about dates but take 3.1.1 onwards and look at dates and appreciate frustration by users, especially what happened between the versions?
I agree, I was surprised about the version jump when I returned from a short holiday.
However, I don't mind the fast release of a security update ;)
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

grayz
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 128
Joined: Tue Dec 12, 2006 8:37 pm

Re: Discuss Joomla! 3.1.5 Stable Released

Post by grayz » Wed Oct 30, 2013 7:45 am

I'm getting error
Fatal error: Invalid opcode 153/1/8. in
/var/.../libraries/joomla/table/observer/tags.php on line 159

which should be typical for 3.1.4 (if this FAQ is correct) but I get it on 3.1.5!

I have installed eAccelerator v1.0-dev on my hosting server (PHP Version 5.3.27).

What should I do in this case?

RESOLVED: hoster changed version of eAccelerator to 0.9.6.1 and now it's Ok.
www.justPHP.net - HACKS for Hot Property, Custom 404 Error Pages, Templates for Joomla etc.
Developing: www.zerno.org.ua

nwidesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 40
Joined: Thu Jul 12, 2012 7:04 pm

Re: Discuss Joomla! 3.1.5 Stable Released

Post by nwidesigns » Thu Nov 14, 2013 12:22 am

I am between a rock and a hard place with this. I need to run PHP 5.5.3 because a few sites I am building are going to use YooTheme's new WARP7 framework templates and they require it, but I cannot get Joomla 2.5 to install because of this issue. I am having another issue seeing the writing on the wall looking at the supposed fix for this on Github because I guess I don't know where to look for the answer.

What must I correct to get Joomla 2.5 to install on a server running PHP 5.5.3?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19739
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.1.5 Stable Released

Post by leolam » Sun Feb 02, 2014 3:30 pm

@ All: upgrade to Joomla 3.2.1! Do not run outdated and not supported versions!

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

ADvanceref
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Sat Jun 08, 2013 8:25 am

Re: Discuss Joomla! 3.1.5 Stable Released

Post by ADvanceref » Tue Feb 04, 2014 10:00 am

I tried the solution above too but it still not works and I can't upgrade to 3.2.1.
Toutes les informations sur le rachat de crédit, 1RachatCredit.fr : www.1RachatCredit.fr. Pour le referencement de votre site internet, faites appel à une agence web.


Locked

Return to “Announcements Discussions”