Discuss Joomla! 3.2.0 Stable Released

A place to discuss recent announcements made by the Joomla! Core Team. Let's hear what you have to say.
kat05
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Fri May 09, 2008 2:28 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby kat05 » Thu Nov 07, 2013 5:03 pm

hi,

i was able to fix a site that was broken after a 2.4.16 to 3.2.0 update with the following fatal on frontend and backend:

Fatal error: Call to a member function get() on a non-object in /Applications/MAMP/htdocs/joomla_test/plugins/system/remember/remember.php on line 94

i did a file/folder compare between this broken site and a working j3.2.0 installation and noticed that more than 1,400 joomla core files (!) were present in the broken install but not present in the working install.

because this was just a test site for me to play with, i decided to delete all of those files/directories from the broken site.

after i was done, i could access my administrator again, the frontend showed the template but also some database errors.

in the admin, i went to > component > joomla update and it said it was on 3.2.0

i then went to > extensions > extensions manager > install and selected the j3.2.0 package.

after that my site is correctly working on both frontend and backend.

just thought i'd share this info, maybe it will be helpful.

regionallink
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Feb 08, 2008 2:22 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby regionallink » Thu Nov 07, 2013 5:23 pm

FTP the update for 3.2 over updated site files: Joomla3.2.0-Updates
Set config... error report to max...

Still have blank front and backend and this error reporting

Fatal error: Cannot redeclare class JComponentHelper in /mnt/data/vhosts/casite-543452.cloudaccess.net/httpdocs/libraries/legacy/component/helper.php on line 20

Is this a conflict with the JComponentHelper, can this be disabled to get working?

User avatar
mbabker
Joomla! Hero
Joomla! Hero
Posts: 2010
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby mbabker » Thu Nov 07, 2013 5:56 pm

I've added a fix for the JEvents issue to a patch dealing with other issues due to unusual use cases. This will be fixed for 3.2.1, thanks for that info.
Production Department Coordinator, Release Lead, CMS Maintainer, Framework Maintainer, Security Team Member, .org System Administrator

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

User avatar
TheWebSet
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Sun Jul 24, 2011 8:15 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby TheWebSet » Thu Nov 07, 2013 6:16 pm

mbabker wrote:I've added a fix for the JEvents issue to a patch dealing with other issues due to unusual use cases. This will be fixed for 3.2.1, thanks for that info.

Thank you!
"All government, of course, is against liberty."
H. L. Mencken

User avatar
N6REJ
Joomla! Explorer
Joomla! Explorer
Posts: 337
Joined: Sun Nov 27, 2005 9:25 am
Location: Ponca City, OK
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby N6REJ » Thu Nov 07, 2013 6:34 pm

Cannot update to 3.2 from 3.1.5
the package is not being downloaded. Confirmed with matias.
http://joomlacode.org/gf/project/joomla ... 83&start=0 for tracker issue.
Updating via install manager functions.
Setting Value

PHP Built On Linux host.jowwow.net 2.6.32-358.14.1.el6.x86_64 #1 SMP Tue Jul 16 23:51:20 UTC 2013 x86_64
Database Version 5.5.32-cll
Database Collation utf8_general_ci
PHP Version 5.3.27
Web Server Apache/2.2.25 (Unix) mod_ssl/2.2.25 OpenSSL/1.0.0-fips mod_bwlimited/1.4 mod_fcgid/2.3.6
WebServer to PHP Interface cgi-fcgi
Joomla! Version Joomla! 3.1.5 Stable [ Ember ] 01-August-2013 14:00 GMT
Joomla! Platform Version Joomla Platform 12.2.0 Stable [ Neil Armstrong ] 21-September-2012 00:00 GMT
User Agent Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36
Bear

Hugg
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Thu Nov 07, 2013 10:11 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Hugg » Thu Nov 07, 2013 7:26 pm

mbabker wrote:
Hugg wrote:....


Unfortunately, you have an issue where old files are not deleted. There were some files shifted around before 3.2. If you have shell access, you can run the CLI script at cli/deletefiles.php to automate this removal, otherwise you'll need to remove the files I've highlighted at https://github.com/joomla/joomla-cms/bl ... L651-L1012 to properly update your file structure from 3.1.5 to 3.2.0.


Thanks, I managed to run deletefiles.php using SSH and the command "php deletefiles.php". I do however now get another error when logged in to the backend:

Code: Select all

Table '*_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `tuu_postinstall_messages`

I assume it's just a minor error because the install wasn't finished properly the normal way, but yeah, not foolproof. This should be skipped or given the option to skip if it's not found. Not lock you out of the control panel.

Should I import 3.2.0.sql to database from com_admin?
Hmm nope that didn't work out of the box:

Code: Select all

#__content_types' doesn't exist

But I guess this is because of the translation of #_ to the database prefix. How do I fix that? (except search and replace)

User avatar
mbabker
Joomla! Hero
Joomla! Hero
Posts: 2010
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby mbabker » Thu Nov 07, 2013 7:43 pm

Go to domain/administrator/index.php?option=com_installer&view=database and run the database fix tool.
Production Department Coordinator, Release Lead, CMS Maintainer, Framework Maintainer, Security Team Member, .org System Administrator

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

taoandthen
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Feb 10, 2010 7:54 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby taoandthen » Thu Nov 07, 2013 9:46 pm

I also get this error:
Fatal error: Call to undefined method JApplicationSite::isWinOS() in /home3/wlba/public_html/modules/mod_jevents_latest/tmpl/default/latest.php on line 89

sseguin
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Sat Apr 10, 2010 2:24 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby sseguin » Thu Nov 07, 2013 9:57 pm

Hello, I just updated from 3.1.5 to 3.2.0

I tried the Joomla Update component and got white screens on Frontpage and Admin. So i restored, and did the ZIP upload in the installer. I got the following error, but everything seems to be ok. Should I take it as the update didn'T work and I should restore or just ignore?

Error on updating manifest cache: (type, element, folder, client) = (plugin, newsfeeds, newsfeeds, 0)

User avatar
mbabker
Joomla! Hero
Joomla! Hero
Posts: 2010
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby mbabker » Thu Nov 07, 2013 10:05 pm

@taoandthen - That will be addressed with 3.2.1, it is an issue we did not account for in refactoring code for 3.2.0.

@sseguin - Updating the manifest cache won't cause site errors, it's just a cache of what's in each extension's manifest XML and not really used within the system.
Production Department Coordinator, Release Lead, CMS Maintainer, Framework Maintainer, Security Team Member, .org System Administrator

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

sseguin
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Sat Apr 10, 2010 2:24 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby sseguin » Thu Nov 07, 2013 10:09 pm

Thanks for the quick reply. Very much appreciated.

Drakkheim
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri Mar 13, 2009 4:15 pm
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Drakkheim » Fri Nov 08, 2013 3:55 am

Upgraded from 3.1.5 to 3.2.0 and now the admin index.php is blank after login , however the index.php?option=com_config did let me get in there and tweak the settings. I Did the Max error level and the actual message Im getting is:

Code: Select all

Fatal error: Call to a member function getInt() on a non-object in /[pathtomysite]/html/administrator/components/com_postinstall/models/messages.php on line 37


Which says:

Code: Select all

36:      // Add a forced extension filtering to the list
37:      $eid = $this->input->getInt('eid', 700);
38:      $query->where($db->qn('extension_id') . ' = ' . $db->q($eid));


Any Ideas?

hoanta
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 134
Joined: Thu Jun 14, 2007 2:22 pm
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby hoanta » Fri Nov 08, 2013 4:04 am

I am having the blank page with menu - single contact. Here is the mss:

Code: Select all

Fatal error: main(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "JCategoryNode" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/public_html/modules/mod_articles_categories/mod_articles_categories.php on line 29


and here is line 29's code:

Code: Select all

24 . $list = JModuleHelper::moduleCache($module, $params, $cacheparams);
25.
26. if (!empty($list))
27. {
28.   $moduleclass_sfx = htmlspecialchars($params->get('moduleclass_sfx'));
29.   $startLevel = reset($list)->getParent()->level;
30.   require JModuleHelper::getLayoutPath('mod_articles_categories', $params->get('layout', 'default'));
31. }

One another error is that all modules (type: Articles Categories) now using the same category.
GTmetrix AA grade
http://www.locnuocmy.com

User avatar
mirovic
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Fri Dec 22, 2006 12:07 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby mirovic » Fri Nov 08, 2013 9:58 am

I am getting this error after login to administration and on post-installation component administration page:

Fatal error: Cannot redeclare class JDispatcher in Unknown on line 0

How to fix this?

cappuccino
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Tue Aug 04, 2009 3:49 pm
Location: Hamburg
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby cappuccino » Fri Nov 08, 2013 10:36 am

I do get a blank Frontend on Upgrading from 3.1.5 to 3.2.0 as well:

Fatal error: Call to a member function getTag() on a non-object in /xxxxxxxx/libraries/cms/application/site.php on line 305

Backend works fine. Looks like it has something to do with a language parameter.

Thanks for fixing this issue.

albertorp
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Nov 08, 2013 2:59 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby albertorp » Fri Nov 08, 2013 3:18 pm

Hi
I have updated my site with Joomla_3.2.0-Stable-Update_Package
However I still get this message on all my front pages:

Fatal error: Call to a member function getTag() on a non-object in /home/aprendi3/public_html/libraries/cms/application/site.php on line 436

Line 436 and context is:

if ($this->_language_filter)
{
$tag = $this->getLanguage()->getTag();
}
else
{
$tag = '';
}

Please urgent help as our site is down!

nick-birch
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Feb 05, 2010 9:08 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby nick-birch » Fri Nov 08, 2013 4:00 pm

I seem to have the blank admin control panel page problem too.

The message I get is:
Fatal error: Call to a member function getInt() on a non-object in /home/<my home directory>/public_html/administrator/components/com_postinstall/models/messages.php on line 37

cosmincirciu
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Mar 21, 2011 9:53 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby cosmincirciu » Sat Nov 09, 2013 11:00 am

prinla wrote:Hello,

I had a big problem after installing the auto-update to 3.2

An error message "1146 Table 'XXX_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `joom_postinstall_messages" appeared and blocked the access to the admin control panel !!!

Another joonla user had the same problem:
viewtopic.php?f=707&t=825351

I finally resolved the problem by downloading the "3.2 Update" manually and installing it over the "Extensions-Install". I am still missing some small pics in my control panel but at least I can work again.

Even if it works for me right now, could you please check it and prevent others from having the same problem ?

Thankx



Hi,
I had the same problem, and tried your fix (it helped me).
Just one thing, I had multiple problems during installation of the update package and worked only after uploading it (extracted) on the server and the installing it from directory.
So I think that the update package is to large for most of the users (usually php.ini is set to 4MB upload).
After installing it from directory, everything went ok, and now is working great.
I hope this will help others to.

Thank you

User avatar
fantasea
Joomla! Intern
Joomla! Intern
Posts: 82
Joined: Thu Aug 18, 2005 8:12 am
Location: Woudrichem. Nederland (NL)
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby fantasea » Sat Nov 09, 2013 12:12 pm

Nick Savov wrote:For everyone that's getting a blank page on the front-end, go to:
1) Your admin area
2) System (top menu)
3) Global configuration (sub menu)
4) Server (tab)
5) Turn error reporting to maximum
6) Save
7) Check your blank page, refresh, and see if you get a detailed error message. If so, post in this forum topic.

As to everyone else, please create a backup and try installing the following package, as you would an extension, to reset all your core files:
http://joomlacode.org/gf/download/frsre ... ackage.zip

Kind regards,
Nick


Hy Nick,

No error just a black page, afther reload (f5) the page is there. i can't find any error

gr Bas
Bas van Kollenburg
Instructor / Director

http://www.soterios.eu

stavroch
Joomla! Intern
Joomla! Intern
Posts: 70
Joined: Wed Feb 15, 2006 10:23 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby stavroch » Sat Nov 09, 2013 12:31 pm

I have the same error as fantasea.
Also I use Joomlart template and Jomsocial.

On the administrator I can login normally

Hoffi
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Aug 16, 2010 12:36 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Hoffi » Sat Nov 09, 2013 4:11 pm

Hi,

after upgrading from 3.1.6 to 3.2.0 using Joomla_3.2.0-Stable-Update_Package.zip without any visible problems and some hours sleep I can't login!
Not on frontend and not on backend!
The browser waits endless but the server doesn't answer - no error, no white page, absolutely nothings.
On frontend I see all and can do all as guest - but can't login.

It seems there is at least one real use-case showing 3.2.0 is not as stable as suggested. So please stop jumbling the code and concentrate on stability and quality.

Thanks.

BionicNellyWiz
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Wed Nov 24, 2010 12:24 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby BionicNellyWiz » Sat Nov 09, 2013 6:16 pm

clicking on a user.png
Took a backup of joomla 3.1.5 (as well as database)

and did the Joomla update 3.2.0

First it came up with this:

error 0 SQL=CREATE TABLE `k3vcg_postinstall_messages` ( `postinstall_message_id` bigint(20) unsigned NOT NULL AUTO_INCREMENT, `extension_id` bigint(20) NOT NULL DEFAULT '700' COMMENT 'FK to #__extensions', `title_key` varchar(255) NOT NULL DEFAULT '' COMMENT 'Lang key for the title', `description_key` varchar(255) NOT NULL DEFAULT '' COMMENT 'Lang key for description', `action_key` varchar(255) NOT NULL DEFAULT '', `language_extension` varchar(255) NOT NULL DEFAULT 'com_postinstall' COMMENT 'Extension holding lang keys', `language_client_id` tinyint(3) NOT NULL DEFAULT '1', `type` varchar(10) NOT NULL DEFAULT 'link' COMMENT 'Message type - message, link, action', `action_file` varchar(255) DEFAULT '' COMMENT 'RAD URI to the PHP file containing action method', `action` varchar(255) DEFAULT '' COMMENT 'Action method name or URL', `condition_file` varchar(255) DEFAULT NULL COMMENT 'RAD URI to file holding display condition method', `condition_method` varchar(255) DEFAULT NULL COMMENT 'Display condition method, must return boolean', `version_introduced` varchar(50) NOT NULL DEFAULT '3.2.0' COMMENT 'Version when this message was introduced', `enabled` tinyint(3) NOT NULL DEFAULT '1', PRIMARY KEY (`postinstall_message_id`) ) DEFAULT CHARSET=utf8;

And then I ran the database command in the web browser that someone suggested in an earlier posting doing. Did that and then I notice this when I clicked on User Manager - clicked on a user and got this as shown attached below that says Fatal error on line 92 of the cache file. What do I do to fix it? :( ???

clicking on a user.png


EDIT: I got it solved by using the Akeeba Admin Tool and selected on "repair and optimize" and then went back to the user and it is now looking ok! Phew!!
You do not have the required permissions to view the files attached to this post.

mapalmer
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Mar 07, 2013 8:07 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby mapalmer » Sun Nov 10, 2013 5:40 pm

My update to 3.2.0 went without a hitch. However...

After updating no new user can be added. The process seems to complete OK but then on logging in, the message "username and password do not match or you do not have an account yet".

Also the SP Download function does not "insert" - just hangs.

I have returned to 3.1.5 and everything is working again. Clearly, 3.2.0 does not appear to be ready for release.

Joomstore
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Apr 21, 2013 8:43 am
Location: Western Australia
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Joomstore » Mon Nov 11, 2013 7:15 am

I also have 2 live Joomla 3.1 sites. Both crashed with Fatal Errors after upgrading. I managed to get them working. However, on my newly updated sites the new Content Versioning feature can't be found. On a fresh install it works great but not on sites updated from 3.1.

"Content History" is activated in the article options. The Versions button is visible but clicking on it gives an error. 404 Component not found.

Is it possible the upgrade packages aren't complete?

BionicNellyWiz
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Wed Nov 24, 2010 12:24 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby BionicNellyWiz » Mon Nov 11, 2013 9:33 am

:-[ Further to my earlier posting I had the same problem back again - this time on creating a user - something isn't right! So I restored my backup 3.1.5 (using the akeeba method). So glad I took a backup before the upgrade!

it does look like it's relating to the database structure with existing joomla sites having an upgrade.

I'm going to try a test site with a fresh install of joomla 3.2 and see if it is better there.

sovainfo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8818
Joined: Sat Oct 01, 2011 7:06 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby sovainfo » Mon Nov 11, 2013 9:38 am

@Joomstore: Try Extension manager=>Discover and install and/or =>Database=>Fix.

Upgraded 3.1.5 to 3.2.0 and enabled versions in content options. It works.
Issue with migrating? Include logs/joomla_update.php in your report!
Blank screen? Verify pagesource for HTML code (javascript error)
Installation failing on populating database? Install with set_time_limit(0)
Document your customizations!

norwegian
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Nov 11, 2013 10:55 am
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby norwegian » Mon Nov 11, 2013 11:26 am

I have also upgraded to 3.2 and have alle frontend pages blank.
Set error reporting to max and got this error:
Notice: Undefined property: PlgSystemJSNTPLFramework::$app in /home/fitnessl/public_html/libraries/cms/plugin/plugin.php on line 102

Fatal error: Call to protected method JApplicationSite::route() from context 'PlgSystemJSNTPLFramework' in /home/fitnessl/public_html/plugins/system/jsntplframework/jsntplframework.php on line 112

EDITH
Ok, i find that i have to deactivate JSN Template Framework in my plugins,
this one is used in MijoShop. My site now works fine, as far as I can see.

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1270
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby darb » Mon Nov 11, 2013 3:03 pm

Tried to login to Joomla 3.2 demo from my mobile. Seems that an error occur and site hacked?
Success in the long run Its not about the code its about the people and community that's make it!
Its not what you say its what you do that matters!

Darb - aka ssnobben

User avatar
htmgarcia
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Fri Dec 16, 2011 4:33 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby htmgarcia » Tue Nov 12, 2013 2:54 am

I got the same blank page in admin after trying to update from 3.1.x to 3.2 . This is what I did to get the admin working again.

I opened configuration.php file and changed the line 23 $error_reporting from 'default' value to 'maximum':

Code: Select all

public $error_reporting = 'maximum';


After this, if you refresh your backend and frontend and you see your site an error related to remember plugin like:
Fatal error: Call to a member function get() on a non-object in .../plugins/system/remember/remember.php on line 94

Then go to your phpMyAdmin >> yourpreffix__extensions table and find the row "plg_system_remember". Change the value of enabled from 1 to 0

Note: yourpreffix means the unique preffix of your own database.


Refresh your backend and you will see your site working again. At least was my case.

Kind regards,
Valentín

petri71
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Nov 14, 2011 3:51 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby petri71 » Tue Nov 12, 2013 4:46 am

same problem here

blank admin page... what can we do in this case, download the package you guys added above ?

I set my config error to maximum but I have no message... tried htmgarcia's trick but it does not help..

thank you in advance for any useful answer


Return to “Announcements Discussions”

Who is online

Users browsing this forum: No registered users and 2 guests