Discuss Joomla! 3.2.0 Stable Released

A place to discuss recent announcements made by the Joomla! Core Team. Let's hear what you have to say.
User avatar
pishro
Joomla! Explorer
Joomla! Explorer
Posts: 285
Joined: Tue Oct 09, 2012 7:22 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby pishro » Wed Dec 18, 2013 4:47 pm

mirovic wrote:After upgrade from 3.1.5 to 3.2 I have this error on Administrator Control Panel page and new Post-Installation Messages component page in administration:

Fatal error: Cannot redeclare class JDispatcher in Unknown on line 0

How can I fix it?

joomla! administrator wrote:You will be taken to your user profile page where you can find more information on two factor authentication and enable it for your user account.

This paper is useful in that case: http://magazine.joomla.org/issues/issue ... l-messages

mindcandy
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Thu Nov 07, 2013 9:40 am
Location: AUSTRIA
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby mindcandy » Fri Jan 03, 2014 7:42 pm

clunky wrote:Hi I am facing a similar issue although my front end has gone, just a blank page whereas my admin seems fine.
I had a load of database errors afrer the upgrade but I clicked the fix button and then there were no errors, just no front end site.

I have checked permissions but cannot see anything obvious.

help please?



I have the exact same issue!!!!

The funny thing: I have updated two other sites on the same server with the exact same config - both work fine, no blank pages... the third: should go live this night... guess I can forget this....

edit: solved! Was caused by the JoomlaCK Editor... after disabling everything that belongs to CK the site started to work again!

8medium
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jan 03, 2014 10:10 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby 8medium » Fri Jan 03, 2014 10:18 pm

i just upgraded my site from version 3.1.5 to 3.2 I and now my front-end and admin is just blank pls i need urgent help because i don't have a recent backup

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby leolam » Sun Jan 05, 2014 5:06 pm

8medium wrote:i just upgraded my site from version 3.1.5 to 3.2 I and now my front-end and admin is just blank pls i need urgent help because i don't have a recent backup
Extension Manager-->Install-->Install from URL-->paste this: http://joomlacode.org/gf/download/frsre ... ackage.zip and hit "install"

Than refresh browser and clear cache and reload. Should resolve

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

8medium
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jan 03, 2014 10:10 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby 8medium » Mon Jan 06, 2014 11:32 am

leolam wrote:
8medium wrote:i just upgraded my site from version 3.1.5 to 3.2 I and now my front-end and admin is just blank pls i need urgent help because i don't have a recent backup
Extension Manager-->Install-->Install from URL-->paste this: http://joomlacode.org/gf/download/frsre ... ackage.zip and hit "install"

Than refresh browser and clear cache and reload. Should resolve

Leo 8)

i dont have access to Administrator

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33410
Joined: Sat Apr 05, 2008 9:58 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Webdongle » Mon Jan 06, 2014 1:40 pm

If you don't have access to admin why do you think you are authorised to make changes to the site like updating ? Did you lock yourself out of admin and think updating would solve it ?

If you don't have access to admin how did you attempt an update ?

Moosebase1
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jan 07, 2014 10:54 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Moosebase1 » Tue Jan 07, 2014 11:13 am

Wow, this is a first... and it sucks. I have a site that i've been working on, and in past, clicking update was a no brainer. Luckily I backed up before hand and will now restore. The site I'm working on is praguepost.com and I get the error:

Code: Select all

Fatal error: main(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition "JCategoryNode" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /home/www/praguepostcom/modules/mod_articles_categories/mod_articles_categories.php on line 29


I have no clue what that means. Just that it's a problem. If i delete the mod_articles_categories directory, the front page loads, but i lose my categories based menu.

Any thoughts?

EmraanHashmi
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sat Jan 11, 2014 7:53 am
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby EmraanHashmi » Sat Jan 11, 2014 8:04 am

blank page!! my datas will get lost?

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21848
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby pe7er » Sat Jan 11, 2014 12:08 pm

EmraanHashmi wrote:blank page!! my datas will get lost?

No, PHP error with error reporting off = blank page.
The data is still in your database.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Developer of Options Manager Lite https://db8.eu/download/file/options-manager-lite

EmraanHashmi
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sat Jan 11, 2014 7:53 am
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby EmraanHashmi » Mon Jan 13, 2014 9:01 am

pe7er wrote:
EmraanHashmi wrote:blank page!! my datas will get lost?

No, PHP error with error reporting off = blank page.
The data is still in your database.


Okk..
I got that
Found error in the database..

thank you

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby leolam » Mon Jan 13, 2014 2:31 pm

EmraanHashmi wrote:Found error in the database..
Why have you not upgraded to J3.2.1 yet? 3.2.0 is old and obsolete?

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

caroltt
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Jan 17, 2014 8:41 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby caroltt » Fri Jan 17, 2014 8:45 pm

I also now have a blank front end after upgrading. Already tried installing http://joomlacode.org/gf/download/frsre ... ackage.zip to no avail. Here's my error message:
-------------------------------------------------------------------------------------

Strict Standards: Accessing static property PlgSystemJSNTPLFramework::$app as non static in /home/atomi91/domains/atomicspices.com/public_html/libraries/cms/plugin/plugin.php on line 102

Notice: Undefined property: PlgSystemJSNTPLFramework::$app in /home/atomi91/domains/atomicspices.com/public_html/libraries/cms/plugin/plugin.php on line 102

Strict Standards: Accessing static property PlgSystemJSNTPLFramework::$app as non static in /home/atomi91/domains/atomicspices.com/public_html/libraries/cms/plugin/plugin.php on line 104

Fatal error: Call to protected method JApplicationSite::route() from context 'PlgSystemJSNTPLFramework' in /home/atomi91/domains/atomicspices.com/public_html/plugins/system/jsntplframework/jsntplframework.php on line 112
---------------------------------------------------------------
Any help would be greatly appreciated. Thanks!
Last edited by imanickam on Sat Jan 18, 2014 3:30 am, edited 1 time in total.
Reason: http://forum.joomla.org/viewtopic.php?f=9&t=825287

Terje R
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Jan 15, 2010 3:01 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Terje R » Sat Jan 18, 2014 4:52 pm

Upgrade from 3.2.0.alpha to 3.2.1

- The site is located on localhost, IIS on Windows 7(64). (Joomla! 3.2.0.alpha Alpha [ Ember ] 10-September-2013 14:00 GMT)
- System Directory Permissions reports all Writable
- Components, Joomla Update, http://joomlacode.org/gf/download/frsre ... ackage.zip

ERROR:
The archive file is corrupt, truncated or archive parts are missing

- Discovered that configuration.php had relative paths to tmp and log
- Restored backup and made paths to tmp and log folders absolute
- Components, Joomla Update, http://joomlacode.org/gf/download/frsre ... ackage.zip
- Redirected to: http://localhost/skadedyr32/administrat ... e.finalise

Fatal error: Call to undefined method JApplicationHelper::getHash() in C:\inetpub\wwwroot\skadedyr32\libraries\cms\application\cms.php on line 637

- Restored backup
- Followed the instructions for manual upgrade on: http://docs.joomla.org/J3.2:Upgrading_f ... al_Upgrade
- After manual upgrade: http://localhost/skadedyr32/administrator/

Fatal error: Call to undefined method JApplicationHelper::getHash() in C:\inetpub\wwwroot\skadedyr32\libraries\cms\application\cms.php on line 637

Backup is not cowardly or redundant!!

??? ??? ???

Edit:

The error is caused by 3.2.1 code in libraries\cms\application\cms.php calling JApplicationHelper::getHash()
JApplicationHelper class is defined in libraries\legacy\application\helper.php (3.2.0.alpha) and has no function getHash()

libraries\legacy\application\application.php (3.2.1, JApplication class), line 917, public static function getHash($seed) has a leading comment:

* @deprecated 4.0 Use JApplicationHelper::getHash instead

and the code is: return JApplicationHelper::getHash($seed);

Seems to me that a new JApplicationHelper class (libraries\legacy\application\helper.php) is missing in Joomla_3.2.x_to_3.2.1-Stable-Patch_Package.zip

Edit II:

I installed the full 3.2.1 package and checked the libraries\cms\application folder which had helper.php and default index.html not found in the patch-package
After I copied those files and reloaded http://localhost/skadedyr32/administrat ... e.finalise I received:

Fatal error: Class 'JResponse' not found in C:\inetpub\wwwroot\skadedyr32\plugins\system\p3p\p3p.php on line 35

After copying the folder libraries\legacy\response I reloaded again and received a 404 due to bad redirect to http://localhost/index.php?option=com_j ... te.cleanup (missing sitename)
Fixed the url and reloaded: localhost/skadedyr32.no/index.php?option=com_joomlaupdate&task=update.cleanup

Fatal error: Class 'JPluginHelper' not found in C:\inetpub\wwwroot\skadedyr32\libraries\cms\application\site.php on line 544

Copied folder libraries\cms\plugin and reloaded:

Fatal error: Class 'JModuleHelper' not found in C:\inetpub\wwwroot\skadedyr32\libraries\joomla\document\html\renderer\modules.php on line 37

Copied folder libraries\cms\module and reloaded:

http://localhost/skadedyr32/index.php?o ... te.cleanup

Received 404 on Joomla error page
Clicked Homepage

Fatal error: Class 'JSite' not found in C:\inetpub\wwwroot\skadedyr32\modules\mod_menu\helper.php on line 104

Copied folder modules\mod_menu

Received my front-end !!!

Conclusion 1:

Joomla_3.2.x_to_3.2.1-Stable-Patch_Package.zip are missing:

    files libraries\cms\application\helper.php and default index.html
    file modules\mod_menu\helper.php changes
    folder libraries\legacy\response
    folder libraries\cms\plugin
    folder libraries\cms\module

Changed to administrator and received:

Fatal error: Call to undefined method JCrypt::timingSafeCompare() in C:\inetpub\wwwroot\skadedyr32\libraries\joomla\user\helper.php on line 376

More debugging required!!!! :eek:

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: I messed up my 3.2.0 to 3.2.1 upgrade

Postby leolam » Mon Jan 20, 2014 2:44 am

@ Mods: Adjusted the Title in this reply to reflect what is happening here

Terje R wrote:Fatal error: Call to undefined method JCrypt::timingSafeCompare() in C:\inetpub\wwwroot\skadedyr32\libraries\joomla\user\helper.php on line 376

More debugging required!!!! :eek:
JCrypt was introduced with Joomla 3.2.0 and removed due to bugs from 3.2.1.This being present means that your upgrade has gone wrong and that should be corrected.

It is of course totally wrong to update without creating a proper backup (Akeebabackup) and testing if that backup is working.

Next your post should have been in the migration and upgrade forum and not in a release discussion.

Go to Extensions-->Install--> paste "http://joomlacode.org/gf/download/frsrelease/19008/134338/Joomla_3.2.1-Stable-Update_Package.zip" in the "Install from URL" and hit "Install"

Than go to "maintenance" and purge both caches.

Than go to Extension Manager --> Discover and hit the "Discover" option --> Install what shows up.

Than go to Extension Manager --> Database --> Hit the "FIX-button"

These steps should resolve all.

When all working, download and install a backup and check with installing the backup on for instance http://www.uniformserver.com if your backup is proper functioning

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

Terje R
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Jan 15, 2010 3:01 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Terje R » Mon Jan 20, 2014 11:49 am

Thanks for your quick response :)

After restoring the 3.2.0.alpha site and starting administrator the Control Panel reported 'All extensions is up-to-date' and 'Joomla! is up-to-date' (changed since yesterday)

Than go to Extension Manager --> Discover and hit the "Discover" option --> Install what shows up.


One extension showed up - FOF. Installed.

Is this part of the system or some remnants leftover from my experiments with extensions?

Than go to Extension Manager --> Database --> Hit the "FIX-button"


Database table structure is up to date.

Database schema version (in #__schemas): 3.2.1.
Update version (in #__extensions): 3.2.1.
Database driver: mysqli.
79 database changes were checked successfully.
131 database changes did not alter table structure and were skipped


.. but the Fix-button was visible so I pressed it. The result did not change and was as referred above

The good news is that both front- and back-end are back again and seems to work as before :)

User avatar
Jeyjoo
Joomla! Explorer
Joomla! Explorer
Posts: 321
Joined: Tue Jul 19, 2011 8:56 am
Location: Monaco
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Jeyjoo » Mon Jan 20, 2014 1:04 pm

Terje R I have the same problem after updating 3.1.5 to 3.2.1
Front and backoffice error message:

Fatal error: Call to undefined method JApplicationHelper::getHash() in .../libraries/cms/application/cms.php on line 637

If anyone find a fix please post.
I am currently restoring my backup

Terje R
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Fri Jan 15, 2010 3:01 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Terje R » Mon Jan 20, 2014 1:24 pm

Jeyjoo wrote:If anyone find a fix please post.
I am currently restoring my backup


I followed the advice above from Leo and it worked

User avatar
Jeyjoo
Joomla! Explorer
Joomla! Explorer
Posts: 321
Joined: Tue Jul 19, 2011 8:56 am
Location: Monaco
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Jeyjoo » Mon Jan 20, 2014 1:47 pm

Terje R wrote:
Jeyjoo wrote:If anyone find a fix please post.
I am currently restoring my backup


I followed the advice above from Leo and it worked


Thanks Terje R

Did you make any changes to the file libraries\legacy\application\application.php (3.2.1, JApplication class), line 917

User avatar
Jeyjoo
Joomla! Explorer
Joomla! Explorer
Posts: 321
Joined: Tue Jul 19, 2011 8:56 am
Location: Monaco
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Jeyjoo » Mon Jan 20, 2014 1:49 pm

I cannot even see my backoffice due to the error - Fatal error: Call to undefined method JApplicationHelper::getHash() in libraries/cms/application/cms.php on line 637

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby leolam » Mon Jan 20, 2014 1:52 pm

Jeyjoo wrote:Did you make any changes to the file libraries\legacy\application\application.php (3.2.1, JApplication class), line 917
you should not do that for sure..... (THAT is BAD!) read what i wrote and install the package as I advised

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

User avatar
Jeyjoo
Joomla! Explorer
Joomla! Explorer
Posts: 321
Joined: Tue Jul 19, 2011 8:56 am
Location: Monaco
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Jeyjoo » Mon Jan 20, 2014 2:11 pm

Leolam - I would never do that without checking - I have nto made any changes.
The problem is, I cannot follow your instructions, as I cannot even see my backoffice:

http://jeyjoo.com/blog/administrator/

User avatar
Jeyjoo
Joomla! Explorer
Joomla! Explorer
Posts: 321
Joined: Tue Jul 19, 2011 8:56 am
Location: Monaco
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby Jeyjoo » Mon Jan 20, 2014 2:56 pm

Hi finally resolved this. I had to delete the library folder completely and reload.
Thanks everyone who helped.

I would just like to warn anyone who is considering upgrading to Joomla 3.2 to make sure they know what they are doing - it is not as smooth as previous updates. I do (to an extent), and had issues.
Last edited by imanickam on Fri Jan 24, 2014 10:08 am, edited 1 time in total.
Reason: Changed the subject from Resolved to Re: Discuss Joomla! 3.2.0 Stable Released

BrooklynzX
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Jan 26, 2014 11:32 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby BrooklynzX » Mon Jan 27, 2014 12:02 am

Hey I have just updated using the auto update to 3.2.0 stable and now received the following error message and original page is gone!

Fatal error: Call to undefined method JApplicationSite::stringURLSafe() in /home3/public_html/xm/modules/mod_jxtc_hikashopwall/tmpl/default_parse.php on line 43

Anyone know how to correct this so the site appears & functions again!

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby leolam » Mon Jan 27, 2014 3:53 am

BrooklynzX wrote:Hey I have just updated using the auto update to 3.2.0 stable
that is a wrong version. You should have upgraded to Joomla 3.2.1 (since 3.2.0 is having serious issues!) and you should have upgraded following what I advised here: viewtopic.php?f=710&t=793171. You have not checked if your extensions including the mentioned module are compatible with joomla 3.2.x and for instance
mod_jxtc_hikashopwall
is not compatible I believe and you might have some others as well which are not compatible.

You need to remove those extensions that are not compatible and upgrade immediately to joomla 3.2.1

Please post next time in the proper forum?

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

lovind
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Feb 11, 2014 11:38 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby lovind » Tue Feb 11, 2014 11:53 pm

Grazie Leo ho installato package joomla 3.2.1 che hai suggerito nel link tramite ftp perchè blackend era inaccessibile e finalmente dopo 2 gioni di ricerche e sofferenze il sito è ok!!! grazie!!!!

galtline
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sat May 07, 2011 7:48 pm

Re: Discuss Joomla! 3.2.0 Stable Released

Postby galtline » Tue Feb 18, 2014 8:43 pm

Getting the following error when going to templates or Joomla update page

Error 1054 - Unknown column 'extra_query' in 'field list' SQL=SELECT DISTINCT update_site_id, type, location, last_check_timestamp, extra_query FROM ssptk_update_sites WHERE enabled = 1

yohebon
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue Sep 03, 2013 5:15 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby yohebon » Sun Feb 23, 2014 6:40 am

This doesn't work for templates apparently. But does it work for packages?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby leolam » Sun Feb 23, 2014 7:44 am

galtline wrote:Getting the following error when going to templates or Joomla update page Error 1054 - Unknown column 'extra_query' in 'field list' SQL=SELECT DISTINCT update_site_id, type, location, last_check_timestamp, extra_query FROM ssptk_update_sites WHERE enabled = 1
Go to extension Manager --> database-->hit the FIX button

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

User avatar
johngw
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 113
Joined: Mon Nov 27, 2006 12:26 pm
Location: Handen Stockholm
Contact:

Re: Discuss Joomla! 3.2.0 Stable Released

Postby johngw » Thu Feb 27, 2014 3:50 pm

I having the same problem. Upgrading from 2.5.18 to 3.2.2 and can't access front-end and back-end. I just get a blank web page.
But I got this error:
1146 - An error has occurred.
Table 'famserv_new.g7d4w_postinstall_messages' doesn't exist SQL=SHOW FULL COLUMNS FROM `g7d4w_postinstall_messages`

Any solutions out there?
Best regards
John Wennerlund

K-Designed
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Oct 05, 2013 9:31 am

Re: Discuss Joomla! 3.2.0 Stable Released

Postby K-Designed » Sun Mar 02, 2014 11:06 am

after upgrading from 3.1 to 3.2.2 got the lovely FATAL ERROR with the hint for the remember.php line 96 error.

after some search and testing, following fix helped:
1. rename folder /plugins/system/remember to remember-me (or something like that)
2. now you can get into the administrator again, also you can see the frontpage again. Clear the cache via the admin panel.
3. paste this URL into your browser http://your-domain/administrator/index. ... w=database
4. you will see plenty of red database errors which obviously happened during the upgrade, means that the simple upgrade has a flaw and does not respect the database structure of previous versions.
5. on the present page you see the "FIX" button in the left upper corner, hit it
6. get nervous and wait, after a few seconds all shows "fixed" in green.
7. rename the previously changed /remember folder back to the original name
8. check your administrator and frontpage, it worked for me, all is fine again.

Hope this helps others who started sweating like me...I hit the upgrade button and at the same moment I realized that my last backup was 2 days old...bad during development....
Good luck all.


Return to “Announcements Discussions”

Who is online

Users browsing this forum: No registered users and 5 guests