Discuss Joomla! 3.4.4

A place to discuss recent announcements made by the Joomla! Core Team. Let's hear what you have to say.
User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21848
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Discuss Joomla! 3.4.4

Postby pe7er » Tue Sep 08, 2015 9:53 pm

Here you can discuss about the release of Joomla 3.4.4

See Announcement: viewtopic.php?f=8&t=894309
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Developer of Options Manager Lite https://db8.eu/download/file/options-manager-lite

User avatar
xfsgpr
Joomla! Guru
Joomla! Guru
Posts: 969
Joined: Mon Feb 14, 2011 4:02 am
Location: London

Re: Discuss Joomla! 3.4.4

Postby xfsgpr » Wed Sep 09, 2015 2:43 am

Since nobody has posted anything yet, I thought I'll start to post something that puzzles me. I am getting an error similar to this one:

Image

or this one:

Screenshot01.png


Does this mean that another update is expected next week?

The error I have produced have been replicated on three machines using Linux Ubuntu 12.04 fully updated on the morning of: 8th September, 2015) - before this update was released.

Screenshot01.png
You do not have the required permissions to view the files attached to this post.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.4.4

Postby leolam » Wed Sep 09, 2015 5:19 am

xfsgpr wrote:Since nobody has posted anything yet, I thought I'll start to post something that puzzles me. I am getting an error similar
When does this happen with what action

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21848
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Discuss Joomla! 3.4.4

Postby pe7er » Wed Sep 09, 2015 6:10 am

xfsgpr wrote:The error I have produced have been replicated on three machines using Linux Ubuntu 12.04 fully updated on the morning of: 8th September, 2015) - before this update was released.

And after you've updated to 3.4.4?
Can you still reproduce that error?
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Developer of Options Manager Lite https://db8.eu/download/file/options-manager-lite

Dizee
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Jul 07, 2010 3:09 pm

Re: Discuss Joomla! 3.4.4

Postby Dizee » Wed Sep 09, 2015 11:40 am

OK - immediately after updating, I've lost all the links to all my categories! 500 Unknown column 'm.ordering' in 'order clause' SQL=SELECT a.id, a.title, a.alias, a.introtext, a.fulltext, a.checked_out, a.checked_out_time, a.catid, a.created, a.created_by, a.created_by_alias, CASE WHEN a.modified = '0000-00-00 00:00:00' THEN a.created ELSE a.modified END as modified, a.modified_by, uam.name as modified_by_name,CASE WHEN a.publish_up = '0000-00-00 00:00:00' THEN a.created ELSE a.publish_up END as publish_up,a.publish_down, a.images, a.urls, a.attribs, a.metadata, a.metakey, a.metadesc, a.access, a.hits, a.xreference, a.featured, a.language, LENGTH(a.fulltext) AS readmore,CASE WHEN badcats.id is not null THEN 0 ELSE a.state END AS state,c.title AS category_title, c.path AS category_route, c.access AS category_access, c.alias AS category_alias,CASE WHEN a.created_by_alias > ' ' THEN a.created_by_alias ELSE ua.name END AS author,ua.email AS author_email,parent.title as parent_title, parent.id as parent_id, parent.path as parent_route, parent.alias as parent_alias,ROUND(v.rating_sum / v.rating_count, 0) AS rating, v.rating_count as rating_count,c.published, CASE WHEN badcats.id is null THEN c.published ELSE 0 END AS parents_published FROM info_content AS a LEFT JOIN info_content_frontpage AS fp ON fp.content_id = a.id LEFT JOIN info_categories AS c ON c.id = a.catid LEFT JOIN info_users AS ua ON ua.id = a.created_by LEFT JOIN info_users AS uam ON uam.id = a.modified_by LEFT JOIN info_categories as parent ON parent.id = c.parent_id LEFT JOIN info_content_rating AS v ON a.id = v.content_id LEFT OUTER JOIN (SELECT cat.id as id FROM info_categories AS cat JOIN info_categories AS parent ON cat.lft BETWEEN parent.lft AND parent.rgt WHERE parent.extension = 'com_content' AND parent.published != 1 GROUP BY cat.id ) AS badcats ON badcats.id = c.id WHERE a.access IN (1,1,5) AND c.access IN (1,1,5) AND CASE WHEN badcats.id is null THEN a.state ELSE 0 END = 1 AND a.catid = 15 AND (a.publish_up = '0000-00-00 00:00:00' OR a.publish_up <= '2015-09-09 11:35:47') AND (a.publish_down = '0000-00-00 00:00:00' OR a.publish_down >= '2015-09-09 11:35:47') ORDER BY m.ordering, a.created LIMIT 0, 105

Dizee
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Jul 07, 2010 3:09 pm

Re: Discuss Joomla! 3.4.4

Postby Dizee » Wed Sep 09, 2015 11:41 am

this is what happens on every single link to category I have, and there are hundreds!

Dizee
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Jul 07, 2010 3:09 pm

Re: Discuss Joomla! 3.4.4

Postby Dizee » Wed Sep 09, 2015 11:44 am

2 sites, completely poleaxed :(

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.4.4

Postby leolam » Wed Sep 09, 2015 12:00 pm

You updated from what version? You are using a specific component for "multi-categories?"

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

Dizee
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Jul 07, 2010 3:09 pm

Re: Discuss Joomla! 3.4.4

Postby Dizee » Wed Sep 09, 2015 12:07 pm

its alright, sorry was panicking, I updated my multi categories component and all fell back in place... but I got really sweaty for a bit!

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.4.4

Postby leolam » Wed Sep 09, 2015 12:14 pm

Dizee wrote:its alright, sorry was panicking, I updated my multi categories component and all fell back in place
Yep that I was seeing on the code. Just like to remind you because of your panic.....

BACKUP BEFORE UPDATING

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

Dizee
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Wed Jul 07, 2010 3:09 pm

Re: Discuss Joomla! 3.4.4

Postby Dizee » Wed Sep 09, 2015 1:11 pm

:D

yaanimai
Joomla! Explorer
Joomla! Explorer
Posts: 327
Joined: Thu Jun 14, 2007 2:48 pm
Location: Coppell, Texas
Contact:

Re: Discuss Joomla! 3.4.4

Postby yaanimai » Thu Sep 10, 2015 11:58 pm

I noticed there are 2 issues associated with this 3.4.4
https://docs.joomla.org/Category:Version_3.4.4_FAQ

If I upgrade will I encounter errors or problems with Joomla due to these issues if I upgrade?

Should I wait for 3.4.5 to upgrade?

Thank you for any information you can give about the 3.4.4 FAQ info.

User avatar
darb
Joomla! Ace
Joomla! Ace
Posts: 1267
Joined: Thu Jul 06, 2006 12:57 pm
Location: Stockholm Sweden
Contact:

Re: Discuss Joomla! 3.4.4

Postby darb » Fri Sep 11, 2015 6:20 am

What you think will Joomla support php 7 in the 3.4.+ serie or wait for 3.5 to support php 7?

I see these posting that hosting companies start supporting php 7 and also that it probably would have some positive performance for Joomla?

https://github.com/joomla/joomla-cms/issues/7571
https://www.siteground.com/blog/php-7-with-opcache/

rgs
Success in the long run Its not about the code its about the people and community that's make it!
Its not what you say its what you do that matters!

Darb - aka ssnobben

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 21848
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Discuss Joomla! 3.4.4

Postby pe7er » Fri Sep 11, 2015 7:40 am

I've read about a security issue on PHP 5.5 with OPcache & shared memory:
https://ikanobori.jp/php55-opcache-shared-hosting.html
Not sure if the problem has been solved in PHP7...
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Developer of Options Manager Lite https://db8.eu/download/file/options-manager-lite

User avatar
mbabker
Joomla! Hero
Joomla! Hero
Posts: 2010
Joined: Sun Feb 28, 2010 8:26 pm
Location: White Bear Lake, MN, USA
Contact:

Re: Discuss Joomla! 3.4.4

Postby mbabker » Fri Sep 11, 2015 2:58 pm

PHP 7 is fully supported in the 3.5 branch. 3.4 will not support PHP 7.
Production Department Coordinator, Release Lead, CMS Maintainer, Framework Maintainer, Security Team Member, .org System Administrator

Manually updating Joomla? See https://gist.github.com/mbabker/d7bfb4e1e2fbc6b7815a733607f89281

yaanimai
Joomla! Explorer
Joomla! Explorer
Posts: 327
Joined: Thu Jun 14, 2007 2:48 pm
Location: Coppell, Texas
Contact:

Re: Discuss Joomla! 3.4.4

Postby yaanimai » Sat Sep 12, 2015 4:07 pm

I updated three websites from 3.4.3 to 3.4.4 & everything went great & is working great. Thank you Team Joomla!

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33408
Joined: Sat Apr 05, 2008 9:58 pm

Re: Discuss Joomla! 3.4.4

Postby Webdongle » Wed Sep 16, 2015 7:49 pm

On localhost J3.4.4 ... Phoca Gallery 4.2.1.zip fails to install upload/install. But eventually installs from url https://github.com/PhocaCz/PhocaGallery ... v4.2.1.zip

Because of the problems on localhost win 10 installing Joomla database (ie not populating database with Host: localhost but eventually populates database with Host: 127.0.0.1) ... and some extensions having problems installing. It suggests all the various errors are the result of something 'hanging' when the database is being populated with data.

Depending on where the installation script 'hangs' will be responsible for the error message. The common factor of all the error messages is the script hanging when it is communicating with the database.

Addendum
j3.4.4 on my remote Host ... Phoca Gallery 4.2.1.zip installed (upload/install) without problem in about 30 seconds. Perhaps its just that large 3rd party extensions just time out on slow servers ?

User avatar
yvonlali
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Nov 22, 2011 12:28 am
Location: Montreal, Quebec, Canada
Contact:

Re: Discuss Joomla! 3.4.4

Postby yvonlali » Wed Sep 16, 2015 9:06 pm

Since I upgrade one site to V3.4.4 when I try to modify an article, the buttons to save, copy, save and close and the one to close are not working.

I upgrade an other site and it works perfectly.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33408
Joined: Sat Apr 05, 2008 9:58 pm

Re: Discuss Joomla! 3.4.4

Postby Webdongle » Wed Sep 16, 2015 9:45 pm

Clear browser cache

User avatar
yvonlali
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Tue Nov 22, 2011 12:28 am
Location: Montreal, Quebec, Canada
Contact:

Re: Discuss Joomla! 3.4.4

Postby yvonlali » Thu Sep 17, 2015 12:17 am

Hi, I clear the browser cache, I use Microsoft Edge, Microsoft explorer and Google chrome and it's the same.

I still can't use the buttons.

zulugreen
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Oct 26, 2006 11:35 am

Content item associations broken after upgrade to 3.4.4

Postby zulugreen » Thu Sep 17, 2015 9:19 am

Hi,

After upgrade to 3.4.4, content item association feature (used on multilingual sites) seems to be broken.
In the article edit screen, there's 'Associations' tab which won't save the selected choices, and there's a 'Content item associations' tab where only modal background opens (no selection options).

Joomla 3.4.4 / PHP 5.4 or 5.5.

Can anyone confirm the bug and suggest a fix?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Content item associations broken after upgrade to 3.4.4

Postby leolam » Thu Sep 17, 2015 9:46 am

zulugreen wrote:After upgrade to 3.4.4, content item association feature (used on multilingual sites) seems to be broken.
I have just tested your experience on our Joomla Bug Squad testsite and I cannot replicate your issues posted. This works for me as expected

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

zulugreen
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Oct 26, 2006 11:35 am

Re: Content item associations broken after upgrade to 3.4.4

Postby zulugreen » Thu Sep 17, 2015 2:47 pm

leolam wrote:
zulugreen wrote:After upgrade to 3.4.4, content item association feature (used on multilingual sites) seems to be broken.
I have just tested your experience on our Joomla Bug Squad testsite and I cannot replicate your issues posted. This works for me as expected

Leo 8)


I have two sites upgraded fom 3.4.3 to 3.4.4 with the same issue. It seems as if the 3.4.3 'Associations' tab was changed to 'Content Item Associations' in the 3.4.4. version, but the change doesn't seem to have been applied fully.

Perhaps the test site is a clean install, I updated my sites from 3.4.3 to 3.4.4 via Joomla update manager.

Screenshot:
associations344.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.4.4

Postby leolam » Thu Sep 17, 2015 3:14 pm

Sorry with all respect but the image you show is not a representation of the multi-lingual Article-Edit Screen. I have never seen a tab called "Content-Items-Association"

Also your screen does not reflects my multi-lingual Joomla 3.4.4 layout see attachment since "meta-data-tab" and CIA-tab" are not present in current Joomla state.

Was this an upgrade from an earlier Joomla version maybe? I have asked my peers in the JBS for advise since this is a first one for me as you can see?

Leo 8)

cia.jpg
You do not have the required permissions to view the files attached to this post.
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Content item associations broken after upgrade to 3.4.4

Postby leolam » Thu Sep 17, 2015 3:26 pm

zulugreen wrote:I have two sites upgraded fom 3.4.3 to 3.4.4 with the same issue. It seems as if the 3.4.3 'Associations' tab was changed to 'Content Item Associations' in the 3.4.4. version
This seems to be caused by a 3rd party extension since we do not have 2 tabs in the Article editor screen namely "Metadata" and "Content Item Associations"

Both do not exist in Joomla 3.4.4 Please clarify?

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

zulugreen
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Oct 26, 2006 11:35 am

Re: Content item associations broken after upgrade to 3.4.4

Postby zulugreen » Thu Sep 17, 2015 9:32 pm

leolam wrote:
zulugreen wrote:I have two sites upgraded fom 3.4.3 to 3.4.4 with the same issue. It seems as if the 3.4.3 'Associations' tab was changed to 'Content Item Associations' in the 3.4.4. version
This seems to be caused by a 3rd party extension since we do not have 2 tabs in the Article editor screen namely "Metadata" and "Content Item Associations"

Both do not exist in Joomla 3.4.4 Please clarify?

Leo 8)


Your screenshot depicts what my Joomla 3.4.3 article edit screen looks like, while my screenshot is from Joomla 3.4.4 upgraded from 3.4.3.
I've now upgraded a third site and it has the exact same issue. I can't think of any 3rd party extensions which would cause this kind of a behavior in the backend.
So I'm a bit puzzled, but if it's not bug, I'll have to figure it out. I just don't know where to start.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 33408
Joined: Sat Apr 05, 2008 9:58 pm

Re: Discuss Joomla! 3.4.4

Postby Webdongle » Thu Sep 17, 2015 10:00 pm

I get the same result as Leo 3.4.4 updated from 3.4.3
association 01.JPG


However in /administrator/language/en-GB/en-GB.com_content.ini
line 112 of 3.4.3 and line 113 of 3.4.4 is
COM_CONTENT_ITEM_ASSOCIATIONS_FIELDSET_LABEL="Content Item Associations"

As both Leo and my are unable to reproduce your configuration we need you to give exact steps to reproduce

Addendum
Searching the Joomla full package for COM_CONTENT_ITEM_ASSOCIATIONS_FIELDSET_LABEL can only be found in en-GB.com_content.ini

Addendum 2
/administrator/components/com_content/views/article/tmpl/edit.php only contains code to display the tabs that Leo and myself are seeing
Content
Publishing
Images and links
Associations
Options
Configure Edit Screen
Permissions
You do not have the required permissions to view the files attached to this post.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Content item associations broken after upgrade to 3.4.4

Postby leolam » Fri Sep 18, 2015 2:04 am

zulugreen wrote:Your screenshot depicts what my Joomla 3.4.3 article edit screen looks like, while my screenshot is from Joomla 3.4.4 upgraded from 3.4.3.
Wrong. My screenshot is from a Joomla 3.4.4 installation upgraded from Joomla 3.0.1 with each new version. Also see this announcement : Do you see that tab you refer at? No See this http://screencast.com/t/p92zEH78s before you hit the start button scroll down and see it is J3.4.4

Also you screen shows the Metadata tab. This was moved to the Publishing Tab in Joomla earlier version (would have to look when but metadata entries are given now under the "Publishing Tab")

So in other words, Your file system is corrupt and shows a mixup of data. Please download a full version of Joomal 3.4.4, extract locally and upload in binary mode all file and folders (except for 'installation' - folder) and overwrite existing files and folders. That should take care of the issue

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18458
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Discuss Joomla! 3.4.4

Postby infograf768 » Fri Sep 18, 2015 5:41 am

COM_CONTENT_ITEM_ASSOCIATIONS_FIELDSET_LABEL is used in hathor only, not in Isis.
Screen Shot 2015-09-18 at 07.38.17.png


IMHO, we could change it there too to Associations

Code: Select all

<?php echo JHtml::_('sliders.panel', JText::_('COM_CONTENT_ITEM_ASSOCIATIONS_FIELDSET_LABEL'), '-options');?>


to use
JGLOBAL_FIELDSET_ASSOCIATIONS="Associations"
You do not have the required permissions to view the files attached to this post.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
Multilanguage in 2.5: http://help.joomla.org/files/EN-GB_multilang_tutorial.pdf
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 18387
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.4.4

Postby leolam » Fri Sep 18, 2015 6:29 am

Think that is a good idea JM just to avoid these kind of issues. Kindly please you make a PR? Thanks in advance

That however does not take away that the @zulugreen edit pane is messed up since again it does show the "CIA"-tab and also shows the "Metatab" Both should not show in the editing pane of the article as shown (Isis)

Leo 8)
Celebrating 12-Years of Professional Joomla Support Services
- Joomla Professional Support:https://gws-desk.com -
- Joomla Specialized Hosting Solutions:https://gws-host.com -
- Member Joomla Bug Squad & J-CMS Release Team


Return to “Announcements Discussions”

Who is online

Users browsing this forum: No registered users and 4 guests