Discuss Joomla! 3.4.7

A place to discuss recent announcements made by the Joomla! Core Team. Let's hear what you have to say.
User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22225
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Discuss Joomla! 3.4.7

Post by pe7er » Mon Dec 21, 2015 10:49 pm

Here you can discuss about the release of Joomla 3.4.7

See Announcement: http://forum.joomla.org/viewtopic.php?f=8&t=902920
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

bentk
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Thu Nov 10, 2011 11:52 pm

Re: Discuss Joomla! 3.4.7

Post by bentk » Mon Dec 21, 2015 10:56 pm

Since the upgrade to 3.4.7, I cannot edit my articles.

"Error
You are not permitted to use that link to directly access that page (#article_id)"

and when I try to edit an article, Joomla locks it also. After "check in" the same situation is happening.

PHP version 5.4.45-0
Joomla! 3.4.7 Stable [ Ember ] 21-December-2015 16:00 GMT
Last edited by bentk on Mon Dec 21, 2015 11:22 pm, edited 1 time in total.

User avatar
zomtec
Joomla! Intern
Joomla! Intern
Posts: 78
Joined: Tue Jan 13, 2015 12:49 pm

Re: Discuss Joomla! 3.4.7

Post by zomtec » Mon Dec 21, 2015 11:11 pm

bentk wrote:Since the upgrade to 3.4.7, I cannot edit my articles.

"Error
You are not permitted to use that link to directly access that page (#article_id)"

and when I try to edit an article, Joomla locks it also. After "check in" the same situation is happening.
I cannot confirm that. After upgrading from 3.4.6 to 3.4.7 editing articles works fine. Maybe you have to clean up your browser cache and try again.
Last edited by zomtec on Mon Dec 21, 2015 11:14 pm, edited 1 time in total.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3377
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Discuss Joomla! 3.4.7

Post by ribo » Mon Dec 21, 2015 11:14 pm

I can confirm also that editing articles and from backend and from frontend works fine.
chat room spontes : http://www.spontes.com

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22225
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Discuss Joomla! 3.4.7

Post by pe7er » Mon Dec 21, 2015 11:18 pm

bentk wrote:Since the upgrade to 3.4.7, I cannot edit my articles.
See: https://docs.joomla.org/J3.x:Unable_To_ ... icle_3.4.7
How to fix: Logging out and back in again will fix this issue.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

Americandane
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 13, 2015 4:25 pm

3.4.7 Question

Post by Americandane » Mon Dec 21, 2015 11:21 pm

So just to confirm I understand 100%, the upgrade is not urgent if we are running the versions of php named in the announcement (PHP 5.4.45, 5.5.29, 5.6.13), since the underlying bug is in php.

Is that right?
Last edited by imanickam on Wed Dec 23, 2015 3:54 am, edited 1 time in total.
Reason: Merged with topic http://forum.joomla.org/viewtopic.php?f=9&t=902921

wavesweb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 25, 2012 7:00 am

Re: Discuss Joomla! 3.4.7

Post by wavesweb » Mon Dec 21, 2015 11:23 pm

After upgrade to 3.4.7 I cannot add menu items to any menu. I select menu item type "single article" and it erases all content and does not provide an option to select the article. Is this a known bug or unique to me?

bentk
Joomla! Apprentice
Joomla! Apprentice
Posts: 48
Joined: Thu Nov 10, 2011 11:52 pm

Re: Discuss Joomla! 3.4.7

Post by bentk » Mon Dec 21, 2015 11:25 pm

pe7er wrote:
bentk wrote:Since the upgrade to 3.4.7, I cannot edit my articles.
See: https://docs.joomla.org/J3.x:Unable_To_ ... icle_3.4.7
How to fix: Logging out and back in again will fix this issue.
Thank you guys!

Logging out and back in again fixed the issue.

Thanks again and sorry...!

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3377
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Discuss Joomla! 3.4.7

Post by ribo » Mon Dec 21, 2015 11:27 pm

wavesweb wrote: Is this a known bug or unique to me?
I tested, no bug, works fine
chat room spontes : http://www.spontes.com

wavesweb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 25, 2012 7:00 am

Re: Discuss Joomla! 3.4.7

Post by wavesweb » Mon Dec 21, 2015 11:29 pm

As a follow up note when I restored my site back to 3.4.5 everything works again so I feel this may be a bug with 3.4.7. I have not tried with 3.4.6 yet.

User avatar
ribo
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3377
Joined: Sun Jan 03, 2010 8:47 pm
Contact:

Re: Discuss Joomla! 3.4.7

Post by ribo » Mon Dec 21, 2015 11:35 pm

wavesweb wrote:As a follow up note when I restored my site back to 3.4.5 everything works again so I feel this may be a bug with 3.4.7. I have not tried with 3.4.6 yet.
If it is a bug like you say why i dont have such issue with 3.4.7?
chat room spontes : http://www.spontes.com

wilsonge
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Wed Jan 20, 2010 4:33 pm
Contact:

Re: Discuss Joomla! 3.4.7

Post by wilsonge » Tue Dec 22, 2015 12:31 am

Hi guys,
As Peter noted in the Docs page. We had to make some changes to the way that sessions worked in Joomla to work around a critical PHP bug (see https://bugs.php.net/70219). Whilst we could easily migrate enough data to keep you logged in and have a successful update - it's apparent that we didn't do a good enough job. Logging out and back in again will reset your session data and fix everything however. So make sure you try that before reporting any bugs :) I totally get it's not ideal - but it's the best of a bad situation.

Kind Regards,
George

wilsonge
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Wed Jan 20, 2010 4:33 pm
Contact:

Re: 3.4.7 Question

Post by wilsonge » Tue Dec 22, 2015 1:09 am

I still advise that you patch. Although there no vulnerabilities that we know of this patch does have other uses. If you need to prioritise then work on the vulnerable PHP versions first. But you should patch ALL your sites with this patch as soon as you can.

User avatar
ixchup
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Nov 03, 2005 12:10 pm
Location: Potomac, MD
Contact:

Re: Discuss Joomla! 3.4.7

Post by ixchup » Tue Dec 22, 2015 1:14 am

I upgraded to 3.4.7 and it logged me out of Administrator and now it won't let me log back in. I have purged my browser cache and refreshed the page and I still get the error message: The most recent request was denied because it contained an invalid security token. Please refresh the page and try again.

This is occurring on two separate Joomla sites. I'm very frustrated. Any tricks to fix this?
"I'm the kid who has this habit of dreaming. Sometimes gets me in trouble too. But the truth is I could no more stop dreaming than I could see them all come true." Noel Paul Stookey

solesky
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jan 19, 2015 4:21 pm

Re: Discuss Joomla! 3.4.7

Post by solesky » Tue Dec 22, 2015 1:39 am

I just upgraded to 3.4.7 and I got the same problem as ixchup. I won´t let me log back in.
Im getting this error:The most recent request was denied because it contained an invalid security token. Please refresh the page and try again.

Help please!!!

sleighd
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Sep 05, 2014 12:25 am

Re: Discuss Joomla! 3.4.7

Post by sleighd » Tue Dec 22, 2015 2:55 am

Same Here.
I just upgraded to 3.4.7 and I have the same problem as ixchup and solesky. It booted me out when clicking 'Update' and I haven't been able to log back in.
I'm getting this error: The most recent request was denied because it contained an invalid security token. Please refresh the page and try again.

mikeh00
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri Sep 02, 2005 3:56 am

Re: Discuss Joomla! 3.4.7

Post by mikeh00 » Tue Dec 22, 2015 3:00 am

Sort of similar problem. Upgraded and ended up at error screen. This webpage has a redirect loop

ERR_TOO_MANY_REDIRECTS

Now it won't let me login anymore. Keep getting that same error. Nice one Joomla.

nickwalks
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Tue Sep 14, 2010 2:16 am

Re: Discuss Joomla! 3.4.7

Post by nickwalks » Tue Dec 22, 2015 4:23 am

I am seeing a similar error after upgrading ' The most recent request was denied because it contained an invalid security token. Please refresh the page and try again.' I have tried clearing browser cache and active logins. Tried deleting sessions from database. Nothing seems to work. Any suggestions would be greatly appreciated.

**edit - extracting 3.4.6 full package in root directory (and deleting installation folder) rolled version back and can now access site. Had tried extracting 3.4.7 first but problem persisted.
Last edited by nickwalks on Tue Dec 22, 2015 5:09 am, edited 1 time in total.

wavesweb
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Apr 25, 2012 7:00 am

Re: Discuss Joomla! 3.4.7

Post by wavesweb » Tue Dec 22, 2015 4:27 am

As a note to my previous post - I updated to latest version again. Logged out and then back in and it works. As a note to others with my previously posted on issue - log in and out and menu items will work for you. Usually when you upgrade this is not necessary but you will need to log in and out to continue any work you have for this upgrade. Hope this helps someone.

User avatar
JacquesR
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Tue May 19, 2009 3:00 pm
Location: Cape Town, South Africa
Contact:

Re: Discuss Joomla! 3.4.7

Post by JacquesR » Tue Dec 22, 2015 7:12 am

ixchup wrote:I upgraded to 3.4.7 and it logged me out of Administrator and now it won't let me log back in. I have purged my browser cache and refreshed the page and I still get the error message: The most recent request was denied because it contained an invalid security token. Please refresh the page and try again.

This is occurring on two separate Joomla sites. I'm very frustrated. Any tricks to fix this?
The following worked for me, in how to solve the "The most recent request was denied because it contained an invalid security token. Please refresh the page and try again" message:

Instead of refreshing, go to /administrator/ and log in again.
(you are most likely at /administrator/index.php when it is showing that message)
Jacques Rentzke
New Web Consulting
http://www.new-web-consulting.co.za/ -- http://twitter.com/JacquesRentzke
Joomla Community Magazine Co-Lead Editor -- Joomla! Bug Squad

makotosun
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Sep 11, 2012 5:01 am

Re: Discuss Joomla! 3.4.7

Post by makotosun » Tue Dec 22, 2015 9:08 am

nickwalks wrote:I am seeing a similar error after upgrading ' The most recent request was denied because it contained an invalid security token. Please refresh the page and try again.' I have tried clearing browser cache and active logins. Tried deleting sessions from database. Nothing seems to work. Any suggestions would be greatly appreciated.

**edit - extracting 3.4.6 full package in root directory (and deleting installation folder) rolled version back and can now access site. Had tried extracting 3.4.7 first but problem persisted.
So if I am reading this right, you simply extracted a fresh copy of 3.4.6, then uploaded that right over your old install, then deleted the "installation folder" and your site rolled back one version and is now working? If that works, I should be good to go.

I did the upgrade, and now cannot log in to log out then re-log in to fix the session issue.

Is there a way to make some changes in the site before an upgrade to avoid this? I have 5 different sites and don't want to mess any more of them up, but want to take advantage of the security upgrades. Any help would be greatly appreciated as I am really a novice on the under the hood stuff.

Thanks in advance!

User avatar
JacquesR
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Tue May 19, 2009 3:00 pm
Location: Cape Town, South Africa
Contact:

Re: Discuss Joomla! 3.4.7

Post by JacquesR » Tue Dec 22, 2015 9:56 am

@makotosun: If you close any tabs in your browser, where you had the site admin open, and then go to your site's /administrator/ and log in there, do you still get the session expired message?
Last edited by JacquesR on Tue Dec 22, 2015 10:01 am, edited 1 time in total.
Jacques Rentzke
New Web Consulting
http://www.new-web-consulting.co.za/ -- http://twitter.com/JacquesRentzke
Joomla Community Magazine Co-Lead Editor -- Joomla! Bug Squad

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 19661
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ UK/ S'pore/Jakarta/ North America
Contact:

Re: Discuss Joomla! 3.4.7

Post by leolam » Tue Dec 22, 2015 9:57 am

makotosun wrote:So if I am reading this right, you simply extracted a fresh copy of 3.4.6, then uploaded that right over your old install, then deleted the "installation folder" and your site rolled back one version and is now working? If that works, I should be good to go.
That is not a solution. Login to phpMyAdmin and truncate the session table (not delete but empty it) --> Delete entire browser history, close and reopen browser and go to yoursite/administrator (not yoursite/administrator/index.php

After this you should be able to login again

Leo 8)
Joomla's #1 Professional Support Provider:
-> Joomla Professional Support: https://gws-desk.com -
-> Joomla Specialized Hosting Solutions: https://gws-host.com -
-> Joomla Webmaster Services: gws-webmaster.services

makotosun
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Sep 11, 2012 5:01 am

Re: Discuss Joomla! 3.4.7

Post by makotosun » Tue Dec 22, 2015 10:23 am

Thank you for the help on this. Alas, neither of the two above solutions worked. I still get the following message:

"The most recent request was denied because it contained an invalid security token. Please refresh the page and try again."

a bit more info: I have historically had three super user accounts. One which I use for normal site work, and two in reserve that are not used except once in awhile to verify functionality.

My site was running Joomla 3.4.6 (the last security update) and seemed to be working fine. No issues at all.

I updated to 3.4.7 using the site update feature. In the middle of the update, the site logged me out (I was logged in as an admin to do the update) and I have not been able to log in since. I redirected my domain to a temporary landing page which I sort this out. It is a Kunena forum site if that makes a difference.

I used MySql to create a new administrator account to see if maybe a fresh account would use the new session handler and let me get in that way. No luck - same result as above. The site is functioning in view mode, but no one can log in.

If you have any other suggestions, I am at a loss right now. I would simply like to try and roll back to the version that worked and then I can plan a path forward. The site is quite large so rebuilding it is a bit daunting if I can avoid it :)

Thank you all so much!

User avatar
JacquesR
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Tue May 19, 2009 3:00 pm
Location: Cape Town, South Africa
Contact:

Re: Discuss Joomla! 3.4.7

Post by JacquesR » Tue Dec 22, 2015 10:34 am

makotosun wrote: I updated to 3.4.7 using the site update feature. In the middle of the update, the site logged me out (I was logged in as an admin to do the update) and I have not been able to log in since. I redirected my domain to a temporary landing page which I sort this out. It is a Kunena forum site if that makes a difference.
Check if the Kunena component is affected by this change in 3.4.7:
https://docs.joomla.org/J3.x:Backward_C ... omla_3.4.7
Jacques Rentzke
New Web Consulting
http://www.new-web-consulting.co.za/ -- http://twitter.com/JacquesRentzke
Joomla Community Magazine Co-Lead Editor -- Joomla! Bug Squad

makotosun
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Sep 11, 2012 5:01 am

Re: Discuss Joomla! 3.4.7

Post by makotosun » Tue Dec 22, 2015 10:42 am

The site profiler actually uses Easysocial for registration and user management. The site has Kunena as a forum, but I don't use Kunena as the registration. It also uses a bunch of other bits and pieces, so figuring out exactly what is going wrong is probably going to be a bit of a challenge.

I can try to go in and shut off parts and pieces and see if that opens the door, but as I said, I am not any kind of expert on this stuff. Probably in way over my comfort level, but I will keep trying. I have been able to learn from reading and forums and helpful folks, so this too shall pass.

I will report back if I find anything out, as I am sure I am not the only one with an issue like this.

Thank you!

bienenf
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Dec 22, 2015 10:50 am

Re: Discuss Joomla! 3.4.7

Post by bienenf » Tue Dec 22, 2015 11:27 am

Hello team,

I have the same issue, we don't use Kunena,

And i can't login in Front, or access to the administrator side,

i have the security messager also,

thank you in advance for your support

bienenf
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Dec 22, 2015 10:50 am

Re: Discuss Joomla! 3.4.7

Post by bienenf » Tue Dec 22, 2015 12:36 pm

Hello,

I did the truncate without success,

and also the history delete, and went to yoursite/administrator
.... not good,

Thank you for your help
leolam wrote:That is not a solution. Login to phpMyAdmin and truncate the session table (not delete but empty it) --> Delete entire browser history, close and reopen browser and go to yoursite/administrator (not yoursite/administrator/index.php

After this you should be able to login again

Leo 8)

User avatar
LUMBERJACK
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Wed Jul 12, 2006 2:28 am
Location: Malta or Bulgaria

Re: Discuss Joomla! 3.4.7

Post by LUMBERJACK » Tue Dec 22, 2015 12:45 pm

Hi,
I use VirtueMart 3.0.12.
After updating Joomla! from 3.4.6 to 3.4.7 I cannot access any detailed product page (on front). When I click on a certain product from the list of products, it gives me an error 404 - there is no such product.
I'm Lumberjack 'n' I'm OK

User avatar
LUMBERJACK
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Wed Jul 12, 2006 2:28 am
Location: Malta or Bulgaria

Re: Discuss Joomla! 3.4.7

Post by LUMBERJACK » Tue Dec 22, 2015 1:15 pm

LUMBERJACK wrote:Hi,
I use VirtueMart 3.0.12.
After updating Joomla! from 3.4.6 to 3.4.7 I cannot access any detailed product page (on front). When I click on a certain product from the list of products, it gives me an error 404 - there is no such product.
O!
After changing my hosting PHP to version 5.5.1 the problem got disappeared.

BUT a lot of problems bloomed on the other websites that are hosted in the same place!

:'(
I'm Lumberjack 'n' I'm OK


Locked

Return to “Announcements Discussions”