Page 1 of 1

Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 2:12 pm
by ooffick
Here you can discuss about the release of Joomla 3.8.9

See Announcement: viewtopic.php?f=8&t=963128

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 2:49 pm
by toivo
Please note that an issue has been reported with the update on Windows platforms:

https://github.com/joomla/joomla-cms/issues/20875

This patch fixes the issue: https://github.com/joomla/joomla-cms/pull/20877

Fatal error while updating Joomla

Posted: Tue Jun 26, 2018 2:59 pm
by garly01
I was updating a site I was working on on localhost from joomla 3.8 to 3.9 and the site crashed while performing the update and I got a fatal error.

I now can't access the backend or frontend. This is the error I get when I try to access the site

Fatal error: Uncaught Error: Class 'JClassLoader' not found in C:\xampp\htdocs\hikashop\libraries\cms.php:40 Stack trace: #0 C:\xampp\htdocs\hikashop\includes\framework.php(18): require_once() #1 C:\xampp\htdocs\hikashop\index.php(40): require_once('C:\\xampp\\htdocs...') #2 {main} thrown in C:\xampp\htdocs\hikashop\libraries\cms.php on line 40


Would anyone know what went wrong or how I might possibly fix it. Thanks

Crash...

Posted: Tue Jun 26, 2018 3:03 pm
by ies
I tried twice in two different websites and in localhost server to update Joomla from 3.8.8 to 3.8.9 and it crashed showing the following:

Fatal error: Uncaught Error: Class 'JClassLoader' not found in ...\libraries\cms.php:40 Stack trace: #0 ...\administrator\includes\framework.php(18): require_once() #1 ...\administrator\index.php(40): require_once('D:\\Localhost\\...') #2 {main} thrown in ...\libraries\cms.php on line 40

Now I am afraid to try to a live server...

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 3:16 pm
by toivo
The release team fixed this issue quickly, producing this patch:

https://github.com/joomla/joomla-cms/pull/20877

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 3:33 pm
by ies
Thank you for your fast answer.

Unfortunately the problem remains to localhost.
I tried to a few live websites but there was no problem there.

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 3:42 pm
by imanickam
ies wrote:Unfortunately the problem remains to localhost.
The issue happens only in Windows platform.

Please note that the title of the Pull Request is "Fix the autoloader for Windows platforms". Also, toivo has mentioned this in his post.

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 3:54 pm
by ies
You are right, I didn't notice it. Thank you.

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 3:54 pm
by toivo
Update to 3.8.10 has now been released.

Re: Discuss Joomla! 3.8.9

Posted: Tue Jun 26, 2018 4:02 pm
by ies
Yes, I just saw, so there is no need for applying the patch.

Thank you all.