Problema en el enlace de las banderitas

Para cuestiones relacionadas con el uso de los idiomas en Joomla, así como para hablar sobre las traducciones al español del core y cualquier extensión. Todas las versiones de Joomla.

Moderators: hefesto, carcam

Locked
ogonzalez
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Feb 07, 2007 1:37 pm

Problema en el enlace de las banderitas

Post by ogonzalez » Wed Feb 07, 2007 1:52 pm

Hola a todos
Tengo una pagina web creada con joomla v1.0 .Acabo de instalar joomfish 1.7 y tras cargar los idiomas y configurar joomfish me he metido con las traducciones de los textos y menus de español a gallego.

El tema es que funciona correctamente la traduccion si cambio en el menu de joomla el idioma por defecto. En ese caso se muestra el contenido en español o en gallego segun realice la seleccion.

Para ir mas alla, active el menu de joomfish para que muestre las banderitas correspondientes de los idiomas. Estas se muestran correctamente pero no hacen que cambie el idioma. He probado a que en vez de banderita apareciese el nombre y tampoco.

Hubo un momento en que funciono correctamente. hice unos cambios que describo a continuacion (los cuales describo) y me dejo de funcionar el enlace de las banderitas:
1. Cambie el nombre de los idiomas en joomla: He comprobado en joomfish por si perdio la referencia pero veo que la conserva.
2. Cambie el texto del menu de joomfish que aparece en el frontend, justo encima de las banderitas, para que pusiese "Seleccione idioma"

y en principio nada mas.

Alguien me puede echar una mano....

Gracias

ogonzalez
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Feb 07, 2007 1:37 pm

Re: Problema en el enlace de las banderitas

Post by ogonzalez » Wed Feb 07, 2007 2:09 pm

Ya he solucionado el problema. Lo dejo aqui por si alguien tiene alguna vez el mismo...

El tema es que tenia desactivada el parametro Enable Language determination del modulo Multi lingual abstraction layer bot y sin embargo tenia activado como Language selection for new visitors el lenguaje del sitio por defecto.

Esto hacia que si el sitio por defecto tenia el idioma Castellano, al querer cambiar a otro idioma, como el parametro enable language determitation estaba desactivado, no le hacia caso. Con poner esta casilla a Yes se soluciono el problema.


Locked

Return to “Idioma y traducciones”