Problemas Joomla - Firefox - Acentos - Css

Para cuestiones relacionadas con el uso de los idiomas en Joomla, así como para hablar sobre las traducciones al español del core y cualquier extensión. Todas las versiones de Joomla.

Moderators: hefesto, carcam

Locked
serknor
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Fri Sep 30, 2005 3:10 pm

Problemas Joomla - Firefox - Acentos - Css

Post by serknor » Wed Nov 23, 2005 6:34 pm

Tengo un graaan problema. Ya no sé donde buscar ayuda, me leí montones de threads sin encontrar la solución. Ví un montón de consejos, pero ninguno me funcionó.
--------------------------------------------------------
Tengo un sitio hecho en Joomla! 1.1.0 Alpha [ Nigthfall ].
El host se llama funpic.de
El sitio es http://monocromatico.mo.funpic.de/
Database Version:  4.0.26-log 
PHP Version:  4.4.1 
Web Server:  Apache 
--------------------------------------------------------

Tengo instalado el idioma en español, un template propio, con css propio.
El problema es multiple
1) En el internet explorer todas los acentos, "ñ", etc, que sean parte del archivo de lenguaje se ven mal. No así los acentos y las eñes que yo escribo a mano.
2) En firefox , al revés. Se ven bien los acentos propios del arhivo de lenguaje, pero no los que yo tipeo.
3) La página no se ve bien en firefox, porque no utiliza bien el css. No así el Internet Explorer. Por ejemplo, si abrieron la página, en el IE, las secciones que aparecen en el menú principal tienen un recuadro, todas del mismo tamaño. En cambio en el firefox, pasa por alto el "width=100%" y el recuadro de cada link a la secciones del menú principal se adapta al tamaño del nombre de la sección.

Datos extras:
- Cuando lo pruebo al template y al lenguaje con el MSAS (con mambo, obvio), no tengo este problema de los acentos con el internet explorer.
- Leí sobre modificar el charset=iso-8859-1, pero lo unico q hace es alternarme como funciona en el IE y FF, pero sigue con problemas en uno o en el otro.

Me leí todos los consejos y no logré nada! Por favor, alguien me puede ayudar con éso? Para ambas cosas, los acentos y lo del css. Thanks!

NikoDella

Re: Problemas Joomla - Firefox - Acentos - Css

Post by NikoDella » Wed Nov 23, 2005 7:00 pm

Hola serknor

Lamentablemente no tengo la solución de esto, pero sí me acuerdo de que a mí me pasaba lo mismo... pero se pasó cuando empecé a meter mano al ccs, y al archivo de lenguaje "english" (sip, traduje manualmente las cosas del archivo).

Asi es que no sé cuál es la solución... a mi se me pasó solo...  ???

serknor
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Fri Sep 30, 2005 3:10 pm

Re: Problemas Joomla - Firefox - Acentos - Css

Post by serknor » Wed Nov 23, 2005 7:16 pm

Jejeje, Gracias! Mirá, acabo de solucionar el problema con IE. Ahí anda barbaro. Éso lo solucioné abriendo el archivo de idioma desde el admin, abriendo el archivo de lenguaje en mi rígido, y copiando el texto de éste archivo en el primero. Y listo.
Sigo teniendo problemas con Firefox, y llegué un poco a la conclusión de que es un histerico :P. Los acentos en FF se pueden ver bien, llendo al menú "ver" y en la codifiación pongo UTF-8. El problema es que no lo hace automaticamente! Y éso que se lo aclaro tanto en el template como en el archivo de idioma!!! jajajajaja. Es más, entro en el codigo fuente, y no aparece en ningún lado la codificación ISO-8859-1 que es la que está tomando. No sé de donde lo saca! jajajaja. En fin. Ahora mi preocupación es por que no se la antoja abrirme bien el css.... encima me lo abre bien de a partes! porque no es que está toooodo mal. Debe ser que no es compatible con ciertas propiedades. Muchas gracias por la sugrencia NikoDella.

NikoDella

Re: Problemas Joomla - Firefox - Acentos - Css

Post by NikoDella » Wed Nov 23, 2005 9:17 pm

Ah, esto del idioma es bien raro en joomla...

Justo cuando estaba feliz porque no tenía este problema, hago una corrección en el archivo de lenguaje para que supuestamente se vean las fechas en español, y todo los acentos se van a la m...  :'( ésta corrección

:(

Según tú entonces, hay que poner ISO-8859-1 tanto en la plantilla como en el archivo de lenguiaje??  ???

User avatar
Atrevidoweb
Joomla! Guru
Joomla! Guru
Posts: 893
Joined: Fri Aug 19, 2005 4:01 am
Location: Buenos Aires Argentina
Contact:

Re: Problemas Joomla - Firefox - Acentos - Css

Post by Atrevidoweb » Thu Nov 24, 2005 6:07 pm

hola, espero que el sitio que menciones no sea uno de producción, es decir uno para exponer al público.

El problema principal que tienes es generado por la inclusión de UTF-8 como standard.
Y eso es parte de lo que se está trabajando en este estadio de joomla1.1... por eso es una versión alpha.

Justamente se están probando y testeando todos estas situaciiones complicadas.
Para tener una versión estable es preferible esperar a que se lancen las versiones beta, o mejor aun la version final 1.1 La versión estable más actual es la 1.0.4

la única solución que se me ocurre es que generes el contenido en un editor que cumpla con las normas de utf-8
uno posible es PSPad... funciona bien en windows, y luego copiar y pegar el contenido a tu joomla.

Suerte

Atrevidoweb
Atrevidoweb


Locked

Return to “Idioma y traducciones”