Web multiidiomas. No funciona el selector de idiomas (no aparece el español)

Para cuestiones relacionadas con el uso de los idiomas en Joomla, así como para hablar sobre las traducciones al español del core y cualquier extensión. Todas las versiones de Joomla.

Moderators: hefesto, carcam

Post Reply
evacm
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Oct 05, 2014 3:25 pm

Web multiidiomas. No funciona el selector de idiomas (no aparece el español)

Post by evacm » Thu Jun 27, 2019 8:20 am

Buenos días:

Llevo una página web con 3 idiomas (ES/CA/EN): https://catedrademetrioribes.com

El problema es que en la home en español sí que aparecen en el selector los otros dos idiomas, pero en cuanto cambias tanto a inglés como a valenciano dejan de aparecer 2 idiomas: el español nunca aparece en el selector. Así que solo puedes pasar de valenciano a inglés y viceversa. Para volver a español la única manera es añadir /es a la URL. ¿Alguna idea de qué puede estar pasando?

La web funciona sobre Joomla 3.9.8 y todo está actualizado. La plantilla tiene una versión para cada idioma, el plugin de Filtro está activado, los tres idiomas están bien configurados en Idiomas-Contenido... El módulo del selector está en Idiomas: Todos...

No sé qué puede estar mal.

Os agradezco toda ayuda.

E.

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 873
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: Web multiidiomas. No funciona el selector de idiomas (no aparece el español)

Post by john-doe » Thu Jun 27, 2019 4:12 pm

Si los menús por idioma están configurados, hiciste el vinculo entre los tres Home?
Me parece que tiene vinculado inglés y valenciano pero no español, asegúrese de que los tres inicios (y las secciones correspondientes) estén vinculados en los tres idiomas.
www.aldemar-hernandez.com - Custom templates and design services.

evacm
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Oct 05, 2014 3:25 pm

Re: Web multiidiomas. No funciona el selector de idiomas (no aparece el español)

Post by evacm » Thu Jun 27, 2019 4:22 pm

Gracias por su respuesta, John. Creo que el problema ya está resuelto.
No sabía que si hay 3 idiomas, debe haber 4 inicios: uno por idioma y otro asignado a todos. Eso era lo que me fallaba. Tenía el Home de español en predeterminado (estrella) y asignado a todos, así que he tenido que crear un elemento de menú falso/oculto (del tipo url embebida) para lograr que funcionara. Me parece una solución muy ortopédica, pero no se me ocurría otra. Si tiene alguna idea, será bien recibida.

Gracias de nuevo y un saludo,

Ev

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 873
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: Web multiidiomas. No funciona el selector de idiomas (no aparece el español)

Post by john-doe » Thu Jun 27, 2019 4:29 pm

evacm wrote:
Thu Jun 27, 2019 4:22 pm
Gracias por su respuesta, John. Creo que el problema ya está resuelto.
No sabía que si hay 3 idiomas, debe haber 4 inicios: uno por idioma y otro asignado a todos. Eso era lo que me fallaba. Tenía el Home de español en predeterminado (estrella) y asignado a todos, así que he tenido que crear un elemento de menú falso/oculto (del tipo url embebida) para lograr que funcionara. Me parece una solución muy ortopédica, pero no se me ocurría otra. Si tiene alguna idea, será bien recibida.

Gracias de nuevo y un saludo,

Ev
De hecho, llegaste a la respuesta correcta pero al mencionar como llegaste a ella indica que no prestaste atención a la documentación, ya que se necesita el Home de Todos los idiomas y los tres home de cada uno. La documentación sugiere que el menú que viene por defecto se quede tal cual con la entrada del home únicamente, la estrella en todos, y vayas armando cada menú de cada idioma.
www.aldemar-hernandez.com - Custom templates and design services.


Post Reply

Return to “Idioma y traducciones”