Slow loading Joomla 1.5 site

Discussion regarding Joomla! 1.5 Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
newart
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3177
Joined: Fri Sep 02, 2005 10:06 am
Location: Solar system - Earth - European Union

Re: Slow loading Joomla 1.5 site

Post by newart » Tue Jan 13, 2009 5:51 pm

...I'm trying to talk about this problem by dev forum, if good news I'll post something! have a good joomla!
former Q&T WorkGroup Joomla member - Italian Translation Team Member

mamikonjanm
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Dec 29, 2008 6:50 pm

Re: Slow loading Joomla 1.5 site

Post by mamikonjanm » Tue Jan 13, 2009 8:39 pm

newart wrote:...I'm trying to talk about this problem by dev forum, if good news I'll post something! have a good joomla!
ok thanks so much buddy ;) appreciate your help!

Marc-O
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Sep 18, 2007 5:03 pm

Re: Slow loading Joomla 1.5 site

Post by Marc-O » Thu Jan 15, 2009 2:49 pm

My site is also loading extremely slow, taking approx. 20 seconds to load. It's hosted at Rochen. Although the frontend is slow, the site's backend is loading just very quickly. I tried all cache on/off, gzip on/off, sessionhandler options and combinations, but none seems to work. All unused components, modules and plugins have been removed.

Running the site timer results in:
http://farm4.static.flickr.com/3317/319 ... 580dda.jpg
It looks like the host is taking a lot of time between "connect" and "first byte". Am I reading that graph correctly.

Live site:
http://www.onrust-yacht-charters.com
Joomla 1.5.9
Joomfish 2.0RC
sh404SEF build218 (turning it on or off doesn't make a difference)


My test site needs approx. 7 seconds to load. Backend is a lot quicker, <1s.

Test site:
localhost (kubuntu 8.0.4, Apache2)
Joomla 1.5.9
Joomfish 2.0.1
sh404SEF build232
No difference between mod_rewrite yes/no

Marc-O
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Sep 18, 2007 5:03 pm

Re: Slow loading Joomla 1.5 site

Post by Marc-O » Thu Jan 15, 2009 4:11 pm

Strange.....right now it loads within 3 seconds. Didn't do a thing. My test site also loads quicker than 2 hours ago. Could it be some kind of module or component that makes contact to an external server which, at that time, is taking a long time to respond? I don't see another explanation for two completely independent webservers (Rochen and my test site on localhost) to simultaneously load a site either slowly or quickly.

newpow
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Mar 22, 2008 2:14 pm

Re: Slow loading Joomla 1.5 site

Post by newpow » Thu Mar 12, 2009 8:21 pm

Well hosting can be a problem but a try you can do is to create a static html page and upload it then you will see if load faster or not. If your hosting is ok then you can check for various solutions, i post here an article that i found on the internet:

http://www.conanstevens.com/general-stu ... urces.html

activate your cache from global configuration but be sure that also the system cache plugin is activated, just to go to extensions->plugins->system cache. Since joomla loads datas from MySQL
should be made a check on it too...

Hope this can help...

Take care...

Marc-O
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Tue Sep 18, 2007 5:03 pm

Re: Slow loading Joomla 1.5 site

Post by Marc-O » Thu Mar 12, 2009 8:44 pm

Thanks for the tip!

The plugin you mentioned was disabled. I enabled it and it looks to load a lot faster now!

Thank you very much!!

Marc

andy1001
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon May 14, 2007 4:23 pm

Re: Slow loading Joomla 1.5 site

Post by andy1001 » Sun Apr 26, 2009 7:35 am

There are several occasions whereby my Joomla 1.5 site takes forever to load. Im using Joomla 1.59 with Mixxmag and Joomla 1.0 with Versatility. They are hosted on the same server. But my joomla 1.0 site is fine most of the time.

Recent experience: Joomla 1.5 site (home page and admin) cant load for more than 15mins. I really wonder is this a Joomla 1.5 performance issue?

andy1001
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Mon May 14, 2007 4:23 pm

Re: Slow loading Joomla 1.5 site

Post by andy1001 » Sun Apr 26, 2009 7:41 am

Just debug:

Profile Information
Application afterLoad: 0.001 seconds, 0.26 MB
Application afterInitialise: 0.046 seconds, 3.75 MB
Application afterRoute: 0.054 seconds, 4.22 MB
Application afterDispatch: 0.142 seconds, 10.77 MB
Application afterRender: 0.334 seconds, 19.50 MB

Memory Usage
20488536
74 queries logged

Is this normal?

gareth01
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Oct 09, 2008 2:46 pm

Re: Slow loading Joomla 1.5 site

Post by gareth01 » Tue Apr 28, 2009 8:47 am

Had similar issues with a slow joomla install, turned out to be the server.

One point I feel I have to make is it's bizarre that so many of you guys are still using an out-dated version of Joomla! Some still on 1.5.0!!! ???

Guys, update to 1.5.10 or you'll be dealing with an attack too!

User avatar
davetanguay
Joomla! Hero
Joomla! Hero
Posts: 2511
Joined: Fri Sep 22, 2006 6:21 pm
Location: Orlando, FL
Contact:

Re: Slow loading Joomla 1.5 site

Post by davetanguay » Mon May 04, 2009 6:22 pm

If "Session Handler" must be set to "Database" then why is there an option to change it to "None" within the global config? Also can't the sessions be handled by the file system instead? I could have sworn 1.0.x was setup like this. Or I might be confusing it with phpBB. I remember with one of them you could select "File" or "Database" to handle the Sessions. It would be very nice if Joomla 1.5.x could handle the sessions using the file system instead of MySQL. This would reduce the load tremendously especially on shared hosting servers.

Also whether it's the host or not, the fact is Joomla is using the MySQL database to handle sessions which is more taxing on the server than if it used the file system.
CPanel Web Hosting Services http://interactiveonline.com/shared-web-hosting
Follow us on Twitter @interactiveo

PETEREAST
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jun 06, 2009 10:23 pm

Re: Slow loading Joomla 1.5 site

Post by PETEREAST » Sun Jun 07, 2009 2:24 am

Can anyone please help? This is most urgent.

Our site over the last few weeks has become slower and slower. We thought it was the server as we were maxing out on our shared space se we moved all multimedia files 20gb worth to another server however now things are worse. It was taking the site about 20 – 30 seconds to load and now it can’t take in excess of 5 minutes!

I checked out myphpadmin and find there are always lots of these queries:

SELECT ru.email, ru.name AS uname, ru.id AS uid, u.id, u.user_id, p.name, a.id AS aid
FROM jos_jcs_user_subscr AS u
LEFT JOIN jos_jcs_plans AS p ON p.id = u.subscription_id
LEFT JOIN jos_jcs_exp_alerts AS a ON a.user_subscription_id = u.id
LEFT JOIN jos_users AS ru ON ru.id = u.user_id
WHERE u.extime < CURDATE( ) + INTERVAL 5
DAY

Anyone have any advice or help?

hbbd
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Wed Dec 10, 2008 4:47 am

Re: Slow loading Joomla 1.5 site

Post by hbbd » Mon Jun 08, 2009 3:41 am

PETEREAST wrote:Can anyone please help? This is most urgent.

Our site over the last few weeks has become slower and slower. We thought it was the server as we were maxing out on our shared space se we moved all multimedia files 20gb worth to another server however now things are worse. It was taking the site about 20 – 30 seconds to load and now it can’t take in excess of 5 minutes!

I checked out myphpadmin and find there are always lots of these queries:

SELECT ru.email, ru.name AS uname, ru.id AS uid, u.id, u.user_id, p.name, a.id AS aid
FROM jos_jcs_user_subscr AS u
LEFT JOIN jos_jcs_plans AS p ON p.id = u.subscription_id
LEFT JOIN jos_jcs_exp_alerts AS a ON a.user_subscription_id = u.id
LEFT JOIN jos_users AS ru ON ru.id = u.user_id
WHERE u.extime < CURDATE( ) + INTERVAL 5
DAY

Anyone have any advice or help?
it's your hosting company overloading the servers, i had a similar issue 2 days ago, opened a trouble ticket with them and in a few hours, guess what ? went down from 20 seconds to 3 seconds ... if they cannot assume the load i suggest changing, oh and stay away from netfirms, they're the worst ;)

hbbd
Joomla! Apprentice
Joomla! Apprentice
Posts: 14
Joined: Wed Dec 10, 2008 4:47 am

Re: Slow loading Joomla 1.5 site

Post by hbbd » Mon Jun 08, 2009 3:43 am

oh check this link for optimizing your server, it might help ...

http://dev.mysql.com/tech-resources/pre ... index.html

PETEREAST
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jun 06, 2009 10:23 pm

Re: Slow loading Joomla 1.5 site

Post by PETEREAST » Mon Jun 08, 2009 8:49 pm

Thank you so much guys... it was the indexes in the DB. Site is now loading in 16 seconds for a new member and 8 seconds for old members with cached data.

aKosmAn
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue Jun 09, 2009 7:51 am
Contact:

Re: Slow loading Joomla 1.5 site

Post by aKosmAn » Tue Jun 09, 2009 3:27 pm

Thank you so much guys

amelie7
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Jul 26, 2009 12:15 pm

Re: Slow loading Joomla 1.5 site

Post by amelie7 » Wed Aug 26, 2009 4:25 pm

Hey, guys!
I also have the problem with the slow loading site, but when changing the template to the default one everything goes right... So, could it be the template that slows down the loading process and how to fix it? the template is written in CSS only.

Markstein
Joomla! Hero
Joomla! Hero
Posts: 2268
Joined: Sat Feb 09, 2008 8:27 am
Location: California, USA

Re: Slow loading Joomla 1.5 site

Post by Markstein » Fri Sep 04, 2009 2:26 am

I see this topic has become quite popular since I posted it and I apologize for not replying to this sooner. "My" problem was Dreamhost. Dreamhost is not bad..they are quite good actually, however, they were having server issues and they couldn't fix in a reasonable amount of time so I switched. I switched over to Bluehost and have had no issues!

Mark

wanflap
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Apr 09, 2009 2:00 pm

Re: Slow loading Joomla 1.5 site

Post by wanflap » Fri Sep 11, 2009 2:22 am

Can someone check my site, www.LittleSamurai.com
Does it load slow for you?
thx!

brewmastermk
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Tue Sep 08, 2009 8:55 am

Re: Slow loading Joomla 1.5 site

Post by brewmastermk » Fri Sep 11, 2009 4:33 pm

Wanflap - I get about 5-6 seconds on your site load - better than I'm getting.

Has anyone else tried copying your site files into a /test/ subfolder over ftp? If I do this my Test version runs a LOT quicker than the Live version. Accessing same DB, and all files the same as those in the Live site.

Any comment from the guys in the know? Would really appreciate your input...

ourislamic
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Nov 08, 2009 5:48 am
Contact:

Re: Slow loading Joomla 1.5 site

Post by ourislamic » Fri Nov 20, 2009 2:06 am

The same thing is happening for me.

I'm using LunarPages basic plan.

My two Joomla sites are loading very slowly. Can you please check them, and tell me if I'm doing something wrong?

http://www.OurIslamic.com
http://www.DMQM.com

my website using Wordpress, which is still under construction, is fine (http://www.Q-Seminar.com).
http://OurIslamic.com Islamic Forum
Signature rules - Literal URLs Only - normal size

wanflap
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Apr 09, 2009 2:00 pm

Re: Slow loading Joomla 1.5 site

Post by wanflap » Thu Nov 26, 2009 2:34 am

Your sites (below) loaded very slow (over 20 sec) for me.
http://www.OurIslamic.com
http://www.DMQM.com

I think Mozilla has some plug ins for debugging, you should try them.
Also, I think there are some loading tips on alledia.com
Do you have google code installed? if so, where?
try testing by turning some plugins off.
Do you have something with a large sql query?
JR

horizoninfo
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jan 25, 2010 1:25 pm

Re: Slow loading Joomla 1.5 site

Post by horizoninfo » Mon Jan 25, 2010 1:40 pm

Hi,

I have a problem that this site http://www.indore360.com/portal15 loading is slow. It is made in joomla 15.

But the http://www.indore360.com/portal is faster than portal15. It is made in joomla 1.0.


Both site is on hosted on same server .

In http://www.indore360.com/portal15 global setting are following :

GZIP Page Compression = no
Enable Web Services = yes.
Cache = yes
Session Handler = none

and acesef is install and enable
Site is hosted on :- netfirms.com

check phpinfo of server here : http://www.indore360.com/portal15/phpinfo.php

Plz tell me the solution of loading speed slow of http://www.indore360.com/portal15

Thanks and Regards,
Hori

Corvo
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Fri Apr 16, 2010 6:29 am

Re: Slow loading Joomla 1.5 site

Post by Corvo » Sat May 01, 2010 9:32 am

Hi i am new to Joomla and have tried to use GZip Compression under the server tab and i think this has improved to speed.

Corvo

int1m1d8r
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Thu Jun 17, 2010 1:06 am

Re: Slow loading Joomla 1.5 site

Post by int1m1d8r » Thu Jul 15, 2010 1:41 am

I've read alot of similar threads on this topic. Has the issue ever been discovered? I see alot of folks saying they switched hosting companies or turned on cache or whatever... but these things are not addressing the root cause of the problem.

On Day 1 I have a site that loads in <2 seconds consistently for 6-8 months. Then the hosting site goes down for most of one day (all pages; Cpanel, host page, website, everything was offline) and when it comes back online my site consistently takes 40 seconds to load--I changed nothing. Now that is not a "you forgot to turn on caching" problem, but if the hosting company is still operating all the PhP, MySQL and Apache versions supported by Joomla, then what's up? This must be something more like a PhP nuance between version A and version B and how it interprets/executes php code(?)...

My hosting site is now operating PhP 5.2.9 now, but I am not clear if that is a different version than before their outage. My working with them now to determine what, if any, changes happened during their outage.

Frustrating part is that on Day 1 all is well, and on Day 2 the site runs like crap... no changes to Joomla. Software doesn't just work like that--something in the underlying foundation operates differently than before, just trying to learn what that might be.

Has anyone determined the root cause of this issue?

Thanks for your time, these forums are a valuable source for non-pros like me to learn from.

UPDATE ONE: My Debug information shows an application called PMJUpdater taking 35 seconds to complete (or timeout). Does anyone know what that application is??
PROFILE INFORMATION

Application afterLoad: 0.000 seconds, 0.24 MB
Application afterInitialise: 0.060 seconds, 2.36 MB
Application afterRoute: 0.237 seconds, 2.83 MB
Application PMJUpdater::run start: 0.274 seconds, 3.36 MB
Application PMJUpdater::run end: 35.857 seconds, 3.43 MB
Application afterDispatch: 36.422 seconds, 5.48 MB
Application afterRender: 37.016 seconds, 6.14 MB
MEMORY USAGE

6519440
19 QUERIES LOGGED

Thanks!!!

tdickson
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Sep 01, 2010 8:18 pm

Re: Slow loading Joomla 1.5 site

Post by tdickson » Wed Sep 01, 2010 8:21 pm

I had a site showing:

Code: Select all

Application afterDispatch: 0.341 seconds, 24.86 MB
Application afterRender: 6.456 seconds, 30.09 MB
Changing the template to default dropped it to:

Code: Select all

Application afterDispatch: 0.124 seconds, 12.02 MB
Application afterRender: 0.246 seconds, 16.68 MB
Check your templates if you've custom ones!

KevJager
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Fri Oct 15, 2010 1:55 pm

Re: Slow loading Joomla 1.5 site

Post by KevJager » Mon Nov 22, 2010 8:54 am

Ive been having the same problem at www.tealfarm.co.uk. Im using the Yootheme Mellow template
I deactivated mootools and javascript and it speeded the page loading of th site up immediately.

lauri00001
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 30, 2010 2:15 am

Re: Slow loading Joomla 1.5 site

Post by lauri00001 » Thu Dec 30, 2010 5:30 pm

We are now in December 2010, and still no solid solutions.

The shared server discussion should be a moot point, as most of us are confined to shared servers. I would imagine that a huge percentage of websites on the Internet run on shared servers. I would also imagine that GoDaddy and other extremely large hosts know how to configure their servers, but I do also imagine that they pack them too full. Either way - it seems from this thread that 1.0 worked fast and fine and now 1.5 does not. This should tell us all that it is not a host issue, but a Joomla! issue (or possibly a little of both).

By the way - those of you suggesting that a static page be created to test server performance - you should also say that this page must connect to a database and pull the same amount of information from the database as Joomla! does. Because one "hello world" document showing up in a split second is not an apples to apples comparison to a Joomla! page load time.

Let's hope the developers of Joomla! can fix this issue of slow loading pages in the next release. Joomla! is free, so I'm not holding my breath, but I do appreciate all they have done so far!

User avatar
Chris
Joomla! Guru
Joomla! Guru
Posts: 812
Joined: Sat Aug 20, 2005 3:58 am
Location: Australia
Contact:

Re: Slow loading Joomla 1.5 site

Post by Chris » Mon Jan 03, 2011 3:37 am

Yes, it could be a Joomla 1.5.# problem.
And that problem is not Joomla 1.5.# but what you use with Joomla.
Your template could be stuffed with so many .js links or images, flash or what not that the server, and certainly a shared server, will take forever to generate the page.

One can easily do test why you site is loading slow.
Firstly, your site could have been tested by Google and you can find that with your Google tools under Site Performance.
Then there is a Joomla site that has a testing tool to check your site:
http://www.joomlaperformance.com/compon ... Itemid,52/
And also another one, more general:
http://sitereportcard.com/

And don't forget, you also should check if you site is compliant.
There might be somewhere an error in your coding that slows things down.

I use those regularly and they help me to tweak sites.
Some of these sites, running Joomla, gives performances of being faster than 92% of sites.
So before putting the blame on Joomla, check your site out.
There is no failure until you give up.

Chris

User avatar
keliix06
Joomla! Ace
Joomla! Ace
Posts: 1022
Joined: Wed Aug 17, 2005 11:46 pm
Location: Minneapolis, MN
Contact:

Re: Slow loading Joomla 1.5 site

Post by keliix06 » Tue Jan 04, 2011 12:20 am

lauri00001 wrote:This should tell us all that it is not a host issue, but a Joomla! issue (or possibly a little of both).
We host thousands of Joomla sites. I can tell you it's a host issue (and some end-user as well), not a Joomla issue. Joomla is slower than something like WP out of the box, but it's got a lot more going on, so that's understandable.

People like to install a ton of plugins, not understanding how that's going to affect their site loading time. But with properly configured, tuned, and not oversold servers, there's no reason your Joomla site should load slowly.
Doyle Lewis
BuyHTTP Internet Services
http://www.buyhttp.com/joomla_hosting.html - No Overselling Guarantee. Your Joomla site, faster.
http://www.joomlademo.com - 30 day free trial of Joomla

lauri00001
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Dec 30, 2010 2:15 am

Re: Slow loading Joomla 1.5 site

Post by lauri00001 » Tue Jan 04, 2011 2:04 pm

keliix06 wrote:
lauri00001 wrote:This should tell us all that it is not a host issue, but a Joomla! issue (or possibly a little of both).
We host thousands of Joomla sites. I can tell you it's a host issue (and some end-user as well), not a Joomla issue. Joomla is slower than something like WP out of the box, but it's got a lot more going on, so that's understandable.

People like to install a ton of plugins, not understanding how that's going to affect their site loading time. But with properly configured, tuned, and not oversold servers, there's no reason your Joomla site should load slowly.

Many of us have a dog slow Joomla installation straight out of the box. No plug ins, no extras. I installed just the sample files, and my site is embarrassingly slow - with no content added yet.


Locked

Return to “Performance - Joomla! 1.5”