Wrong date and time formating in other languages than orig

How to support more than one language on your site.

Moderator: General Support Moderators

Locked
vstfreak
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 28, 2006 2:34 pm

Wrong date and time formating in other languages than orig

Post by vstfreak » Thu Mar 06, 2008 9:27 am

Hi!
Have a small prob with Joomfish. Works great otherwise. I use it on a swedish site. And have English as second lang. Swedish, as the original language. Locale is set right with sv_SE . Have "Created Date and time" on "Hide" globaly and put it on for each page that I use it on. In this case for News and pictures sectionised and categorised and presented in table.

In swedish the date looks like this: 2007-10-18 - English like this: torsdag, 18 oktober 2007 .Swedish formating yes.
So. I can explaine a lot more but. Maybe there is someone that have seen this type of problem before and have a good answer. i'.m pretty shure i have it configured right. I mean, shoose "English" in select menu when you are under translate if I want to translate into english. The instruktions sais that. Otherwise If you do it the other way around the language select module shows the wrong language according to flag. :eek:

Hope someone has the answer :-[

User avatar
Rhand
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Sat Oct 01, 2005 3:09 pm
Location: World
Contact:

Re: Wrong date and time formating in other languages than orig

Post by Rhand » Tue Jul 28, 2009 2:34 pm

I don't and I have the same issue..
CEO Imagewize Ltd: webdesign | web development | branding
website: Imagewize.net

User avatar
akede
Joomla! Ace
Joomla! Ace
Posts: 1636
Joined: Fri Aug 12, 2005 6:15 am
Location: Munich, Germany
Contact:

Re: Wrong date and time formating in other languages than orig

Post by akede » Tue Jul 28, 2009 2:47 pm

You need to make sure that the Joomla language files fit to the language you look at. In these standard files is the formating information for the date included. Joomla uses this one to render the dates.

In your case I would assume that the English language file is associated to the swedish language in the Joom!Fish language manager. Or something similar in this direction.

Alex
Joom!Fish 2.0 your free multilingual solution for Joomla! 1.5 i - http://www.joomfish.net - follow us on twitter @joomfish
Meet us at J and Beyond, 30.05 - 1.06.10, Wiesbaden, Germany - http://jandbeyond.org

User avatar
Rhand
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Sat Oct 01, 2005 3:09 pm
Location: World
Contact:

Re: Wrong date and time formating in other languages than orig

Post by Rhand » Tue Jul 28, 2009 2:53 pm

In the language manager I switched from - in my case - English to Dutch and Dutch to French to see if the data on the front office would be displayed differently, but no date/days in English yet . Joomfish has English as the main language as well. So I am pretty lost here...
Here is a link to a page where the date + day is displayed in Dutch: [URL banned]
CEO Imagewize Ltd: webdesign | web development | branding
website: Imagewize.net

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18881
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Wrong date and time formating in other languages than orig

Post by infograf768 » Tue Jul 28, 2009 4:15 pm

vstfreak wrote:Swedish, as the original language. Locale is set right with sv_SE .
locale should be sv-SE and not sv_SE
Can you check the locales are exactly the same (in the Joomfish language manager) as the name of the language folders?
en-GB, sv-SE, etc.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
Rhand
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Sat Oct 01, 2005 3:09 pm
Location: World
Contact:

Re: Wrong date and time formating in other languages than orig

Post by Rhand » Tue Jul 28, 2009 4:34 pm

In my case /httpdocs/language has nl-NL fr-FR and en-GB.
/httpdocs/language/language has en-GB
/httpdocs/administrator/language has en-GB fr-FR and nl-NL
Language manager has english set as main language and Dutch and English are available.
Site default language is indicated as being English next to Joomfish icon at the top in the Joomla! administration
So why are my dates in Dutch?
CEO Imagewize Ltd: webdesign | web development | branding
website: Imagewize.net

User avatar
Rhand
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Sat Oct 01, 2005 3:09 pm
Location: World
Contact:

Re: Wrong date and time formating in other languages than orig

Post by Rhand » Tue Jul 28, 2009 4:48 pm

I think I know what the problem is. I just don't know how to fix it yet. Somehow Joomfish makes me switch to Dutch every time I click a link and creates links such as http://imagewize.net/nl/blog instead of http://imagewize.net/en/blog. maybe because I started Ductch as default a long time ago??? Now I need to find out how to fix this.
CEO Imagewize Ltd: webdesign | web development | branding
website: Imagewize.net

User avatar
Rhand
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Sat Oct 01, 2005 3:09 pm
Location: World
Contact:

Re: Wrong date and time formating in other languages than orig

Post by Rhand » Tue Jul 28, 2009 4:51 pm

Well I changed the language order in Joomfish. En 1, FR 2 and Nl three and now English is displayed when you enter the website. So my problem seems to have eebn solved.
CEO Imagewize Ltd: webdesign | web development | branding
website: Imagewize.net

User avatar
akede
Joomla! Ace
Joomla! Ace
Posts: 1636
Joined: Fri Aug 12, 2005 6:15 am
Location: Munich, Germany
Contact:

Re: Wrong date and time formating in other languages than orig

Post by akede » Tue Jul 28, 2009 8:39 pm

Rhand wrote:In my case /httpdocs/language has nl-NL fr-FR and en-GB.
/httpdocs/language/language has en-GB
/httpdocs/administrator/language has en-GB fr-FR and nl-NL
Language manager has english set as main language and Dutch and English are available.
Site default language is indicated as being English next to Joomfish icon at the top in the Joomla! administration
So why are my dates in Dutch?
Hi,

The original problem you have is the fact that you did not installed the front-end language packs for Frensh and Dutch. Otherwise your httpdocs/languages/ directory would have those languages as well. Or may be your directory names are vis versa?

The other item is related to your browser settings and the configuration of your JFRouter Plugin. This plugin is captable to use the browser settings to directy switch to the language the browser uses. If your browser is set to NL as default language then this will be the language automatically choosen by Joom!Fish. - You can switch of the behavior in the router parameters.

Alex
Joom!Fish 2.0 your free multilingual solution for Joomla! 1.5 i - http://www.joomfish.net - follow us on twitter @joomfish
Meet us at J and Beyond, 30.05 - 1.06.10, Wiesbaden, Germany - http://jandbeyond.org

User avatar
Rhand
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 213
Joined: Sat Oct 01, 2005 3:09 pm
Location: World
Contact:

Re: Wrong date and time formating in other languages than orig

Post by Rhand » Wed Jul 29, 2009 6:10 am

Rhand wrote:In my case /httpdocs/language has nl-NL fr-FR and en-GB.
/httpdocs/language/language has en-GB
/httpdocs/administrator/language has en-GB fr-FR and nl-NL
akede wrote: The original problem you have is the fact that you did not installed the front-end language packs for French and Dutch. Otherwise your httpdocs/languages/ directory would have those languages as well. Or may be your directory names are vis versa?
No, not vice versa. Well I guess I will need to at NL and FR to front end packages. Just need to find out how to do this again.
akede wrote: The other item is related to your browser settings and the configuration of your JFRouter Plugin. This plugin is capable to use the browser settings to directly switch to the language the browser uses. If your browser is set to NL as default language then this will be the language automatically choosen by Joom!Fish. - You can switch of the behavior in the router parameters.
Great intel. Thanks for that! Normally I use an English Language Browser (Firefox), but I remember changing some Firefox language settings for a while so maybe that was the issue..
CEO Imagewize Ltd: webdesign | web development | branding
website: Imagewize.net

User avatar
akede
Joomla! Ace
Joomla! Ace
Posts: 1636
Joined: Fri Aug 12, 2005 6:15 am
Location: Munich, Germany
Contact:

Re: Wrong date and time formating in other languages than orig

Post by akede » Wed Jul 29, 2009 7:53 am

Rhand wrote: No, not vice versa. Well I guess I will need to at NL and FR to front end packages. Just need to find out how to do this again.
Just download the specific front-end language packs from extensions.joomla.org and install them using the Joomla installer. Its just the specification of the packages, the process is the same.
Rhand wrote: Great intel. Thanks for that! Normally I use an English Language Browser (Firefox), but I remember changing some Firefox language settings for a while so maybe that was the issue..
[/quote]
It seems like our default settings are to smart. We might need to consider using simpler default settings e.g. with a fixed language instead of automatic changing languages.

Alex
Joom!Fish 2.0 your free multilingual solution for Joomla! 1.5 i - http://www.joomfish.net - follow us on twitter @joomfish
Meet us at J and Beyond, 30.05 - 1.06.10, Wiesbaden, Germany - http://jandbeyond.org


Locked

Return to “Joom!Fish and Multilingual Sites”