Advertisement

session.save_path error during installation

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
abc02
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 26, 2008 4:09 am

session.save_path error during installation

Post by abc02 » Wed Mar 26, 2008 7:24 pm

Hi,

I tried installing Joomla through Fantastico on HostMonster, but I had trouble logging into the backend of Joomla and can't seem to fix it. So I decided I'd try uploading the zip file and installing it through the browser that way, but now I'm getting this error in the second step.

Cookies do not appear to be enabled on your browser client. You will not be able to install the application with this feature disabled. Alternatively, there could also be a problem with the server's session.save_path, if this is the case please consult your hosting provider if you don't know how to check or fix this yourself.

How do I fix this? Thanks!

Advertisement
User avatar
jgentile
Joomla! Apprentice
Joomla! Apprentice
Posts: 44
Joined: Tue Jan 01, 2008 3:41 pm
Contact:

Re: session.save_path error during installation

Post by jgentile » Mon May 12, 2008 2:39 am

I'm having the same problem. Just bought a dedicated server package with aplus.net so I can run our no profit website off of it using the latest Joomla 1.5. This may look long but I'm literally typing out everything I've done so its very clear and cuts down on back and forth emails.

(1) I created a "client " in Plesk
(2) I added our websites domain name (the "real" domain name is still pionting at the old IP running the old site until I get this one up and going... and I will redirect the site to the new dedicated server IP)
(3) I unzipped Joomla 1.5 on my hard drive and uplaoded it
(4) I see the joomla install page and whoop for joy
(5) I choose "English" as my language from the first page of the joomla install menu and hit NEXT
(6) I see this error message:

Cookies do not appear to be enabled on your browser client. You will not be able to install the application with this feature disabled. Alternatively, there could also be a problem with the server's session.save_path, if this is the case please consult your hosting provider if you don't know how to check or fix this yourself.

(7) I make sure cookie are on. They are.
(8) I start reading forums about this "session.save_path" and get a bit lost but I've done the following.

(a) I logged into with SSH (shell) and found my php.ini file in the /etc bin of Linux root
(b) I edit the php.ini file by typing "nano php.ini" command in SSH (shell)
(c) I located the line where session.save_path is and it says this below in brown:
--------------------------------------------------------------

; Argument passed to save_handler. In the case of files, this is the path
; where data files are stored. Note: Windows users have to change this
; variable in order to use PHP's session functions.
;
; As of PHP 4.0.1, you can define the path as:
;
; original was: session.save_path = "N;/path"
;
;
; where N is an integer. Instead of storing all the session files in
; /path, what this will do is use subdirectories N-levels deep, and
; store the session data in those directories. This is useful if you
; or your OS have problems with lots of files in one directory, and is
; a more efficient layout for servers that handle lots of sessions.
;
; NOTE 1: PHP will not create this directory structure automatically.
; You can use the script in the ext/session dir for that purpose.
; NOTE 2: See the section on garbage collection below if you choose to
; use subdirectories for session storage
;
; The file storage module creates files using mode 600 by default.
; You can change that by using
;
; session.save_path = "N;MODE;/path"
;
; where MODE is the octal representation of the mode. Note that this
; does not overwrite the process's umask.
;

session.save_path = "/var/lib/php/session"
--------------------------------


(d) so change the session.save_path line to: session.save_path = "var/www/vhosts/acareaccount/httpdocs/tmp"
(All the joomla files are sitting in the acareaccount/httpdocs directory )

(e) I restart apache by typing "apachectl graceful" (which doesn't seem like it does much .. .doesn't say antying)

Result: Nothing

In another post it seems to say something about putting a /tmp directory inside Joomla's /administrator directory.

I tried doing that, and tried to install joomla with the above php.ini file set to both:

- session.save_path = "var/www/vhosts/acareaccount/httpdocs/administrator/tmp" (as a wild guess)
and
- session.save_path = "var/lib/php/session" (setting it back to the original in case all I needed was a /tmp directory in the /administrator directory)

Neither worked.

Anyone want to tell me the next step or suggestion?

morales24
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed May 14, 2008 10:49 pm

Re: session.save_path error during installation

Post by morales24 » Wed May 14, 2008 10:58 pm

Make sure you have the CGI-BIN in the /root directory where Joomla is going to be install.
Actual path
This work for me
/cgi-bin/tmp

Joomla 1.5

http://www.flexxmall.com

User avatar
jgentile
Joomla! Apprentice
Joomla! Apprentice
Posts: 44
Joined: Tue Jan 01, 2008 3:41 pm
Contact:

Re: session.save_path error during installation

Post by jgentile » Thu May 15, 2008 3:11 am

I found the answer to the problem.

I'm running Joomla on a dedicated server... using Plesk to administer the server. Since I haven't built the site, I have not yet transfered the official URL over to piont at the IP address yet. I had not yet learned how to assign the IP address for the server to any of the accounts I'd created in Plesk. SO... I was using a "page preview" function to view the pages and JOomla installation. Once the ISP tech guy told me how to assign the servers IP address to one of the accounts (you can set ONE account to be the default that the IP address points at... until you give it a real domain name)... once I did it... Joomla was fine. It had something to do with viewing it through the Plesk page preview feature.

Who would have guessed.

Plesk users... take note.

JMG

jagsys
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Dec 04, 2008 7:38 pm

Re: session.save_path error during installation

Post by jagsys » Thu Dec 04, 2008 7:48 pm

Hi Fellows,

I had the same problem, and I found that in my case it was with PHP memcache config.

1) Look in the /etc/php.d directory. There is a memcache.ini file.
2) Comment out these lines:
;session.save_handler=memcache
;session.save_path="tcp://localhost:11211?persistent=1&weight=1&timeout=1&retry_interval=15"
4) Restart the http server.
5) Resumed with the installation of Joomla. Old error messages are now gone.

Cheers

jagsys
:D

tiamda
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Feb 14, 2009 8:32 am

Re: session.save_path error during installation

Post by tiamda » Sat Feb 14, 2009 8:41 am

try this:

copy php5ts.dll or php4ts.dll to C:\windows\system32 and restart IIS

make sure that your session.save_path directory set to writeable

:geek:

rcshield
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Apr 03, 2009 10:55 pm
Contact:

Re: session.save_path error during installation

Post by rcshield » Fri Apr 03, 2009 10:58 pm

I am stuck of this second step; however, I am trying to install Joomla on shared hosting, not dedicated. How can I get rid of this error?

catapult
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Wed Apr 15, 2009 12:15 pm

Re: session.save_path error during installation

Post by catapult » Thu Apr 30, 2009 10:25 am

I seem to have the same problem on my development server. I created a new directory and unzipped Joomla into it as I have done before. As this is an internal development server I given the directory full permisions to everyone. I then opened IE7 and browsed to my site "http://devserver/joomlasite". I select the language I want and click next. I then get the error "Cookies do not appear..."

So I tried to access the installation from a different browser, Firefox. Installation works fine, no problems. I can login and access the administration fine in Firefox, still can't log in to the backend from IE7.

I decided to see if I could log into the backend of one of our sites on our live server in IE7. Logged in no problems.

So I deleted IE's cookies, temp files, etc... I even reset the brower to the default state. Still unable to login to the backend.

So it looks like it's serverside. I considered it could be a problem with saving the sessions and searched for information and found this post "http://www.mydigitallife.info/2007/11/2 ... ng-joomla/". I have checked my php.ini file and it looks ok. I can even see the sessions being written to the directory when I browse to the Joomla installation.

I have no idea how to fix the problem. Has anyone else experienced this?

about_image
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Jun 30, 2009 9:44 pm

SOLVED: session.save_path error during installation

Post by about_image » Wed Aug 05, 2009 7:58 pm

I, too, had this problem with Plesk. It would seem that Joomla is incapable of installing through the Plesk Preview, due to the URL's configuration.

Here's the work-around:

- For this example, let's assume the domain you have registered in Plesk is Domain.com, and Plesk's IP is 15.15.15.15
- You need to edit YOUR computer's "hosts" file. I'm a Mac user, so I'm going to give you the Mac example of how to do it. The Windows/UNIX methods and locations to the hosts file may be different, but you can Google your own configuration to find the location.
- Open a terminal
- Type "su" to go to superuser mode
- Enter your administrator password
- Type "open /Applications/TextEdit.app /etc/hosts"
- On the top of the file, you should see something like this:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost

- Add the following:

15.15.15.15 domain.com
15.15.15.15 http://www.domain.com

(change the IP and domain to match YOUR Plesk server's setup, obviously)

- Save and close

This will "trick" your system into believing that "domain.com" is really the domain you created on your Plesk server. When you open "domain.com" in your browser, you should be presented with the Joomla Install package, assuming you've already uploaded the files.

Do your install, and remember to remove the lines from your "hosts" file after you have transferred DNS to point to Plesk.

Hope this helps!

theChronic
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Mon Jan 16, 2006 5:30 pm
Location: Silicon Valley, California
Contact:

Re: session.save_path error during installation

Post by theChronic » Thu Sep 02, 2010 1:50 am

I had the same problem (installing Joomla on my mac on localhost) and was using Chrome and got the session save / cookies error. I just switched to Firefox and it went smoothly with no errors.

Best
John

Advertisement

Locked

Return to “Installation 1.5”