popular problems when Upgrade to Joomla 1.5.15

Need help upgrading your Joomla! website or converting to Joomla! 1.5?

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Joomplaza
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sat Mar 28, 2009 11:23 am
Contact:

popular problems when Upgrade to Joomla 1.5.15

Postby Joomplaza » Wed Dec 30, 2009 10:59 am

Here is some popular problems which you can encouter when upgrade to Joomla 1.5.15. I hope it can help you. This article are collected from many questions from Joomla forum

Author : Joomplaza. You can read This Original Post Here
---------------------------------------------------------------------------------------------

I upgraded from joomla 1.5.14 - 1.5.15 and now my editor does not appear. All files are transferred when I upgrade, the error that occurs in explorer is like this in attachment.

Try to change component.php in your template folder (administrator/templates/system). you change that file with 1.5.14 version of file.

---------------------------------------------------------------------------------------------------------------

After upgrading to 1.5.15 with the patch package I am not able to inserst images in an article.

Try setting the following parameters in the Editor - TinyMCE plugin. Use Plugin Manager (Extensions -> Plugin Manager) for this.

(a) Functionality to Extended
(b) Code cleanup on save to Never or Front Only

I get this errors on 2 website, one of it was fix But another site can not.If this errors can not fix, You can use CKEditor . I tested it. Ok

---------------------------------------------------------------------------------------------------------------

I've just upgraded my site to 1.5.15 and none of the installed editors are showing up. I've tried JCE, TinyMCE, no luck. Could you tell me how to fix this?

Solution:
Either upgrade the component to a 1.5.x native version of JCE (don't know if that exists, you do the cyber leg-work please) or uninstall it and make another editor (TinyMCE) your default editor or choose another by the User Manager!

Recommend:
Stay away from components/plugins/modules that require the legacy plugin to be enabled!
Why?
You will save yourself some headaches and Joomla 1.5.x will soon be the legacy system, so learn to let go of older extensions and find something new. It probably does it b

etter anyway!

If you can not fix, you can try another way

1. Go to [Admin/Site/Global Configuration], under [Site/Default WYSIWYG Editor] select TinyMCE or No Editor as your default and click save.

2. Go to [Admin/Site/User Manager] and click on your current login 'Name' and under [Parameters/User Editor] select JCE as your editor (probably Editor - JCE 154).

3. Now go back to your Article/Custom Module and see if the editor appears. If not, go back to [Admin/Site/User Manager] and click on your current login 'Name' and under [Parameters/User Editor] select TinyMCE or No Editor as your editor for this current login.

4. Go back to your Article/Custom Module and see if the editor appears. If so, then you know it is a problem with JCE alone (more than likely). If the editor still fails to appear / the problem fails to resolve; then did you install another new component/plugin/module/template recently that could cause the problem? Try un-installing those one at a time until you get success!

Note added: If the above fails...

5. Re-install Joomla, you may have broken something or a third-party extension could have?

---------------------------------------------------------------------------------------------------------------

After upgrading to 1.5.15 now I get JPAGE_CURRENT_OF_TOTAL displayed at the bottom of the page just below the page navigation.

Fix is easy. You also have to upgrade your language pack.

---------------------------------------------------------------------------------------------------------------

I experienced an error after upgrading, and all the contents are not loading and the error causes by the line 209 of pathway.php where you can find in this path: \libraries\joomla\application\pathway.php

Maybe this problem come from Your PHP versions. I guess you use PHP 4.x.. This problem can solved when you update to PHP 5.x

---------------------------------------------------------------------------------------------------------------

After upgrade to 1.5.15 my rss reader shows error on each page - problem with loading the data - I tried some other rss modules other than joomla native and same happends!

Was the htaccess.txt file in the Joomla! install directory renamed to .htacces
---------------------------------------------------------------------------------------------------------------

I can not Save or Cancel articles while editing in front end

- download the tinymce.zip file, see below
- unzip the file
- replace the file located at: plugins/editors/tinymce.php

---------------------------------------------------------------------------------------------------------------

What happend to the Media Manager?

- download the view.html.zip file, see below
- unzip the file
- replace the file located at: administrator/components/com_media/views/media/view.html.php

---------------------------------------------------------------------------------------------------------------

I upgraded to 1.5.15. I just discovered that the TinyMCE 2.0 editor is gone now?? When I open an article, it only shows the text as html code with tags. How can I get TinyMCE back??

You could consider this a blessing and install JCEditor! Its light years ahead of TinyMCE. Errors will be fixed

---------------------------------------------------------------------------------------------------------------

When I tried to upgrade my Joomla! website from 1.5.14 to 1.5.15 I get the error:"Error! Could not find an XML setup file in the package."


I believe that you are using the Extension Manager for Installing the Upgrade. Joomla! upgrade is simply copying the patch files over the existing files in the site.

---------------------------------------------------------------------------------------------------------------

When upgrading from 1.5.14 to 1.5.15, I found out that the file pathway.php file located in the libraries folder was giving me a lot of trouble.

This message is caused by a bug in PHP version 4 and a change made for Joomla! version 1.5.15. For version 1.5.15, we fixed tracker issue 18493 to correct a problem where UTF-8 (non-ASCII) characters did not display correctly in the breadcrumbs module. However, this bug fix used a feature that doesn't work correctly in some older versions of PHP.


To correct this problem, upgrade your server to use PHP version 5. If that is not possible, you can make a change to line 209 of the file libraries/joomla/application/pathway.php. In version 1.5.15, this line is as follows:$item->name = html_entity_decode($name, ENT_COMPAT, 'UTF-8');


To fix this problem on a site running PHP 4.x, change line 209 to:

$item->name = html_entity_decode($name);

If you like, you can make the following code change instead of the one above. This will allow the function to correctly display UTF-8 if the site is running PHP 5.x. Replace line 209 with the following lines:
if((version_compare( phpversion(), '5.0' ) < 0)) {
$item->name = html_entity_decode($name);
} else {
$item->name = html_entity_decode($name, ENT_COMPAT, 'UTF-8');
}

So the entire function will now be as follows:
function _makeItem($name, $link)
{
$item = new stdClass();
if((version_compare( phpversion(), '5.0' ) < 0)) {
$item->name = html_entity_decode($name);
} else {
$item->name = html_entity_decode($name, ENT_COMPAT, 'UTF-8');
}
$item->link = $link;
return $item;
}

------------------------------------------------------------------------------------

I hope this article can help you solve your questions when upgrade to Joomla 1.5.15
All Free Joomla templates and Extensions , Tutorials, Tips and tricks For Joomla .
http://www.Joomplaza.com

Best Of Joomla : Best extensions, Best templates, and Admin templates
Best Extensions For Joomla

TheStar
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Dec 28, 2009 12:08 am

Re: popular problems when Upgrade to Joomla 1.5.15

Postby TheStar » Mon Jan 04, 2010 1:55 am

Thanks for all this info. I had trouble with editors not showing and I was able to fix the problem after reading this.

myjoomla1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Jan 07, 2010 11:15 pm

Re: popular problems when Upgrade to Joomla 1.5.15

Postby myjoomla1 » Sun Jan 10, 2010 12:56 am

Hi,

I can say thanks for post it is useful. I make instal joomla 1.5.15 and I have problem with artical editor.In my global configuration I have :

*Editor-No Editor
*Editor-Tiny MCE
*Editor-XStandard Lite 2.0

I don't have JCE Editor. So I need some good editor, please tell me what good Editor I can instal and where I can find them.

Thank's

myjoomla1
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Thu Jan 07, 2010 11:15 pm

Re: popular problems when Upgrade to Joomla 1.5.15

Postby myjoomla1 » Sun Jan 10, 2010 1:41 pm

Any help please?

trinitymedia
Joomla! Apprentice
Joomla! Apprentice
Posts: 29
Joined: Mon Dec 01, 2008 7:09 pm
Location: Seattle

Re: popular problems when Upgrade to Joomla 1.5.15

Postby trinitymedia » Thu Jan 21, 2010 11:45 pm

Thanks for all the info...and THANK you for putting it all in the same place. I've had pretty much all of these problems.

My big one now is that TinyMCE seems to have a problem loading .swf files. I lost the icon for adding media and when I try to just change the html it doesn't show up. Has anyone else had/solved this problem?

I like to keep the versions updated but I sure hate the time it takes to sort out the problems.


I'm hoping something in this post will help.

~susan

UPDATE: I did this:

Try setting the following parameters in the Editor - TinyMCE plugin. Use Plugin Manager (Extensions -> Plugin Manager) for this.

(a) Functionality to Extended
(b) Code cleanup on save to Never

That added the 'insert media' icon for me.
>I added the .swf, it showed up as active in the insert media pop up window, but it did not show up in the front end. The page was blank.
>I looked at the html and found a bunch of bogus code that was added by TinyMCE. Even adding the code directly to the html window didn't work because TinyMCE added the code on saving.

My fix: in global config I changed it to 'no editor', then added the code directly to the page, saved it and voila...it worked. Then I changed it back to TinyMCE because my clients don't write code and want the WYSIWYG editor.

I guess I'll try to install JCE to see if that works.

Any suggestions?
thnx,
~s
Last edited by trinitymedia on Sat Jan 23, 2010 6:55 pm, edited 1 time in total.

Huldra
Joomla! Apprentice
Joomla! Apprentice
Posts: 23
Joined: Tue Jan 27, 2009 8:04 pm

Re: popular problems when Upgrade to Joomla 1.5.15

Postby Huldra » Sat Jan 23, 2010 12:22 pm

This is just what happened to me: "I can not Save or Cancel articles while editing in front end

- download the tinymce.zip file, see below
- unzip the file
- replace the file located at: plugins/editors/tinymce.php", so I did as told, and now I can Cancel when editing, but I still can't save. Any ideas as to what I should do?

Solnoir
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Jan 24, 2010 7:09 am

Re: popular problems when Upgrade to Joomla 1.5.15

Postby Solnoir » Sun Jan 24, 2010 7:15 am

I recently upgraded to 1.5.15. When I try to access pages on my site from the main menu I get "page not found" error messages. What am I doing wrong?

clientel
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Dec 26, 2008 3:52 am

Re: popular problems when Upgrade to Joomla 1.5.15

Postby clientel » Fri Jan 29, 2010 1:26 pm

After upgrading, my SEF urls and mod_rewrite seem broken, i.e., I'm getting 404 errors when I just try to click on an article in blogview. What can I do to fix it?


Return to “Migrating and Upgrading to Joomla! 1.5”

Who is online

Users browsing this forum: No registered users and 2 guests