Getting JFolder Create error when installing module

This forum is for general questions about extensions for Joomla! version 1.5.x.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
blueicreate
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 08, 2008 8:01 pm

Getting JFolder Create error when installing module

Post by blueicreate » Mon Feb 18, 2008 4:44 am

I'm trying to install the Google Analytics module and getting the error:
JFolder::create: Could not create directory
Warning! - Failed to move file

I have the exact same site on another server and installed it successfully so there must be some setting on this server that is messing up my module install. I have checked that safe mode is off but besides that, don't know what to do.

blueicreate
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Feb 08, 2008 8:01 pm

Re: Getting JFolder Create error when installing module

Post by blueicreate » Mon Feb 18, 2008 4:46 am

Forgot to mention that I have the folder permissions set at 777 for the components and modules folders.

supern00b
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Wed Aug 31, 2005 8:37 pm

Re: Getting JFolder Create error when installing module

Post by supern00b » Tue Mar 25, 2008 1:27 am

Any luck on this?
I get the same thing with a Fireboard install on a fresh J1.5 install on the server.

supern00b
Joomla! Intern
Joomla! Intern
Posts: 55
Joined: Wed Aug 31, 2005 8:37 pm

Re: Getting JFolder Create error when installing module

Post by supern00b » Thu Mar 27, 2008 1:06 am

Correction... I get it when trying to install anything.

/sigh/

User avatar
pvh123
Joomla! Ace
Joomla! Ace
Posts: 1125
Joined: Wed Oct 05, 2005 7:25 am
Location: Amsterdam

Re: Getting JFolder Create error when installing module

Post by pvh123 » Thu Mar 27, 2008 1:36 pm

blueicreate wrote: JFolder::create: Could not create directory
Warning! - Failed to move file
Can you check (from the xml file) if a specific directory must be placed for Analytics to put its files in?
Note: Sending me private messages for personal support, without this been requested, would lead to ignoring any of your posts in future!

kmsrentals
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Wed Nov 28, 2007 10:58 am

Re: Getting JFolder Create error when installing module

Post by kmsrentals » Tue May 27, 2008 1:03 pm

have the same problem. i can't install anything. is there a sure way of fixing this already?

User avatar
pvh123
Joomla! Ace
Joomla! Ace
Posts: 1125
Joined: Wed Oct 05, 2005 7:25 am
Location: Amsterdam

Re: Getting JFolder Create error when installing module

Post by pvh123 » Tue May 27, 2008 2:17 pm

I have just succesfully loaded the Google Analytics module. This on Joomla 1.5.3.
So, try this again after upgrading Joomla to at least 1.5.3 and download the J! 1.5 version of the module from the extension directory: htp://extensions.joomla.org
Note: Sending me private messages for personal support, without this been requested, would lead to ignoring any of your posts in future!

User avatar
Smartie
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 115
Joined: Tue May 16, 2006 5:55 pm
Location: Nederland

Re: Getting JFolder Create error when installing module

Post by Smartie » Sun Jun 01, 2008 7:16 pm

I have the shame problem..
Installed Joomla 1.5.3 so how do we fix this?
I can't install anything.

First had the error message I couldn't move anything or something like that.
When I changed permissions of all needed maps to 777 I got the same error message as named in the first of this topic.

Thanks in advance.

kmsrentals
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Wed Nov 28, 2007 10:58 am

Re: Getting JFolder Create error when installing module

Post by kmsrentals » Mon Jun 02, 2008 1:10 pm

Found the problem in my site.

My host moved the files and it caused the problems

Followed this tip and my problem is solved:

Changes in configuration.php

var $log_path = '/usr/home/web/web***/joomla/logs'; //*= my username on ISP
var $tmp_path = '/usr/home/web/web***/joomla/tmp'; //*= my username on ISP

to:

var $log_path = './logs';
var $tmp_path = './tmp';

User avatar
pvh123
Joomla! Ace
Joomla! Ace
Posts: 1125
Joined: Wed Oct 05, 2005 7:25 am
Location: Amsterdam

Re: Getting JFolder Create error when installing module

Post by pvh123 » Mon Jun 02, 2008 2:03 pm

Well done.
Good Luck
Note: Sending me private messages for personal support, without this been requested, would lead to ignoring any of your posts in future!

celini
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Fri Dec 28, 2007 7:11 pm

Re: Getting JFolder Create error when installing module

Post by celini » Mon Jun 09, 2008 1:39 pm

I moved my website to a new hosting company. Everything went fine except when I tried to install a new component/module/plugin I got the same error. I went through the steps mentioned above (see configuration.php) and everything worked perfectly. Thank you kmsrentals for your great help.

eadaoin
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sun Feb 19, 2006 3:41 pm

Re: Getting JFolder Create error when installing module

Post by eadaoin » Wed Oct 01, 2008 11:00 am

I have tried this too, but it had no effect... I am trying to install Signallogin on a Joomla 1.5 running in Legacy mode... again, I have successfully installed it locally, but get the same error message when I attempt to install it on the server.

Thanks

imadden
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Fri May 09, 2008 6:42 pm
Location: Boston, MA, USA

Re: Getting JFolder Create error when installing module

Post by imadden » Tue Oct 14, 2008 4:47 pm

kmsrentals, thanks for pointing that out, it did the trick for me! I can't believe I over looked that in the config file. I must have stared at it at least 100 times... :eek:

me_likey
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Oct 23, 2006 7:10 pm

Re: Getting JFolder Create error when installing module

Post by me_likey » Tue Oct 28, 2008 4:10 pm

I agree! thanks for the help... The remedy was perfect!

titanic
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Nov 02, 2008 6:02 am

Re: Getting JFolder Create error when installing module

Post by titanic » Sun Nov 02, 2008 6:39 am

I gfet the same error with joomla 1.5.7 can anybody help me to sole this problem

User avatar
psantamaria
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 208
Joined: Tue Aug 26, 2008 8:14 pm
Location: Brisbane, Australia
Contact:

Re: Getting JFolder Create error when installing module

Post by psantamaria » Mon Nov 03, 2008 8:38 pm

I have the same problem with my 1.5.7, before I made the changes at configuration.php the warning was:

Code: Select all

Warning! Failed to move file.
And after the changes, the warning is:

Code: Select all

JFolder::create: Path not in open_basedir paths
Warning! Failed to move file.
Please, someone must have a solution for joomla 1.5.7

User avatar
psantamaria
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 208
Joined: Tue Aug 26, 2008 8:14 pm
Location: Brisbane, Australia
Contact:

Re: Getting JFolder Create error when installing module

Post by psantamaria » Mon Nov 03, 2008 9:09 pm

I solved my problem.
At 1.5.7 installs is not needed to change anything at configuration.php

I just turned all my folders' CHMOD into 777, and it worked.



Hope it works for others.

Pablo.

mawpublicidad
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Jul 29, 2008 7:55 pm

Re: Getting JFolder Create error when installing module

Post by mawpublicidad » Thu Nov 20, 2008 11:06 pm

kmsrentals wrote:Found the problem in my site.
...
Changes in configuration.php

var $log_path = '/usr/home/web/web***/joomla/logs'; //*= my username on ISP
var $tmp_path = '/usr/home/web/web***/joomla/tmp'; //*= my username on ISP

to:

var $log_path = './logs';
var $tmp_path = './tmp';
kmsrentals !

thank you ! thank you ! thank you ! thank you !

really, it saves me hours !!!

:pop

I began to have the problem after moving my site to a temporal folder...

shirestudios
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Wed Apr 16, 2008 12:37 pm

Re: Getting JFolder Create error when installing module

Post by shirestudios » Mon Dec 08, 2008 2:40 pm

Thank you...worked perfectly!!!

;)

GreenWorldWeb
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jan 31, 2009 2:01 am

Re: Getting JFolder Create error when installing module

Post by GreenWorldWeb » Mon Feb 02, 2009 2:13 pm

Thank you!
Was stuck on it but now It's working!

User avatar
Rowby
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 193
Joined: Sun Dec 11, 2005 9:13 pm
Location: California
Contact:

Re: Getting JFolder Create error when installing module

Post by Rowby » Mon Feb 09, 2009 11:08 pm

ANother place to check, especially when moving your site from one host to another, is your Joomla Administrator Control Global Configuration section.

In the System tab, in "Path to Log folder" make sure you you have the correct path to your site.
In the Server tab, in "Path to Temp-folder" make sure you you have the correct path to your site.

I found that just correcting your configuration.php file did not update the Global COnfiguration Section.

Rowby
http://www.rowby.com

padztar
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Dec 18, 2008 3:29 pm

Re: Getting JFolder Create error when installing module

Post by padztar » Wed Mar 11, 2009 3:18 pm

kmsrentals wrote:Found the problem in my site.

My host moved the files and it caused the problems

Followed this tip and my problem is solved:

Changes in configuration.php

var $log_path = '/usr/home/web/web***/joomla/logs'; //*= my username on ISP
var $tmp_path = '/usr/home/web/web***/joomla/tmp'; //*= my username on ISP

to:

var $log_path = './logs';
var $tmp_path = './tmp';
Thanks KMSRENTALS, this solution worked for me :)

Point202
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri May 15, 2009 6:34 pm

Re: Getting JFolder Create error when installing module

Post by Point202 » Fri May 15, 2009 6:48 pm

THANK YOU! I was having a similar error for a different module. The solution posted by kmsrentals worked perfectly!

bioblaster
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Fri Jul 06, 2007 10:23 pm

Re: Getting JFolder Create error when installing module

Post by bioblaster » Thu Jun 25, 2009 3:56 am

Thanks a bunch! That worked perfectly messing with the config file.
Have you tried hitting the side of it yet?

emagin
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 136
Joined: Sun Sep 11, 2005 7:46 pm
Location: san francisco, ca usa

Re: Getting JFolder Create error when installing module

Post by emagin » Thu Jan 28, 2010 1:03 am

Just wanted to add a twist to this. I was getting the error because I changed my cpanel account ID for the website in question.
This changed all my /home/userID/ paths
Configuration.php had all the log and tmp folders at /home/oldUserID/.... and was choking since they no longer existed.

So sometimes we are foiled by our own stupidity!

daop
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Tue Jan 26, 2010 9:42 am

Re: Getting JFolder Create error when installing module

Post by daop » Tue Feb 16, 2010 5:52 pm

Brilliant thanks!!

fstrube
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Feb 16, 2010 5:28 pm
Location: Washington, DC
Contact:

Re: Getting JFolder Create error when installing module

Post by fstrube » Tue Feb 16, 2010 6:57 pm

kmsrentals wrote:Found the problem in my site.

My host moved the files and it caused the problems

Followed this tip and my problem is solved:

Changes in configuration.php

var $log_path = '/usr/home/web/web***/joomla/logs'; //*= my username on ISP
var $tmp_path = '/usr/home/web/web***/joomla/tmp'; //*= my username on ISP

to:

var $log_path = './logs';
var $tmp_path = './tmp';

Setting the log_path and tmp_path fixed it for me.
Franklin Strube
Developer
Global Thinking
Washington, DC
http://www.globalthinking.com

tekkon
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Mar 25, 2010 11:52 pm

Re: Getting JFolder Create error when installing module

Post by tekkon » Thu Mar 25, 2010 11:56 pm

once I figured out the changes needed to me made in joomla (thks Rowboy) and not cPanel it worked perfectly. I am such a newb!! I have so much to learn

seriously thank you so much :) :)

albisatya
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Oct 26, 2007 9:41 pm
Contact:

Re: Getting JFolder Create error when installing module

Post by albisatya » Wed Mar 31, 2010 6:25 am

Thanks so much! This worked perfectly!
Albisatya
Special Agent
Mole Clan
Project Restoration -- The Ultimate Reality Game

peskyhuman
Joomla! Apprentice
Joomla! Apprentice
Posts: 40
Joined: Wed Apr 28, 2010 8:42 pm
Location: New Zealand
Contact:

Re: Getting JFolder Create error when installing module

Post by peskyhuman » Wed Apr 28, 2010 9:59 pm

kmsrentals wrote:Found the problem in my site.

My host moved the files and it caused the problems

Followed this tip and my problem is solved:

Changes in configuration.php

var $log_path = '/usr/home/web/web***/joomla/logs'; //*= my username on ISP
var $tmp_path = '/usr/home/web/web***/joomla/tmp'; //*= my username on ISP

to:

var $log_path = './logs';
var $tmp_path = './tmp';
:p Your a legend! Thanks very much! :pop
Check out my latest Joomla! website:

http://thegamegate.co.nz


Locked

Return to “Extensions for Joomla! 1.5”