Plesk Application Vault Installation

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
mvilares
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Apr 30, 2008 5:12 am

Plesk Application Vault Installation

Post by mvilares » Wed Apr 30, 2008 5:38 am

I have searched and searched and have yet to find any instructions on how to install Joomla! 1.5 to a Plesk Application Vault. My current Application Vault has Joomla! 1.0.12 installed, but I would like to either migrate that to 1.5, or do a clean install into my Application Vault. Does anyone know how to go about this? I have tried the "Add New Application Distribution Package" option with the Joomla! .zip file but it throws out the following errors:
Error: sappmng: ERROR: unable to extract file APP-META.xml into temporary dir:

System error 2: No such file or directory
Metadata file APP-META.xml is broken.
sappmng: test_package: failed to test RPM package /tmp/phpyiIdMt

System error 2: No such file or directory
1
:eek: Say what now? Do I have to build my own installation package for it to work with the Application Vault in Plesk, or is there one available for download somewhere already pre-built? Plesk is asking for one of these file packages: *.rpm, *.sh, *.app.zip

Many thanks.

 
User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Plesk Application Vault Installation

Post by humvee » Fri May 02, 2008 12:14 am

Joomla! does not develop packages for the different Control Panels that Web Hosts might use - that is for them and / or their communities to do.

Have you tried uploading the files using an FTP client and installing that way? Check out the Installation Manual for guidance.

Andy

User avatar
Actor
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Fri Aug 19, 2005 10:59 am
Location: Netherlands

Re: Plesk Application Vault Installation

Post by Actor » Sun Oct 26, 2008 12:32 pm

You can find them here:
http://www.apsstandard.com/app/
Download the APS, and upload it within Plesk from your admin control panel.
(currently, they are still a version behind: 1.5.6)

Works great, even creates the database for you, and offers version upgrades.

Sorbee
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sat Apr 17, 2010 6:55 pm

Re: Plesk Application Vault Installation

Post by Sorbee » Sat Apr 17, 2010 7:01 pm

Actor wrote:You can find them here:
http://www.apsstandard.com/app/
Download the APS, and upload it within Plesk from your admin control panel.
(currently, they are still a version behind: 1.5.6)

Works great, even creates the database for you, and offers version upgrades.
I tried that and then went to plesk to install *I am running 8.2* and it doesnt give me an error but it also doesnt show up on the list when its done

dcolumbus
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Apr 23, 2010 10:01 pm

Re: Plesk Application Vault Installation

Post by dcolumbus » Fri Apr 23, 2010 10:21 pm

I'm having an issue with this as well...

Plesk version: 8.6

I downloaded the Joomla! package from http://www.apsstandard.com/app/ and uploaded it using the Application Vault within Plesk.

I now have the following WARNING:

Code: Select all

Unable to register the package located in the directory "joomla-1.5.15-18": The uploaded application distribution package does not conform to the AppPacks specifications: DOMDocument::relaxNGValidate() [<a href='domdocument.relaxngvalidate'>domdocument.relaxngvalidate</a>]: Did not expect element id there.. You should remove the package from the server because it will not function properly.
What's the deal?

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Plesk Application Vault Installation

Post by humvee » Fri Apr 23, 2010 10:56 pm

This is not a Joomla! issue and you should take it up with the people who are putting out this package.

dcolumbus
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Apr 23, 2010 10:01 pm

Re: Plesk Application Vault Installation

Post by dcolumbus » Fri Apr 23, 2010 11:15 pm

This is not a Joomla! issue and you should take it up with the people who are putting out this package.
It's more a Joomla! issue than anyone else. This is Joomla! specific. Wordpress, Mambo, etc all install just fine. Besides, who cares whether or not it's the fault of Joomla!? This is a good place - one of the first people choose - to find out information on this issue.

Just because you don't know how to fix the issue doesn't mean that there's no one else in the community...

User avatar
humvee
Joomla! Master
Joomla! Master
Posts: 14713
Joined: Wed Aug 17, 2005 10:27 pm
Location: Kent, England

Re: Plesk Application Vault Installation

Post by humvee » Fri Apr 23, 2010 11:25 pm

dcolumbus wrote:It's more a Joomla! issue than anyone else. This is Joomla! specific. Wordpress, Mambo, etc all install just fine. Besides, who cares whether or not it's the fault of Joomla!? This is a good place - one of the first people choose - to find out information on this issue.
No the error is with the package that a third party has created from Joomla! and therefore their responsibility.
Just because you don't know how to fix the issue doesn't mean that there's no one else in the community...
Absolutely right I don't - because it is not a Joomla! issue. But the correct place is with the developer of the package.

dcolumbus
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Apr 23, 2010 10:01 pm

Re: Plesk Application Vault Installation

Post by dcolumbus » Sat Apr 24, 2010 12:15 am

Look, the issue isn't about the package. I don't care about that package. I noted it because I had exhausted that particular package as an option.

Instead of trying to hijack my question, perhaps you could point me (and any others with the same issue) in the direction of how we would go about installing Joomla! on Plesk 8.6. Telling me that it isn't a Joomla! issue is hardly helpful.

If we can't go to the Joomla! forums to inquire about Joomla! issues, what's the point of these forums? Please leave this thread alone for someone else to assist.

migzam
Joomla! Intern
Joomla! Intern
Posts: 77
Joined: Sat Dec 20, 2008 12:29 am

Re: Plesk Application Vault Installation

Post by migzam » Sat Oct 16, 2010 1:49 pm

Hey, did you ever get a solution? I have the same issue and seems no where to get help.

Thanks

Hope_floats
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Nov 12, 2010 3:20 pm

Re: Plesk Application Vault Installation

Post by Hope_floats » Fri Nov 12, 2010 3:23 pm

I was trying to do this as well but found out that Plesk keeps the files on their server, the applications that they have in the application vault. Apparently you cannot edit these and although they are outdated most of the time you have to weed your way through them. Its a cat and mouse game - as certain versions of joomla (noah classifieds, etc etc) are hackers dreams and all they have to do is search to find an exploit and boom, server compromised.

We are really reviewing if application vault is worth having on the server. If someone wants to install wordpress or joomla and can't figure out how to do via ftp - they need to pay their host. Application vault, while a GREAT idea and Fantastico too, seems to be more headache to the host than worth.

migzam
Joomla! Intern
Joomla! Intern
Posts: 77
Joined: Sat Dec 20, 2008 12:29 am

Re: Plesk Application Vault Installation

Post by migzam » Tue Nov 16, 2010 11:22 pm

You can add new or updated apps by uploading from this site.

www.apsstandard.org

Hope_floats
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Nov 12, 2010 3:20 pm

Re: Plesk Application Vault Installation

Post by Hope_floats » Wed Nov 17, 2010 12:42 am

yes, I saw that shortly after making my post - the newest version of plesk is really nice as well (10) and it seems to load all pretty quick. tried to load newest joomla and with joomla and another app, they just hung and never uploaded - many tries later too...strange.

 

Locked

Return to “Installation 1.5”