Joomla 1.5.20 SMTP with Gmail not working

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
johnmurphy01
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Sep 08, 2010 10:10 pm

Joomla 1.5.20 SMTP with Gmail not working

Post by johnmurphy01 » Thu Sep 09, 2010 4:07 pm

I am trying to use my Gmail account to send Registration emails to users via Joomla's Global configuration settings. I have setup my configuration as follows

Mailer SMTP Server
Mail from email@gmail.com
From Name Site Name
Sendmail Path /usr/sbin/sendmail
SMTP Authentication Yes
SMTP Security SSL
SMTP Port 465
SMTP Username email@gmail.com
SMTP Password password
SMTP Host smtp.gmail.com

I am getting a "Cannot connect to SMTP Host" error message each time.

I've tried to use the Joomla Gmail trick of making the Host gmail-smtp-in.l.google.com. This did not work either. I've also tried editing the controller.php file as I heard this also works sometimes.

Does anyone know why Joomla 1.5.20 is not sending emails when I try to use Gmail as my SMTP mail? Any help would be appreciated.

johnmurphy01
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Sep 08, 2010 10:10 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by johnmurphy01 » Tue Sep 21, 2010 9:38 pm

Does anyone have any insight into this? I have recently switched from a Godaddy Windows shared hosting plan to a Godaddy Linux shared hosting plan in the hopes that this would help fix the issue. But still no luck.

nur_afini
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jul 21, 2010 2:24 am

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by nur_afini » Wed Sep 22, 2010 9:04 am

I am facing the same problem here. I had tried the solution (changing the global configuration and also the config file), but still the same error been previewed to me. It is really a pain in the neck. Hope someone can help... ???

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by wises » Thu Oct 14, 2010 2:37 am

its been over a month and NO reply/fix or anything for this?.. kind of reminds me of the VM forums :P where important posts don't get answered even after years..

I think the only way to resolve this issue is to revert backwards as even version 1.5.21 has the same problem(s).. and there's not a fix publicly anywhere from what Ive seen

1 would almost assume that it was removed deliberately.
check back here in a few months ;)

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

IS GMAIL SUPPORT DISABLED 1.5.20-21?!?

Post by wises » Thu Oct 14, 2010 2:49 am

Upgraded 2 sites and noticed that Gmail SMTP no longer works...
noticed a number of posts asking about this and NO FIX...ANYWHERE.

Not recommended to update if you are using Gmail accounts.

Restoring backup's :\

:eek:

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14781
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: IS GMAIL SUPPORT DISABLED 1.5.20-21?!?

Post by mandville » Thu Oct 14, 2010 3:40 am

i did follow your link and found that there were several answers..
speak to google, and when searching via yahoo, they said "speak to google"
and when i went through ask.com and bing, they mostly said - speak to google.. but then i did searh without an out of date version number (we are now on 1.5.21)
Not recommended to update if you are using Gmail accounts.
recommended to update for security reasons and not use google, i wasnt aware that joomla core used google mail anyway
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14781
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: IS GMAIL SUPPORT DISABLED 1.5.20-21?!?

Post by mandville » Thu Oct 14, 2010 3:42 am

to save editing,, did you see this topic? http://forum.joomla.org/viewtopic.php?f=430&t=451035
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14781
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by mandville » Thu Oct 14, 2010 3:45 am

wises wrote:its been over a month and NO reply/fix or anything for this?.. kind of reminds me of the VM forums :P where important posts don't get answered even after years..
[perhaps because there isnt an answer
I think the only way to resolve this issue is to revert backwards as even version 1.5.21 has the same problem(s).. and there's not a fix publicly anywhere from what Ive seen
did you submit a bug report? or try here http://forum.joomla.org/viewtopic.php?f=430&t=556475
1 would almost assume that it was removed deliberately. check back here in a few months ;)
suggest you read this one.. as im not sure how many other people (seems only 3 ) have reported issues with it. http://www.gjfreepress.com/article/2010 ... /100529981
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by wises » Thu Oct 14, 2010 4:01 am

mandville wrote:perhaps because there isnt an answer
There's always an answer... just looking for the right one ;)
did you submit a bug report? or try here http://forum.joomla.org/viewtopic.php?f=430&t=556475
on my way now...
suggest you read this one.. as im not sure how many other people (seems only 3 ) have reported issues with it. http://www.gjfreepress.com/article/2010 ... /100529981
Probably because the other developer's who use smtp.gmail.com have not yet realized that it is not working as It's not immediately noticeable until you start trying to use contact forms and other such mods then the Error will alert them ..

By that time it is too late , because they would have already updated there respective sites to the newer version and are probably ripping their hair out as I type.

As far as the 10,000 other Developers are concerned... they'll be in later - when they discover that no email's are being sent... or they stumble across these threads in their journey's then check for themselves... and come back looking for a solution as we have.

already the (3) you mentioned has accumulated into 100+ curious onlookers;
Look_Down_Below wrote:Users browsing this forum: kmanstudios, lordtheydon, Markstein, newlands_3d, sameg, wises and 103 guests
thanks for your reply btw.. any new lead is better then what Ive found so far.. Have even gone so far as to hack the controller.php without success.

Code: Select all

   $mail->addRecipient( $contact->email_to );
               // $mail->setSender( array( $email, $name ) );
               // ^ Removed Line
                  $mail->setSender( array( $MailFrom, $FromName ) )
               // added line
               // tested and not working..

Code: Select all

my_domain.com/components/com_contact/controller.php
Above hack:is from this post

Relevant Debug Info;

Code: Select all

SET `time`='1287027912',`userid`='62',`usertype`='Super Administrator',`username`='admin',`gid`='[b]25[/b]',`guest`='0',`client_id`='1',`data`='__default|a:8:{s:15:\"session.counter\";i:17;s:19:\"session.timer.start\";i:1287025168;s:18:\"session.timer.last\";i:1287027898;s:17:\"session.timer.now\";i:1287027911;s:22:\"session.client.browser\";s:11:\"Mozilla/4.0\";s:8:\"registry\";O:9:\"JRegistry\":3:{s:17:\"_defaultNameSpace\";s:7:\"session\";s:9:\"_registry\";a:3:{s:7:\"session\";a:1:{s:4:\"data\";O:8:\"stdClass\":0:{}}s:11:\"application\";a:1:{s:4:\"data\";O:8:\"stdClass\":1:{s:4:\"lang\";s:0:\"\";}}s:10:\"com_cpanel\";a:1:{s:4:\"data\";O:8:\"stdClass\":1:{s:9:\"mtupgrade\";O:8:\"stdClass\":1:{s:7:\"checked\";b:1;}}}}s:7:\"_errors\";a:0:{}}s:4:\"user\";O:5:\"JUser\":19:{s:2:\"id\";s:2:\"62\";s:4:\"name\";s:13:\"Administrator\";s:8:\"username\";s:5:\"admin\";s:5:\"email\";s:17:\"someone@gmail.com\";s:8:\"password\";s:65:\"Password_for_someone@gmail.com\";s:14:\"password_clear\";s:0:\"\";s:8:\"usertype\";s:19:\"Super Administrator\";s:5:\"block\";s:1:\"0\";s:9:\"sendEmail\";s:1:\"1\";s:3:\"gid\";s:2:\"25\";s:12:\"registerDate\";s:19:\"2009-09-08 22:17:44\";s:13:\"lastvisitDate\";s:19:\"2010-10-13 19:45:13\";s:10:\"activation\";s:0:\"\";s:6:\"params\";s:60:\"admin_language=\nlanguage=\neditor=jce\nhelpsite=\ntimezone=12\n\n\";s:3:\"aid\";i:2;s:5:\"guest\";i:0;s:7:\"_params\";O:10:\"JParameter\":7:{s:4:\"_raw\";s:0:\"\";s:4:\"_xml\";N;s:9:\"_elements\";a:0:{}s:12:\"_elementPath\";a:1:{i:0;s:82:\"/path_to_domain/somesite.com/libraries/joomla/html/parameter/element\";}s:17:\"_defaultNameSpace\";s:8:\"_default\";s:9:\"_registry\";a:1:{s:8:\"_default\";a:1:{s:4:\"data\";O:8:\"stdClass\":5:{s:14:\"admin_language\";s:0:\"\";s:8:\"language\";s:0:\"\";s:6:\"editor\";s:3:\"jce\";s:8:\"helpsite\";s:0:\"\";s:8:\"timezone\";s:2:\"12\";}}}s:7:\"_errors\";a:0:{}}s:9:\"_errorMsg\";N;s:7:\"_errors\";a:0:{}}s:13:\"session.token\";s:32:\"some_token\";}' 
:pop

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: IS GMAIL SUPPORT DISABLED 1.5.20-21?!?

Post by wises » Thu Oct 14, 2010 5:04 am

Hi ya , thanks for the swift reply , I have been using Google for several years with Joomla from version 1.0 through 1.5 without a hitch (well there's been a couple) hehe.

but mainly configuration type problems. apart from that ... nothing major.

Thanks for help Appreciate it.. read the links that you posted and for the most part they were old deprecated fixes for previous (earlier) versions of Joomla which I think were fixed in version 1.5.9 up-wards..

I did however find the testmailer.php of interest and used this to test all other possible combination(s) & Fixes to no avail.

^drop it into your domain.root.directory and exec http://www.yourdomain.com/testmailer.php

here's my results;

Code: Select all

SMTP -> ERROR: Failed to connect to server: Connection timed out (110) Mailer Error: SMTP Error: Could not connect to SMTP host. 
unfortunately another dead end...
:pop

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 14781
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: IS GMAIL SUPPORT DISABLED 1.5.20-21?!?

Post by mandville » Thu Oct 14, 2010 1:02 pm

maybee its google that have changed their methods.
submit a bug request in the right place and it may get looked at
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by wises » Fri Oct 15, 2010 1:30 am

could be ... as other sites not working either now ..

will look into it later thanks.

also note that it would seem that the testmailer.php mentioned above could now be deprecated as t was written several years ago and the variables have long since changed.

checking to see if Google have changed it at there end now

results

here's a google page for google settings here

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by wises » Sun Oct 17, 2010 6:07 am

man navigating the tracking system requires a degree in IT lmao

anyway it's the only one to do with this issue in there and the id: 22916

for anyone else who can actually get into the bug tracking area.

here

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by wises » Sun Oct 17, 2010 11:07 am

sorted in case of the cheap hosting companies that many of us loathe..

Code: Select all

PHP mail Function
SMTP Security = none
SMTP port = 25
SMTP Host = gmail-smtp-in.l.google.com
seems to works fine
only problem I have with it is that it is not secure... which concerns me a bit..

next step is to try appending ssl://gmail-smtp-in.l.google.com:465 to the equation and see if that works ..

ok just tested and this also works;

Code: Select all

SMTP HOST = ssl://gmail-smtp-in.l.google.com:465
not sure how to tell if it is actually secure though perhaps though headers.. how would i test this?

Thanks

Mhaddy
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Mon Mar 13, 2006 10:29 pm
Location: Canada
Contact:

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by Mhaddy » Tue Mar 29, 2011 3:34 am

wises wrote:

Code: Select all

PHP mail Function
SMTP Security = none
SMTP port = 25
SMTP Host = gmail-smtp-in.l.google.com
You Sir, are a God. I have spent hours trying to get this bloody thing to work and if my client wasn't set on sticking with GoDaddy, I would have been out of there years ago. Anyhow, I digress. Using your settings above and the AIContactSafe Component, my contact forms are finally working again.

FWIW, I tried the settings and code hacks mentioned here, and it would only work for non-Gmail addresses. Your settings work for all emails I've tested.

Thank you.
Mad Dog Studios (http://www.maddogstudios.net) - graphic design & web dev

wises
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Wed Feb 18, 2009 11:28 pm

Re: Joomla 1.5.20 SMTP with Gmail not working

Post by wises » Tue Mar 29, 2011 5:52 am

:) glad to be of service try using the the following setting instead as it encrypts the data between the server and google.

SMTP HOST = ssl://gmail-smtp-in.l.google.com:465

Godady/ixwebhosting and many other ultimate unlimited plan type companies all have the same problem.

this fortunately for us does the job nicely. Problem that Ive had with such companies is that their mail services are mediocre at best.

Again glad i could help.


Locked

Return to “General Questions/New to Joomla! 1.5”