Problem with redirecting loop - Language Filter plugin

General questions relating to Joomla! 2.5. Note: All 1.6 and 1.7 releases have reached end of life and should be updated to 2.5. There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Locked
Erestor84
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jul 14, 2009 6:15 pm

Problem with redirecting loop - Language Filter plugin

Post by Erestor84 » Sat May 07, 2011 4:46 pm

Hi,

I've read all the post concerning this problem but I havn't found any working solution.

Problem: can't access front-end (error message in the browser: The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies.)

Cause: the site stopped working after I've installed Zazu emoticon plugin (http://zaazu.com/joomla_plugin.html) and cleared cache with the use of JAT3 Clean Cache tool

Steps taken to slove the problem:
- deleted the plugin
- changed the template to default
- made sure that there is no httacces file present
- made sure that mod_rewrite is off

Website address: http://meetenglish.pl/teacher/
Joomla version: Joomla! 1.6.0 Stable [ Onward ] 10-Jan-2011 23:00 GMT

Can anyone help me to identify the source of the problem?
Last edited by Erestor84 on Sat May 07, 2011 8:52 pm, edited 1 time in total.

 
g1smd
Joomla! Guru
Joomla! Guru
Posts: 951
Joined: Mon Feb 21, 2011 4:02 pm
Location: UK

Re: Problem with redirecting loop

Post by g1smd » Sat May 07, 2011 5:42 pm

Use the Live HTTP Headers extension for Firefox to see exactly what is sent and received in the server-browser HTTP transactions.
Online since 1995.

Erestor84
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jul 14, 2009 6:15 pm

Re: Problem with redirecting loop

Post by Erestor84 » Sat May 07, 2011 8:11 pm

Ok, I've installed the extension and got the problematic cookie:

Cookie: ecf27c3cd4a43e7c42e34815c0eb2d8a=95d7711b74ee778ad11d981beefba73f; jpanetabs_config-tabs-com_plugins_configuration=0; jpanesliders_permissions-sliderscom_plugins=0; jpanesliders_warning-sliders=1; jpanesliders_permissions-sliders=0; configuration=system; jpanesliders_panel-sliders=0; information=site; jpanesliders_content-sliders-115=0; jpanesliders_permissions-sliders-115=0; jpanesliders_permissions-sliderscom_content=0; df84466c2f178e649c2f287cea855cc1=879cea432614df1ebd580dbb3566aa07

However, I dont know how to get the name of the plugin from this string :(

EDIT

Ok. I've found it. I disabled all plugins and was enabling them one by one to find the problematic one. I don't know why I Hadn't thought about that before >:(

The problematic plugin is System - Language Filter any idea why it causes the problem?

Perarg
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Nov 03, 2008 3:24 pm

Re: Problem with redirecting loop - Language Filter plugin

Post by Perarg » Fri Aug 19, 2011 6:08 pm

I have the same problem with Language Filter plugin. When it is enabled, the front-end is doing a redirecting loop until browser go to an error...

What is going on with this plugin ??

RubbelDeKatz
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Oct 13, 2010 11:31 am

Re: Problem with redirecting loop - Language Filter plugin

Post by RubbelDeKatz » Tue Oct 11, 2011 10:19 am

Same Problem here!!!

Joomla! 1.7.1 Stable [ Ember ] 26-Sep-2011 14:00 GMT

With and without enabled .htaccess

RubbelDeKatz
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Oct 13, 2010 11:31 am

Re: Problem with redirecting loop - Language Filter plugin

Post by RubbelDeKatz » Tue Oct 11, 2011 10:29 am

Here ist the response Header

Request URL:http://www.domain.de/index.php?option=c ... Itemid=128
Request Method:GET
Status Code:303 See other

It seems that the Language Filter plugin redirets permanently to the same page!!

RubbelDeKatz
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Wed Oct 13, 2010 11:31 am

Found the solution

Post by RubbelDeKatz » Tue Oct 11, 2011 10:46 am

It happens if you upgrade from 1.6 to 1.7

Just add a integer field called ordering to jos_languages table, order your languages and the plugin will work.

Perarg
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Mon Nov 03, 2008 3:24 pm

Re: Problem with redirecting loop - Language Filter plugin

Post by Perarg » Tue Oct 11, 2011 10:56 am


 

Locked

Return to “General Questions/New to Joomla! 2.5”