المشاكل التي حدثت معي بعد الترقية (الهجرة) من 1.5 إلى 1.6

إذا واجهتك مشكلة أثناء التثبيت أو الترقية , قم بطرحها هنا

Moderators: sherif, General Support Moderators, sherif, General Support Moderators

Forum rules
Locked
issag
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jan 13, 2010 7:24 am

المشاكل التي حدثت معي بعد الترقية (الهجرة) من 1.5 إلى 1.6

Post by issag » Tue Jun 14, 2011 9:16 am

لقد قمت بالترقية (الهجرة) من جملة 1.5.23 إلى الإصدار الجديد من جملة 1.6.3 وقد أتبعت كافة الأجراءات المذكورة في الملف المخصص لعملية الهجرة بدءاً من التأكد من كافة الملفات وأخذ النسخة الإحتياطية وتنصيب jupgrade إلى كافة هذه الأمور ..عملية الترقية من الناحية التقنية تمت بنجاح للموقع (الحي) حيث تم نقل أسماء القوائم والمجموعات والأقسام بالإضافة إلى نقل كافة الأعضاء ولكن مع وجود بعض المشاكل والملاحظات وهي كالتالي :

1- لم يتم نقل كافة المواضيع والأخبار حيث وجدت أن بعض الأخبار المضافة حديثاً ناقصة (لم يتم نقل الأخبار والمواضيع التي أضيفت قبل خمس أيام)
2- وجدت بعض المشاكل في القوائم حيث تقوم بتحويلك إلى قائمة أخرى أو غير موجودة عند الضغط على إحداها (بعض القوائم وليس جميعها)
3- تغيير في بعض خواص المجموعات حيث أعيدت كافة المجموعات ووطريقة نشر المواضيع إلى الحالة (الأفتراضية) مما يجبرك إلى القيام بإعادة تخصيصها من جديد)
4- ملفات الترجمة للغة العربية غير كاملة ويوجد بها بعض النواقص
5- أنت بحاجة إلى إعادة ضبط SEO Settings و Use URL rewriting وبعد عملية إعادة الضبط حدث إختلاف بشكل الرابط النهائي رغم إعادة ضبطها بنفس الإعدادات السابقة


أما من ناحية الاضافات والتي من المفروض أن أقوم بنقلها يدوياً :
1-لم أستطيع نقل التعليقات الموجودة أسفل المواضيع والأخبار
2- لم أستطع نقل الإعلانات الموجودة في تطبيق مدير الإعلانات

إما انه حدثت بعض الأخطاء التي لم أستطع أن أنتبه لها أثناء عملية الهجرة أو أنه علي علي أن أنتظر قليلاً حتى تستقر أمور النسخة أكثر .؟؟

Thank you to everyone who provided assistance

amrshaar
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Fri Feb 18, 2011 1:59 pm

Re: المشاكل التي حدثت معي بعد الترقية (الهجرة) من 1.5 إلى 1.

Post by amrshaar » Tue Jun 14, 2011 9:20 am

اول الأمر سعدت كثيرا بشخص يتكلم العربية هنا
تانيا هل تاكدة من ان القالب template
متوافق مع الجوملا 1.6
و السؤال الأهم لماذا انتقلت من 1.5 الى 1.6

issag
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jan 13, 2010 7:24 am

Re: المشاكل التي حدثت معي بعد الترقية (الهجرة) من 1.5 إلى 1.

Post by issag » Tue Jun 14, 2011 1:14 pm

شكراً لك صديقي amrshaar على الرد وأنا كمان سعيد بردك ..
هلق بالنسبة "للقالب" فبعد عملية النقل أستخدمت أحد القوالب التي تأتي مع النسخة 1.6 ولم أستخدم القالب القديم فهو لايعمل مع النسخة الجديدة
وإليك ولمن يهتم في هذه الأمور بعض الأمثلة عن التغيرات التي حدثت للروابط .. علماً أن الرابطان يعملان قبل وبعد عملية النقل

الرابط الأساسي (جملة 1.5)
international-news/464-1.html

الرابط بعد الأنتقال إلى (جملة 1.6)
jupgrade/20-international-news/international-news/464--------.html
----------
مثال آخر
الرابط الأساسي (جملة 1.5)
various/775-1.html

الرابط بعد الأنتقال إلى (جملة 1.6)
jupgrade/arts-news/775--------.html

أما روابط الأقسام فعند الضغط على قسم (الصور) فينقلك إلى مجموعة في قسم (الأغاني)
وبعضها ينقلك إلى صفحة فارغة مع رسالة (لقد حدث خطأ لايمكن العثور على الصفحة المطلوبة.)
---------------------
أما حول سؤالك لماذا أنتقلت من 1.5 إلى 1.6 ؟

بالحقيقة لعدة أسباب علماً أنني لم أخسر النسخة القديمة (1.5.23) فأنا محتاط لهذا الأمر وسأقوم بإستعادتها فوراً وحذف النسخة الجديدة بعد أحصاء جميع المشاكل التي حدثت معي بعد عملية الهجرة
- وأهم أسباب الأنتقال هو أن عليك أن تنتقل إن لم يكن الآن فربما بعد عدة أشهر فالدعم للنسخة القديمة حتماً سيتوقف بعد عدة أشهر (لاأعرف عددها) وربما سنة أخرى أو أكثر قليلاً على ماأعتقد ..
- ومن ناحية أخرى فمن المفترض أن تتفوق النسخة الجديدة على النسخة القديمة من كافة النواحي وكنت أنتظر أن تستقر النسخة لأباشر بعملية الأنتقال
- ومن ناحية أخرى أريد أن أجرب بعض التطبيقات الجديدة ولاأرغب أن أبدأ مع النسخة القديمة خوفاً من الصعوبة في نقلها إلى النسخة الجديدة مستقبلاً عندما أضطر إلى ذلك ..
شكراً للاهتمام ...

Thank you to everyone who provided assistance

amrshaar
Joomla! Apprentice
Joomla! Apprentice
Posts: 24
Joined: Fri Feb 18, 2011 1:59 pm

Re: المشاكل التي حدثت معي بعد الترقية (الهجرة) من 1.5 إلى 1.

Post by amrshaar » Tue Jun 14, 2011 3:39 pm

النسخة القديمة 1.5 أضمن لك انه لن يتم استبدالها قبل عامين او ثلاثة و ذلك لعدم و جود تطبيقات لحد الأن متطابقة مع ال 1.6 مثل التطبيقات التي تمت في 1.5
و هنالك نسخة افضل من 1.5.3 هنالك 1.5.7 افضل لن تشغر بالفرق و لكن ثغرات امنية تم حلها في هذه النسخة
بالإضافة لذلك سوف ابشرك ان النسخة 1.7 قد تم وضعها بشكلها الأولي و بامكانك تنزيلها و لكن ليشت مستفرة بعد
لذلك انصحك بعدم التعجل بالأمر
بالنسبة للتطبيقات الجديدة فكن و اثق بانها موجودة في النسخة الثديمة
و لقد تذكرت اهم سبب لعدم الإنتقال لل1.6 انها لا تدعم بشكل عام الا اللغة الإنكليزية ال 1.5 تدعم
joomfish
و هو تطبيق اساسي للغتين
و سؤال اضافي من بعد اذنك
هل لديك علم بال php

issag
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Wed Jan 13, 2010 7:24 am

Re: المشاكل التي حدثت معي بعد الترقية (الهجرة) من 1.5 إلى 1.

Post by issag » Tue Jun 14, 2011 8:16 pm

[quote]النسخة القديمة 1.5 أضمن لك انه لن يتم استبدالها قبل عامين او ثلاثة و ذلك لعدم و جود تطبيقات لحد الأن متطابقة مع ال 1.6 مثل التطبيقات التي تمت في 1.5 [/quote]
صديقي ... العديد من التطبيقات والقوالب والاضافات الآن تتوافق مع جملة 1.6 (التطبيقات التي أستخدمها على الأقل ..) ومن لم يقم بتحديث تطبيقه سيقوم بالتحديث خلال الأشهر القادمة بكل تأكيد ..
أما حديثك عن دعم جملة 1.5 لمدة ثلاث سنوات أخرى فلا أعتقد ذلك .. فأنا أطلعت على الملف المرفق من إدارة جملة حول طريقة الأنتقال من 1.5 إلى 1.6 وذكر فيه بالحرف الواحد
Do you NEED to migrate to Joomla 1.6? Joomla 1.5 is powerful and very mature. For many people there is not a need to rush into Joomla 1.6. Joomla will continue to support Joomla 1.5 for at least another year and three months, releasing security updates and bug squashing updates when needed.

[quote]و هنالك نسخة افضل من 1.5.3 هنالك 1.5.7 افضل لن تشغر بالفرق و لكن ثغرات امنية تم حلها في هذه النسخة
بالإضافة لذلك سوف ابشرك ان النسخة 1.7 قد تم وضعها بشكلها الأولي و بامكانك تنزيلها و لكن ليشت مستفرة بعد
لذلك انصحك بعدم التعجل بالأمر
[/quote]
عن أي نسخة تتحدث .. ؟ أرجوا أن ترفق رابط التحميل لأطلع عليها ..

[quote]و لقد تذكرت اهم سبب لعدم الإنتقال لل1.6 انها لا تدعم بشكل عام الا اللغة الإنكليزية ال 1.5 تدعم
joomfish
و هو تطبيق اساسي للغتين [/quote]
صديقي .. لقد صدر فعلاً تعريب للنسخة جملة 1.6.3 (ويشكر كل من ساهم في هذا التعريب ..) ..وحديثنا لإستكمال النواقص والمشاركة في أغنائها ..

[quote]و سؤال اضافي من بعد اذنك
هل لديك علم بال php[/quote]
لاأدري ماهي الخبرة التي تسأل عنها ولكن .. خبرتي على ماأعتقد أنها جيدة وخاصة في ادارة وتركيب جملة ولكن في حال كان لديك مشكلة يصعب عليك حلّها ..فتستطيع طرحها في موضوع جديد وسنرى إن كان في إمكاني مساعدتك ..

شكراً لك ..

Thank you to everyone who provided assistance


Locked

Return to “التثبيت و الترقية”