Upgrading 1.7.0 to 1.7.1 - Failing

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Stoofa
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Sep 01, 2011 3:25 pm
Location: Cambridge, UK
Contact:

Upgrading 1.7.0 to 1.7.1 - Failing

Post by Stoofa » Wed Sep 28, 2011 1:41 pm

Hi,
I was informed last night that there is an update available from Joomla 1.7.0 to 1.7.1
From within Joomla I went:

Extension Manager
Update

After a quick refresh I can indeed see:

Joomla - Update - File - 1.71

So I select this update and click on the "Update" button.
Almost immediately it comes back with:

-1 - An error has occurred
Copy Failed

This is the first time I've ever attempted to upgrade Joomla - it was installed as version 1.7.0
Is this "built in" upgrader the incorrect way of doing things?

Thanks.

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Wed Sep 28, 2011 9:08 pm

The built in upgrader should work, and it worked on another site I have.

But for one site, I got the same error message as you did:
-1 - An error has occurred
Copy Failed

So I dont know what we can do :(

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Wed Sep 28, 2011 9:32 pm

Just a shot in the dark: Have you changed the domainname on your site? For example; did your site had another domainname before?

This is the only thing that is different for my two sites; the site that upgraded well have always had the same domainname. But the another site I changed the domainname but it still lies on the old site, if you understand what I mean...

User avatar
flips01
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Wed Sep 28, 2011 10:38 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by flips01 » Wed Sep 28, 2011 10:52 pm

I get the same error message, but not immediately.
It's working for half a minute or more before the error occurs.
Joomla_1.7.1-Stable-Full_Package.zip is downloaded into <site-dir>/tmp

Also, everytime I try to run the update, it creates a directory in /tmp, like:
install_4e234d59e042b

Nothing in /logs. Should I turn on debugging or something?

Edit: And I've not done anything to my domainname ... Or, well. Not sure I ever defined a domainname. But I have copied the files and the database to my local laptop from a remote lab installation. (Running on XAMPP/OSX.)
flips 8)

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Wed Sep 28, 2011 10:59 pm

flips01 wrote: Also, everytime I try to run the update, it creates a directory in /tmp, like:
install_4e234d59e042b
Yep, same here. Now I have got lots of those install_xxxxxxxxx directories :eek:

dumini
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Thu Jan 22, 2009 4:10 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by dumini » Wed Sep 28, 2011 11:18 pm

Kengun wrote:The built in upgrader should work, and it worked on another site I have.

But for one site, I got the same error message as you did:
-1 - An error has occurred
Copy Failed

So I dont know what we can do :(
This is exactly what is happening to me :( Works on one site, error on the other ???

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Wed Sep 28, 2011 11:26 pm

Could it be something with what template is running? Well, it sound strange though. I use different templates on my two sites. Beez5 on the troublemaker site :o

Somehow it seems that it have done something to the database because Administration shows Version 1.7.1 in bottom of site. But when I click on "Find updates" it still find the upgrade :'(

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Wed Sep 28, 2011 11:35 pm

It could be a server setting

Try
Download the update zip
Then use the Joomla installer to install like you would an extension.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

dumini
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Thu Jan 22, 2009 4:10 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by dumini » Wed Sep 28, 2011 11:39 pm

Kengun wrote: Somehow it seems that it have done something to the database because Administration shows Version 1.7.1 in bottom of site. But when I click on "Find updates" it still find the upgrade :'(
Same here - I'm not even sure what version is running. It says 1.7.1 but for all I know I could still be on 1.7.0 :( The reason is, when I did the update the page just blinked or refreshed itself but never gave a Update successfully bla, bla, bla

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Wed Sep 28, 2011 11:44 pm

@dumini
Have you tried installing it like an extension yet ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

dumini
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Thu Jan 22, 2009 4:10 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by dumini » Thu Sep 29, 2011 12:33 am

Webdongle wrote:@dumini
Have you tried installing it like an extension yet ?
Hi webdongle, yes tried that. No success.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Thu Sep 29, 2011 12:39 am

OK
Go to Global config
Click 'Save'
Click 'Save' a second time

What messages do you get each time ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

dumini
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Thu Jan 22, 2009 4:10 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by dumini » Thu Sep 29, 2011 2:11 am

Configuration Successfully Saved.

What are you looking for?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Thu Sep 29, 2011 2:32 am

If you got that twice then Joomla has file Ownership. Want to PM me a login so I can have a quick look ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

johnny_mont
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Sep 29, 2011 3:26 am

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by johnny_mont » Thu Sep 29, 2011 3:40 am

Hi guys,

my site was on 1.6 and I was trying to upgrade to 1.7.1, the built in upgrader give me the same error that Stoofa had and when I access the /admin it returned an error.

So I tried to make a manual upgrade (I downloaded the package, unziped and uploaded all whit a ftp client) and now I can acces the /admin directory, but is an strange error message that says "This plugin is supported only on Joomla versions 1.5.23 and higher. Joomla 1.5.x users can use jAutoUpdate from Joomla Extensions for updating", and when I try to login the page turns all white.

Someone has any idea how to fix that? :x

PS: My frontend is working fine

Virtu
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Sep 29, 2011 8:19 am

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Virtu » Thu Sep 29, 2011 8:22 am

dumini wrote:
Kengun wrote: Somehow it seems that it have done something to the database because Administration shows Version 1.7.1 in bottom of site. But when I click on "Find updates" it still find the upgrade :'(
Same here - I'm not even sure what version is running. It says 1.7.1 but for all I know I could still be on 1.7.0 :( The reason is, when I did the update the page just blinked or refreshed itself but never gave a Update successfully bla, bla, bla

Yes... same to me.. no "Update sucessfull..", on bottom 1.7.1 but update to 1.7.1 is still available??? :(

Stoofa
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Thu Sep 01, 2011 3:25 pm
Location: Cambridge, UK
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Stoofa » Thu Sep 29, 2011 10:15 am

I'm using a template called "Adana".
I'm also using the JCE Editor
(In case either of those facts might be causing the issue).

I've tried the update from machines running IE8, IE9 and Firefox - so I don't think it's browser dependant.
I've not tried installing the update as a module yet - however somebody in another thread said there is an issue using the JCE Editor and updating this way?

User avatar
flips01
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Wed Sep 28, 2011 10:38 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by flips01 » Thu Sep 29, 2011 11:21 am

I entered Global Config, changed a minor detail. Saved it successfully twice.
Automatic update still had same issue/error. (v1.7.1 listed at bottom, but update found and failed when installing.)
Then I downloaded the patch instead of the Full package:
Joomla_1.7.0_to_1.7.1-Stable-Patch_Package.zip
It reported that "Installing file was successful."
And this time around the update is no longer found/listed under Extension Manager->Updates

Case solved for me. :)
flips 8)

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Thu Sep 29, 2011 11:36 am

flips01 wrote:Then I downloaded the patch instead of the Full package:
Joomla_1.7.0_to_1.7.1-Stable-Patch_Package.zip
What did you do with the patch file? Did you use FTP to upload it or what did you do to install it?
Stoofa wrote:I've not tried installing the update as a module yet - however somebody in another thread said there is an issue using the JCE Editor and updating this way?
I dont think JCE Editor have anything to do with this problem. Both of my sites was set up to use JCE Editor when I tried to run the upgrade.

User avatar
flips01
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Wed Sep 28, 2011 10:38 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by flips01 » Thu Sep 29, 2011 12:21 pm

Kengun wrote:What did you do with the patch file? Did you use FTP to upload it or what did you do to install it?
I downloaded the patch file to my laptop.
Then: Extension Manager -> Upload Package File -> Choose File -> Upload & Install
flips 8)

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Thu Sep 29, 2011 12:26 pm

flips01 wrote:I downloaded the patch file to my laptop.
Then: Extension Manager -> Upload Package File -> Choose File -> Upload & Install
Didn't work here >:( - got same errormessage :'(

dumini
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 112
Joined: Thu Jan 22, 2009 4:10 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by dumini » Thu Sep 29, 2011 1:30 pm

Kengun wrote:
flips01 wrote:I downloaded the patch file to my laptop.
Then: Extension Manager -> Upload Package File -> Choose File -> Upload & Install
Didn't work here >:( - got same errormessage :'(
This is also failing at my end :(

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Fri Sep 30, 2011 1:32 am

Tried with AdminTools and got the following error
Cannot write to
media/media/js/mediamanager.js

This is strange
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Fri Sep 30, 2011 9:06 pm

Is there any chance that an developer will have a look on this issue?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Fri Sep 30, 2011 11:30 pm

No reply to http://groups.google.com/group/joomlabu ... d0b4038f63 yet

The only sites I have failed to update have Apache Handler, Joomla appears to have Ownership of the files but something is preventing the update files from writing. Perhaps it's worth starting a Tracker.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".

User avatar
princessfiona_2
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue Feb 19, 2008 9:55 am

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by princessfiona_2 » Sat Oct 01, 2011 5:55 am

I got the same error message as you did:
-1 - An error has occurred
Copy Failed
I got this message too and saw that I had used 100% of my disc space. I went to my host manager and got more disc space and was then able to successfully upgrade to J 1.7.1

PF

User avatar
princessfiona_2
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Tue Feb 19, 2008 9:55 am

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by princessfiona_2 » Sat Oct 01, 2011 5:55 am

I got the same error message as you did:
-1 - An error has occurred
Copy Failed
I got this message too and saw that I had used 100% of my disc space. I went to my host manager and got more disc space and was then able to successfully upgrade to J 1.7.1

PF

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Sat Oct 01, 2011 8:30 am

princessfiona_2 wrote:
I got the same error message as you did:
-1 - An error has occurred
Copy Failed
I got this message too and saw that I had used 100% of my disc space. I went to my host manager and got more disc space and was then able to successfully upgrade to J 1.7.1

PF
My site have plenty of free disc space and I still can't upgrade. This is frustrating :'(

Kengun
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Fri Jun 12, 2009 12:38 pm
Location: Lyngdal, Norway
Contact:

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Kengun » Sat Oct 01, 2011 8:34 am

Webdongle wrote:No reply to http://groups.google.com/group/joomlabu ... d0b4038f63 yet

The only sites I have failed to update have Apache Handler, Joomla appears to have Ownership of the files but something is preventing the update files from writing. Perhaps it's worth starting a Tracker.
The strange thing is that my two sites is hosted at same host and as I can see everything is set up totally the same. But one site upgraded ok, but the another did not.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 41260
Joined: Sat Apr 05, 2008 9:58 pm

Re: Upgrading 1.7.0 to 1.7.1 - Failing

Post by Webdongle » Sun Oct 02, 2011 4:09 am

With dumini's site

I have
Installed Akeeba
Backed up the site
Downloaded the backup
Installed locally
And it updated no problem

My localhost is
WebServer to PHP Interface apache2handler
with mod_cgi
Xampp 1.7.4 on Ubuntu 10.1
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"When I'm right no one remembers but when I'm wrong no one forgets".


Locked

Return to “Migrating and Upgrading to Joomla! 2.5”