SOLVED: Unable to Find Install Package

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Kotetsu52
Joomla! Intern
Joomla! Intern
Posts: 50
Joined: Fri Jul 03, 2009 11:37 am

Re: SOLVED: Unable to Find Install Package

Post by Kotetsu52 » Sun Sep 13, 2009 10:26 pm

photoman wrote:(Unable to Find Install Package)
(Unable to Find Install Package)
(Unable to Find Install Package)

:'( :'( :'( :'( :'( :'( :'( :'( :'(

please help me, I used all the solution above and noway, still have the same problem,
i am using joomla 1.5.9 and uploaded it using WS_FTP 2007 & installed it normally , but if i wanna upload and install a plug in or module from the administrator area it keep giving me (Unable to Find Install Package)
i need help please
It took me months to figure it out. Actually I reinstalled Joomla (before removing it from good from my server) and rechecked the config file.

You need to chek the path of the temp and log folder and deactivate the ftp layer option. You may need to edit your configuration.php file manually because Joomla with its bugs oftne don't let you change the settings no matter if the file writable or not.

User avatar
zombie4eva
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Wed Jul 29, 2009 11:50 am

Re: SOLVED: Unable to Find Install Package

Post by zombie4eva » Sat Oct 10, 2009 10:16 am

Thanks Vicky.. I had the same issue when I installed a template with a "Jumpstart" which comes with Joomla installed... after that I couldn't install any thing from the back-end... your solution worked.. You saved my day...

gneissguy
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Oct 22, 2009 12:47 am

Re: SOLVED: Unable to Find Install Package

Post by gneissguy » Thu Oct 22, 2009 12:54 am

I transferred my site and installed using JoomlaPack and had this error. Using your solution I changed var $ftp_enable = '1'; to var $ftp_enable = '0'; solved this problem.

Thank you for posting your solution!!

StephanBotha
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 105
Joined: Sun Dec 02, 2007 7:27 am

Re: SOLVED: Unable to Find Install Package

Post by StephanBotha » Mon Nov 09, 2009 6:25 am

Google brought me here. I would like to cofirm that if you change the path to your TMP folder to the FULL path, it should work.

It worked for me, thanks guys!

positiveg
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Sun Jan 20, 2008 3:50 pm

Re: SOLVED: Unable to Find Install Package

Post by positiveg » Thu Nov 12, 2009 1:39 pm

Thank you Miss Vicki,
this is amazing I looked all over and should of come here first. Found this link in another forum
I couldn't believe and I've been battling with this for over an hour now.
Thanks soo much
Simply Amazing
or soo simple it's amazing
lol
thanks again
G

TunerRunner
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Nov 18, 2009 6:09 pm

Re: SOLVED: Unable to Find Install Package

Post by TunerRunner » Wed Nov 18, 2009 6:19 pm

I Love You MissVivky... I'm too happy... wanna cry

User avatar
koppie1
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue Dec 01, 2009 12:39 am
Location: San Francisco
Contact:

Re: SOLVED: Unable to Find Install Package

Post by koppie1 » Tue Dec 01, 2009 12:45 am

MissVicky wrote:Sorry, Swift... I do not use FTP layer.
That was the clue! I turned off the FTP layer and it worked! I'm new here and I don't really know what I need the FTP layer for anyway (especially since my test machine is my laptop!) but it's easy enough to re-enable if I should ever need it.

Thanks for providing a double solution to a single problem!

J<

User avatar
Carl Henry
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Jul 29, 2008 9:29 am
Location: Switzerland
Contact:

Re: SOLVED: Unable to Find Install Package

Post by Carl Henry » Sat Jan 02, 2010 8:08 pm

Well done Miss Vicky,

This worked for me too, first time I ever had this error in 3 years!

Just goes to show - forums work - Saved me hours I expect.

Thanks again,

Carl Henry
CHOBS | Carl Henry Online Business Systems
http://www.Carl-Henry.com
Helping People & Companies Make Money Online with Websites

User avatar
amar_strange
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 183
Joined: Fri Jan 19, 2007 8:06 am
Contact:

Re: SOLVED: Unable to Find Install Package

Post by amar_strange » Tue Jul 13, 2010 1:00 pm

You need to increase the PHP MAX FILE SIZE LIMIT.
How can you increase the PHP upload limit?

This can be done with the php.ini file. Here is how you do it:

Create a file under public_html and name it php.ini (if you do not have one yet.) Put the following in it:

upload_max_filesize = 2M

post_max_size = 2M

Replace the 2 with 20 or less. If you are letting other people upload, a size cap protects your storage space from abuse/overuse.

You will then need to add this line to a .htaccess file: (Please replace "yourusername" with your cpanel user name an add to the end of the comand line the folder(s) to the location of the php.ini file - Also there is a space between path and /home)

suPHP_ConfigPath /home/Yourusername/public_html

Now your PHP upload limit should be increased.

julianj
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Tue Jun 19, 2007 2:00 pm
Location: Boston

Re: SOLVED: Unable to Find Install Package

Post by julianj » Sun Jul 25, 2010 8:23 pm

Thank you so much!

MaxDurango
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Jul 21, 2009 2:12 pm

Re: SOLVED: Unable to Find Install Package

Post by MaxDurango » Sun Aug 15, 2010 9:02 pm

Couple of comments; I was looking for options b/c I had the same issue on one site. After MUCH troubleshooting I learned it was actually a poorly configured PHP.INI file. I use a custom PHP.INI on my sites and somehow I uploaded a blank.

I only discovered this after setting all dir permissions to 755 (NEVER USE 777), countless troubleshooting steps, messing with config file, and of course FTP.

rcochran
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Sun Feb 17, 2008 1:16 pm

Re: SOLVED: Unable to Find Install Package

Post by rcochran » Fri Sep 17, 2010 3:17 am

I was banging my head against the wall with this one as well until I realized that the var $tmp_path =" " that it was looking for was not a relative path like unix machines would accept. Instead, on my windows hosting environment, it was looking for the full file path. Since I use a hosting company, I had to look at their control panel to see what the physical file path was and it turned out to be var $tmp_path = "d:\inetpub\mysitename\tmp"

servaris
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Sep 19, 2010 5:42 pm
Location: Toronto Canada
Contact:

Re: SOLVED: Unable to Find Install Package

Post by servaris » Sun Sep 19, 2010 5:50 pm

We run FreeBSD. What works well is, setup proftpd. Create a virtualhost for 127.0.0.1 and use passive ports. I use it like this:

# Port 21 is the standard FTP port.
Port 21
PassivePorts 49152 65534

In your joomla configuration.php (all of ours are in /usr/local/www/data/site_name/configuration.php) set the ftp port to be something like 49155.

I don't like the ownership to be www:www only because of scriptkiddies <tm> but that is what it must be to work right. And all dirs and files must be writable. 644 for files and 755 for dirs.

Once you can use your web browser to get to your site, if you've setup ftp as shown above then you should be able to upload the .zip file(s) and get them installed.

Remember to setup your /etc/pf.conf to allow passive connections through!

pass in on $public proto tcp from any to any port 49151:65535 flags S/SA keep state

dannycool
Joomla! Intern
Joomla! Intern
Posts: 68
Joined: Sun May 31, 2009 11:55 pm
Location: Toronto, Ontario

Re: SOLVED: Unable to Find Install Package

Post by dannycool » Fri Nov 19, 2010 1:24 pm

Excellent it worked for me. I got so worried that another prob to solve. This type of prob happened for the first time because of permission issues on the server. I installed a QUICK LAUNCH TEMPLATE and had to manually copy and paste the code that the setup gave into the config.php to create the config manually. Because I did that, the server didn't allow the ftp permissions so that I can upload joomla extensions in the backend and thats why i got the error. So as this tutorial says, go into your config.php and write in the FTP info like here on mine:

In config.php
var $ftp_enable = '1';
var $ftp_host = '174.142.##the rest of the number';
var $ftp_port = '21';
var $ftp_user = 'your user name';
var $ftp_pass = ' your password';
var $ftp_root = 'public_html';

User avatar
TechiChik
Joomla! Explorer
Joomla! Explorer
Posts: 254
Joined: Fri Oct 17, 2008 12:51 pm
Location: Northern NSW, Australia
Contact:

Re: SOLVED: Unable to Find Install Package

Post by TechiChik » Thu Nov 25, 2010 10:55 pm

I fixed this by simply installing .tar.gz copy rather than the .zip copy.

Alternatively I heard you could fix it by extracting and then recompressing the .zip file.
Read the Joomla Docs. Read the doc for any extensions you're using. Search the forum for help and Google It. If all else fails ask for help on the forum :)

priamcse
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sat Oct 16, 2010 7:20 am

Re: SOLVED: Unable to Find Install Package

Post by priamcse » Sun Jan 16, 2011 1:02 pm

Oh my Allah

It's a great solution!

But I can make it more easier.. :)

See from Global Configuration when you disabled the ftp But Joomla Still show all information you was gave isn't it?

So delete these info from your global admin also...

Hope all is now working without customizing configuration.php

Regards
Priam

jlwegaba
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jan 20, 2011 9:32 pm

Re: SOLVED: Unable to Find Install Package

Post by jlwegaba » Thu Jan 20, 2011 10:16 pm

Guys thank you very much for all your solutions. Am kind new to forum and joomla

Following your steps/solutions I still was getting an error of "No file Selected .......... Unable to find install package".
So What I finally did was upload a folder of extensions i wanted to install then used "Install from Directory".
Actually this worked well even when i disabled FTP, changed back folder chomd to 755.

Is there anything you think might have caused the "Upload Package File" option fail to work.

thank you once again.

Bernald

vidya_parab
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jan 24, 2011 9:35 am

Re: SOLVED: Unable to Find Install Package

Post by vidya_parab » Mon Jan 24, 2011 9:43 am

Ohhhhhh.... u r really a life saver... god bless you... thanks a ton... :)

soledad1905
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Mar 20, 2011 11:49 am

Re: SOLVED: Unable to Find Install Package

Post by soledad1905 » Mon Mar 21, 2011 6:23 am

harelguy wrote:Another solution:
The solution turned out to be quite simple - the PHP upload_max_filesize parameter was too small.
To change it, find the php.ini file (on my Mac XAMPP install, this was in: /Applications/xampp/xamppfiles/etc), and change the value to something reasonable like 5M.

Remember to restart your apache after doing this :)
It worked for me! Thanks U! :D

djacouma
Joomla! Apprentice
Joomla! Apprentice
Posts: 44
Joined: Thu Jun 17, 2010 1:49 pm

Re: SOLVED: Unable to Find Install Package

Post by djacouma » Fri Apr 22, 2011 1:46 pm

Thanks for the clue in.

In my case, it happened when DNS got resolved for a domain, right after moving servers.

I still had the old ip address info in for ftp access in the site configuration back end.

I put in the correct ftp server address and problem resolved.

superx11
Joomla! Intern
Joomla! Intern
Posts: 80
Joined: Thu Mar 04, 2010 9:03 am

Re: SOLVED: Unable to Find Install Package

Post by superx11 » Wed Apr 27, 2011 6:33 am


miciah_amberong
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Apr 19, 2011 1:22 am

Re: SOLVED: Unable to Find Install Package

Post by miciah_amberong » Wed May 11, 2011 2:48 am

chmod -R 777 root_dir

//root_dir can be any directory pertaining to the root directory of you Joomla! folder.

This terminal command will enable the whole Joomla! folder.

It worked for me. :D

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 15058
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: SOLVED: Unable to Find Install Package

Post by mandville » Wed May 11, 2011 4:11 am

miciah_amberong wrote:chmod -R 777 root_dir

//root_dir can be any directory pertaining to the root directory of you Joomla! folder.

This terminal command will enable the whole Joomla! folder.

It worked for me. :D
and in doing so will enable any hacker to wipe out your webiste.
do not suggest or implement such reckless suggestions
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

auzmartist
Joomla! Intern
Joomla! Intern
Posts: 89
Joined: Thu May 20, 2010 8:39 pm

Re: SOLVED: Unable to Find Install Package

Post by auzmartist » Thu Jul 07, 2011 5:31 pm

I've tried every single one of the suggestions above. I am on a Windows server so I have to contact my host about permissions and they swear up and down that the /tmp and /logs folders are writable. My php upload size is 10M and I have no other permissions problems. My FTP Layer is disabled. I've quadruple checked my /tmp path. Nothing seems to work. Any other suggestions?

User avatar
mandville
Joomla! Master
Joomla! Master
Posts: 15058
Joined: Mon Mar 20, 2006 1:56 am
Location: The Girly Side of Joomla in Sussex

Re: SOLVED: Unable to Find Install Package

Post by mandville » Thu Jul 07, 2011 6:37 pm

auzmartist wrote:I've quadruple checked my /tmp path. Nothing seems to work. Any other suggestions?
have you tried the dedicated iis forum? http://forum.joomla.org/viewforum.php?f=543
HU2HY- Poor questions = Poor answer
Un requested Help PM's will be reported, added to the foe list and possibly just deleted
{VEL Team Leader}{TM Auditor }{ Showcase & Security forums Moderator}

auzmartist
Joomla! Intern
Joomla! Intern
Posts: 89
Joined: Thu May 20, 2010 8:39 pm

Re: SOLVED: Unable to Find Install Package

Post by auzmartist » Thu Jul 07, 2011 7:04 pm

I just posted my question there as well. Here is a link in case you think of anything:
http://forum.joomla.org/viewtopic.php?f=543&t=634107

moldmaker
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Jun 16, 2011 9:02 am
Contact:

Re:Setup2GO 7

Post by moldmaker » Sat Jul 09, 2011 1:05 am

Although the picture is not very good, but does not require coding, but also very simple to get started, the registry allows the import and the best is to have the file open automatically after installation of the benefits, and the file opened automatically support any file extension

will824
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Sep 20, 2011 5:09 am

Re: SOLVED: Unable to Find Install Package

Post by will824 » Tue Sep 20, 2011 5:11 am

I can also confirm the issue arises in Joomla 1.7 too and it was solved the same way. :)

IsKe2008
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Tue Sep 20, 2011 12:03 pm

Re: SOLVED: Unable to Find Install Package

Post by IsKe2008 » Tue Sep 20, 2011 1:20 pm

MOST OF THESE ERRORS ARE BEING CAUSED BY ACCESS PEEMISSION RESTRICTIONS. THERE IS NO BUG!!! INFACT THE FTP LAYER WAS ACTUALLY CREATED TO SOLVE SUCH KIND OF PROBLEMS BUT THE WAY IT WORKS IS NOT SO INTUITIVE AND THE CONFUSION IS BEING CAUSED BY THE FOLLOWING.
1). If the FTP layer is enabled, JOOMLA will use the account provided and the permissions it has to try and write to the particular folder or file. If that account has no write permissions to that file, the operation will fail with an error like jftp bad response

2). If the FTP layer is not enabled then JOOMLA will use the web servers permissions to do the same, because it is Apache that will be used to serve the page. so kindly check that the FTP account you are using has the appropriate permissions on your config and tmp folders

User avatar
greenbean
Joomla! Apprentice
Joomla! Apprentice
Posts: 41
Joined: Fri Jul 04, 2008 4:18 pm
Contact:

Re: SOLVED: Unable to Find Install Package

Post by greenbean » Sun Oct 09, 2011 8:14 pm

Hi,
I had this problem on GoDaddy. I was testing Joomla 1.7 in a sub directory. Unfortunately a php5.ini file was placed in the parent directory and it was preventing me from uploading anything on any of my sites. I uninstalled the new test version. Went through and tried to CHMOD all the directories and files. Nothing worked.
FINALLY I renamed my php5.ini to php5.txt (there was only one line in it anyway) and it all started working again.
I hope this saves someone 8 hours of frustration like it caused me.
Be the change you want to see in the world.


Locked

Return to “Administration 1.5”