1.7.2. installation hangs on language screen

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
michalW
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Oct 21, 2011 3:31 pm

1.7.2. installation hangs on language screen

Post by michalW » Fri Oct 21, 2011 6:56 pm

Hello,
First of all sorry if this has been solved already, but after searching all day today I gave up.
Basically installation gets stuck after choosing language and clicking [next] button, with the circle in the middle going and going forever.

I am installing fresh 1.7.2. on a remote host which is at home.pl - It has php 5.3
I am using latest firefox

I upload joomla zip file together with akeeba kickstart file into the subfolder, which I want to use for this site.
Then I:
Point the domain to the subfolder
Extract zip using kickstart,
Edit the libraries/joomla/filesystem/path.php line179 (replace JPATH_ROOT with '/')
Change the name htaccess.txt to .htaccess

Go to domain.com/installation/index.php
press [next] and then it gets stuck

I searched the forum and googled for clues but unsuccesfully. I would appreciate if anyone knows the solution to this issue.

Thanks

edit:
Just tried unzipping 1.7.2 locally and uploading all the files. Result is the same. installer stuck on step 1, language selection.

User avatar
alikon
Joomla! Champion
Joomla! Champion
Posts: 5941
Joined: Fri Aug 19, 2005 10:46 am
Location: Roma
Contact:

Re: 1.7.2. installation hangs on language screen

Post by alikon » Fri Oct 21, 2011 8:45 pm

is quite strange above all if you are starting for scratch

this is a guide http://docs.joomla.org/Installing_Joomla!_1.7
Nicola Galgano
i know that i don't know
www.alikonweb.it

michalW
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Oct 21, 2011 3:31 pm

Re: 1.7.2. installation hangs on language screen

Post by michalW » Fri Oct 21, 2011 9:15 pm

I forgot to mention, it's not my first joomla install. I maintain, backup and restored already a couple of sites within last few years. Now I am doing some tests before I upgrade one of the sites from 1.5 to 1.7.
I actually dont know why this happens because I installed 1.7.0 few weeks ago without any problems doing it exactly the same way.
I re-read the manual. Uploaded joomla172.zip file to the root/folder, unziped it using akeeba's kickstart.php. Installer shows up and gets stuck at first step. To make sure it's not akeeba's fault I unzipped it locally, uploaded painfully slowly all the files, got the installer running, and got stuck again at the first step.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28317
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: 1.7.2. installation hangs on language screen

Post by Per Yngve Berg » Fri Oct 21, 2011 10:15 pm

Do php on your server have JSON support?

michalW
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Fri Oct 21, 2011 3:31 pm

Re: 1.7.2. installation hangs on language screen

Post by michalW » Sat Oct 22, 2011 8:26 am

They say it does. I checked it by running script that i found:

<?php
$json = '{"a":1,"b":2,"c":3,"d":4,"e":5}';

var_dump(json_decode($json));
var_dump(json_decode($json, true));

?>
and got the result:

object(stdClass)#1 (5) { ["a"]=> int(1) ["b"]=> int(2) ["c"]=> int(3) ["d"]=> int(4) ["e"]=> int(5) } array(5) { ["a"]=> int(1) ["b"]=> int(2) ["c"]=> int(3) ["d"]=> int(4) ["e"]=> int(5) }

so I gues they're telling the truth.

They also advised me to switch off the statistic counting script available from configuration panel and that solved the issue for me.

Thank you very much for help and pointing me in the right direction.

aaanativearts
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 203
Joined: Fri Aug 04, 2006 12:38 pm

Re: 1.7.2. installation hangs on language screen

Post by aaanativearts » Sat Oct 22, 2011 10:25 pm

This is also hanging for me on a fresh install using IE9 and Firefox. I have Json enabled, the version is 1.2.1. PHP Version is 5.2.17. Linux, Apache 2.0.52 (Red Hat)

I unpacked the files on my harddrive, then uploaded them with ftp. Pointed url to installation files. The language page comes up and then it won't go any farther. I too, get the waiting circle when I click Next, then nothing happens, just the circle going round and round forever in the IE or Firefox browser.

However, it installed correctly using Google Chrome.

IozzoI
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sat Jan 29, 2011 1:34 pm

Re: 1.7.2. installation hangs on language screen

Post by IozzoI » Sun Oct 23, 2011 2:07 pm

Hi, same problem. My solution was to deleted the temporary files in Google Chrome.

Jonas

thompsontw
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Oct 28, 2011 1:33 am

Re: 1.7.2. installation hangs on language screen

Post by thompsontw » Fri Oct 28, 2011 1:47 am

I am also having this problem. I am using IE and it hangs when selecting the language. I am doing a fresh installion. It does work with Firefox

jjph
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Oct 30, 2011 1:29 am

Re: 1.7.2. installation hangs on language screen

Post by jjph » Sun Oct 30, 2011 1:33 am

Did anyone figure this out yet??? Not only does my install hang at the language step of the installation in firefox, chrome and safari but it has a bunch of error codes in the background of the installation. (see screenshot)
I have had Joomla 1.7x running on my server before when I installed with godaddy but I need to do it manually though ftp so I can install a specific template. Please advise, this is very frustrating.
You do not have the required permissions to view the files attached to this post.

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20400
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ Germany/ S'pore/Bogor/ North America
Contact:

Re: 1.7.2. installation hangs on language screen

Post by leolam » Sun Oct 30, 2011 4:42 am

jjph wrote: but I need to do it manually though ftp so I can install a specific template.
Can you explain why? You can install Joomla and than install a template or are you trying to install a template as a package installer with samples?

You can see from the errors that the 'session_save_path' on your server are incorrect set. Is this on 'Godaddy'?

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services

jjph
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Oct 30, 2011 1:29 am

Re: 1.7.2. installation hangs on language screen

Post by jjph » Sun Oct 30, 2011 6:53 am

yes using godaddy :(

I'm trying to install that way just because thats what the instructions for the template from theme forest said to do. Im trying to install the template with the sample data, I was told I can't do it in the backend of joomla. Any ideas?

User avatar
leolam
Joomla! Master
Joomla! Master
Posts: 20400
Joined: Mon Aug 29, 2005 10:17 am
Location: Netherlands/ Germany/ S'pore/Bogor/ North America
Contact:

Re: 1.7.2. installation hangs on language screen

Post by leolam » Sun Oct 30, 2011 7:22 am

yeah...do a search on this forum about problems related to that company...than I wish you all the best in contacting 'support' of that company and telling them that the session_save_path settings are wrong.....You will than hear that Joomla is at fault and that your template is wrong and etc etc.....Than after a long time of suffering you will decide yo change host

Better do now...

Leo 8)
Joomla's #1 Professional Services Provider:
#Joomla Professional Support: https://gws-desk.com -
#Joomla Specialized Hosting Solutions: https://gws-host.com -
#Joomla Webmaster Services: gws-webmaster.services


Locked

Return to “Installation Joomla! 2.5”