Error 500 when uploading a image

Need help with the Administration of your Joomla! 2.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
adrianobokao
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Fri Jan 13, 2012 4:05 pm

Error 500 when uploading a image

Post by adrianobokao » Fri Jan 13, 2012 4:12 pm

When I try to upload a image it gives me the next error:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@podepa.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
All the folders are with 755 permission, its curious because when I upload images using the JomSocial works fine, but in the media manager it gives me that error.

User avatar
fmmarzoa
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Sun Nov 11, 2007 1:15 pm
Location: Spain
Contact:

Re: Error 500 when uploading a image

Post by fmmarzoa » Fri Jan 13, 2012 5:01 pm

its curious because when I upload images using the JomSocial works fine, but in the media manager it gives me that error.
Although I do not know how JomSocial image upload works, do you mean that uploading SAME image works on JomSocial but not on media manager?

At first sight it seems that you are uploading an image to big for your php.ini (upload_max_filesize), but if it works with JomSocial this may no be the case.

You may check that option anyway to discard it at all.

Regards,
“The media's the most powerful entity on earth. They have the power to make the innocent guilty and to make the guilty innocent, and that's power. Because they control the minds of the masses.” -- Malcolm X

adrianobokao
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Fri Jan 13, 2012 4:05 pm

Re: Error 500 when uploading a image

Post by adrianobokao » Fri Jan 13, 2012 5:18 pm

I uploaded the same image in jomsocial with success, but when I use the media manager gives me that error. The limit in the php.ini is 2mb, the image have just 150kb...
Sorry if you are having any problem to understand what I say, english is my second language ><

User avatar
fmmarzoa
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Sun Nov 11, 2007 1:15 pm
Location: Spain
Contact:

Re: Error 500 when uploading a image

Post by fmmarzoa » Fri Jan 13, 2012 7:32 pm

It is rather extrange. AFAIK that kind of error is not raised by Joomla, but by Apache web server.

Does jomsocial uploads the files to the same directories than Joomla's media uploader?

Do not need to apologize by your english. Mine is the worst of my town ;-)

Regards,
“The media's the most powerful entity on earth. They have the power to make the innocent guilty and to make the guilty innocent, and that's power. Because they control the minds of the masses.” -- Malcolm X

User avatar
fmmarzoa
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 123
Joined: Sun Nov 11, 2007 1:15 pm
Location: Spain
Contact:

Re: Error 500 when uploading a image

Post by fmmarzoa » Fri Jan 13, 2012 7:34 pm

[blockquote]All the folders are with 755 permission[/blockquote]

And who is the owner? You should make sure that the owner is the same user that runs the apache server, often www-data.

Regards,
“The media's the most powerful entity on earth. They have the power to make the innocent guilty and to make the guilty innocent, and that's power. Because they control the minds of the masses.” -- Malcolm X

adrianobokao
Joomla! Apprentice
Joomla! Apprentice
Posts: 26
Joined: Fri Jan 13, 2012 4:05 pm

Re: Error 500 when uploading a image

Post by adrianobokao » Fri Jan 13, 2012 7:45 pm

the problem just solved by himself ;s
now I am uploading images without any error and I have no idea of what happened, but I hope that never happen again :D
thanks a lot for your attention! :D

atho83
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Mon Oct 18, 2010 10:08 am

Re: Error 500 when uploading a image

Post by atho83 » Wed Apr 16, 2014 1:46 am

My client came to me with the same problem.

turns out they were trying to upload a file/s with the same name as an existing file in that directory.

no clue as to why Joomla didnt just give an error message of its own which would have saved a lot of confusion!!!

umapathi20
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Nov 10, 2014 2:43 pm

Re: Error 500 when uploading a image

Post by umapathi20 » Mon Nov 10, 2014 2:52 pm

In my website we need to upload 30 images at time so we have increased the size for some php configurations below

post_max_size = 128M
upload_max_filesize = 128M

Is it correct method to increase more size.Please help me out

Thanks in advance


Locked

Return to “Administration Joomla! 2.5”