Upgrade from 1.5.0 to 1.5.26 did not work

Joomla version 1.5 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
lettie_dude
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Jul 19, 2011 11:11 am

Upgrade from 1.5.0 to 1.5.26 did not work

Post by lettie_dude » Wed Aug 28, 2013 4:28 pm

Hi

Have an old site built in Joomla 1.5.0. Our server provider has just upgraded to php5.3 and several things have stopped working in the backend of the site menu list being one of them.

So I need to upgrade to the latest version of Joomla. Sit is pretty simple so I figure there would not be a problem. Downloaded patch suggested Joomla_1.5.0_to_1.5.26-Stable-Patch_Package.zip unzipped and uploaded to server. Changed the config file over to the latest version and added in the test server details.

However it hasn't worked. Just comes up with server error on the frontend and same again when trying to login to the admin.

Any suggestions? Had a look at the Joomla documentation but it just says unzip and upload. What am I missing? Extra db tables not installed, htaccess overwritten? Is there a definitive guide to doing this anywhere that provides a bit more info than just upload the files?

Any help appreciated.

Cheers

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27300
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Upgrade from 1.5.0 to 1.5.26 did not work

Post by imanickam » Wed Aug 28, 2013 4:44 pm

Hope you have done it in a test environment.
lettie_dude wrote:Changed the config file over to the latest version and added in the test server details.
What have you changed in the configuration file?

What is your site's URL where you have upgraded?
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

lettie_dude
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Jul 19, 2011 11:11 am

Re: Upgrade from 1.5.0 to 1.5.26 did not work

Post by lettie_dude » Thu Aug 29, 2013 8:38 am

Hi imanickam

Yes all done on a test site. Old site set up and tested so was all working. Unzipped upgrade files as stated and uploaded them. With the config file I just saved the distribution file as the config file after going through it and seeing there were a few added variables and adding in the existing database access codes etc. Nothing complex. Test site is here http://vcs.the-websiteagency.co.uk/

Cheers

User avatar
imanickam
Joomla! Master
Joomla! Master
Posts: 27300
Joined: Wed Aug 13, 2008 2:57 am
Location: Chennai, India

Re: Upgrade from 1.5.0 to 1.5.26 did not work

Post by imanickam » Thu Aug 29, 2013 12:44 pm

First remove the file index.html that is located in the directory where Joomla! is installed.

Check in the Apache and/or error log for any apparent reasons.
Ilagnayeru (MIG) Manickam | இளஞாயிறு மாணிக்கம்
Joomla! - Global Moderators Team | Translations Coordination Team | Tamil (தமிழ்) Translation Team

Eegan - Support the poor and underprivileged

lettie_dude
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Jul 19, 2011 11:11 am

Re: Upgrade from 1.5.0 to 1.5.26 did not work

Post by lettie_dude » Thu Aug 29, 2013 1:12 pm

Ok cheers. This is the error being logged.

Fatal error: Call to undefined method JFactory::getDate()

lettie_dude
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Jul 19, 2011 11:11 am

Re: Upgrade from 1.5.0 to 1.5.26 did not work

Post by lettie_dude » Fri Aug 30, 2013 2:47 pm

Finally sorted. It seems the ftp client did not upload some of the files correctly so I downloaded the patch again and re-uploaded. Now seems to be working Ok.

Cheers


Locked

Return to “Migrating and Upgrading to Joomla! 1.5”