Multilanguage problem

General questions regarding the use of languages in Joomla! 2.5.

Moderators: infograf768, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Branwell
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Sep 24, 2012 7:14 pm

Multilanguage problem

Post by Branwell » Fri May 02, 2014 8:59 pm

Hi,

I'm running a multilingual website with Joomla 2.5.7

I'm using default multilingual tool, I tried Falang with no improvement.

Everything works well, except if you try to follow a link to a French page when you have another page in English already open...

Try it yourselves : the site is : http://www.musinfo.fr

Switch to English and follow this link : http://www.musinfo.fr/index.php/present ... nscription

404! :'(

Any clue? I'm really struggling!

Thanks!

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22346
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Multilanguage problem

Post by pe7er » Sat May 03, 2014 9:02 am

Branwell wrote:I'm running a multilingual website with Joomla 2.5.7
Could you please upgrade (backup your site before doing so) to the latest Joomla version within the same series first before trying to solve errors with an older version?

Possible bugs might have been solved in the meantime. It's a waste of time for you trying to solve issues that are caused because of non-updated software...

The latest version in the 2.5 series is Joomla 2.5.20: http://www.joomla.org/download.html
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

Branwell
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Sep 24, 2012 7:14 pm

Re: Multilanguage problem

Post by Branwell » Sat May 03, 2014 1:10 pm

OK, I'll do this right away. Thanks for your answer!

Branwell
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Sep 24, 2012 7:14 pm

Re: Multilanguage problem

Post by Branwell » Sat May 03, 2014 9:41 pm

It seems that I'm unable to upgrade my Joomla.

I tried to upgrade from 2.5.7 to 2.5.20 using Joomla update component.

Any attempt leads to numerous errors and website malfunction.

I went through all sorts of trouble these last hours and have learnt that it is actually crucial to backup your site before trying to upgrade...

I know this is too vague and not the right place anymore, but what can I do?

User avatar
pe7er
Joomla! Master
Joomla! Master
Posts: 22346
Joined: Thu Aug 18, 2005 8:55 pm
Location: Nijmegen, The Netherlands
Contact:

Re: Multilanguage problem

Post by pe7er » Sun May 04, 2014 10:14 am

Branwell wrote:Any attempt leads to numerous errors and website malfunction.
What kind of errors? Front-end or back-end?
Did you empty your Joomla + browser cache after the update?

Did you modify Joomla's 2.5.7 source code?

Do you have any HTML overrides from Joomla 2.5.7 that might give errors with Joomla 2.5.20?
(check your template's folder for fodlers in /html/ and temporary disable your /html/ overrides by renaming it to /html-old/ and test your site again.
Kind Regards,
Peter Martin, Global Moderator
https://db8.nl - Joomla specialist, Nijmegen, Nederland
Co-developer of d2 Content https://data2site.com/joomla-extensions/d2-content

Branwell
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Sep 24, 2012 7:14 pm

Re: Multilanguage problem

Post by Branwell » Wed May 07, 2014 8:31 pm

Actually it seems that the problem was the default language of my Joomla install is French... I could update by installing the French package.

Thanks for your help!

faisslam
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue May 20, 2014 3:09 pm
Contact:

Re: Multilanguage problem

Post by faisslam » Thu May 22, 2014 2:40 pm

I had the same problem, and I will make you my say, and now it works fine thank you very much.

royhiggs
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Jun 05, 2014 7:27 am

Re: Multilanguage problem

Post by royhiggs » Fri Jun 06, 2014 2:40 pm

Hi pe7er

New to this Forum and way short of being an expert in Joomla or websites in general however I have built my own site in Joomla 2.5 and have taken the site multilingual using the JA Lang extension.

I have followed the tutorials and installed 4 new languages and created separate templates for each one, 3 languages work fine and have there own mega menus as well as a default menu and a menu for my site language of English.

The problem is that the fifth language will not show even though it has a menu, a template, articles (associated) and categories (associated).

I can install new languages no problem so I assume I have made a mistake somewhere in the Polish installation and don't know how to fix it.

All help gratefully received as it's driving me bananas and I keep just going around in circles

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18886
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: Multilanguage problem

Post by infograf768 » Thu Jun 12, 2014 6:15 am

@royhiggs

Please attach here a screencapture of the multilanguage status module
See: http://forum.joomla.org/viewtopic.php?f=617&t=658605
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group


Locked

Return to “Language - Joomla! 2.5”