Joomla! 2.5.28 Install hangs at Database step

Joomla versions 2.5, 1.7 and 1.6 are all end-of-life since December 31st 2014 and are no longer supported. Please use Joomla 3.x instead.
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Apr 16, 2014 10:33 pm

Joomla! 2.5.28 Install hangs at Database step

Post by ntm91307 » Sat Oct 10, 2015 2:29 pm

Hello All;

I have an install package that contains Joomla! 2.5.28 and Virtuemart 3.x. I installed it without incident on XXAMP on my laptop a few weeks ago and have been developing my site. I'm now ready to install my site on a real server so I installed Akeeba and have a current backup. My approach was to redo the original install from the package and restore from the latest backup I took from the laptop. But for some reason I get stopped at the Database step. I fill in all the information but it just spins for 30 seconds and then stops. No message, no moving forward, nothing. Here's the setup:

Server hosted on Site5 - CentOS 6.x
Virtual Server created with Virtualmin
PHP 5.6.x
MySQL 5.5.45
Apache 2.2.x
Virtualmin 4.18.gpl
Webmin 1.77

The database I want to use was created during the initialization of the virtual server and contains no tables. The perfect clean install.

I've read a number of forum posts from all over the world from people with the exact same problem and followed their advice, all of it accurate. My main database user had no permissions, fixed that. My max_execution_time parameter was too low, both in the Virtual server and at the root, changed both of those from 30 to 3000. Increased memory limit to 128M in both places as well. Changed the default engine from MyISAM to INNODB (this one was questionable) and also tried selecting MySql instead of MySqli at the database step. All to no avail.

My only clue is that despite changing the max_execution_time the install still stops spinning at around 30 seconds which tells me I've got a parameter to set somewhere but just can't figure where. I've looked at php.ini both in the /etc of the root and in the virtual server and they both show 3000 for this parameter.

Is there somewhere else or some THING else that I'm missing?

Thank you in advance for your help....

ADDENDUM: Just tried going straight to the Akeeba restore on the off chance it might get past this roadblock. No luck.

User avatar
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 3482
Joined: Sun Jan 03, 2010 8:47 pm

Re: Joomla! 2.5.28 Install hangs at Database step

Post by ribo » Sat Oct 10, 2015 9:43 pm

First of all joomla 2.5.28 is EOL. You must update
Second you don t need to install joomla to restore a back up.
About joomla install that hangs first try to install a fresh joomla without a third party package to see what happens. Also check the configuration of xampp and your vps and what are the differences between them.
If you still have problems please
chat room spontes :

User avatar
Joomla! Master
Joomla! Master
Posts: 39316
Joined: Sat Apr 05, 2008 9:58 pm

Re: Joomla! 2.5.28 Install hangs at Database step

Post by Webdongle » Sat Oct 10, 2015 11:19 pm
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein.


Return to “Installation Joomla! 2.5”