Slow site prior to first initial connection

Discussion regarding Joomla! 3.x Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
ggossamer
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 114
Joined: Wed Sep 29, 2010 4:50 pm

Slow site prior to first initial connection

Post by ggossamer » Sun Oct 14, 2018 4:57 pm

Hi, we have a joomla-3.8.8 site running on fedora28 and the time before the initial first connection, according to watching access_log, is very long.

I don't believe it's a DNS issue because I've visited the site before and it should be cached. Are there specific server tuning parameters you recommend to improve the initial time it takes before the first page is loaded?

How does the site load for you?
https://webstage.linuxsecurity.com/

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37283
Joined: Sat Apr 05, 2008 9:58 pm

Re: Slow site prior to first initial connection

Post by Webdongle » Sun Oct 14, 2018 5:22 pm

Both your Joomla and Fedora are out of date.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

ggossamer
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 114
Joined: Wed Sep 29, 2010 4:50 pm

Re: Slow site prior to first initial connection

Post by ggossamer » Sun Oct 14, 2018 5:29 pm

Webdongle wrote:
Sun Oct 14, 2018 5:22 pm
Both your Joomla and Fedora are out of date.
Yes, thank you. However, fedora29 is still beta, and joomla is not all that far from being the latest that it should be an issue.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 37283
Joined: Sat Apr 05, 2008 9:58 pm

Re: Slow site prior to first initial connection

Post by Webdongle » Sun Oct 14, 2018 7:52 pm

Update Joomla first and update all your extensions
Then please viewtopic.php?f=714&t=793531
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

csthomas
Joomla! Intern
Joomla! Intern
Posts: 79
Joined: Tue Jun 21, 2016 10:07 pm

Re: Slow site prior to first initial connection

Post by csthomas » Mon Oct 15, 2018 8:09 am

Since you have many articles on your site, you must start with optimizing your database queries.

SharkyKZ
Joomla! Ace
Joomla! Ace
Posts: 1597
Joined: Fri Jul 05, 2013 10:35 am
Location: Unknown

Re: Slow site prior to first initial connection

Post by SharkyKZ » Mon Oct 15, 2018 8:41 am

Also disable JCH Optimize or at least lower its settings. It can be very taxing in terms of PHP/server performance.

User avatar
occultfish
Joomla! Apprentice
Joomla! Apprentice
Posts: 49
Joined: Tue Jun 11, 2013 8:07 pm
Contact:

Re: Slow site prior to first initial connection

Post by occultfish » Mon Oct 15, 2018 2:51 pm

Personal experience with jch optimize is that it can conflict with other caching resources that are server and joomla side. Disable it and tell us what the difference is in the speed of your site. Also, try clearing your server-side chache (purge) so it can be re-created. Sometimes it can bloat your website.

ggossamer
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 114
Joined: Wed Sep 29, 2010 4:50 pm

Re: Slow site prior to first initial connection

Post by ggossamer » Mon Oct 15, 2018 4:23 pm

Thank you all so much for your help. We're working on updating joomla and the extensions.

I've also disabled JCH-optimize and it made no difference. I don't think that was the problem.

Looking at the logs, the delay is prior to the first entry. On mobile 3G, it's probably 45 seconds before the first entry in the access_log. It then loads the rest of the site nearly instantly.


Post Reply

Return to “Performance - Joomla! 3.x”