Unwritable folders Topic is solved

Need help installing Joomla! 3.x? For all Joomla! 3.x installation issues please use this forum.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Unwritable folders

Post by drussell1974 » Thu Nov 08, 2018 11:23 am

Unwriteable folders

I know this is a frequent question and I've looked at and applied different solutions, but all the folders System > System Information > Folder Permissions still show unwritable.

I have a development platform running on my own CentOS 7:
  • NAME="CentOS Linux"
    VERSION="7 (Core)"
    ID="centos"
    ID_LIKE="rhel fedora"
    VERSION_ID="7"
    PRETTY_NAME="CentOS Linux 7 (Core)"
  • Joomla! 3.9.0 Stable [ Amani ] 30-October-2018 14:00 GMT
    Apache 2.4.6 (CentOS)
    MySQL 5.7.19
    PHP Version 7.0.32
Configuration.php

Code: Select all

<?php
class JConfig {
	public $offline = '0';
	public $offline_message = 'This site is down for maintenance.<br />Please check back again soon.';
	public $display_offline_message = '1';
	public $offline_image = '';
	public $sitename = 'Learn Computer Science';
	public $editor = 'tinymce';
	public $captcha = '0';
	public $list_limit = '20';
	public $access = '1';
	public $debug = '1';
	public $debug_lang = '0';
	public $debug_lang_const = '1';
	public $dbtype = 'mysqli';
	public $host = 'localhost';
	public $user = 'cssow';
	public $password = 'XXXXXXXXXXXXXXXX';
	public $db = 'cssow';
	public $dbprefix = 'lcs_';
	public $live_site = '';
	public $secret = 'XXXXXXXXXXXXX';
	public $gzip = '0';
	public $error_reporting = 'default';
	public $helpurl = 'https://help.joomla.org/proxy?keyref=Help{major}{minor}:{keyref}&lang={langcode}';
	public $ftp_host = 'localhost';
	public $ftp_port = '21';
	public $ftp_user = '';
	public $ftp_pass = '';
	public $ftp_root = ''';
	public $ftp_enable = '0';
	public $offset = 'UTC';
	public $mailonline = '1';
	public $mailer = 'mail';
	public $mailfrom = 'admin@localhost';
	public $fromname = 'Learn Computer Science';
	public $sendmail = '/usr/sbin/sendmail';
	public $smtpauth = '0';
	public $smtpuser = '';
	public $smtppass = '';
	public $smtphost = 'localhost';
	public $smtpsecure = 'none';
	public $smtpport = '25';
	public $caching = '0';
	public $cache_handler = 'file';
	public $cachetime = '15';
	public $cache_platformprefix = '0';
	public $MetaDesc = '';
	public $MetaKeys = '';
	public $MetaTitle = '1';
	public $MetaAuthor = '1';
	public $MetaVersion = '0';
	public $robots = '';
	public $sef = '1';
	public $sef_rewrite = '0';
	public $sef_suffix = '0';
	public $unicodeslugs = '0';
	public $feed_limit = '10';
	public $feed_email = 'none';
	public $log_path = '/var/www/logs';
	public $tmp_path = '/var/www/tmp';
	public $lifetime = '15';
	public $session_handler = 'database';
	public $shared_session = '0';
};
?>
httpd.conf

Code: Select all

[root@sql html]# egrep -v "^ *#|^$" /etc/httpd/conf/httpd.conf 
ServerRoot "/etc/httpd"
Listen 80
Include conf.modules.d/*.conf
User apache
Group apache
ServerAdmin root@localhost
<Directory />
    AllowOverride All
    Require all denied
</Directory>
DocumentRoot "/var/www/html"
<Directory "/var/www">
    AllowOverride All
    Require all granted
</Directory>
<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>
<VirtualHost *:80>
    ServerName sql.velopoint.net
    ServerAdmin admin@velopoint.net
    DocumentRoot /var/www/html
    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"
    <Directory "/var/www/html">
            Options +Indexes +FollowSymLinks +ExecCGI
            AddHandler php-fastcgi .php
            Action php-fastcgi /cgi-bin/php.fastcgi
            AllowOverride All
            Order allow,deny
            Allow from All
    </Directory>
</VirtualHost>
<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>
<Files ".ht*">
    Require all denied
</Files>
ErrorLog "logs/error_log"
LogLevel warn
<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common
    <IfModule logio_module>
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>
    CustomLog "logs/access_log" combined
</IfModule>
<IfModule alias_module>
    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"
</IfModule>
<Directory "/var/www/cgi-bin">
    AllowOverride None
    Options None
    Require all granted
</Directory>
<IfModule mime_module>
    TypesConfig /etc/mime.types
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>
AddDefaultCharset UTF-8
<IfModule mime_magic_module>
    MIMEMagicFile conf/magic
</IfModule>
EnableSendfile on
IncludeOptional conf.d/*.conf
Permissions

I've applied recursive permissions for chown apache:apache and chmod 755 on directories and 644 on files.
With the exception of /logs/ and /tmp/ that have 777.



HTAccess


I have tried with the htaccess and without.

Code: Select all

<IfModule autoindex>
  IndexIgnore *
</IfModule>
Options +FollowSymlinks
Options -Indexes
RewriteEngine On
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
RewriteRule .* index.php [F]
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteCond %{REQUEST_URI} !^/index\.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .* index.php [L]
PHP


I've applied FastCGI php configuration - I read this as a recommended solution (which, incidentally, has not solved this issue).

My Full \etc\PHP.ini....

Code: Select all

[PHP]
engine = On
short_open_tag = Off
precision = 14
output_buffering = 4096
zlib.output_compression = Off
implicit_flush = Off
unserialize_callback_func =
serialize_precision = 17
disable_functions =
disable_classes =
zend.enable_gc = On
expose_php = On
max_execution_time = 30
max_input_time = 60
memory_limit = 128M
error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
display_errors = Off
display_startup_errors = Off
log_errors = On
log_errors_max_len = 1024
ignore_repeated_errors = Off
ignore_repeated_source = Off
report_memleaks = On
track_errors = Off
html_errors = On
variables_order = "GPCS"
request_order = "GP"
register_argc_argv = Off
auto_globals_jit = On
post_max_size = 8M
auto_prepend_file =
auto_append_file =
default_mimetype = "text/html"
default_charset = "UTF-8"
doc_root =
user_dir =
enable_dl = Off
file_uploads = On
upload_max_filesize = 2M
max_file_uploads = 20
allow_url_fopen = On
allow_url_include = Off
default_socket_timeout = 60
[CLI Server]
cli_server.color = On
[Date]
[filter]
[iconv]
[intl]
[sqlite]
[sqlite3]
[Pcre]
pcre.jit=0
[Pdo]
[Pdo_mysql]
pdo_mysql.cache_size = 2000
pdo_mysql.default_socket=
[Phar]
[mail function]
sendmail_path = /usr/sbin/sendmail -t -i
mail.add_x_header = On
[SQL]
sql.safe_mode = Off
[ODBC]
odbc.allow_persistent = On
odbc.check_persistent = On
odbc.max_persistent = -1
odbc.max_links = -1
odbc.defaultlrl = 4096
odbc.defaultbinmode = 1
[Interbase]
ibase.allow_persistent = 1
ibase.max_persistent = -1
ibase.max_links = -1
ibase.timestampformat = "%Y-%m-%d %H:%M:%S"
ibase.dateformat = "%Y-%m-%d"
ibase.timeformat = "%H:%M:%S"
[MySQLi]
mysqli.max_persistent = -1
mysqli.allow_persistent = On
mysqli.max_links = -1
mysqli.cache_size = 2000
mysqli.default_port = 3306
mysqli.default_socket =
mysqli.default_host =
mysqli.default_user =
mysqli.default_pw =
mysqli.reconnect = Off
[mysqlnd]
mysqlnd.collect_statistics = On
mysqlnd.collect_memory_statistics = Off
[PostgreSQL]
pgsql.allow_persistent = On
pgsql.auto_reset_persistent = Off
pgsql.max_persistent = -1
pgsql.max_links = -1
pgsql.ignore_notice = 0
pgsql.log_notice = 0
[bcmath]
bcmath.scale = 0
[browscap]
[Session]
session.save_handler = files
session.use_strict_mode = 0
session.use_cookies = 1
session.use_only_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.cookie_httponly =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor = 1000
session.gc_maxlifetime = 1440
session.referer_check =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
session.hash_function = 0
session.hash_bits_per_character = 5
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"
[Assertion]
zend.assertions = -1
[mbstring]
[gd]
[exif]
[Tidy]
tidy.clean_output = Off
[soap]
soap.wsdl_cache_enabled=1
soap.wsdl_cache_dir="/tmp"
soap.wsdl_cache_ttl=86400
soap.wsdl_cache_limit = 5
[sysvshm]
[ldap]
ldap.max_links = -1
[mcrypt]
[dba]
[curl]
[openssl]
Errors installing Plugins

I wondered whether these errors installing a plugin might assist.

The problem in most cases appears to be permission related. I'm being verbose in case this sheds any light on the Folder Permission issue in general.

Without FTP enabled

Upload Package File
Warning: Failed to move file: /tmp/php8V7LLI to /var/www/tmp/com_contentbuilder_joomla30.zip
Failed deleting com_contentbuilder_joomla30.zip


Install from Folder

Warning: Joomla\CMS\Filesystem\Folder::create: Could not create folder.Path: /var/www/html/components/com_contentbuilder
Component Install: Failed to create folder: /var/www/html/components/com_contentbuilder.


Discover

Call to a member function children() on null
/var/www/html/libraries/src/Installer/Adapter/PluginAdapter.php:205


With FTP enabled

Using both linux user account and root

Upload Package File

JFTP: :connect: Could not connect to host ' localhost ' on port ' 21 '


Install from Folder

I've tried installing plugins and Install from Folder \var\www\tmp (with chmod 777). After downloading and unpacking the plugin in the aforementioned folder, I've ensured files and folders are owned by apache user and that they have the necessary permissions.

When clicking Check and Install from the Install admin page, I get a 500 page and the /etc/httpd/logs/error_log shows the following.

[Thu Nov 08 09:50:04.000533 2018] [cgi:error] [pid 5988] [client 192.168.56.3:8010] AH01215: PHP Warning: require_once(/var/www/html/administrator/components/com_contentbuilder/classes/joomla_compat.php): failed to open stream: No such file or directory in /var/www/tmp/script.php on line 627, referer: http*despam*/index.php?option=com_installer&view=install
[Thu Nov 08 09:50:04.000625 2018] [cgi:error] [pid 5988] [client 192.168.56.3:8010] AH01215: PHP Fatal error: require_once(): Failed opening required '/var/www/html/administrator/components/com_contentbuilder/classes/joomla_compat.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/tmp/script.php on line 627, referer: http*despam*/administrator/index.php?option=com_installer&view=install


Discover

When using Discover to install plugins. Again, I've ensured files and folders are owned by apache user and that they have the necessary permissions.

0 Call to a member function children() on null
/var/www/html/libraries/src/Installer/Adapter/PluginAdapter.php:205
.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Thu Nov 08, 2018 8:56 pm

http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Re: Unwritable folders

Post by drussell1974 » Fri Nov 09, 2018 6:00 pm

Webdongle wrote:
Thu Nov 08, 2018 8:56 pm
viewtopic.php?f=714&t=793531 please
Webdongle, thanks for the response. Unfortunately, the version of Joomla and MySQL that I'm using is not supported by the FPA script.

Please suggest any further information that I should include in my post.

Many thanks

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Fri Nov 09, 2018 6:28 pm

What is the exact error you recieve when you try and run the fpa ?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Re: Unwritable folders

Post by drussell1974 » Fri Nov 09, 2018 9:39 pm

"No input file specified."

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Fri Nov 09, 2018 10:01 pm

That suggests a misconfigured server? What is your url?
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Re: Unwritable folders

Post by drussell1974 » Sat Nov 10, 2018 7:12 am

I'm on an isolated development network, with Joomla in web root. I'm using http://192.168.56.20/administration to access joomla admin and http://192.168.56.20/fpa-en.php to run the FDA script.

As standard it appears to be working fine I.e. to view and create categories and articles. It's only the system information shows unwritable folders, I can't install components or save Global configurations.

Everything points to permissions on the web directory - as far as I can tell* - but I've given necessary 755 on directories and 644 on files. I've also try giving 777 permissions to everything in /var/www.

* I'm a developer (Microsoft ASP.net and more and more turned open source convert) and not a system administrator. Yes, I'm stepping out of my comfort zone here :).

I've had the same issue when originally using virtual directories and using php5.4, before going to php5.6. I've since rolled back and kept installation and configs as standard, and ensuring I use latest version including php7.

I appreciate your help and guidance.

I think I'll see if I can recreate the issue using a Joomla version that will work with the FPA. I have a base snapshot of CentOS that is at least a year old. I'll think I may even try another OS.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 10049
Joined: Thu Feb 15, 2007 5:48 am
Location: Oxford, UK
Contact:

Re: Unwritable folders

Post by toivo » Sat Nov 10, 2018 8:54 am

drussell1974 wrote:"No input file specified."
That message does not originate from the FPA. Does the site perhaps have some security software that blocks the URL with FPA or possibly a rule in the .htaccess file?

drussell1974 wrote:I think I'll see if I can recreate the issue using a Joomla version that will work with the FPA.
The Forum Post Assistant script works with all Joomla versions from 1.0 to 4.0 alpha. According to the documentation, it does not fully support websites where the configuration.php file has been moved outside the main web directory of the server.
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
troubleshooting smtp and other articles https://talikka.com/joomla

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Sat Nov 10, 2018 9:03 am

ftp layer in Joomla Global config is rarely used.
Is the php handler Apache or cgi ?

Methinks it is an ownership not Permissions issue.
https://docs.joomla.org/Why_can%27t_you ... rom_ianmac
At the heart of the issue is file ownership. There are generally two main server users that end up owning your files - the FTP user, and the Apache/PHP user. Obviously, when you upload files using FTP, the FTP user ends up owning them. Therefore, if you give a file 755 permissions, then ONLY the FTP user can write to that file.

If you install Joomla! without the FTP layer, then the files it creates are owned by the Apache/PHP user. If you give the file 755 permissions, then ONLY the Apache/PHP user can write to that file.

Just to emphasize, the fact that these username and passwords happen to be the same has no effect whatsoever on anything. They are different subsystems and are unrelated. It may be convenient, but will not solve your permission issue
But if the php handler is cgi then both ftp and php can 'own' the files.
https://docs.joomla.org/Should_PHP_run_ ... le_Mode.3F
... CGI mode is also claimed to be more flexible in many respects as you should now not see, with phpSuExec (refer Permissions under phpSuExec) issues with file ownership being taken over by the Apache user, therefore you should no longer have problems under FTP when trying to access or modify files that have been uploaded through a PHP interface, such as Joomla! upload options.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Re: Unwritable folders

Post by drussell1974 » Sat Nov 10, 2018 12:55 pm

Methinks it is an ownership not Permissions issue.
Yeah, sorry, I should have said: "or ownership".
Is the php handler Apache or cgi ?
I've tried both. It is currently CGI and permissions and ownership set as follows.

Code: Select all

find /var/www -type d -exec chmod -R 755 {} \;
find /var/www -type f -exec chmod 644 {} \;
chown -R apache:apache /var/www

Code: Select all

chown apache:apache /var/www/cgi-bin/php.fastcgi
chmod +x /var/www/cgi-bin/php.fastcgi
The Forum Post Assistant script works with all Joomla versions from 1.0 to 4.0 alpha. According to the documentation, it does not fully support websites where the configuration.php file has been moved outside the main web directory of the server.
I was going from the link, viewtopic.php?f=714&t=793531, that says FPA supports up to Joomla v1.0... v3.8. My configuration file is at /var/www/html/configuration.php.

I've followed instructions that...
Joomla! is installed in your web_root/ folder:
Upload the fpa-en.php script to: <your_domain-name.com>/web_root/
To run the script: http://example.com/fpa-en.php
That message does not originate from the FPA. Does the site perhaps have some security software that blocks the URL with FPA or possibly a rule in the .htaccess file?
I've already tried the following and different permutations. I'm just having another look.

1) Removing the lines Option +Followlinks and Options -Indexes (according to the comments in the htaccess file).

2) Renaming and removing the htaccess file altogether.

3) With and without LoadModule rewrite_module modules/mod_rewrite.so in the /etc/httpd/conf/httpd.conf file.

Permission and ownership of php.fastcgi is...

Code: Select all

chown apache:apache /var/www/cgi-bin/php.fastcgi
chmod +x /var/www/cgi-bin/php.fastcgi
CPanel

The link you provided above (https://docs.joomla.org/Why_can%27t_you ... rom_ianmac) refers to CPanel. I don't have CPanel and I'm not using FTP. CPanel just appears to be something that host use right? Is that going to make a difference?

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Sat Nov 10, 2018 1:29 pm

afaik cpanel is a gui for the server not the server itself. and (again afaik) documentation by ianmac applies to all Linux servers and the php installed on them.

Just as a tes ... create a test.html and put it in the same folder as the fpa (that's the same folder as your configuration.php). If you can reach the test.html then the problem is the way you have your server setup.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Re: Unwritable folders

Post by drussell1974 » Sat Nov 10, 2018 2:01 pm

I've created test.html, and test.php for good measure, with permission 644 and ownership apache:apache in root (same location as configuration.php and fpa-en.php). Both work fine.

Code: Select all

<html>
<body>test.html</body>
</html>

Code: Select all

<?php echo "<html>
<body>test.php</body>
</html>" ?>
I don't have any problems browsing Joomla. Just the fpa-en.php, also when I try to installing plugins and saving the Global Configuration. Note that the latter just doesn't update the file.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Sat Nov 10, 2018 2:34 pm

This appears to be a server setup problem. Perhaps try a different stack on on your fedora OS?

https://docs.joomla.org/Installing_Joom ... bian_Linux
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein

drussell1974
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Thu Nov 08, 2018 8:05 am

Re: Unwritable folders

Post by drussell1974 » Sun Nov 11, 2018 3:28 pm

Webdongle wrote:
Sat Nov 10, 2018 2:34 pm
This appears to be a server setup problem. Perhaps try a different stack on on your fedora OS?

https://docs.joomla.org/Installing_Joom ... bian_Linux
I've found an earlier image of my CentOS server to start from. It's an old image (year old) but the following packages failed when running sudo yum update...
  • libgpod-0.8.3-14.el7.x86_64 (@epel)
    libgpod-0.8.3-14.el7.x86_64 (@epel)
    libgpod-0.8.3-14.el7.x86_64 (@epel)
I ran the update with --skip-broken "to work around the problem"

Code: Select all

sudo yum update --skip-broken
Step to install XAMPP and Joomla installation

1. I have downloaded the latest version of XAMPP (7.2.11 at time of writing) from
https://www.apachefriends.org/download.html, then ran the following from the terminal to execute the GUI installer...

Code: Select all

cd Downloads/
sudo chmod +x xampp-linux-x64-7.2.11-0-installer.run
sudo ./xampp-linux-x64-7.2.11-0-installer.run
2. Started XAMMP...

Code: Select all

sudo /opt/lampp/lampp start
NOTE: To find the FTP user credentials see comment above the UserPassword setting in the proftpd.conf file...

Code: Select all

sudo cat /opt/lampp/etc/proftpd.conf

Code: Select all

# daemon gets the password "xampp"
UserPassword daemon 2TgxE8g184G9c
2. I have downloaded latest Joomla (3.9.0 at time of writing) from https://downloads.joomla.org/then unzipped the files in the home folder.

3. Using FileZilla uploaded the Joomla files to /webalizer folder (/opt/lampp/htdocs/webalizer) already owned by daemon.

4. Configured the Joomla Site with database credentials: default user: root; password: "" (empty string).

The set up allowed the removal of installation folder and System > System Information > Folder Permission shows all folders are writable


Thanks for your help.

User avatar
Webdongle
Joomla! Master
Joomla! Master
Posts: 36088
Joined: Sat Apr 05, 2008 9:58 pm

Re: Unwritable folders

Post by Webdongle » Sun Nov 11, 2018 4:47 pm

I'm not sure why it works like that ... all I know it took me days to work it out when I used Ubuntu. As Fedora is a fork of Ubuntu I thought it was worth a try on your localhost.
http://www.weblinksonline.co.uk/
https://www.weblinksonline.co.uk/updating-joomla.html
"The definition of insanity is doing the same thing over and over again, but expecting different results": Albert Einstein


Post Reply

Return to “Installation Joomla! 3.x”