Website not working

General questions relating to Joomla! 1.5 There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting.
Forum Post Assistant - If you are serious about wanting help, you should use this tool to help you post.
Post Reply
kcirtapsnimmuc
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 13, 2019 9:35 am

Website not working

Post by kcirtapsnimmuc » Wed Mar 13, 2019 9:40 am

Hi

We have a website called southdublinswans.com and it doesn't seem to be working.

When I go into southdublinswans.com/administrator it looks all weird.

It is like the css is all wrong.

Would you know anything about this?

User avatar
mjparadac
Joomla! Ace
Joomla! Ace
Posts: 1883
Joined: Mon Oct 29, 2012 3:58 pm

Re: Website not working

Post by mjparadac » Wed Mar 13, 2019 2:44 pm

Hello kcirtapsnimmuc, welcome to the forum.

Could you give details about the site?
Any recent changes, updates, new extensions?

Regards,
Joomla Community Ambassador for A2 Hosting | A2 Hosting - Our speed, your success | https://www.a2hosting.com/joomla-hosting

kcirtapsnimmuc
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Mar 13, 2019 9:35 am

Re: Website not working

Post by kcirtapsnimmuc » Wed Mar 13, 2019 4:35 pm

No changes have been made to the site in over a year and it was working a few months ago when I last checked it.

Have no idea what is wrong with it, just getting blank page when going to url

dragonrider
Joomla! Ace
Joomla! Ace
Posts: 1070
Joined: Mon Aug 22, 2005 7:53 pm
Location: Ilkley, West Yorkshire, UK
Contact:

Re: Website not working

Post by dragonrider » Wed Mar 13, 2019 5:15 pm

Looks like it's lost some files, possibly someone has been causing issues. Couldn't suggest fix other than perhaps to check your server to see if there are extra files, or permissions have been changed from 644 (files) 755 (directories).
Also check the configuration.php file to see if anything has been added to it.

User avatar
john-doe
Joomla! Guru
Joomla! Guru
Posts: 900
Joined: Tue Apr 19, 2011 7:39 pm
Location: Colombia
Contact:

Re: Website not working

Post by john-doe » Wed Mar 13, 2019 10:21 pm

dragonrider wrote:
Wed Mar 13, 2019 5:15 pm
Looks like it's lost some files, possibly someone has been causing issues. Couldn't suggest fix other than perhaps to check your server to see if there are extra files, or permissions have been changed from 644 (files) 755 (directories).
Also check the configuration.php file to see if anything has been added to it.
If you see some gibberish-name.php Be aware because your server has been compromised.
ensure as well that the index.php does not carry suspicipus lines on the first lines of the file.
www.aldemar-hernandez.com - Custom templates and design services.

User avatar
AMurray
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4963
Joined: Sat Feb 13, 2010 7:35 am
Location: Australia

Re: Website not working

Post by AMurray » Thu Mar 14, 2019 9:53 pm

Is the site mission-critical or just a hobby site?

If it's a year out of date.....you have serious catching up on Joomla core updates to do.

Following on from @john-doe's comments, suggest you try the myjoomla.com service; it audits your site for security and other issues. First audit is free, but it is a subscription service, and may be well worth your time and money. It explains most problems is easy to understand language, and takes you through steps to resolve the problems (in many cases, just click a button to fix them)

It will at least advise if there's serious issues with the site in terms of it being compromised (or suspected of such).

This is a lesson learned; make sure Joomla is up to date including third-party extensions. It doesn't matter if the site is a hobby site, or your bread-and-butter.

I can see on the largely white screen just the login form . Front end is no better, with completely white screen.

I think the first thing to do is turn on the error reporting - in configuration.php file (open in a text editor) and turn on the option there. Also, in your hosting account admin panel (not joomla), there should be an error reporting option there, or you can add it to the php.ini file. (You may want to refer to your hosting's support - either contact them or refer to their knowledge-base, forums or FAQ resources, whichever they have available) for info on how to turn on PHP error reporting).

Also it would help us to help you, if you can run the Forum Post Assistant - download it from the link inthe read box, top of this page. viewtopic.php?f=806&t=969442. It's not a Joomla extension, it is a single file script, upload it to the joomla folder, and run it from your browser. Generate the report, and post ther esults to a reply on the forum here.

If the site is hacked (not saying yours is), there is only one solution - a complete deletion and restore of the site. viewtopic.php?f=714&t=946026
Regards,
--------------------------------------------------------------
A Murray
Millennium Falcon - it's the ship that made the Kessel run in less than 12 parsecs! The fastest hunk of junk in the galaxy.

User avatar
PhilTaylor-Prazgod
Joomla! Ace
Joomla! Ace
Posts: 1199
Joined: Sat Aug 20, 2005 12:32 pm
Location: Jersey, Channel Islands
Contact:

Re: Website not working

Post by PhilTaylor-Prazgod » Thu Mar 14, 2019 10:17 pm

You are running Joomla 1.5 in 2019 as evidenced by this in your source code.

Code: Select all

<meta name="generator" content="Joomla 1.5" />
Your webhost is SiteGround, so probably running modern PHP 7

Simple. Your website is not fit for production use in 2019. Its been SEVEN YEARS since Joomla 1.5 was officially end of life.

Get real and delete your site from the internet. And start again from scratch.
Phil Taylor - Full Time Joomla/PHP Security Expert
Blue Flame Digital Solutions Limited.
-- https://mySites.guru - Multi Award Winning Joomla Security & Auditing Service
-- https://www.phil-taylor.com/


Post Reply

Return to “General Questions/New to Joomla! 1.5”