OS Image Gallery problem in my page

This forum is for general questions about extensions for Joomla! 2.5.

Moderators: pe7er, General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Post Reply
eaduniversity
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Mar 15, 2019 1:46 pm

OS Image Gallery problem in my page

Post by eaduniversity » Fri Mar 15, 2019 1:49 pm

Hello,
When I go to the edpuroa.net address I get an error - Fatal error: Call to undefined method JSite :: getBody () in /home/edpuroa/public_html/plugins/system/osgallery_system/osgallery_system.php on line 31.

I also get an error when I go to the edpuroa.net/administrator page - Fatal error: Call to undefined method JAdministrator :: getBody () in /home/edpuroa/public_html/plugins/system/osgallery_system/osgallery_system.php on line 62 .

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11429
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: Problem in my page

Post by toivo » Fri Mar 15, 2019 2:35 pm

Which version of OS Responsive Image Gallery are you using?

The free version was updated in December and it works at least in Joomla 3.9.4 and PHP 7.3.2.
Toivo Talikka, Global Moderator

eaduniversity
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Mar 15, 2019 1:46 pm

Re: Problem in my page

Post by eaduniversity » Fri Mar 15, 2019 2:41 pm

I was using this version: OS Gallery 4/5/2018 12.05 Joomla 2.5

The problem is that I can not access any of the two pages. how could he fix this problem

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11429
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: OS Image Gallery problem in my page

Post by toivo » Fri Mar 15, 2019 2:46 pm

You can disable the system plugin. Edit the extensions table in the database using phpMyAdmin from the cPanel of your host, locate the row where the column 'element' has the value 'osgallery_system' and change the column 'enabled' from 1 to 0.
Toivo Talikka, Global Moderator

eaduniversity
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Mar 15, 2019 1:46 pm

Re: OS Image Gallery problem in my page

Post by eaduniversity » Fri Mar 15, 2019 3:16 pm

I get to the phpMyAdmin and look for sgj_osgallery. Where I see to change it to "enabled". It's my first time in this part it's phpmyadmin
You do not have the required permissions to view the files attached to this post.

eaduniversity
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Mar 15, 2019 1:46 pm

Re: OS Image Gallery problem in my page

Post by eaduniversity » Fri Mar 15, 2019 3:30 pm

I get it done but I still get the same error.

Fatal error: Call to undefined method JAdministrator::getBody() in /home/edpuroa/public_html/plugins/system/osgallery_system/osgallery_system.php on line 62

Fatal error: Call to undefined method JSite::getBody() in /home/edpuroa/public_html/plugins/system/osgallery_system/osgallery_system.php on line 31

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11429
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: OS Image Gallery problem in my page

Post by toivo » Fri Mar 15, 2019 3:42 pm

The screenshot has the list of database tables and the tables highlighted in the screenshot were created by the OS Image Gallery. The table you need to find is sqj_extensions.

Scroll up the page or go to the previous page and list the rows from the table sgj_extensions until you find the row where the column 'element' has the value 'osgallery_system'.
Toivo Talikka, Global Moderator

eaduniversity
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Mar 15, 2019 1:46 pm

Re: OS Image Gallery problem in my page

Post by eaduniversity » Fri Mar 15, 2019 3:55 pm

Thank you very much, I was able to fix the problem and I was able to access it.

User avatar
toivo
Joomla! Master
Joomla! Master
Posts: 11429
Joined: Thu Feb 15, 2007 5:48 am
Location: Suzhou, China

Re: OS Image Gallery problem in my page

Post by toivo » Fri Mar 15, 2019 4:10 pm

Glad to hear that. It is good to learn new skills, isn't it?
Toivo Talikka, Global Moderator


Post Reply

Return to “Extensions for Joomla! 2.5”